Subject: [Megaco] request-id in individual audit

From: "Milton" <[email-masked]>
Date: Tue, 16 Nov 2004 17:59:13 +0530

In The Megaco/H.248 Gateway Control Protocol, version 2,  in section  7.2.5
describing AuditValue command, protocol text says:

     " -  To audit an event, the relevant stream id (optional), eventID, 

         requestID (optional) are provided. The values of all the event 

         parameters are returned including: event actions and packaged 

         defined parameters."

Request Id has also been made optional in the asn encoding.

But in Annex B text encoding of the protocol the following rule is given to
audit individual events: 

indAudeventsDescriptor     = EventsToken EQUAL RequestID  

                        LBRKT indAudrequestedEvent RBRKT ; request id is not
optional

Is that a bug?

Regards,

Milton

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 17 Nov 2004 05:49:23 -0500

The RequestID is only optional in the sense that it is not required for
specification of the Events token for auditing the entire descriptor.
 
This is intentional grammar.
 
Kevin

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Milton
Sent: Tuesday, November 16, 2004 7:29 AM
To: [email-masked]
Subject: [Megaco] request-id in individual audit

         defined parameters."

Is that a bug?

Regards,

Milton