Subject: RE: [Megaco] MGC/MG Failure

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 11 Nov 2004 08:32:06 -0500

I disagree.  I have seen MGC switchovers with zero outage in the field under
6 9's operation from more than one implementation.  It depends upon how
redundancy is accomplished for the implementation.
 
The definition of acceptable downtime is a regulatory matter for the
locality -- generic statements of what is acceptable is misleading and
non-constructive.  Be very careful about making statements like this in an
international forum.  Just because the statement is true for your market,
does not mean it is true worldwide.
 
The statements here pertaining to MGC internal failure seem to be made with
a particular implementation in mind.  I do not believe that it would
necessarily hold true across all implementations.
 
Kevin

  _____  

From: Rajeev K R [mailto:[email-masked]] 
Sent: Wednesday, November 10, 2004 9:29 PM
To: 'Jones, Nevin R (Nevin)'; Boyle, Kevin [NCRTP:3Z40:EXCH];
[email-masked]
Subject: RE: [Megaco] MGC/MG Failure

Hi,
 
There are some other factors to be considerd here.
 
In a 5 nine reliable network, you simply cannot afford to have an MGC
switchover in normal situations.
Since there are network delays involved, it is almost impossible to switch
over and restore service within 1 minute.
Major factors being failure detection time and MG re-registration time
(including avalanche protection timer).
(You can switch over faster, but that would result in  stray switch overs.)
 
So MGC switch over can be considered only as a disaster recovery method when
you lose the service
of one MGC completely due to physical destruction of the equipment or
network.
In such cases up to 5 minutes is acceptable to restore service. 
(5 nines translate to 5 minutes downtime per year)
 
But in normal running, the MGC should not fail to that extent.
Internal failures of an MGC should be taken care by other mechanisms and
should not result in MGC switchover.
The MGC should have 6 nines availability (or close) by itself, for the total
service availability to be 5 nines.
 
Anyway, wrt H.248, I agree with Kevin that this timing need not be enforced
by protocol.
 
Rajeev

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Jones, Nevin R (Nevin)
Sent: Wednesday, November 10, 2004 10:47 PM
To: Kevin Boyle; [email-masked]
Subject: RE: [Megaco] MGC/MG Failure

Kevin:
 
I agree that Megaco is not particularly specific to rt- services but it does
purport to support VoIP services. If such services are to be "carrier grade"
i.e. 5 nines then this would therefore suggest some need to address the
matter of rapid failover times for MGCs.
 
Regards,

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]] 
Sent: Wednesday, November 10, 2004 9:43 AM
To: Jones, Nevin R (Nevin); [email-masked]
Subject: RE: [Megaco] MGC/MG Failure

This is an implementation detail that would depend upon your needs.  Note
that Megaco does not have sole use in the real-time services arena,
therefore it is inappropriate for any timing requirements to be specified as
part of the protocol.
 
Kevin

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Jones, Nevin R (Nevin)
Sent: Tuesday, November 09, 2004 6:48 PM
To: [email-masked]
Cc: Jones, Nevin R (Nevin)
Subject: [Megaco] MGC/MG Failure

All: 

I am a newbie to the megao list so please forgive me if this question was
asked and answered previously. Is there a stipulation (and better yet,
mechanism) somewhere in the Megaco/H.248 standard for the maximum switching
time from one MGC to another in the case of a handover? I ask this question
with the concern that if real time IP based services are to operate at 5
nines availability, then it would seem that the MGC switchover would have to
be in the 10s of milliseconds.

Thanks! 

Regards 

Nevin Jones 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Rajeev K R <[email-masked]>
Date: Fri, 12 Nov 2004 15:24:20 +0800

Hi Kevin,
I agree. The service levels are different between markets and cannot be
generalised.
So I would refrain from making statements pertaining to this.
 
But I have some questions about MGC switchover with zero outage.
Wouldn't this require switchover within milliseconds as mentioned in the
original question ?
Or is it within seconds ?(because  6 nines translate approx to down time <
30 sec/year)
 
What methods can be adopted to remove MG re-registration delay ?
Inactivity timer package delay, normalMGCexecution time, retransmission
time, no. of retries etc all gets added up here.
Because of the network delay, there is a risk in keeping these timers to the
possible minimum value.
 
Is it possible for the secondary(newly active) MGC to force the MG to
re-register to it ? 
(instead of waiting for the MG to find out by itself and initiate
re-registration)
This would be something like handoff request from secondary MGC. Does the
protocol permit this?
Assuming that MGCs have sufficient mechanism to detect failure and initiate
switchover very fast, 
this would be desirable to minimise the service outage time.
 
Rajeev

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]] 
Sent: Thursday, November 11, 2004 9:32 PM
To: Rajeev K R; 'Jones, Nevin R (Nevin)'; [email-masked]
Subject: RE: [Megaco] MGC/MG Failure

 
 
Kevin

  _____  

Hi,

 

 
Rajeev

-----Original Message-----

Kevin:

Regards,

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]] 
Sent: Wednesday, November 10, 2004 9:43 AM
To: Jones, Nevin R (Nevin); [email-masked]
Subject: RE: [Megaco] MGC/MG Failure

Kevin

  _____  

All: 

Thanks! 

Regards 

Nevin Jones