Subject: RE: [Megaco] H.248.1 V3 Appendix II "H.248 Package Template": Err orCodes

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 3 Nov 2004 10:25:42 -0500

To date, error codes which are specifically related to a particular
package's function are defined by the package and those independent of
package function get put in H.248.8.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Taylor, Tom-PT [CAR:5N00:EXCH]
Sent: Wednesday, November 03, 2004 9:38 AM
To: [email-masked]
Cc: Christian Groves; [email-masked]
Subject: Re: [Megaco] H.248.1 V3 Appendix II "H.248 Package Template":
ErrorCodes

Error codes may be defined in packages, but in fact they are generally
applicable. 
  The package just happens to be where they are documented.

Of course, by its nature the error may be something that can't possibly
occur unless you are using a particular package.  When defining an error,
you need to come up with a balance between the amount of information it
provides (which should be enough to point corrective action in the right
direction, but not enough to be a debugging tool on its own) and the
possibility of its more general application (which is desirable).

[email-masked] wrote:
> Hello Christian,
> 
> got a basic question to the Error Code section
> (H.248.1 V3, Appendix II, cl. 5.5,
> http://ftp3.itu.int/av-arch/avc-site/2001-2004/0408_San/TD-33.zip)
> in the V3 template.
> 
> Package specific error codes shall be defined in form of
> 
> 
> <Error Code Title>
> 
>        Error Code #:    <number>
> 
>        Name:                  <name>
> 
>        Definition:            <definition>
> 
>        Error Text in the Error Descriptor:
> 
>           <error text to return>
> 
>        Comment:   <comment>
> 
> 
> Question: how are local (i.e, package specific error codes) 
> distinguished from global ones (= H.248.8)?
> How may the MGC distinguish between local & global?
> 
> Background: I'm currently drafting the H.248.33 local error code.
> 
> Thanks
> Albrecht
> 
> 
> 
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 
> 

--
Tom Taylor
Carrier VoIP Standards Development
Nortel Networks
Phone +1 613 763 1496  (ESN 393-1496)
E-mail: [email-masked]

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Wed, 3 Nov 2004 17:15:46 +0100

Thanks Tom & Kevin!
This means that there's a common codepoint space for package independent
and package specific error codes, meaning, I need an IANA registration for
package specific error codes as well. Right?

If yes, perhaps a corresponding note in H.248.1 V3, Appendix II, cl. 5.5
might be helpful.
E.g.: "Error code assignment shall follow the same rules as described in
H.248.4, clause 4.1 'Assigning Error Codes'".

What do you think about such a note?
Shall I write a contribution?

Regards
Albrecht

                      "Kevin Boyle"                                                                                             
                      <kboyle@nortelne         To:      "Tom-PT Taylor" <[email-masked]>, Albrecht                   
                      tworks.com>              SCHWARZ/DE/ALCATEL@ALCATEL                                                       
                      Sent by:                 cc:      Christian Groves <[email-masked]>, [email-masked]       
                      megaco-bounces@i         Subject: RE: [Megaco] H.248.1 V3 Appendix II "H.248 Package Template": Err       
                      etf.org                  orCodes                                                                          

                      03.11.2004 16:25                                                                                          

Kevin

---

From: Christian Groves <[email-masked]>
Date: Thu, 04 Nov 2004 11:18:09 +1100

Hello Albrecht,

Yes you are correct that even for package specific error codes you need to 
register them with IANA. The note you propose would be beneficial. Rather than 
writing a new contribution you could add this to the proposal section of the 
contribution that introduces the error codes.

Regards, Christian

---

From: Richard Sun <[email-masked]>
Date: Mon, 08 Nov 2004 18:00:43 -0500

Kevin,
or any expert there who can help please:

I am trying to implement "held tone" feature.
Searching the web, found draft-boyle-megaco-tonepkgs-05.txt:

       Held Tone
           SignalID: ht (0x0051)

           Generate held tone, indicating that the remote end has the
           call in a held state.

           Tone Direction
                 ParameterID: btd (0x01)
                 Type: Enumeration
                 Possible Values: External   ext  (0x01),
                                  Internal   int  (0x02),
                                  Both       both (0x03)

Yes, this is exactly what I need. But this was removed since
draft-boyle-megaco-tonepkgs-06.txt (=H248.27).
I can not find any discussion on why "ht" was removed.
Could you please let me know what is the standard package
to suppor "ht" equivalent now?

Thanks,
-Richard

---

From: [email-masked]
Date: Wed, 10 Nov 2004 17:24:23 +0530

Hi Richard

All the packages defined in the draft below are now part of the Q.1950 
document.
Refer the Q.1950(Bearer independent call bearer control protocol, 
12/2002), subsection number A.10.3.3 under Basic services tones generation 
package section.

regards
B. Venkat S.R Swamy
Hughes Software systems
www.hssworld.com

Richard Sun <[email-masked]> 
Sent by: [email-masked]
11/09/2004 04:30 AM

To
Kevin Boyle <[email-masked]>
cc
[email-masked]
Subject
[Megaco] what package supports "held tone" now?

Kevin,

Held Tone
SignalID: ht (0x0051)

Tone Direction
ParameterID: btd (0x01)
Type: Enumeration

Thanks,
-Richard

***********************  HSS-Private   ***********************

"Please note:The email domain of Hughes Software Systems Ltd. has been changed to "hssworld.com" from hss.hns.com"

"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited (HSS) and is intended 
solely for the use of the individual to whom it is addressed. It may contain  privileged or 
confidential information and should not be circulated or used for any purpose other than for 
what it is intended. If you have received this message in error, please notify the originator 
immediately. If you are not the intended recipient, you are notified that you are strictly 
prohibited from using, copying, altering, or disclosing the contents of this message. HSS 
accepts no responsibility for loss or damage arising from the use of the information transmitted 
by this email including damage from virus."