Subject: RE: [Megaco] Re: Extended DTMF packages

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 24 Nov 2004 04:30:56 -0500

How, exactly, does one play an event as a signal?
 
Kevin

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Geetha
Sent: Wednesday, November 24, 2004 5:42 PM
To: [email-masked]
Subject: [Megaco] Re: Extended DTMF packages

Hi,
 
The extended DTMF package(H.248.16 (11/2002)) adds the Extended DigitMap
Completion Event. Is this event also a tone-id for playtone?
 
Pls clarify/confirm this.
 
Thanks & Rgds,
Geetha

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 25 Nov 2004 02:14:55 -0500

Completion events are not tones.  Therefore, it would not make any sense to
assign them ToneIDs.
 
Note that the completion event in E.6/H.248.1 does not have a ToneID.
 
Kevin

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Geetha
Sent: Thursday, November 25, 2004 1:40 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Megaco] Re: Extended DTMF packages

Hi,
 
Sorry for the confusion. 
 
Actually the doubt was this..
Whether the Extended DigitMap Completion Even defined in Extended DTMF
package is also a tone-id for  the events Std, Ltd and Etd defined in Tone
detection package?
The Enhanced DTMF package also adds an event Matched DigitMap Completion
Event. Will this also be a tone-id for  the events Std, Ltd and Etd defined
in Tone detection package?
 
Also note that the DTMF detection package which extends from the tonedet
package adds the DTMF digits D0-DD to the toneid for the events Std, Ltd and
Etd.
 
Thanks & Regards,
Geetha

----- Original Message ----- 
From: [email-masked] <mailto:[email-masked]>  
To: Geetha <mailto:[email-masked]>  
Cc: [email-masked] <mailto:[email-masked]>  
Sent: Wednesday, November 24, 2004 3:28 AM
Subject: Re: [Megaco] Re: Extended DTMF packages

I think you are confused with other DTMF items(D0-DD) which are basically
tones which can be both generated as well as detected on a endpoint, 
whereas Digitmap completion event occurs whenever the digit dialling is over
and MG has to report collected digits to MGC as per the digitmap, and hence
this can never be a tone to be played on endpoint. 

regards 
B. Venkat S.R Swamy 
Hughes Software Systems 
www.hssworld.com 

"Geetha" <[email-masked]> 
Sent by: [email-masked] 

11/25/2004 04:12 AM 

To
<[email-masked]> 

cc

Subject
[Megaco] Re: Extended DTMF packages	

Hi, 

  
Thanks & Rgds, 
Geetha 

***********************  HSS-Private   *********************** 

"Please note:The email domain of Hughes Software Systems Ltd. has been
changed to "hssworld.com" from hss.hns.com"

"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited
(HSS) and is intended 

solely for the use of the individual to whom it is addressed. It may contain
privileged or 

confidential information and should not be circulated or used for any
purpose other than for 

what it is intended. If you have received this message in error, please
notify the originator 

immediately. If you are not the intended recipient, you are notified that
you are strictly 

prohibited from using, copying, altering, or disclosing the contents of this
message. HSS 

accepts no responsibility for loss or damage arising from the use of the
information transmitted 

by this email including damage from virus."