Subject: [Megaco] about servicechage with restart

From: "wesley.wang" <[email-masked]>
Date: Thu, 25 Nov 2004 18:12:08 +0800

Hi All:
    There is one question.

    We have one Terminations in busy status(which we are using), in some time it comes ServiceChange Request with restart of this Termination. what should the server do?

   should it release all the call relative with this termination?

   We are using one Media gateway, when it doing hand over inside, it will report all the E1 resource ServiceChange with restart parameter,  Is this nessesary?

   Can Server conside the resource is in free state when recv servicechange request with restart method?

Thanks.

BR

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 26 Nov 2004 03:38:09 -0500

There is no one answer.  The actions the MGC takes depends also upon the
ServiceChangeReason.  Note that it is entirely possible that the MGC could
Subtract the physical term, then add it back to the context.  It all depends
upon the implementation.
 
Kevin

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
wesley.wang
Sent: Thursday, November 25, 2004 8:44 PM
To: [email-masked]
Cc: [email-masked]; KellyJiang
Subject: ??: [Megaco] about servicechage with restart

Thanks. still I m a little confused. 
Suppose one case below:
 
    We held an ISUP call which makes TrunkTerm1/1 and IPTerm1234 in Context1
Mg1. in this time we receieve a ServiceChange command from Mg1 with
Term=TrunkTerm1/* Methord=Restart.
 
    which way is the best to handle this below?
 
    1: We need Keep  TrunkTerm1/1 and IPTerm1234 in Context1 since the
methord is restart means these terms are now in InService Mode.
 
    2: We need Release IPTerm1234 and and all the relative Control Block in
Server, 
       no need release TrunkTerm1/1 since after ServiceChange it should in
Free(InService) mode.

    3: We need Release both IPTerm1234 and and TrunkTerm1/1 and all the
relative Control Block in Server Since the TrunkTerm1/1 shoudl not report
ServiceChange With restart Methord in InService State. 
 
    4: Any Other Way?
 
    Thanks all.

-----ԭʼ�ʼ�-----
������: Kevin Boyle [mailto:[email-masked]]
����ʱ��: 2004��11��25�� 19:02
�ռ���: wesley.wang; [email-masked]
����: KellyJiang
����: RE: [Megaco] about servicechage with restart

The MGC is responsible for cleaning up any terminations after it sends or
receives a ServiceChange command for those terminations.

The signalling related to a Failover of a Media Gateway to a secondary unit
is largely an implementation detail.  However, the MGC should consider the
states of the terminations unchanged unless the MG signals otherwise.

Kevin 

-----Original Message----- 
From: [email-masked] [mailto:[email-masked]
<mailto:[email-masked]> ] On Behalf Of wesley.wang 
Sent: Thursday, November 25, 2004 5:12 AM 
To: [email-masked] 
Cc: KellyJiang 
Subject: [Megaco] about servicechage with restart 

Hi All: 
    There is one question. 

    We have one Terminations in busy status(which we are using), in some
time it comes ServiceChange Request with restart of this Termination. what
should the server do?

   We are using one Media gateway, when it doing hand over inside, it will
report all the E1 resource ServiceChange with restart parameter,  Is this
nessesary?

   Can Server conside the resource is in free state when recv servicechange
request with restart method? 

Thanks. 

BR