Subject: RE: [Megaco] Version negotiation in Handoff case

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 11 Nov 2004 08:17:58 -0500

ServiceChange messages to any MGC that serve as registration or
re-registration messages MUST be encoded using version 1.  See section 11.3.
Protocol version negotiation then occurs as it would at any other time.
 
Kevin

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Thursday, November 11, 2004 7:20 AM
To: Rashim Anand
Cc: [email-masked]
Subject: RE: [Megaco] Version negotiation in Handoff case

Hi Rashim 

If MG is doing version negotiation then I suppose MG should send Service
Change with its highest version support.(in your case V2) 

regards 
B. Venkat S.R Swamy 
Hughes Software Systems 
www.hssworld.com 

"Rashim Anand" <[email-masked]> 

11/11/2004 05:48 PM 

To
B Venkat S.R Swamy/HSS@HSS, "'Mahesh'" <[email-masked]> 

cc
<[email-masked]> 

Subject
RE: [Megaco] Version negotiation in Handoff case

Hi  Ventak, 
  
I  believe that the question was which version should the MG use to contact
the new  MGC. Should it use the version with which it was communicating with
the old MGC  or should it use the maximum version supported at MG? Ofcourse,
either way there  will be version negotiation with the new MGC. The final
version negotiated with  the new MGC might be V1 or V2 but the doubt is
which version should be used in  sending the srvcChng to the new MGC
(irrespective of the new MGC's subsequent  reply). 
  
Regards, 
-Rashim Anand 

-----Original Message----- 
From:  [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked] 
Sent: Thursday, November 11, 2004 3:39  AM 
To: Mahesh 
Cc: [email-masked] 
Subject: Re:  [Megaco] Version negotiation in Handoff case 

Hi 

As per  the protocol specs, Version Negotiation also takes place during
Handoff and  Failover procedures.(Section 11.3) 

Regards 
B. Venkat S.R  Swamy 
Hughes Software Systems   
www.hssworld.com   

"Mahesh"  <[email-masked]> 
Sent  by: [email-masked]   

11/11/2004 03:18 PM 

To
<[email-masked]>   

cc

Subject
[Megaco] Version  negotiation in Handoff case

HI All, 

I will be thankful to you if you can clarify the following scenario   of
handoff . 

MG can support v1 and V2 .   

MG is currently in a session with Primary MGC and the  negotiated version
is V1. 

Primary MGC sends  a handoff to MG. 

Then for contacting the secondary MGC which version shall the MG use in  the
Service change . 

With regards 

Mahesh 

_______________________________________________ 
Megaco mailing  list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco   

***********************   HSS-Private   ***********************   

"Please note:The email domain of Hughes Software Systems Ltd. has been
changed to "hssworld.com" from hss.hns.com" 

"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited
(HSS) and is intended 
solely for the use of the individual to whom it is addressed. It may contain
privileged or 
confidential information and should not be circulated or used for any
purpose other than for 
what it is intended. If you have received this message in error, please
notify the originator 
immediately. If you are not the intended recipient, you are notified that
you are strictly 
prohibited from using, copying, altering, or disclosing the contents of this
message. HSS 
accepts no responsibility for loss or damage arising from the use of the
information transmitted 
by this email including damage from virus." 

***********************  HSS-Private   *********************** 

"Please note:The email domain of Hughes Software Systems Ltd. has been
changed to "hssworld.com" from hss.hns.com"

"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited
(HSS) and is intended 

solely for the use of the individual to whom it is addressed. It may contain
privileged or 

confidential information and should not be circulated or used for any
purpose other than for 

what it is intended. If you have received this message in error, please
notify the originator 

immediately. If you are not the intended recipient, you are notified that
you are strictly 

prohibited from using, copying, altering, or disclosing the contents of this
message. HSS 

accepts no responsibility for loss or damage arising from the use of the
information transmitted 

by this email including damage from virus."

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Thu, 11 Nov 2004 19:09:18 +0530

Hi Kevin

I have been referring to the ServiceChangeVersion field in the Service 
Change message since IMO version negotiation is triggered only if
MG adds ServicechangeVersion field. Yes you are right that in this case 
registration or re-registration will be done by encoding using Version 1.

However if V2 based MG does not want to do version negotiation, then in 
that case MG can send Service Change message for 
registration/re-registration  encoded using Version 2.  Correct me if I am 
wrong..

regards
Venkat

"Kevin Boyle" <[email-masked]> 
11/11/2004 06:47 PM

To
B Venkat S.R Swamy/HSS@HSS, Rashim Anand <[email-masked]>
cc
[email-masked]
Subject
RE: [Megaco] Version negotiation in Handoff case

ServiceChange messages to any MGC that serve as registration or 
re-registration messages MUST be encoded using version 1.  See section 
11.3.  Protocol version negotiation then occurs as it would at any other 
time.
 
Kevin

From: [email-masked]  [mailto:[email-masked]] On Behalf 
Of  [email-masked]
Sent: Thursday, November 11, 2004 7:20  AM
To: Rashim Anand
Cc: [email-masked]
Subject:  RE: [Megaco] Version negotiation in Handoff case

Hi Rashim 

regards 
B. Venkat S.R Swamy 
Hughes Software Systems 
www.hssworld.com 

11/11/2004 05:48 PM 

To

Hi  Ventak, 
  
I  believe that the question was which version should the MG use  to 
contact the new  MGC. Should it use the version with which it was 
communicating with the old MGC  or should it use the maximum version 
supported at MG? Ofcourse, either way there  will be version negotiation 
with the new MGC. The final version negotiated with  the new MGC might be 
V1 or V2 but the doubt is which version should be used in  sending the 
srvcChng to the new MGC (irrespective of the new MGC's subsequent  reply). 

Regards, 
-Rashim Anand 

-----Original Message----- 
From:  [email-masked]  [mailto:[email-masked]] On Behalf 
Of   [email-masked] 
Sent: Thursday,  November 11, 2004 3:39  AM 
To:  Mahesh 
Cc: [email-masked] 
Subject: Re:  [Megaco] Version negotiation in Handoff  case 

Hi 

Regards 
B. Venkat S.R   Swamy 
Hughes Software  Systems   
www.hssworld.com   

11/11/2004 03:18 PM 

To
<[email-masked]>   
cc

Subject

HI All, 

  

MG is currently in a session with Primary  MGC and the  negotiated 
version  is V1. 

Then for contacting the secondary MGC which  version shall the MG use in 
 the Service change . 

With regards 

Mahesh 

"DISCLAIMER: This  message is proprietary to Hughes Software Systems 
Limited (HSS) and is  intended 
solely for the use of the  individual to whom it is addressed. It may 
contain  privileged or 
confidential information and should not  be circulated or used for any 
purpose other than for 
what it is intended. If you have  received this message in error, please 
notify the originator 
immediately. If you are not the  intended recipient, you are notified that 
you are strictly 
prohibited from using, copying,  altering, or disclosing the contents of 
this message. HSS 
accepts no responsibility for loss or  damage arising from the use of the 
information transmitted 
by this email including damage from  virus." 

"DISCLAIMER: This message is proprietary to Hughes Software Systems 
Limited (HSS) and is intended 
solely for the use of the individual to whom it is addressed. It may 
contain  privileged or 
confidential information and should not be circulated or used for any 
purpose other than for 
what it is intended. If you have received this message in error, please 
notify the originator 
immediately. If you are not the intended recipient, you are notified that 
you are strictly 
prohibited from using, copying, altering, or disclosing the contents of 
this message. HSS 
accepts no responsibility for loss or damage arising from the use of the 
information transmitted 
by this email including damage from virus."

***********************  HSS-Restricted   ***********************

"Please note:The email domain of Hughes Software Systems Ltd. has been changed to "hssworld.com" from hss.hns.com"

"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited (HSS) and is intended 
solely for the use of the individual to whom it is addressed. It may contain  privileged or 
confidential information and should not be circulated or used for any purpose other than for 
what it is intended. If you have received this message in error, please notify the originator 
immediately. If you are not the intended recipient, you are notified that you are strictly 
prohibited from using, copying, altering, or disclosing the contents of this message. HSS 
accepts no responsibility for loss or damage arising from the use of the information transmitted 
by this email including damage from virus."

---

From: Christian Groves <[email-masked]>
Date: Fri, 12 Nov 2004 09:49:08 +1100

Hello Venkat,

The MG can always send "v2" but it runs the risk of being rejected. The MGC may 
have restarted and is expecting v1 messages. Safer to send a v1 message and 
ServiceChangeVersion with 2.

[email-masked] wrote:
> registration/re-registration  encoded using Version 2.  Correct me if I 
> am wrong..
> 
> regards
> Venkat
> 
> 
> 
> 
>  11.3.  Protocol version negotiation then occurs as it would at any 
> other  time.
>  
> Kevin
> ------------------------------------------------------------------------
> 
> 
> From: [email-masked]  [mailto:[email-masked]] On 
> Behalf Of  [email-masked]
> If MG is doing version negotiation then I suppose MG  should send 
> Service Change with its highest version support.(in your case  V2)
> 
> 
> regards
> B. Venkat S.R Swamy
> Hughes Software Systems
> www.hssworld.com
> 
> 
> 
>  supported at MG? Ofcourse, either way there  will be version 
> negotiation  with the new MGC. The final version negotiated with  the 
> new MGC might be  V1 or V2 but the doubt is which version should be used 
> in  sending the  srvcChng to the new MGC (irrespective of the new MGC's 
> subsequent   reply).
>  
> Regards,
> -Rashim Anand
>  
>  
>  
> From:  [email-masked]  [mailto:[email-masked]] On 
> Behalf Of   [email-masked]
> I will be  thankful to you if you can clarify the following scenario 
>   of  handoff .
> 
>  
> 
>    
> 
> ------------------------------------------------------------------------
>