Subject: [Megaco] Re: Analog Line Supervision Package

From: "Geetha" <[email-masked]>
Date: Thu, 18 Nov 2004 12:49:01 -0800

Hi All,

In Analog Line Supervision package, for the observedEvents descriptor parameter init of event ID on , 

In draft-ietf-megaco-h248v2-04,
the type is given as boolean and the possible values are given as "True" and "False".(Both in quotes). 
In RFC 3015 the possible values are given as True and False(Without quotes)

In section B.2 ABNF specification in draft is given as 
Boolean values are encoded as "on" and "off" and are case insensitive. The safechar form of value MUST be used.
 and in RFC it is said as 
Boolean values, indicated in the text as True and False, encoded as "On" and "Off", respectively, in the ABNF

This is slightly confusing..What values are to be used? Either on/off or "True"/"False"

Thanks and Rgds,
Geetha
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 18 Nov 2004 03:18:34 -0500

True/False is the generic reference that is encoded in the ABNF as on/off.
Note that Annex A has defined values for true/false.
 
Kevin

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Geetha
Sent: Thursday, November 18, 2004 3:49 PM
To: [email-masked]
Subject: [Megaco] Re: Analog Line Supervision Package

Hi All,
 
In Analog Line Supervision package, for the observedEvents descriptor
parameter init of event ID on , 
 
In draft-ietf-megaco-h248v2-04,
the type is given as boolean and the possible values are given as "True" and
"False".(Both in quotes). 
In RFC 3015 the possible values are given as True and False(Without quotes)
 
In section B.2 ABNF specification in draft is given as 
Boolean values are encoded as "on" and "off" and are case insensitive. The
safechar form of value MUST be used.
 and in RFC it is said as 
Boolean values, indicated in the text as True and False, encoded as "On" and
"Off", respectively, in the ABNF

This is slightly confusing..What values are to be used? Either on/off or
"True"/"False"
 
Thanks and Rgds,
Geetha