Subject: [Megaco] H.248.1 V3 Appendix II "H.248 Package Template": Error Codes

From: [email-masked]
Date: Wed, 3 Nov 2004 15:00:19 +0100

Hello Christian,

got a basic question to the Error Code section
(H.248.1 V3, Appendix II, cl. 5.5,
http://ftp3.itu.int/av-arch/avc-site/2001-2004/0408_San/TD-33.zip)
in the V3 template.

Package specific error codes shall be defined in form of

<Error Code Title>

       Error Code #:    <number>

       Name:                  <name>

       Definition:            <definition>

       Error Text in the Error Descriptor:

          <error text to return>

       Comment:   <comment>

Question: how are local (i.e, package specific error codes) distinguished
from global ones (= H.248.8)?
How may the MGC distinguish between local & global?

Background: I'm currently drafting the H.248.33 local error code.

Thanks
Albrecht

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Tom Taylor <[email-masked]>
Date: Wed, 03 Nov 2004 09:37:49 -0500

Error codes may be defined in packages, but in fact they are generally applicable. 
  The package just happens to be where they are documented.

Of course, by its nature the error may be something that can't possibly occur 
unless you are using a particular package.  When defining an error, you need to 
come up with a balance between the amount of information it provides (which should 
be enough to point corrective action in the right direction, but not enough to be 
a debugging tool on its own) and the possibility of its more general application 
(which is desirable).

-- 
Tom Taylor
Carrier VoIP Standards Development
Nortel Networks
Phone +1 613 763 1496  (ESN 393-1496)
E-mail: [email-masked]