Subject: [Megaco] Protocol Version negotiation

From: "Mahesh" <[email-masked]>
Date: Mon, 8 Nov 2004 17:46:47 +0530

HI  All,

I would like to clarify one doubt regarding version negotiation.

Assume a scenario like this.

MG is sending MGC a service change  with version 1.

MGC sends a reply With version 2 .

What should be the expected behavior from the MG side .Assume that

Both MG and MGC supports versions 1 and 2 .

I think the section (11.3  )  doesn't explains this scenario clearly .

Could you please correct me if I am wrong?

With regards

Mahesh

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "THIAGO MELLO" <[email-masked]>
Date: Mon, 8 Nov 2004 10:38:13 -0200

As the same section, I interpreted that the MGC will send a reply with
version 1.

Thiago Mello - <[email-masked]>
------------------------------------------
Siemens Brazil - http://www.siemens.com.br <http://www.siemens.com.br/> 
COM RCC R&D SWC - SW Control Development
Tel.: +55 (41) 3025-9728 / 9958-0802  

	-----Original Message-----
	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Mahesh
	Sent: Monday, November 08, 2004 10:17 AM
	To: [email-masked]
	Subject: [Megaco] Protocol Version negotiation

	HI  All,

	What should be the expected behavior from the MG side .Assume
that

	 

	I think the section (11.3  )  doesn't explains this scenario
clearly .

	With regards

	Mahesh

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 8 Nov 2004 09:05:20 -0500

This is not permitted.  The procedures clearly state that the MGC can only
offer a lower version.  If the MG offers v1, and the MGC supports it, it
should start communicating using V1.
 
To quote: 

Upon receiving such a message, if the MGC supports only a lower version,
then the MGC shall send a ServiceChangeReply with the lower version and,
thereafter, all the messages between MG and MGC shall conform to the lower
version of the protocol. 

[clip]

If the MGC supports a higher version than the MG but is able to support the
lower version proposed by the MG, it shall send a ServiceChangeReply with
the lower version and thereafter all the messages between MG and MGC shall
conform to the lower version of the protocol.

This means that even if the MGC supports v2, if v1 is what the MG offers,
the MGC either has to use v1 or NACK.
 
Kevin

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Mahesh
Sent: Monday, November 08, 2004 7:17 AM
To: [email-masked]
Subject: [Megaco] Protocol Version negotiation

HI  All,

 

With regards

Mahesh