Subject: [Megaco] Re: Extended DTMF packages

From: "Geetha" <[email-masked]>
Date: Wed, 24 Nov 2004 14:42:18 -0800

Hi,

The extended DTMF package(H.248.16 (11/2002)) adds the Extended DigitMap Completion Event. Is this event also a tone-id for playtone?

Pls clarify/confirm this.

Thanks & Rgds,
Geetha

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Wed, 24 Nov 2004 16:58:21 +0530

I think you are confused with other DTMF items(D0-DD) which are basically 
tones which can be both generated as well as detected on a endpoint,
whereas Digitmap completion event occurs whenever the digit dialling is 
over and MG has to report collected digits to MGC as per the digitmap, and 
hence this can never be a tone to be played on endpoint.

regards
B. Venkat S.R Swamy
Hughes Software Systems
www.hssworld.com

"Geetha" <[email-masked]> 
Sent by: [email-masked]
11/25/2004 04:12 AM

To
<[email-masked]>
cc

Subject
[Megaco] Re: Extended DTMF packages

Hi,
 
The extended DTMF package(H.248.16 (11/2002))  adds the Extended DigitMap 
Completion Event. Is this event also a tone-id for  playtone?

Thanks & Rgds,
Geetha

***********************  HSS-Private   ***********************

"Please note:The email domain of Hughes Software Systems Ltd. has been changed to "hssworld.com" from hss.hns.com"

"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited (HSS) and is intended 
solely for the use of the individual to whom it is addressed. It may contain  privileged or 
confidential information and should not be circulated or used for any purpose other than for 
what it is intended. If you have received this message in error, please notify the originator 
immediately. If you are not the intended recipient, you are notified that you are strictly 
prohibited from using, copying, altering, or disclosing the contents of this message. HSS 
accepts no responsibility for loss or damage arising from the use of the information transmitted 
by this email including damage from virus."

---

From: "Geetha" <[email-masked]>
Date: Thu, 25 Nov 2004 10:39:45 -0800

Hi,

Sorry for the confusion. 

Actually the doubt was this..
Whether the Extended DigitMap Completion Even defined in Extended DTMF package is also a tone-id for  the events Std, Ltd and Etd defined in Tone detection package?
The Enhanced DTMF package also adds an event Matched DigitMap Completion Event. Will this also be a tone-id for  the events Std, Ltd and Etd defined in Tone detection package?

Also note that the DTMF detection package which extends from the tonedet package adds the DTMF digits D0-DD to the toneid for the events Std, Ltd and Etd.

Thanks & Regards,
Geetha

  ----- Original Message ----- 
  From: [email-masked] 
  To: Geetha 
  Cc: [email-masked] 
  Sent: Wednesday, November 24, 2004 3:28 AM
  Subject: Re: [Megaco] Re: Extended DTMF packages

  I think you are confused with other DTMF items(D0-DD) which are basically tones which can be both generated as well as detected on a endpoint, 
  whereas Digitmap completion event occurs whenever the digit dialling is over and MG has to report collected digits to MGC as per the digitmap, and hence this can never be a tone to be played on endpoint. 

  regards 
  B. Venkat S.R Swamy 
  Hughes Software Systems 
  www.hssworld.com 

       To <[email-masked]>  
              cc  
              Subject [Megaco] Re: Extended DTMF packages 

  Hi, 

    
  Thanks & Rgds, 
  Geetha 

  ***********************  HSS-Private   *********************** "Please note:The email domain of Hughes Software Systems Ltd. has been changed to "hssworld.com" from hss.hns.com"

---

From: Rajeev K R <[email-masked]>
Date: Thu, 25 Nov 2004 17:09:21 +0800

Hi,
As you have mentioned,  DTMF detection package adds the DTMF digits D0-DD to
the tone list 
for Std, Ltd and Etd events, but not the digit map completion event.
Digit map completion is an event and NOT an audio tone and hence this can
not be 
included in the tone list for the tone detection events.
Tone detection is intended to identify the tones that you "hear" on the
termination,
so it could be digits or call progress tones as defined by the extension
packages.
 
Rajeev

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Geetha
Sent: Friday, November 26, 2004 2:40 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Megaco] Re: Extended DTMF packages

Hi,
 
Sorry for the confusion. 
 
Actually the doubt was this..
Whether the Extended DigitMap Completion Even defined in Extended DTMF
package is also a tone-id for  the events Std, Ltd and Etd defined in Tone
detection package?
The Enhanced DTMF package also adds an event Matched DigitMap Completion
Event. Will this also be a tone-id for  the events Std, Ltd and Etd defined
in Tone detection package?
 
Also note that the DTMF detection package which extends from the tonedet
package adds the DTMF digits D0-DD to the toneid for the events Std, Ltd and
Etd.
 
Thanks & Regards,
Geetha

----- Original Message ----- 
From: [email-masked] 
To: Geetha <mailto:[email-masked]>  
Cc: [email-masked] 
Sent: Wednesday, November 24, 2004 3:28 AM
Subject: Re: [Megaco] Re: Extended DTMF packages

I think you are confused with other DTMF items(D0-DD) which are basically
tones which can be both generated as well as detected on a endpoint, 
whereas Digitmap completion event occurs whenever the digit dialling is over
and MG has to report collected digits to MGC as per the digitmap, and hence
this can never be a tone to be played on endpoint. 

regards 
B. Venkat S.R Swamy 
Hughes Software Systems 
www.hssworld.com 

11/25/2004 04:12 AM 

To
<[email-masked]> 

cc

Subject

Hi, 

  
Thanks & Rgds, 
Geetha 

"Please note:The email domain of Hughes Software Systems Ltd. has been
changed to "hssworld.com" from hss.hns.com"

"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited
(HSS) and is intended 

solely for the use of the individual to whom it is addressed. It may contain
privileged or 

confidential information and should not be circulated or used for any
purpose other than for 

what it is intended. If you have received this message in error, please
notify the originator 

immediately. If you are not the intended recipient, you are notified that
you are strictly 

prohibited from using, copying, altering, or disclosing the contents of this
message. HSS 

accepts no responsibility for loss or damage arising from the use of the
information transmitted