Subject: RE: [Megaco] Full match or unambiguous match

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 3 Dec 2004 01:54:48 -0500

In all cases, this would be a Full Match, with the octothorpe ('#') as an
extra digit.  Remember that 'x' only matches the digits 0-9.

Note that Unambiguous Match only applies to the base matching procedures,
and not to the enhanced procedures described by H.248.16.

Kevin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
C. Kamath.
Sent: Friday, December 03, 2004 12:20 PM
To: [email-masked]
Subject: [Megaco] Full match or unambiguous match

Hi all,

Can anybody confirm me the following.

MGC has sent the digitmap as [1-9]xxx|xxxxx to MG.

The caller dials  1234#

Now whether MG is supoosed to notify with digits 1234 as Full match or
unambiguous match

rgds
kamath

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 3 Dec 2004 03:24:06 -0500

This is incorrect.  According to the base match rules, the notify would
occur once the '#' was pressed as a Full Match.

When using the enhanced matching rules from H.248.16, then the match would
express as a Full Match once the 4 was detected.

Kevin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Terry L Howe
Sent: Friday, December 03, 2004 6:26 AM
To: C. Kamath.
Cc: [email-masked]
Subject: Re: [Megaco] Full match or unambiguous match

The MG would generate the notify as soon as the 4 was pressed, so it all
depends on what the MGC asked the MG to do after it got the notify.

--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 
Terry L Howe                                    [email-masked] 
http://www.jeeptech.com/          http://www.tiptoprockracing.com/ 
~             http://www.tiptopsoftwarecompany.com/              ~