Subject: RE: [Megaco] does MGC have to answer?

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 8 Dec 2004 01:44:28 -0500

I would think that MGCs would ignore any messages from unregistered MGs that
are not ServiceChanges.  Sending Pendings may only serve to extend a DoS
attack.
 
I do not believe that the use of Pending in this case is typical, either.
In fact, I would say that it is atypical, and in fact, wrong.
 
Kevin

  _____  

From: [email-masked] on behalf of Pascal Lambers
Sent: Wed 12/8/2004 1:00 AM
To: [email-masked]
Subject: Fw: [Megaco] does MGC have to answer?

Hi,
 
Is it mandatory for an MGC to answer to (eg Notify) messages from
unregistered MGs? If the MGC receives such a message, typically, its
underlying Megaco stack will send pending messages to the the MG anyway,
even though the actual MGC does not answer to the message. In other words,
is the following scenario a good one:
 
MG                     MGC
------------Notify-------->
<---------Pending--------  
<---------Pending--------
<---------Pending--------
                        (mgc stops sending
                          pending msgs)
...
(retries)
-----------Sc Restart----->

Kind regards,
Pascal
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Pascal Lambers" <[email-masked]>
Date: Wed, 15 Dec 2004 22:28:42 +0100

I can more ore less agree with this point of view. On the other hand, what is the purpose of the error reply "402 - Unauthorized" (as it was defined in the past in RFC 3015 and now defined in H.248.8)?  Should an MGC never sent it to a gateway which is not registered? 

Kind regards,
Pascal

  ----- Original Message ----- 
  From: Kevin Boyle 
  To: Pascal Lambers ; [email-masked] 
  Sent: Wednesday, December 08, 2004 7:44 AM
  Subject: RE: [Megaco] does MGC have to answer?

  I would think that MGCs would ignore any messages from unregistered MGs that are not ServiceChanges.  Sending Pendings may only serve to extend a DoS attack.

  I do not believe that the use of Pending in this case is typical, either.  In fact, I would say that it is atypical, and in fact, wrong.

  Kevin

------------------------------------------------------------------------------
  From: [email-masked] on behalf of Pascal Lambers
  Sent: Wed 12/8/2004 1:00 AM
  To: [email-masked]
  Subject: Fw: [Megaco] does MGC have to answer?

  Hi,

  Is it mandatory for an MGC to answer to (eg Notify) messages from unregistered MGs? If the MGC receives such a message, typically, its underlying Megaco stack will send pending messages to the the MG anyway, even though the actual MGC does not answer to the message. In other words, is the following scenario a good one:

  MG                     MGC

  Kind regards,
  Pascal

------------------------------------------------------------------------------