Subject: RE: [Megaco] how codec negotiation is triggered by MGC?

From: "Marcello Pantaleo (AC/EDD)" <[email-masked]>
Date: Fri, 17 Dec 2004 11:15:23 +0100

Hi,

MGC can use audit capabilities to get the list of codecs supported by a MG. Alternatively a MGC can be provisioned with MG capabilities.

MGC wouldn't use Add to know MG capabilities (e.g. supported codecs).

If MGC sends an Add command with an empty local desciptor, this is a request to release any resources previously reserved for the media flow received, that means nothing given that MGC is now creating the termination.
If local descriptor is unspecified (i.e. absent), MG considers this as missing mandatory parameter. MG uses whatever previously specified. 

If MGC sends "m=audio $ RTP/AVP $" it requests MG to choose one of the supported codecs, so you don't get the list.

I don't think you can use * wildcard in the "m=".

Regards,
Marcello 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Richard Sun
Sent: Thursday, December 16, 2004 3:08 PM
To: [email-masked]
Subject: [Megaco] how codec negotiation is triggered by MGC?

Hi, Can anyone pelase clarify the standard
for MGC to trigger a codec negotiation in MG
(i.e, MG should provide a list of codecs
it supports)?

One way I can think of is an empty "Local{}"
without SDP, such as:
Transaction = 299012 {
  Context = $ {
    Add = aaln/1 {
      Media { Stream = 1 {
        LocalControl {Mode = SendReceive}
    }}},
    Add = $ {
      Media {Stream = 1 {
        LocalControl {Mode=ReceiveOnly},
        Local {}
}}}}}

The question is: is this legal? Should MG reject
the message with some kind of error such as "SDP missing",
or MG is suppose to fill up the SDP section in response?
What if the "Local{}" does not present at all?

The other way is something like this:
Transaction = 299012 {
  Context = $ {
    Add = aaln/1 {
      Media { Stream = 1 {
        LocalControl {Mode = SendReceive}
    }}},
    Add = $ {
      Media {Stream = 1 {
        LocalControl {Mode=ReceiveOnly},
        Local {
v=0
o=$ $ $ IN IP4 $
s=$
c=IN IP4 $
t=$ $
m=audio $ RTP/AVP -
a=ptime:20
}}}}}}
With "-" in "m=audio $ RTP/AVP -", should MG
fill up the list of codecs?
Or should it be something like
"m=audio $ RTP/AVP $"?

Thanks for any information.
-Richard

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Richard Sun <[email-masked]>
Date: Fri, 17 Dec 2004 12:39:06 -0500

Marcello,
Thanks for your helpfull information.

Now assume that MGC audits MG and learns
that MG supports "PCMU" *and* "telephone-event".
If "m=audio $ RTP/AVP $" means that
MG to choose *one* codec, then
what is the syntax for MGC to instruct MG
"use PCMU, *and* choose a payload number for
telephone-event"?

-Richard