Subject: [Megaco] Does MGC have to answer?

From: "Pascal Lambers" <[email-masked]>
Date: Wed, 5 Jan 2005 21:06:00 +0100

Is there anybody who has an answer to this question I posted a while ago? I'm still puzzled...
Thanks,
Pascal

I can more ore less agree with this point of view. On the other hand, what is the purpose of the error reply "402 - Unauthorized" (as it was defined in the past in RFC 3015 and now defined in H.248.8)?  Should an MGC never sent it to a gateway which is not registered? 

Kind regards,
Pascal

    ----- Original Message ----- 
    From: Kevin Boyle 
    To: Pascal Lambers ; [email-masked] 
    Sent: Wednesday, December 08, 2004 7:44 AM
    Subject: RE: [Megaco] does MGC have to answer?

    I would think that MGCs would ignore any messages from unregistered MGs that are not ServiceChanges.  Sending Pendings may only serve to extend a DoS attack.

    I do not believe that the use of Pending in this case is typical, either.  In fact, I would say that it is atypical, and in fact, wrong.

    Kevin

----------------------------------------------------------------------------
    From: [email-masked] on behalf of Pascal Lambers
    Sent: Wed 12/8/2004 1:00 AM
    To: [email-masked]
    Subject: Fw: [Megaco] does MGC have to answer?

    Hi,

    Is it mandatory for an MGC to answer to (eg Notify) messages from unregistered MGs? If the MGC receives such a message, typically, its underlying Megaco stack will send pending messages to the the MG anyway, even though the actual MGC does not answer to the message. In other words, is the following scenario a good one:

    MG                     MGC
    ------------Notify-------->
    <---------Pending--------  
    <---------Pending--------
    <---------Pending--------
                            (mgc stops sending
                              pending msgs)
    ...
    (retries)
    -----------Sc Restart----->

    Kind regards,
    Pascal

----------------------------------------------------------------------------

    _______________________________________________
    Megaco mailing list
    [email-masked]
    https://www1.ietf.org/mailman/listinfo/megaco

------------------------------------------------------------------------------

  _______________________________________________
  Megaco mailing list
  [email-masked]
  https://www1.ietf.org/mailman/listinfo/megaco
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 5 Jan 2005 15:54:31 -0500

If the MGC wishes to answer, it can -- that would be an implementation
decision.  Implementors should be aware, however, that choosing to respond
to unknown entities may be extending a DoS attack by wasting time processing
the messages, and then adding to the messaging load on the network.
 
In my personal opinion, I think it is unwise to respond to unknown entities.
 
Kevin

  _____  

From: Pascal Lambers [mailto:[email-masked]] 
Sent: Wednesday, January 05, 2005 3:06 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked]
Subject: Does MGC have to answer?

Is there anybody who has an answer to this question I posted a while ago?
I'm still puzzled...
Thanks,
Pascal

I can more ore less agree with this point of view. On the other hand, what
is the purpose of the error reply "402 - Unauthorized" (as it was defined in
the past in RFC 3015 and now defined in H.248.8)?  Should an MGC never sent
it to a gateway which is not registered? 

Kind regards,
Pascal

----- Original Message ----- 
From: Kevin Boyle <mailto:[email-masked]>  
To: Pascal Lambers <mailto:[email-masked]>  ; [email-masked]
<mailto:[email-masked]>  

I would think that MGCs would ignore any messages from unregistered MGs that
are not ServiceChanges.  Sending Pendings may only serve to extend a DoS
attack.
 
I do not believe that the use of Pending in this case is typical, either.
In fact, I would say that it is atypical, and in fact, wrong.
 
Kevin

  _____  

From: [email-masked] <mailto:[email-masked]>  on behalf of
Pascal Lambers
Sent: Wed 12/8/2004 1:00 AM
To: [email-masked] <mailto:[email-masked]> 
Subject: Fw: [Megaco] does MGC have to answer?

Hi,
 
Is it mandatory for an MGC to answer to (eg Notify) messages from
unregistered MGs? If the MGC receives such a message, typically, its
underlying Megaco stack will send pending messages to the the MG anyway,
even though the actual MGC does not answer to the message. In other words,
is the following scenario a good one:
 
MG                     MGC

Kind regards,
Pascal

  _____  

  _____