Subject: RE: [Megaco] Statictics in the Network package

From: "CHATRAS Bruno RD-CORE-ISS" <[email-masked]>
Date: Fri, 18 Feb 2005 16:36:16 +0100

Kevin,
 
What about the second question? I don't think it is something that can be left to the implementation.
 
BC
 
________________________________

De : Kevin Boyle [mailto:[email-masked]] 
Envoyé : vendredi 18 février 2005 16:21
À : CHATRAS Bruno RD-CORE-ISS; [email-masked]
Objet : RE: [Megaco] Statictics in the Network package

	I think it would depend upon your implementation.  Note that both Appendix I and the I-D you mention are informational in nature, and are not binding.
	 
	If it isn't possible to keep these counts for a particular termination, then the MG ought to return 0, or some other indication of the lack of counts.
	 
	Kevin

________________________________

		From: [email-masked] [mailto:[email-masked]] On Behalf Of CHATRAS Bruno RD-CORE-ISS
		Sent: Friday, February 18, 2005 9:49 AM
		To: [email-masked]
		Subject: [Megaco] Statictics in the Network package

		Hello, 

		Can someone clarify the following two issues regarding the statistics defined in the Network package: 

		1) Are the Octets Sent/Received statistics applicable to all types of terminations, including analog terminations? 

		2) Does the number of octets include the IP header? 

		I'm inclided to think that these statitics are not applicable to terminations representing analog lines. However, the example call flow of H.248.1 Appendix I seems to have made a different assumption: when the MGC subtract an analog termination (A5555), the MG returns the following:

		Statistics { 
		             nt/os=45123, ; Octets Sent 
		             nt/or=45123, ; Octets Received 
		             nt/dur=40000 ; in milliseconds 
		             } 
		On the other hand, in the examples documented in ftp://ftp.rfc-editor.org/in-notes/internet-drafts/draft-ietf-megaco-callflows-04.txt <ftp://ftp.rfc-editor.org/in-notes/internet-drafts/draft-ietf-megaco-callflows-04.txt> , the nt/os and nt/or statistics are never reported for physical terminations.

		Regards, 
		Bruno 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Mon, 21 Feb 2005 08:27:55 +1100

Hello Bruno,

If the MGC isn't interested in statistics for analogue termination there's a 
couple things it could do.
A new capability in H.248.1v3 is to be able to turn off the collection of 
individual statistics. The other alternative is to suppress the return of 
statistics in the subtract whenever you subtract an analogue line.

Regards, Christian

CHATRAS Bruno RD-CORE-ISS wrote:

>   _____  
> I think it would depend upon your implementation.  Note that both
> Appendix I and the I-D you mention are informational in nature, and are
> not binding.
>  
> If it isn't possible to keep these counts for a particular termination,
> then the MG ought to return 0, or some other indication of the lack of
> counts.
>  
> Kevin
> 
> 
>   _____  
> 
> 1) Are the Octets Sent/Received statistics applicable to all types of
> terminations, including analog terminations? 
> 
> I'm inclided to think that these statitics are not applicable to
> terminations representing analog lines. However, the example call flow
> of H.248.1 Appendix I seems to have made a different assumption: when
> the MGC subtract an analog termination (A5555), the MG returns the
> following:
> 
> Statistics { 
> On the other hand, in the examples documented in
> <ftp://ftp.rfc-editor.org/in-notes/internet-drafts/draft-ietf-megaco-cal
> lflows-04.txt>
> ftp://ftp.rfc-editor.org/in-notes/internet-drafts/draft-ietf-megaco-call
> flows-04.txt, the nt/os and nt/or statistics are never reported for
> physical terminations.
> 
> Regards, 
> Bruno 
> 
> 
> 
> ------------------------------------------------------------------------
>