Subject: [Megaco] autonomous event arming of media gateway

From: "Milton" <[email-masked]>
Date: Sat, 26 Feb 2005 20:58:03 +0530

Hi,

Initially, at the time of startup of the media gateway is it allowed to  arm
certain events for all the terminations without receiving any explicit event
descriptor from MGC ?  I mean, does it in anyway break the conformance with
the protocol?

Regards,

Milton

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Kapil Nayar <[email-masked]>
Date: Sun, 27 Feb 2005 01:40:46 +0000 (GMT)

Hi Milton

I guess you may be referring to some sort of
persistent events which don't need explicitly
specified by the MGC. This is a mechanism allowed in
MGCP only. MEGACO doesn't allow any unsolicited event
reporting by MG, i.e., MGC needs to specify the event
descriptor before MG can notify any event.

thanks,
-kapil

> https://www1.ietf.org/mailman/listinfo/megaco

Send instant messages to your online friends http://uk.messenger.yahoo.com

---

From: Tom Taylor <[email-masked]>
Date: Sun, 27 Feb 2005 08:45:24 -0500

As far as I'm concerned, you can pre-provision the events descriptor just as you 
can other descriptors.  Of course, the implementation has to provide an interface 
to allow this.

Tom Taylor

Milton wrote:
> Hi,
> 
> Initially, at the time of startup of the media gateway is it allowed to 
>  arm certain events for all the terminations without receiving any 
> explicit event descriptor from MGC ?  I mean, does it in anyway break 
> the conformance with the protocol?
> 
>  
> 
> Regards,
> 
> Milton
> 
> 
> ------------------------------------------------------------------------
>

---

From: Kapil Nayar <[email-masked]>
Date: Sun, 27 Feb 2005 16:00:31 +0000 (GMT)

Hi Tom

I couldn't see any mention of pre-provisioning of
descriptors in the protocol document. Although, there
is a mention of provisioning termination Property
values and possibly signal/ event parameter values
which definitely seems more appropriate. 

It would be useful to be explicit in the document
about the provision of pre-provisioning all
descriptors. e.g. in case of event descriptor what
should be the request identifier value in the Notify
request while reporting pre-provisioned events.

I agree this could result in being a very useful
feature if logically understood by the MGC and MG.
But, the micro-level issues need to be addressed -
most of the MGCs that I know of DO explicitly specify
the event descriptor for detection of events - the
logic for detection is built that way. Haven't really
come across any MG/ MGC implementations which allow
pre-provisioning of event descriptor in MG.

thanks,
-kapil

 --- Tom Taylor <[email-masked]> wrote: 
> can other descriptors.  Of course, the
> implementation has to provide an interface 
> to allow this.
> 
> Tom Taylor
> 
> Milton wrote:
> > Hi,
> >