Subject: [Megaco] StreamID.

From: [email-masked]
Date: Wed, 16 Feb 2005 08:44:50 +0200

Hello,

I need a clarification regarding stream id possible values.

 According to H248 V2 corrigendum 1 (03/2004):  "The StreamID shall be in
the range of 1 to 65535". But in the ABNF it is defined as
StreamID = UINT16 (UINT16 = 1*5(DIGIT)  ; %x0-FFFF)

a. In signal/event descriptors, when the even/signal is not related to a
specific stream should we use streamID 1 ? or 0 as mentioned in H248.1 v2?

b. When no stream number was assigned by the MGC, should the MGC use stream
ID 1 as the default one when it has to reply on Audit messages.
Consider the following situation:
 - MG sends Service Change message to MGC.
- MGC replies to Service change
- MGC send Audit capabilities message.
   Should the reply be with stream Id 0, or 1.

I'll appreciate your help on the above.

Thanks, Aliza

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Kapil Nayar <[email-masked]>
Date: Thu, 17 Feb 2005 20:37:12 +0000 (GMT)

Hi Aliza

Kindly, see the responses embedded with KN>>.
thanks,
-kapil

> specific stream should we use streamID 1 ? or 0 as
KN>>
We should use streamID 0....as mentioned by the
protocol document correctly.
>    Should the reply be with stream Id 0, or 1.
KN>>
I think you meant "should the MG use stream...."
instead of "should the MGC...".
Logically, if the MG sends a Service Change message to
MGC...assuming method=restart, the MG terminations
have no active media (streams), the reply would be
with stream ID 0 (or absent). However, since the
protocol allows MGC to send the Audit Capabilities
request at any other operational instance with
streamID (optional) parameter, there is a possibility
of the following scenarios:
1. streamID = non-zero
MG should reply with Audit capabilities for the
specific streamID.
2. streamID = zero
MG should reply with Audit capabilities for non-stream
specific event, signal, properties etc.
3. streamID = absent
MG should reply with Audit capabilities for all valid
existing streamIDs.

NOTE: Protocol doesnot forbid the use of streamID=0 in
media descriptor (stream descriptor). My preference
would be to specifically disallow this usage as this
would clear up the ambiguity.

> I'll appreciate your help on the above.

___________________________________________________________ 
ALL-NEW Yahoo! Messenger - all new features - even more fun! http://uk.messenger.yahoo.com