Subject: Re: [Megaco] autonomous event arming of media gateway

From: Rajkumar Nair <[email-masked]>
Date: Mon, 28 Feb 2005 09:50:29 +0530

Hi Tom,
   What should be the value of Request Id in case of these
pre-provisioned events ?
Do we have to provision the same Request Id at the MGC too ?

Raj.

> 
> As far as I'm concerned, you can pre-provision the events descriptor just as you
> can other descriptors.  Of course, the implementation has to provide an interface
> to allow this.
> 
> Tom Taylor
> 
> Milton wrote:
> > Hi,
> >
> > Initially, at the time of startup of the media gateway is it allowed to
> >  arm certain events for all the terminations without receiving any
> > explicit event descriptor from MGC ?  I mean, does it in anyway break
> > the conformance with the protocol?
> >
> >
> >
> > Regards,
> >
> > Milton
> >
> >

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Aleksandr Ryabin <[email-masked]>
Date: Mon, 28 Feb 2005 11:59:34 -0500

Raj,

The following discussion brought up this same question before.
http://www.ietf.org/mail-archive/web/megaco/current/msg04845.html

Regards,
         Aleks

---

From: Tom Taylor <[email-masked]>
Date: Mon, 28 Feb 2005 14:50:46 -0500

Thanks -- I knew that had been discussed but didn't have the reference at my 
fingertips.

---

From: Kapil Nayar <[email-masked]>
Date: Mon, 28 Feb 2005 21:52:55 +0000 (GMT)

Hi Aleks/ Tom

Thanks for the informational link...a few doubts still
remain.

1. From the example provided by Sampath it seems that
generally not all events are provision-able - the ones
that are shall be explicitly specified by the package
definition. Is it true?

2. The last line of the last e-mail of the thread
(from Carl Rutter) specifies "Provisioned events would
not be allowed.", unless we have some specific text in
the protocol the confusion and questions are ought to
remain - and only proprietary implementations would
use this useful feature. Please correct if I missed
some mail.

Do we expect to see some detailed text about
pre-provisioning of descriptors in general and event
descriptor in particular in the next RFC/ draft?
 
thanks,
-kapil

> >> > As far as I'm concerned, you can pre-provision
> the events descriptor 
> >> just as you
> >> > can other descriptors.  Of course, the
> implementation has to provide 
> >> an interface
> >> > to allow this.
> >> >
> >> > Tom Taylor
> >> >
> >> > Milton wrote:
> >> > > Hi,
> >> > >
> >> > > Initially, at the time of startup of the
> media gateway is it 
> >> allowed to

Send instant messages to your online friends http://uk.messenger.yahoo.com

---

From: Aleksandr Ryabin <[email-masked]>
Date: Mon, 28 Feb 2005 18:39:19 -0500

1. To my knowledge spec does not limit  to any particular events, that is
any set of events can be provisioned in default EventsDescriptor
as long as final EventsDescriptor is valid (i.e. MGC can request it
on a termination in NULL context).

2.
 From RFC 3525 par "3  Definitions"

    Descriptor:
    A syntactic element of the protocol that groups related properties.
    For instance, the properties of a media flow on the MG can be set by
    the MGC by including the appropriate descriptor in a command.

 From RFC 3525 par 6.2.4 Termination properties and descriptors

    Terminations have properties.  The properties have unique
    PropertyIDs. Most properties have default values, which are
    explicitly defined in this protocol specification or in a package
    (see clause 12) or set by provisioning.  If not provisioned
    otherwise, the properties in all descriptors except TerminationState
    and LocalControl default to empty/"no value" when a Termination is
    first created or returned to the null Context.

I think usage of "property" in above two paragraphs create majority of 
confusions.
If you follow the first paragraph's usage then it is very clear from spec 
that descriptors
can be provisioned. I agree it would be beneficial if we can add clarification
to IG that reference to "property" in  the following paragraphs used as defined
in "Descriptor" definition.

 From RFC 3525 par 6.2.4 Termination properties and descriptors

    The provisioning of a property value in the MG will override any
    default value, be it supplied in this protocol specification or in a
    package.  Therefore if it is essential for the MGC to have full
    control over the property values of a Termination, it should supply
    explicit values when ADDing the Termination to a Context.

 From RFC 3525 par "7.2.3 Subtract"
    When a provisioned Termination is Subtracted from a Context, its
    property values shall revert to:

    -  the default value, if specified for the property and not
       overridden by provisioning;

    -  otherwise, the provisioned value.

Regards,
         Aleks