Subject: RE: [Megaco] Move Command Question

From: "Jon Rowland" <[email-masked]>
Date: Fri, 14 Oct 2005 11:01:45 +0100

Sorry, but I don't agree. Nothing about the below text specifically prohibits using CHOOSE (which is effectively a context ID), although I can see that it could be worded more clearly. CHOOSE just asks the MG to create a new context which is a perfectly valid thing to ask it to do on a MOVE request.
 
Moving to CHOOSE is the only way to move a termination into a new context by itself in an atomic fashion. This would be a good way, for example, to implement 'call waiting' function in telephony applications. Using SUBTRACT/ADD doesn't really do the trick as well, because there are various side effects of a subtract, such as resetting of signals and events descriptors.
 
Regards,
Jon.

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of FCG SHI Hao
	Sent: 14 October 2005 01:59
	To: [email-masked]
	Subject: re: [Megaco] Move Command Question

	It doesn't allow a termination to move to the CHOOSE context. "The Context to which the Termination is moved is
	indicated by the target ContextId in the Action." So it should be a specific context with contextID.

		-----原始邮件-----
		发件人: [email-masked] [mailto:[email-masked]]代表 Leonelli, Greg
		发送时间: 2005年10月14日 5:51
		收件人: [email-masked]
		主题: [Megaco] Move Command Question

		Does the spec allow a termination to move to the CHOOSE context ?  I know the spec disallows a move to
		the NULL context.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 14 Oct 2005 10:54:33 -0400

I agree. Look at Figure 2 in section 6 of H.248.1/RFC 3015.  That was
achieved using a MOVE to CHOOSE.

Jon Rowland wrote:
> ------------------------------------------------------------------------
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 14 Oct 2005 10:56:21 -0400

Sorry, should have looked more closely.  I still agree that you can MOVE
to CHOOSE, but the section 6 sequence has nothing to do with it.