Subject: [Megaco] Query on ASN grammer

From: "Deepak Pokharna" <[email-masked]>
Date: Tue, 4 Oct 2005 01:42:16 -0700

Hi 

     According to V2 Draft (ASN Grammar) it says at most one descriptor
is required in list of descriptor in AmmRequest..But it has not made the
descriptors as optional too so it means one Descriptor should be there
in Add, Move and Mod Request. Here it has difference from ABNF grammar
which have made the list of descriptor as optional. Can some one clarify
this.

      Command ::= CHOICE 

      { 

         addReq               AmmRequest, 

         moveReq              AmmRequest, 

         modReq               AmmRequest, 

         -- Add, Move, Modify requests have the same parameters 

         subtractReq          SubtractRequest, 

         auditCapRequest      AuditRequest, 

         auditValueRequest    AuditRequest, 

         notifyReq            NotifyRequest, 

         serviceChangeReq     ServiceChangeRequest, 

         ... 

      } 

      AmmRequest ::= SEQUENCE 

      { 

         terminationID        TerminationIDList, 

         descriptors          SEQUENCE OF AmmDescriptor, 

         -- At most one descriptor of each type (see AmmDescriptor) 

         -- allowed in the sequence. 

         ... 

   Groves et al            Expires - October 2003              [Page
103] 

                         Megaco Protocol version 2            April 2003

      } 

      AmmDescriptor ::= CHOICE 

      { 

         mediaDescriptor         MediaDescriptor, 

         modemDescriptor         ModemDescriptor, 

         muxDescriptor           MuxDescriptor, 

         eventsDescriptor        EventsDescriptor, 

         eventBufferDescriptor   EventBufferDescriptor, 

         signalsDescriptor       SignalsDescriptor, 

         digitMapDescriptor      DigitMapDescriptor, 

         auditDescriptor         AuditDescriptor, 

         ... 

      }

Regards

Deepak

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Fri, 14 Oct 2005 13:06:05 +1000

Hello Depak,

I'm not sure what the problem is. AmmRequest contains a "SEQUENCE OF" 
descriptors. The note simply says that you shouldn't have 2 or more of 
the same descriptors per command. My understanding is that a sequence of 
could be a null sequence.

Christian

Deepak Pokharna wrote:

> Hi
>
>      According to V2 Draft (ASN Grammar) it says at most one 
> descriptor is required in list of descriptor in AmmRequest..But it has 
> not made the descriptors as optional too so it means one Descriptor 
> should be there in Add, Move and Mod Request. Here it has difference 
> from ABNF grammar which have made the list of descriptor as optional. 
> Can some one clarify this.
>
>  
>
>       Command ::= CHOICE
>
>       {
>
>          addReq               AmmRequest,
>
>          moveReq              AmmRequest,
>
>          modReq               AmmRequest,
>
>          */descriptors          SEQUENCE OF AmmDescriptor/*,
>
> *         -- At most one descriptor of each type (see AmmDescriptor) *
>
> *         -- allowed in the sequence. *
>
> *         ... *
>
>    
>
>    
>
>    Groves et al            Expires - October 2003              [Page 103]
>
>
>------------------------------------------------------------------------
>