Subject: [Megaco] ON-OFF signals in signal list

From: Richard Sun <[email-masked]>
Date: Tue, 11 Oct 2005 12:04:46 -0400

Does anyone know if there any reason to disallow
on/off signal in the middle of the signal list?
Is it because that it needs to define
"The duration of a sequential signal list"?

 From implementation point of view, I do not see
any case that the concept of "The duration of a sequential
signal list" can be used, but it is usefull if
on/off signal can be allowed in the middle of
signal list.

Thanks for any insight.
-Richard

QUOTE from H248.1:
A sequential signal list consists of a signal list identifier and a
sequence of signals to be played sequentially. Only the trailing element
of the sequence of signals in a sequential signal list may be an on/off
signal. The duration of a sequential signal list is the sum of the
durations of the signals it contains.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 11 Oct 2005 20:26:29 -0400

It wasn't a question of duration.  We figured you could get into some 
strange situations if you had on/off signals in the middle of the list. 
  It would be hard to specify consistent behaviour.

---

From: Richard Sun <[email-masked]>
Date: Fri, 14 Oct 2005 15:49:47 -0400

Tom, Thanks for your reply.

What would you suggest to accomplish the following
sequential actions:
1) sig1, which is an on/off signal (e.g., xal/las)
2) within 50ms after sig1, play sig2, (e.g. altert/ri).

Signal list can not be used since sig1 is on/off.

Multiple signals can not be used since multiple signals
shall be played simultaneously.

Multiple messages can not be used since there is
a 50ms timing restriction.
H248.1 says: "Production of a signal on a termination
is stopped by application of a new SignalsDescriptor":
After Signals{xal/las}, what should MG do when
it receives a new SignalDescriptor, say Signals{},
or Signals{altert/ri}?
Should MG perform normal polarity?

My requirement is that reverse polarity should be
maintained untill MGC explicity asks MG to go back to
normal polarity. So I'll use H248.34. Just need to find
out the standard to perform a sequential
reversePolarity,then ringing.

-Richard

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Sat, 15 Oct 2005 16:12:09 -0400

How about two Modify commands in the same transaction, one restoring 
normal polarity, the other applying the ringing?

---

From: Richard Sun <[email-masked]>
Date: Mon, 17 Oct 2005 11:49:31 -0400

> normal polarity, the other applying the ringing?

Tom,
There are two issues here:

1. My polarity must be kept reversed while ringing.
    With two Modify commands, the 1st one contains
    Signals{xal/las}, the 2nd one contains Signals{altert/ri},
    how to interpret this requirement from H248.1:
    "Production of a signal on a termination
    is stopped by application of a new SignalsDescriptor".
    What does "is stopped" mean here for on-off signals
    such as xal/las?

2. A general need is a standard to
    accomplish the following two actions sequentially:
    1) apply an on/off signal sig1 (e.g., xal/las)
    2) delay X millisec
    3) apply sig2, (e.g. ringing)

    H248v3 defines an inter signal delay, which is great.
    So if SignalList{sig1,sig2} had been allowed for on-off sig1,
    then it would have been perfect. But H248v3 still restrict
    "Only the trailing element of the sequence of signals in a
    sequential signal list may be an on/off signal."

It would be great to hear any comments of the standard
for above two issues.
Thanks a lot for your helpfull discussions.

-Richard