Subject: RE: [Megaco] ON-OFF signals in signal list

From: "Jon Rowland" <[email-masked]>
Date: Mon, 17 Oct 2005 17:01:00 +0100

How sensitive is the value of X in your delay between the signals? Could
the MGC run the timer and specify two subsequent Modifies in two
Transactions:

First transaction:
Modify: Signals {xal/las}

Second transaction:
Modify: Signals {xal/las{KA}, alert/ri}    (using the keep-active flag
so you don't restart the las signal).

Then later when you want to turn off ringing and/or switch polarity, you
can do something similar.

Slightly hokey, and depends on the intersignal delay not being a very
sensitive value, but could do the trick.

Regards,
Jon.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Richard Sun
Sent: 17 October 2005 16:50
To: Tom-PT Taylor
Cc: [email-masked]
Subject: Re: [Megaco] ON-OFF signals in signal list

> How about two Modify commands in the same transaction, one restoring 
> normal polarity, the other applying the ringing?

Tom,
There are two issues here:

1. My polarity must be kept reversed while ringing.
    With two Modify commands, the 1st one contains
    Signals{xal/las}, the 2nd one contains Signals{altert/ri},
    how to interpret this requirement from H248.1:
    "Production of a signal on a termination
    is stopped by application of a new SignalsDescriptor".
    What does "is stopped" mean here for on-off signals
    such as xal/las?

2. A general need is a standard to
    accomplish the following two actions sequentially:
    1) apply an on/off signal sig1 (e.g., xal/las)
    2) delay X millisec
    3) apply sig2, (e.g. ringing)

    H248v3 defines an inter signal delay, which is great.
    So if SignalList{sig1,sig2} had been allowed for on-off sig1,
    then it would have been perfect. But H248v3 still restrict
    "Only the trailing element of the sequence of signals in a
    sequential signal list may be an on/off signal."

It would be great to hear any comments of the standard
for above two issues.
Thanks a lot for your helpfull discussions.

-Richard

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Richard Sun <[email-masked]>
Date: Mon, 17 Oct 2005 12:30:12 -0400

Jon,

Thanks for the trick.  Signals {xal/las{KA}, alert/ri}
is good enough for my case without CallerID.

About the sensitivity of X, short answer is very sensitive:
it is really about caller ID application.
I've read the andisp/dwa thread, and agree that
andisp/dwa is a good signal to leave many details
to implementor. But now I need to combine
{xal/las{KA}, andisp/dwa}
with a very sensitive inter signal delay.
I'd like to avoid to implement andisp/dwa in such way that
reverse polarity is implicit (because in most regions
reverse polarity is not needed).
Any more suggestions?

Thanks,
-Richard