Subject: Re: [Megaco] ON-OFF signals in signal list

From: "Stephen Mell" <[email-masked]>
Date: Tue, 18 Oct 2005 10:21:11 +0100

> > How about two Modify commands in the same transaction, one restoring 
> > normal polarity, the other applying the ringing?

> Tom,
> There are two issues here:

> 1. My polarity must be kept reversed while ringing.
>     With two Modify commands, the 1st one contains
>     Signals{xal/las}, the 2nd one contains Signals{altert/ri},
>     how to interpret this requirement from H248.1:
>     "Production of a signal on a termination
>     is stopped by application of a new SignalsDescriptor".
>     What does "is stopped" mean here for on-off signals
>     such as xal/las?

> 2. A general need is a standard to
>     accomplish the following two actions sequentially:
>     1) apply an on/off signal sig1 (e.g., xal/las)
>    2) delay X millisec
>    3) apply sig2, (e.g. ringing)

>    H248v3 defines an inter signal delay, which is great.
>     So if SignalList{sig1,sig2} had been allowed for on-off sig1,
>     then it would have been perfect. But H248v3 still restrict
>     "Only the trailing element of the sequence of signals in a
>     sequential signal list may be an on/off signal."

> It would be great to hear any comments of the standard
> for above two issues.
> Thanks a lot for your helpfull discussions.

> -Richard

There are drawbacks with the On/Off disposition of some of these steady 
state DC signals; it would seem
to imply that the line condition returns to "idle" when that signal is 
stopped (or completes if it is 
changed to a timeout disposition). In your case that is not what you 
require, as the reversal condition 
should persist throughout the next signal.

Really you need a signal that is defined (or can meaningfully have its 
disposition changed to) brief, such
that its duration as a brief signal is merely the time it takes to switch 
to the new line condition.
In this case the line condition would actually persist until it is 
explicitly removed. So a package which 
explicitly describes all possible line conditions would be required, so 
that you can remove the reversal 
at the end of ringing, if you need to.

H.248.34 goes some way to doing this by describing all the line 
conditions, but this only really defines
behaviour as OnOff, and would again imply that a "default/idle" DC line 
condition is applied when the signal
is replaced. In practice MGs may very well let the existing DC "stedsig" 
line condition remain during 
the period that subsequent signals like ringing are made, until a specific 
change is made to the line 
condition, but it is far from clear that that is the correct way to 
behave.

I see that you are not trying to indicate called party answer by sending 
"xal/las", but are instead simply 
trying to effect a line reversal (to wake up a ringer amp?), and then 
start other signals in parallel. This seems 
to be partly the reason why the signal is causing you problems. 

I'd be tempted to use a signal that is less purpose-specific, I wouldn't 
be surprised to find that some MGs 
failed to apply "xal/las" in the face of an on-hook line condition.

Steve 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: suker davor <[email-masked]>
Date: Tue, 18 Oct 2005 14:10:51 +0800

HI,
Could the 'keepactive flag' can be used for issue 1?

---

From: Richard Sun <[email-masked]>
Date: Tue, 18 Oct 2005 10:49:07 -0400

One more question on H248.34 and the following text in H248.1:
"Production of a signal on a termination
is stopped by application of a new SignalsDescriptor".

Consider the following 2 scenarios, where the SignalDescriptors
are received in the sequential order.

Scenario1:
   Signals{stimal/stedsig{sig=reversePolarity}}
   Signals{stimal/stedsig{sig=normalPolarity}}}
   Signals{}

Scenario2:
   Signals{stimal/stedsig{sig=reversePolarity}}
   Signals{}

The end result of the line for Scenario2 should be
normal polarity, right?

What should be the end result of the line for
Scenario1?

I noticed some discussions regarding returning
provisioned default value for Subtract.
One may also argue that Signal{} should
return to default for all signals.
But even so, what about the end result
of the polarity in the following:

Scenario3:
   Signals{stimal/stedsig{sig=reversePolarity}}
   Signals{stimal/stedsig{sig=normalPolarity}}}
   Signals{alert/ri}

-Richard

---

From: "Stephen Mell" <[email-masked]>
Date: Wed, 19 Oct 2005 13:51:06 +0100

Hi richard,

We are making an assumption here that there is a default line state that 
will be applied when all signals are removed.

Now that default could be "idle" (normal polarity) or perhaps "parked" 
(reduced battery).

With signals like "ringing" it is more obvious what the default line state 
is ( "not ringing!!!!" ). But with the DC line conditions it is not.

I don't think that stimal package provides much guidance.

I think a lot of Analogue Gateways will allow the DC line condition 
(wherever possible) to persist during the application of further signals, 
but that is down to implementation.

Thats why it should really be possible to modify the signal type to brief, 
and the package should allow this and describe its behaviour: 

{
  stimal/stedsig{sig=reversePolarity, SY=BR}, 
  alert/ri
}

so that you can put this anywhere in a signal list. Then the polarity is 
reversed during alert/ri and remains reversed until something explicitly 
change it back, or a signal is played

which implicitly requires a change in line state.

Steve