Subject: [Megaco] Move Command Question

From: "Leonelli, Greg" <[email-masked]>
Date: Thu, 13 Oct 2005 17:50:37 -0400

Does the spec allow a termination to move to the CHOOSE context ?  I know the spec disallows a move to
the NULL context.
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "FCG SHI Hao" <[email-masked]>
Date: Fri, 14 Oct 2005 08:59:11 +0800

It doesn't allow a termination to move to the CHOOSE context. "The Context to which the Termination is moved is
indicated by the target ContextId in the Action." So it should be a specific context with contextID.

-----????-----
???: [email-masked] [mailto:[email-masked]]?? Leonelli, Greg
????: 2005?10?14? 5:51
???: [email-masked]
??: [Megaco] Move Command Question

---

From: "Julio Martinez Minguito" <[email-masked]>
Date: Fri, 14 Oct 2005 09:17:41 +0000

Hi:

We have the opinion that it's valid to move a termination to a choose 
context.
The GW shall create a new context for that moved termination, and indicate 
the new context id in the command reply.

/Julio

Date: Fri, 14 Oct 2005 08:59:11 +0800
From: "FCG SHI Hao" <[email-masked]>
Subject: re: [Megaco] Move Command Question
To: <[email-masked]>
Message-ID:
	<[email-masked]>
Content-Type: text/plain; charset="iso-8859-1"

It doesn't allow a termination to move to the CHOOSE context. "The Context 
to which the Termination is moved is
indicated by the target ContextId in the Action." So it should be a specific 
context with contextID.

    -----&#21407;&#22987;&#37038;&#20214;-----
    &#21457;&#20214;&#20154;: megaco-bounces at ietf.org 
[mailto:megaco-bounces at ietf.org]&#20195;&#34920; Leonelli, Greg
    &#21457;&#36865;&#26102;&#38388;: 2005&#24180;10&#26376;14&#26085; 5:51
    &#25910;&#20214;&#20154;: megaco at ietf.org
    &#20027;&#39064;: [Megaco] Move Command Question

   Does the spec allow a termination to move to the CHOOSE context ?  I know 
the spec disallows a move to
    the NULL context.

---

From: "Kamitses, Jerry" <[email-masked]>
Date: Fri, 14 Oct 2005 10:46:47 -0400

The consensus seems to have come down on the side of allowing CHOOSE for the context 
ID in a move command.  In particular, this allows sending an action with context ID CHOOSE 
containing a combination of ADD commands (to terminations in the NULL context) and MOVE 
commands (to terminations in a non-NULL context). I only mention this point since, from 
this perspective, it becomes a little more apparent that this is both a reasonable and useful 
capability.  
 
As for the SUBTRACT/ADD alternative, another item for the list of missing tricks here is that 
this option is a non-starter for an ephemeral termination, since SUBTRACT instantly kills them.
So now this becomes a reasonable, useful, and essential capability.  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Jon Rowland
Sent: Friday, October 14, 2005 6:02 AM
To: FCG SHI Hao; [email-masked]
Subject: RE: [Megaco] Move Command Question

Sorry, but I don't agree. Nothing about the below text specifically prohibits using CHOOSE (which is effectively a context ID), although I can see that it could be worded more clearly. CHOOSE just asks the MG to create a new context which is a perfectly valid thing to ask it to do on a MOVE request.
 
Moving to CHOOSE is the only way to move a termination into a new context by itself in an atomic fashion. This would be a good way, for example, to implement 'call waiting' function in telephony applications. Using SUBTRACT/ADD doesn't really do the trick as well, because there are various side effects of a subtract, such as resetting of signals and events descriptors.
 
Regards,
Jon.

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of FCG SHI Hao
Sent: 14 October 2005 01:59
To: [email-masked]
Subject: re: [Megaco] Move Command Question

---

From: "Jon Rowland" <[email-masked]>
Date: Mon, 17 Oct 2005 11:11:22 +0100

You're making a lot of assumptions about the call waiting scenario there.
- What if the call doesn't involve any RTP stream - there'd be no SDP to change - could just be three physical terminations on the same MG.
- What if you aren't using a media server to play music, or indeed, aren't playing music at all, but silence, or an announcement, and the MG has the capabilities to play it directly on the endpoint.

Remember that just because you can see one way to implement some function doesn't mean the protocol doesn’t need to more flexible - it's trying to cover all eventualities.

Glad we've resolved the confusion over the support for MOVE-CHOOSE anyway!

Cheers,
Jon.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of FCG SHI Hao
Sent: 17 October 2005 03:01
To: [email-masked]
Subject: RE: [Megaco] Move Command Question

I don't know the application case which needs to move the termination to a CHOOSE context. As I know, the "call waiting" service doesn't need the MOVE command, it only uses the "Modify" command to modify the waiting user's SDP to point to the Media Server's music resource, let it listen to the music.

But I believe it should be my misunderstanding on the protocol text. I agree the "Move" and "Subtract" have different effects on the terminations. Sorry for my previous answer.

 I suggest to add the CHOOSE allowance of Move command in the protocol directly for the possible application cases.

-----原始邮件-----
发件人: Tom-PT Taylor [mailto:[email-masked]]
发送时间: 2005年10月14日 22:56
抄送: Jon Rowland; FCG SHI Hao; [email-masked]
主题: Re: [Megaco] Move Command Question

Sorry, should have looked more closely.  I still agree that you can MOVE
to CHOOSE, but the section 6 sequence has nothing to do with it.

Tom Taylor wrote:
> I agree. Look at Figure 2 in section 6 of H.248.1/RFC 3015.  That was
> achieved using a MOVE to CHOOSE.
> 
> Jon Rowland wrote:
> 
>>________________________________
>>
>>------------------------------------------------------------------------
>>