Subject: RE: [Megaco] TimeStamp format

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 7 Nov 2005 13:30:39 -0500

Many events can occur within the bounds of a second.  By making it four
digits, fractions of a second can be indicated.  Please see the
definition in ISO 8601:1988 (This reference is taken straight from the
ABNF encoding.)

Yes, there are MGCs that make use of the timestamp.  There are many
possible uses, including rebuilding event ordering in a lossy or
high-latency network.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Richard Sun
Sent: Monday, November 07, 2005 11:35 AM
To: [email-masked]
Subject: [Megaco] TimeStamp format

In the defination of TimeStamp
yyyymmddThhmmssss
why ssss is 4-digit?

Does any MGC really make use of the TimeStamp in the
ObservedEventsDescriptor?

Thanks for any info.
-Richard

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Richard Sun <[email-masked]>
Date: Thu, 10 Nov 2005 11:32:10 -0500

> definition in ISO 8601:1988 (This reference is taken straight from the

Kevin,
Thanks for the info. Looking into ISO8601,
here seems to me the related text:
<QUOTE>
The number of digits in the decimal fraction shall be determined by the 
interchange parties, dependent upon the
application. The format shall be [hhmmss,ss], [hhmm,mm] or [hh,hh] as 
appropriate (hour minute second, hour minute
and hour, respectively), with as many digits as necessary following the 
decimal sign.
</QUOTE>

So in H248, "The number of digits in the decimal fraction" is fixed
to 2 (the last two ss in hhmmssss).
So is it correct to interpret H248 timestamp
yyyymmddThhmmssss as
yyyymmddThhmmss,ss
?

So 20011030T11223350 should mean
2001-10-30 11:22:33 0.50sec=(500ms)?

So 20011030T11223305 should mean
2001-10-30 11:22:33 0.05sec=(50ms)?

-Richard