Subject: [Megaco] context ALL and requests for wildcard response

From: "John Fisher" <[email-masked]>
Date: Tue, 8 Nov 2005 17:22:50 +1100

Dear Megaco members,

Suppose an action for all contexts contains two commands, one command
requests
a wildcard response, and the other does not. For example
TRANSACTION = 81573 {
  CONTEXT = * {
    W-SUBTRACT = rtp/* { <descriptors omitted> },
    MODIFY = al/* { <descriptors omitted> }
  }
}

I can think of a few different ways for an MG to handle this situation.

1. Perhaps it could be argued that the action contradicts itself, that
commands in an action for all contexts should either all request the
wildcard response or none of them request the wildcard response, so the
appropriate response would be an error code perhaps
REPLY = 81573 {
  CONTEXT = * { ERROR = 443 }
}

2. Honour the request for the wildcard response only at the command level
and not at the
action level in this situation.
REPLY = 81573 {
  CONTEXT = 1 {
    SUBTRACT = rtp/* { <descriptors omitted> },
    MODIFY = al/1 { <descriptors omitted> },
    MODIFY = al/2 { <descriptors omitted> }
  },
  CONTEXT = 2 {
    SUBTRACT = rtp/* { <descriptors omitted> },
    MODIFY = al/3 { <descriptors omitted> }
  }
}

This would mean that the entire action would need to be examined before
building the response to any particular command.

3. Start a new action in the response for each change in wildcard response
requested/wildcard response not requested in the list of commands: eg.
REPLY = 81573 {
  CONTEXT = * {
    SUBTRACT = rtp/* { <descriptors omitted> }
  },
  CONTEXT = 1 {
    MODIFY = al/1 { <descriptors omitted> },
    MODIFY = al/2 { <descriptors omitted> }
  },
  CONTEXT = 2 {
    MODIFY = al/3 { <descriptors omitted> }
  }
}

What is the recommendation?

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 8 Nov 2005 13:46:08 -0500

Option 3 would be the way to go.  Note that wildcarded action requests
generally expect multiple action replies, so going with option 3 should
not cause any problems.

Kevin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of John Fisher
Sent: Tuesday, November 08, 2005 1:23 AM
To: [email-masked]
Subject: [Megaco] context ALL and requests for wildcard response

Dear Megaco members,

Suppose an action for all contexts contains two commands, one command
requests a wildcard response, and the other does not. For example
TRANSACTION = 81573 {
  CONTEXT = * {
    W-SUBTRACT = rtp/* { <descriptors omitted> },
    MODIFY = al/* { <descriptors omitted> }
  }
}

appropriate response would be an error code perhaps REPLY = 81573 {

2. Honour the request for the wildcard response only at the command
level and not at the action level in this situation.
REPLY = 81573 {
  CONTEXT = 1 {
    SUBTRACT = rtp/* { <descriptors omitted> },
    MODIFY = al/1 { <descriptors omitted> },
    MODIFY = al/2 { <descriptors omitted> }
  },
  CONTEXT = 2 {
    SUBTRACT = rtp/* { <descriptors omitted> },
    MODIFY = al/3 { <descriptors omitted> }
  }
}

3. Start a new action in the response for each change in wildcard
response requested/wildcard response not requested in the list of
commands: eg.
REPLY = 81573 {
  CONTEXT = * {
    SUBTRACT = rtp/* { <descriptors omitted> }
  },
  CONTEXT = 1 {
    MODIFY = al/1 { <descriptors omitted> },
    MODIFY = al/2 { <descriptors omitted> }
  },
  CONTEXT = 2 {
    MODIFY = al/3 { <descriptors omitted> }
  }
}