Subject: RE: [Megaco] inconsistency in the ASN and ABNF grammars on the MEGACOfor the termination ID

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 22 Nov 2005 16:49:21 -0500

This was changed in Version 3.  TermIDLists are now allowed in both ABNF
and ASN.1.

Kevin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Taylor, Tom-PT [CAR:5N00:EXCH]
Sent: Tuesday, November 22, 2005 3:44 PM
To: Ganesh Kumar
Cc: [email-masked]; Rashim Anand; Pankaj Kumar
Subject: Re: [Megaco] inconsistency in the ASN and ABNF grammars on the
MEGACOfor the termination ID

I think you'll find a comment with the ASN.1 that the length of the
TerminationIDList is 1.

Ganesh Kumar wrote:
> Hello,
> 
>  
> 
>             Here I have some question regarding the termination id.
> 
>  
> 
>             The termination id interpretation in ABNF and ASN are 
> different.
> 
>  
> 
> Here I am giving the interpretation of termination id in ABNF and ASN
> 
>  
> 
> ABNF
> 
>  
> 
> ammRequest           = (AddToken / MoveToken / ModifyToken ) EQUAL  
> 
>                              TerminationID [LBRKT ammParameter *(COMMA
> 
>                              ammParameter) RBRKT]
> 
>  
> 
>  
> 
>       TransactionID        = UINT32
> 
>       TerminationID        = "ROOT" / pathNAME / "$" / "*" 
> 
>        
> 
>       terminationIDList  = LBRKT TerminationID *(COMMA TerminationID) 
> RBRKT
> 
>  
> 
>  
> 
> ASN
> 
>  
> 
>      AmmRequest ::= SEQUENCE
> 
>       {
> 
>          terminationID        TerminationIDList, 
> 
>          descriptors          SEQUENCE OF AmmDescriptor, 
> 
>          -- At most one descriptor of each type (see AmmDescriptor)
> 
>          -- allowed in the sequence. 
> 
>          ...
> 
>       }
> 
>  
> 
> WildcardField ::= OCTET STRING(SIZE(1))
> 
>        
> 
>       TerminationID ::= SEQUENCE
> 
>       {
> 
>          wildcard       SEQUENCE OF WildcardField,  
> 
>          id             OCTET STRING(SIZE(1..8)), 
> 
>          ... 
> 
>       }
> 
>       -- See A.1 for explanation of wildcarding mechanism. 
> 
>       -- Termination ID 0xFFFFFFFFFFFFFFFF indicates the ROOT 
> Termination.
> 
>        
> 
>       TerminationIDList ::= SEQUENCE OF TerminationID
> 
>  
> 
>  
> 
>  
> 
> In the ABNF the AmmRequest contains terminationID but in the ASN 
> AmmRequest contains terminationIDList.
> 
>  
> 
>  
> 
> Then how to make both consistent?
> 
>  
> 
> Thanks,
> 
> Ganesh
> 
> 
> 
> 
> ----------------------------------------------------------------------
> --
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Sat, 26 Nov 2005 12:16:28 -0500

There are many restrictions on the encoding that are not contained
within the syntax -- you have to read the actual text of the spec to
determine that it is not legal to send a ServiceChange Method of
Disconnected on a non-Root termination, for example.  If you read the
spec text, you will know that multiple wildcards in the ASN is a
violation of the specification.

There is no way to catch every encoding problem in side a parser.  Some
post-parsing processing will have to occur to catch all the possible
errors.  Mismatches between context and termination come to mind as a
primary example.

Kevin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Ganesh Kumar
Sent: Wednesday, November 23, 2005 8:05 AM
To: Taylor, Tom-PT [CAR:5N00:EXCH]
Cc: [email-masked]; Rashim Anand; Pankaj Kumar
Subject: RE: [Megaco] inconsistency in the ASN and ABNF grammars on the
MEGACOfor the termination ID

Hello,
	The problem is not with the number of termination ids but with
in the termination id the presence of wildcard and termination id.

	In ASN the termination id contains both wildcard and termination
id as mandatory and wildcard is sequence of that means more than one
wildcard can occur.
	In ABNF the termination id contains choice of wildcard,
pathname, root fields. So in ABNF the termination contains either
wildcard or termination id.

	Here how to make it consistent?

Regards,
Ganesh

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Wednesday, November 23, 2005 2:14 AM
To: Ganesh Kumar
Cc: [email-masked]; Rashim Anand; Pankaj Kumar
Subject: Re: [Megaco] inconsistency in the ASN and ABNF grammars on the
MEGACO for the termination ID

> Then how to make both consistent?
------------------------------------------------------------------------