Subject: RE: [Megaco] RequestID in EventsDescriptor

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 7 Nov 2005 13:51:47 -0500

Comments inline. [KJBII]
 
Kevin

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Tonny Kung
	Sent: Friday, October 21, 2005 6:52 AM
	To: [email-masked]
	Subject: [Megaco] RequestID in EventsDescriptor

	Hi All,
	 
	I have some doubts regarding the use of RequestID = 0.
	 
	1) Is it allowed for the MGC to arm an event in the MG with
RequestID set to 0?
	[KJBII] Generally, no. 
	 
	2) When an event is not armed by the MGC, but provisioned in the
MG, what RequestID should the MG use in the Notify message? 
	From reading H.248.1 section 7.2.7 Notify, I'm assuming it
should be 0. But then it stated the use of RequestID = 0 is for further
study. 
	[KJBII] The common understanding is that 0 is used when the MG
has preprovisioned events in the Events Descriptor.  It is the MGC's
prerogative to accept or reject Notify Commands with a RequestID of 0 as
it sees fit. 
	 
	I would appreciate if someone can clarify that.
	 
	Thanks,
	Tonny

	_______________________________________
	想即時收到新 email 通知？
	下載 Yahoo! Messenger http://messenger.yahoo.com.hk 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Mon, 14 Nov 2005 08:11:14 +0100

Tonny,

just some complementary info:

In § 6.2.5/H.248.1 V3 was following text added in order to clarify the
RequestID in case of provisioned Events:

   ...

   The provisioning of Events Descriptors would include the RequestID to
   use and any parameters of the included events. Any provisioning in the
   MG with respect to Events Descriptors should be duplicated in the MGC to
   avoid error responses to Notify Commands from the MG.

   ...

- Albrecht

                      "Kevin Boyle"                                                                                             
                      <[email-masked]         To:      <[email-masked]>, <[email-masked]>                     
                      om>                      cc:                                                                              
                      Sent by:                 Subject: RE: [Megaco] RequestID in EventsDescriptor                              
                      megaco-bounces@i                                                                                          
                      etf.org                                                                                                   

                      07.11.2005 19:51                                                                                          

Comments inline. [KJBII]

Kevin

             Hi All,

             2) When an event is not armed by the MGC, but provisioned in
the

             Thanks,
             Tonny