Subject: RE: [Megaco] Service change request from MGC

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 17 Nov 2005 17:39:21 -0500

Terminations are inservice by default upon association.  The MG then has
to indicate which terminations are NOT inservice using subsequent SC
Commands.

Generally, the MG and the MGC track the ServiceState of the termination
independently.  Only when both entities permit a termination to be
inservice will it have service.   If the MGC takes a particular term
OOS, the MGC can be expected to put the term back into service.  This
would hold true for the MG as well.  This allows such things as local
maintenance action to be triggered by either the MGC or MG.

Kevin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Artie Mistler
Sent: Thursday, November 17, 2005 4:21 PM
To: [email-masked]
Subject: RE: [Megaco] Service change request from MGC

If I may, I have an expansion on the original question, for the forum.

>From the MG perspective, it appears that the MGC can take physical
terminations out of service and then put them back into service.

If this is done, does the MG retain the out of service setting over any
of:
a reboot, a failed and recovered association, or redirected association?

Is there ever a case where a MGC gets an association with a MG and the
MGC puts physical terminations into service on the MG?  That doesn't
seem to make sense because how would it know what the MG physical
terminations were until it received service changes for the
terminations.  But service change can be sent by the MGC to MG to either
put terminations into, or out of service.  I'm just hoping that these
actions only occur when it first takes known terminations out of
service, and then puts them back into service.

Regards,
- RT

Artie Mistler, "RT"
Performance Technologies, Inc. 
Voice Technology Group
315 Norwood Park
Norwood, MA  02062
(781) 751-2415
Fax: (781) 751-2470
[email-masked] 

Visit our web site at: <http://www.pt.com> 

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Wednesday, November 16, 2005 5:00 PM
To: Ho, Ron; [email-masked]
Subject: RE: [Megaco] Service change request from MGC

Yes.
 
Kevin

________________________________

	From: Ho, Ron [mailto:[email-masked]] 
	Sent: Wednesday, November 16, 2005 11:53 AM
	To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked]
	Subject: RE: [Megaco] Service change request from MGC

	Thanks Kevin. Does it apply to all v1, v2 and v3?

	Cheers,

	Ron

	-----Original Message-----
	From: Kevin Boyle [mailto:[email-masked]] 
	Sent: Wednesday, November 16, 2005 11:47 AM
	To: Ho, Ron; [email-masked]
	Subject: RE: [Megaco] Service change request from MGC

	Yes.  Only Failover and Disconnected are prohibited to MGCs.

	Kevin 

________________________________

		From: [email-masked]
[mailto:[email-masked]] On Behalf Of Ho, Ron
		Sent: Wednesday, November 16, 2005 10:36 AM
		To: [email-masked]
		Subject: [Megaco] Service change request from MGC

		Hi All,

		I am new to Megaco. Here is my simple question.

		Are we allowed to send SC from MGC to MG besides using
the Handoff method or custom method?

		Can we send a SC with Restart method and 900 reason code
from MGC to MG?

		Thanks,

		Ron

		Ron Ho | Software Engineer
		email - [email-masked] | dir +1 905 948 7061
		 
		Navtel Communications Inc. | 55 Renfrew Drive, Markham,
Ontario, Canada L3R 8H3
		web www.navtelcom.com <http://www.navtelcom.com/>  | tel
+1 905 479 8090 | fax +1 905 475 6524

		 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "B Venkat S.R Swamy" <[email-masked]>
Date: Fri, 18 Nov 2005 12:19:44 +0530

Hi
Just to complement this, V3 has added the optional
ServiceChangeIncompleteFlag in the ServiceChange Descriptor wherein MG has
the option to indicate MGC about the status of the MG terminations at the
time of Registration, thereby refraining the MGC on sending the commands on
the terminations which are still in "OutOfService" state. For details of
the feature refer the section 7.2.8.1.10 of the H248.1 V3 as on Sep2005.

regards
B Venkat S.R Swamy
Senior Technical Leader
Flextronics Software Systems
Phone:  +91-124- 5176333 extn 5113
Fax: +91-124-2455345
web: www.flextronicssoftware.com

             "Kevin Boyle"                                                 
             <[email-masked]                                             
             m>                                                         To 
             Sent by:                  "Artie Mistler" <[email-masked]>,  
             megaco-bounces@ie         <[email-masked]>                   
             tf.org                                                     cc 
                                                                           
                                                                   Subject 
             11/18/2005 04:09          RE: [Megaco] Service change request 
             AM                        from MGC                            

                                                                           

Kevin

-----Original Message-----

Regards,
- RT

Artie Mistler, "RT"

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Wednesday, November 16, 2005 5:00 PM
To: Ho, Ron; [email-masked]
Subject: RE: [Megaco] Service change request from MGC

Yes.

Kevin

             Cheers,

             Ron

             -----Original Message-----

             Kevin

                         Hi All,

                         Are we allowed to send SC from MGC to MG besides
using
the Handoff method or custom method?

                         Can we send a SC with Restart method and 900
reason code
from MGC to MG?

                         Thanks,

                         Ron

                         Navtel Communications Inc. | 55 Renfrew Drive,
Markham,
Ontario, Canada L3R 8H3
                         web www.navtelcom.com <http://www.navtelcom.com/>
| tel
+1 905 479 8090 | fax +1 905 475 6524

***********************  FSS-Restricted   ***********************
"DISCLAIMER: This message is proprietary to Flextronics Software
Systems Limited (FSS) and is intended solely for the use of the
individual to whom it is addressed. It may contain  privileged or
confidential information and should not be circulated or used for
any purpose other than for what it is intended. If you have received
this message in  error, please notify the originator immediately.
If you are not the intended recipient, you are notified that you are
strictly  prohibited  from  using, copying, altering, or disclosing
the contents of this message.  FSS  accepts no  responsibility  for
loss or damage arising from the use of  the information transmitted
by this email including damage from virus."