Subject: [Megaco] A question about DTMF erasion

From: [email-masked]
Date: Thu, 24 Nov 2005 20:16:00 +0800

Hi:

  These days we encoute with such a problem: the caller recevied repeated 
numbers due to the missunderstanding of DTMF erasion.
 
  If Softswitch has requested MG to collect numbers , should MG 
automatically enable DTMF erasion?
 
  Is any packets defining enbable/disable MG's DTMF erasion?

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Sat, 26 Nov 2005 12:21:52 -0500

Once a digit is reported to the MGC, I cannot think of a case where the
MG should transmit that digit again.  There are explicit statements in
the digit collection rules about when to hold digits and when to discard
them.
 
Kevin

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of [email-masked]
	Sent: Thursday, November 24, 2005 7:16 AM
	To: [email-masked]
	Subject: [Megaco] A question about DTMF erasion

	Hi: 
	
	  These days we encoute with such a problem: the caller recevied
repeated numbers due to the missunderstanding of DTMF erasion.

---

From: [email-masked]
Date: Tue, 29 Nov 2005 12:49:35 +0800

Hi Kevin: 
   I think You may have misunderstood my question. May be I have not 
clearified the 
situation.

   What I mean is : One MG has been requested to collect digits, and The 
MG detects 
a digit from the user's sending media stream. Then MG report the digit to 
MGC by 
signaling or hold the digit . But what confused me is whether the MG should 
automatically erase the DTMF signal from the sending media stream or Not.
 
   If the MG do not erase the DTMF signal from the sending media stream, 
The called 
may receive repeated numbers: One from signaling, the other comes from The 
caller's 
Media stream.
 
   I wonder if there are some rules defining how to handle this kind of 
situation.
 
   Looking forward to your reply! 
 
   BEST REGARD!

   ShiCao
Message: 3
Date: Sat, 26 Nov 2005 12:21:52 -0500
From: "Kevin Boyle" <[email-masked]>
Subject: RE: [Megaco] A question about DTMF erasion
To: <[email-masked]>, <[email-masked]>
Message-ID: <34B3EAA5B3066A42914D28C5ECF5FEA4055D11DB@zrtphxm2>

Kevin

                 From: [email-masked] 
[mailto:[email-masked]]
On Behalf Of [email-masked]
                 Sent: Thursday, November 24, 2005 7:16 AM
                 To: [email-masked]
                 Subject: [Megaco] A question about DTMF erasion

                 Hi: 
 
                   These days we encoute with such a problem: the caller 
recevied
repeated numbers due to the missunderstanding of DTMF erasion. 
 
                   If Softswitch has requested MG to collect numbers , 
should MG
automatically enable DTMF erasion? 
 
                   Is any packets defining enbable/disable MG's DTMF 
erasion?