Subject: RE: [Megaco] Parameter ID Scope

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 16 Nov 2005 17:02:07 -0500

If you look at all the packages defined for H.248, ParameterID
namespaces are unique only within the item for which they are
parameters.  Because a signal and an event cannot appear in the same
descriptor, there is no way to confuse parameters with IDs that are
common between them.
 
Kevin

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Frank Reno
	Sent: Wednesday, November 16, 2005 3:45 PM
	To: [email-masked]
	Subject: [Megaco] Parameter ID Scope

	 H.248.16 defines the following parameters for xdd/xce
	
	bc    0x0001
	ds    0x0001
	xdd   0x0002
	meth  0x0002
	mp    0x0003
	extra 0x0003
	
	and the following for edd/mce
	
	bc    0x0001
	ds    0x0001
	meth  0x0002
	
	Doesn't this constitute a duplication of the binary parameter
IDs?
	
	Is the intent that parameters are scoped by the descriptor in
	which they may appear, or is this package definition in error?
	
	6.2.3 says "For each package, PropertyIDs, EventIDs, SignalIDs,
	StatisticIDs and ParameterIDs have unique name spaces". This
	seems to imply that there is one parameter ID space per package.
	However, from the packages already defined it seems that
parameter
	IDs need only be unique within the event or signal they qualify.
	
	Any thoughts? 
	Cheers,
	FR

________________________________

	Yahoo! FareChase - Search multiple travel sites in one click.
<http://us.lrd.yahoo.com/_ylc=X3oDMTFqODRtdXQ4BF9TAzMyOTc1MDIEX3MDOTY2OD
gxNjkEcG9zAzEEc2VjA21haWwtZm9vdGVyBHNsawNmYw--/SIG=110oav78o/**http%3a//
farechase.yahoo.com/>  

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Frank Reno <[email-masked]>
Date: Thu, 17 Nov 2005 08:23:08 -0800 (PST)

Thanks, Kevin. In this case, though, an ID is  reused within one event. Okay, you can distinguish them based on  whether they're in the eventsDescriptor or observedEventsDescriptor. It  wasn't clear from the text that scoping at this level was necessary.  None of the other packages have events that duplicate parameter IDs  between events and observedEvents.
  
  Regards

Kevin Boyle <[email-masked]> wrote:          If you look at all the packages defined for H.248, ParameterID namespaces   are unique only within the item for which they are parameters.  Because a   signal and an event cannot appear in the same descriptor, there is no way to   confuse parameters with IDs that are common between them.
   
  Kevin

---------------------------------
    From: [email-masked]     [mailto:[email-masked]] On Behalf Of Frank     Reno
Sent: Wednesday, November 16, 2005 3:45 PM
To:     [email-masked]
Subject: [Megaco] Parameter ID     Scope

bc    0x0001
ds        0x0001
xdd   0x0002
meth  0x0002
mp        0x0003
extra 0x0003

bc    0x0001
ds        0x0001
meth  0x0002

Doesn't this constitute a duplication of     the binary parameter IDs?

However, from the packages already defined it seems that     parameter

Any thoughts? 
Cheers,
FR

---------------------------------
    Yahoo!     FareChase - Search multiple travel sites in one click.   

---------------------------------
 Yahoo! FareChase - Search multiple travel sites in one click.