Subject: RE: [Megaco] Properties in Base Root Package!!

From: "Mudit Gupta" <[email-masked]>
Date: Wed, 1 Mar 2006 20:36:50 +0530

Hi 

Suppose, if I don't want to put any limit on the max number of contexts,
of course there will be system limitation always, but I don't want to
force it. As, I don't have any limit on number of contexts then the MG
should also reply with the same. As the zero ("0") is not being used, we
can use it for this purpose as there are lots of instances where
NULL/ZERO is used to describe infinite.

Regards,

Mudit

________________________________

From: B Venkat S.R Swamy [mailto:[email-masked]] 
Sent: Wednesday, March 01, 2006 3:08 PM
To: Mudit Gupta
Cc: [email-masked]
Subject: Re: [Megaco] Properties in Base Root Package!!

Hi

Any real systems will always be bounded by some resource contraints and
IMO MG should return some finite large value(limited to Double for
"MaxNumberOfContexts" and integer for 
"MaxTerminationsPerContext") as configured either by MGC or locally
provisioned.

regards
B Venkat S.R Swamy 
Senior Technical Leader
Flextronics Software Systems
Phone: +91-124- 4176213
Fax: +91-124-4300247
web: www.flextronicssoftware.com
 "Mudit Gupta" <[email-masked]>

"Mudit Gupta" <[email-masked]> 

03/01/2006 01:23 PM

To

<[email-masked]>

cc

Subject

[Megaco] Properties in Base Root Package!!

Hi All

My query is about the properties defined in base root package. There are
total 8 properties, out of these there are two properties called
"MaxNumberOfContexts" and "MaxTerminationsPerContext". My query is if I
don't want to put any limit on these values then what values should be
returned by the MG if the MGC/CA does audit on the ROOT termination for
Media descriptor.

I think value "0" (zero) can be returned as if any of these properties
has zero value literally then this MG is of no use (what's the use of MG
supporting zero contexts?) and that's why we can interpret zero value as
no-limit. 

Please, provide me your feedbacks and what you think should be returned
in this case or if you think that there should be limit always then also
reply me back. 

Regards,
Mudit _______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

*********************** FSS-Restricted ***********************

*********************** FSS-Restricted ***********************
"DISCLAIMER: This message is proprietary to Flextronics Software 
Systems Limited (FSS) and is intended solely for the use of the 
individual to whom it is addressed. It may contain privileged or 
confidential information and should not be circulated or used for 
any purpose other than for what it is intended. If you have received 
this message in error, please notify the originator immediately. 
If you are not the intended recipient, you are notified that you are
strictly prohibited from using, copying, altering, or disclosing
the contents of this message. FSS accepts no responsibility for
loss or damage arising from the use of the information transmitted
by this email including damage from virus."

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 02 Mar 2006 11:55:02 +1100

Hello Mudit,

You have a limit on how you address Contexts e.g.

;The values 0x0, 0xFFFFFFFE and 0xFFFFFFFF are reserved.
;'-' is used for NULL context. '*' is ALL. '$' is CHOOSE.
ContextID = (UINT32 / "*" / "-" / "$")

So I would suggest the maximum theoretical number of contexts any 
gateway could handle is 0xFFFFFFFD.

Regards, Christian

Mudit Gupta wrote:

> Hi
>
> Suppose, if I don’t want to put any limit on the max number of 
> contexts, of course there will be system limitation always, but I 
> don’t want to force it. As, I don’t have any limit on number of 
> contexts then the MG should also reply with the same. As the zero 
> (“0”) is not being used, we can use it for this purpose as there are 
> lots of instances where NULL/ZERO is used to describe infinite.
>
> Regards,
>
> Mudit
>
> ------------------------------------------------------------------------
>
> *From:* B Venkat S.R Swamy [mailto:[email-masked]]
> *Sent:* Wednesday, March 01, 2006 3:08 PM
> *To:* Mudit Gupta
> *Cc:* [email-masked]
> *Subject:* Re: [Megaco] Properties in Base Root Package!!
>
> Hi
>
> Any real systems will always be bounded by some resource contraints 
> and IMO MG should return some finite large value(limited to Double for 
> “MaxNumberOfContexts” and integer for
> “MaxTerminationsPerContext”) as configured either by MGC or locally 
> provisioned.
>
>
> regards
> B Venkat S.R Swamy
> Senior Technical Leader
> Inactive hide details for "Mudit Gupta" <[email-masked]>"Mudit 
> Gupta" <[email-masked]>
>
> *"Mudit Gupta" <[email-masked]>*
>
> 03/01/2006 01:23 PM
>
> 	
>
> To
>
> 	
>
>
> <[email-masked]>
>
> cc
>
> 	
>
> Subject
>
> 	
>
>
> My query is about the properties defined in base root package. There 
> are total 8 properties, out of these there are two properties called 
> “MaxNumberOfContexts” and “MaxTerminationsPerContext”. My query is if 
> I don’t want to put any limit on these values then what values should 
> be returned by the MG if the MGC/CA does audit on the ROOT termination 
> for Media descriptor.
>
> I think value “0” (zero) can be returned as if any of these properties 
> has zero value literally then this MG is of no use (what’s the use of 
> MG supporting zero contexts?) and that’s why we can interpret zero 
> value as no-limit.
>
> Please, provide me your feedbacks and what you think should be 
> returned in this case or if you think that there should be limit 
> always then also reply me back.
>
> Regards,
>------------------------------------------------------------------------
>

---

From: "B Venkat S.R Swamy" <[email-masked]>
Date: Thu, 2 Mar 2006 10:27:02 +0530

Hi

Although you are right that maximum theoretical number of simultaneous contexts any gateway can handle is 0xFFFFFFFD,

but BaseRoot package allows MG or MGC to specify maximum number to simultaneous context to be 8byte number(double).

I believe it was intentionally specified as double although the Context ID is only 4byte Unsigned Integer.

Therefore even specifying 0xFFFFFFFE or 0xFFFFFFFF would mean a infinite number of contexts support at MG end.

regards

B Venkat S.R Swamy

Senior Technical Leader

Phone: +91-124- 4176213

Fax: +91-124-4300247

Christian Groves <[email-masked]>

Christian Groves <[email-masked]>

03/02/2006 06:25 AM

To

Mudit Gupta <[email-masked]>

cc

B Venkat S.R Swamy/HSS@HSS, [email-masked]

Subject

Re: [Megaco] Properties in Base Root Package!!

Hello Mudit,

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Thu, 02 Mar 2006 17:20:22 +1100

Hello,

I think you'll find that there probably wasn't alot of thought behind 
specifying 'double' and its been hanging around pre-H.248.1v1. There is 
no such thing as an "infinite" number of contexts support. Anyone that 
can design a MG that can support an infinite number of contexts will be 
a rich person!!! However I would be weary buying a MG from someone who 
says this. Needless to say if they design it H.248 won't be able to 
address any more terminations than 0xFFFFFFFD.

Regards, Christian

B Venkat S.R Swamy wrote:

> Hi
>
> Although you are right that maximum theoretical number of simultaneous 
> contexts any gateway can handle is 0xFFFFFFFD,
> but BaseRoot package allows MG or MGC to specify maximum number to 
> simultaneous context to be 8byte number(double).
> I believe it was intentionally specified as double although the 
> Context ID is only 4byte Unsigned Integer.
>
> Therefore even specifying 0xFFFFFFFE or 0xFFFFFFFF would mean a 
> infinite number of contexts support at MG end.
>
> regards
> B Venkat S.R Swamy
> Senior Technical Leader
> Inactive hide details for Christian Groves 
> <[email-masked]>Christian Groves 
> <[email-masked]>
>
>
>                         *Christian Groves
>                         <[email-masked]>*
>
>                         03/02/2006 06:25 AM
>
> 	
>
> To
>