Subject: RE: [Megaco] Question regarding H.248.23 andisp package

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 16 Mar 2006 14:44:04 -0500

Comments inline. [KJBII]
 
Kevin

________________________________

	From: Tonny Kung [mailto:[email-masked]] 
	Sent: Thursday, March 16, 2006 11:00 AM
	To: [email-masked]
	Subject: [Megaco] Question regarding H.248.23 andisp package

	Hi all,
	
	I have some questions regarding the use of andisp/dwa package,
hoping someone could clarify it:
	
	1) In section 6.3.1.1.2, the description for the pattern
parameter for andisp/dwa stated that "The default is no pattern......"
and later stated the default value for the pattern parameter is "1". How
should we interpret this?
	[KJBII] It appears to me that you are referring to the
in-progress Amendment to H.248.23 (that may, in fact, become a
revision).  The default was added after the original text was written.
As editor, I will correct this and make the parameter optional, so that
the package will continue to be backwards compatible to the original
definition. Note that the text you reference has NOT been approved, and
so is currently not standard.  The current definition of this package is
in H.248.23 (7/2003) Corrigendum 1 (8/2004).
	
	2) andisp/dwa is stated for both on-hook and off-hook delivery.
And in case of off-hook, then call waiting alert will be generated. As a
result the subscriber will hear a "beep" sound (normally). But since the
"cw" signal is of type "Brief", then how would the subsequent "beep" be
generated? I suppose the MGC should send down "alert/cw" for ever
subsequent "beep"?
	[KJBII] Successive playout of call wait tones are separate
invocations of that tone.  There are scenarios in which some instances
require retransmission of the data on the second (or other subsequent)
call wait tone.  In some other scenarios this does not happen.  This,
plus the fact that there is a significant time between the call wait
tones, makes it fairly plain that the MGC must send alert/cw or
andisp/dwa  for each individual tone invocation. 
	
	Best Regards,
	Tonny

	_______________________________________
	YM - �x��ӍϢ
	������]���ϾW����������Կ�������ӍϢ�o�㣬�����ϾW�r����������
�����κ��fԒ������ʧ��
	http://messenger.yahoo.com.hk

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Tonny Kung <[email-masked]>
Date: Fri, 17 Mar 2006 16:51:17 +0800 (CST)

Hi Kevin,

Thanks for the clarification.

Just that you know, H.248.23 (01/05) is currently stated as "In force" in the ITU-T webpage. Anyhow, if you are going to correct the text, that will be very helpful.

Could you also clarify the following statement?
"The default is no pattern which indicates that the data transmission should not be associated with any signalling."

Does that mean if no pattern parameter is specified, then the CLIP delivery will be the same as using "andisp/data"?

Best Regards,
Tonny

Kevin Boyle <[email-masked]> 說：     Comments inline. [KJBII]
  
 Kevin

---------------------------------
   From: Tonny Kung    [mailto:[email-masked]] 
Sent: Thursday, March 16,    2006 11:00 AM
To: [email-masked]
Subject: [Megaco]    Question regarding H.248.23 andisp package

Hi all,

I have some questions regarding the use of    andisp/dwa package, hoping someone could clarify it:

1) In section    6.3.1.1.2, the description for the pattern parameter for andisp/dwa stated    that "The default is no pattern......" and later stated the default value for    the pattern parameter is "1". How should we interpret this?
[KJBII] It appears    to me that you are referring to the in-progress Amendment to H.248.23    (that may, in fact, become a revision).  The default was added after the    original text was written.  As editor, I will correct this and make    the parameter optional, so that the package will continue to be backwards    compatible to the original definition. Note that the text you reference has    NOT been approved, and so is currently not standard.  The current    definition of this package is in H.248.23 (7/2003) Corrigendum 1    (8/2004).

2) andisp/dwa is stated for both on-hook and    off-hook delivery. And in case of off-hook, then call waiting alert will be    generated. As a result the subscriber will hear a "beep" sound (normally). But    since the "cw" signal is of type "Brief", then how would the subsequent "beep"    be generated? I suppose the MGC should send down "alert/cw" for ever    subsequent "beep"?
[KJBII] Successive playout of call wait tones are separate    invocations of that tone.  There are scenarios in which some    instances require retransmission of the data on the second (or other    subsequent) call wait tone.  In some other scenarios this does not    happen.  This, plus the fact that there is a significant time between the    call wait tones, makes it fairly plain that the MGC must send alert/cw or    andisp/dwa  for each individual tone    invocation. 

Best Regards,
Tonny

_______________________________________
 YM - 離線訊息
 就算你沒有上網，你的朋友仍可以留下訊息給你，當你上網時就能立即看到，任何說話都冇走失。
 http://messenger.yahoo.com.hk