Subject: RE: ??: RE: [Megaco] Question regarding H.248.23 andisp package

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 17 Mar 2006 10:25:31 -0500

You are correct about the document in force.  I had forgotten that we
revised H.248.23 near the end of 2004 -- and hadn't added it to my
repository of documents.  I will still ensure that the conflict is
corrected.
 
Yes, if the pattern parameter is omitted, there is no alerting.  There
could be some better wording there as well.  I will ensure that also
gets clarified.
 
Kevin

________________________________

	From: Tonny Kung [mailto:[email-masked]] 
	Sent: Friday, March 17, 2006 3:51 AM
	To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked].
hk; [email-masked]
	Subject: ??: RE: [Megaco] Question regarding H.248.23 andisp
package

	Hi Kevin,
	
	Thanks for the clarification.
	
	Just that you know, H.248.23 (01/05) is currently stated as "In
force" in the ITU-T webpage. Anyhow, if you are going to correct the
text, that will be very helpful.
	
	Could you also clarify the following statement?
	"The default is no pattern which indicates that the data
transmission should not be associated with any signalling."
	
	Does that mean if no pattern parameter is specified, then the
CLIP delivery will be the same as using "andisp/data"?
	
	Best Regards,
	Tonny

	Kevin Boyle <[email-masked]> �f�� 

		Comments inline. [KJBII]
		 
		Kevin

________________________________

			From: Tonny Kung
[mailto:[email-masked]] 
			Sent: Thursday, March 16, 2006 11:00 AM
			To: [email-masked]
			Subject: [Megaco] Question regarding H.248.23
andisp package

			Hi all,
			
			I have some questions regarding the use of
andisp/dwa package, hoping someone could clarify it:
			
			1) In section ! 6.3.1.1.2, the description for
the pattern parameter for andisp/dwa stated that "The default is no
pattern......" and later stated the default value for the pattern
parameter is "1". How should we interpret this?
			[KJBII] It appears to me that you are referring
to the in-progress Amendment to H.248.23 (that may, in fact, become a
revision).  The default was added after the original text was written.
As editor, I will correct this and make the parameter optional, so that
the package will continue to be backwards compatible to the original
definition. Note that the text you reference has NOT been approved, and
so is currently not standard.  The current definition of this package is
in H.248.23 (7/2003) Corrigendum 1 (8/2004).
			
			2) andisp/dwa is stated for both on-hook and
off-hook delivery. And in case of off-hook, then call waiting! alert
will be generated. As a result the subscriber will hear a "beep" sound
(normally). But since the "cw" signal is of type "Brief", then how would
the subsequent "beep" be generated? I suppose the MGC should send down
"alert/cw" for ever subsequent "beep"?
			[KJBII] Successive playout of call wait tones
are separate invocations of that tone.  There are scenarios in which
some instances require retransmission of the data on the second (or
other subsequent) call wait tone.  In some other scenarios this does not
happen.  This, plus the fact that there is a significant time between
the call wait tones, makes it fairly plain that the MGC must send
alert/cw or andisp/dwa  for each individual tone invocation. 
			
			Best Regards,
			Tonny

	_______________________________________
	YM - �x��Ӎ? ?br> ������]���ϾW����������Կ�������ӍϢ�o�㣬��
���ϾW�r���������������κ��fԒ������ʧ��
	http://messenger.yahoo.com.hk

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Nurit Shenhar" <[email-masked]>
Date: Fri, 17 Mar 2006 18:11:24 +0200

Kevin

It might be too late at this stage to comment, but I am not sure I understand why the pattern parameter was made optional. If we do not want to alert, there is the data signal.

Nurit

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]] 
Sent: Friday, March 17, 2006 5:26 PM
To: [email-masked]; [email-masked]
Subject: RE: ??: RE: [Megaco] Question regarding H.248.23 andisp package

 
Kevin

	Hi Kevin,

	

	Best Regards,
	Tonny

	Kevin Boyle <[email-masked]> Õf£º 

		Comments inline. [KJBII]
		 
		Kevin

			From: Tonny Kung

			Hi all,

			
			
			Best Regards,
			Tonny

	_______________________________________
	YM - ëx¾€Ó? ?br> ¾ÍËãÄã›]ÓÐÉÏ¾W£¬ÄãµÄÅóÓÑÈÔ¿ÉÒÔÁôÏÂÓÏ¢½oÄã£¬®”
ÄãÉÏ¾W•r¾ÍÄÜÁ¢¼´¿´µ½£¬ÈÎºÎÕfÔ’¶¼ƒÓ×ßÊ§¡£
	http://messenger.yahoo.com.hk

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 17 Mar 2006 11:36:17 -0500

It was made optional at the time to define a behavior when the parameter
was omitted.  This was one of the earlier packages defined, and the
collective experience in what was good and not-so-good in package design
was pretty small.  Given it to do all over again, I would have made this
a mandatory parameter.  However, given that the package was originally
defined six years ago, it will be difficult to change this now.

That being said, I will solicit the opinions of the delegates at the
Q3/16 meeting next month.

Kevin 

-----Original Message-----
From: Nurit Shenhar [mailto:[email-masked]] 
Sent: Friday, March 17, 2006 11:11 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked];
[email-masked]

Kevin

It might be too late at this stage to comment, but I am not sure I
understand why the pattern parameter was made optional. If we do not
want to alert, there is the data signal.

Nurit

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Friday, March 17, 2006 5:26 PM
To: [email-masked]; [email-masked]
Subject: RE: ??: RE: [Megaco] Question regarding H.248.23 andisp package

 
Kevin

	Hi Kevin,

	

	Best Regards,
	Tonny

		Comments inline. [KJBII]
		 
		Kevin

			From: Tonny Kung

			Hi all,

			
			
			Best Regards,
			Tonny