Subject: [Megaco] [Fwd: [Fwd: RE: Service Change ALL]]

From: Christian Groves <[email-masked]>
Date: Thu, 30 Mar 2006 13:48:54 +1000

In 2001 it was understood that the default state is In-Service.

Christian

-------- Original Message --------
Subject: 	RE: Service Change ALL
Date: 	Mon, 16 Apr 2001 11:19:36 -0400
From: 	Madhu Babu Brahmanapally <[email-masked]>
To: 	'Mario Monteiro' <[email-masked]>, <[email-masked]>

Hi Mario,

The example shows MG generating the Registration request and its not for a
given termination. If the MGC needs to address all the terminations
irrespective of their existence in context, today it has to generate two
commands (one for active contexts and other for Null contexts)

(Of course even though the protocol doesn't address about this, but I will
be happy to see that) Similar to the way the MG to register all its
terminations uses all the ROOT termination Identifier, the MGC also should
be able to use the ROOT termination to take all terminations out-of-service,
something like

MGC to MG1:
MEGACO/1 [121.121.121.111]
Transaction = 9998{
      Context = - {
            ServiceChange = ROOT {Services   {
                  Method=Forced.
                  ....................................... etc

Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Mario Monteiro
Sent: Monday, April 16, 2001 10:20 AM
To: [email-masked]
Subject: Service Change ALL

Appendix A.1 shows an example syntax of restarting terminations as
follows:

MG1 to MGC:
MEGACO/1 [124.124.124.222]
Transaction = 9998{
      Context = - {
            ServiceChange = ROOT {Services   {
                  Method=Restart.
                  ....................................... etc

Section 8.1.2 also states...

The MGC may use the ALL wildcard to address all Contexts on the MG. The
null Context is not included when the ALL wildcard is used.

Question is, if  * were used instead of - in the ServiceChange above,
does this mean that only terminations not in the NULL context will be
restarted? In order to restart all MG terminations ( NULL context +
active contexts)  does the ServiceChange have to be issued twice, once
with * and the other with - ?  Or is there another way to do this?

Thanks - Mario

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Thu, 30 Mar 2006 12:07:06 +0200

Thanks Christian for pointers!

Raises an old question to me about the archive database organization:

My impression is that the deepth is fixed, and limited to 265 files in
directory
www1.ietf.org/mail-archive/web/megaco/current/

Thus, currently the history ends at July 18, 2001.
I'm wondering how I may access the list discussion before?

Is there another archive directory (besides "/current/")?

Thanks
Albrecht

                      Christian Groves                                                                                                 
                      <Christian.Groves@nt         To:      megaco ietf <[email-masked]>                                              
                      eczone.com>                  cc:                                                                                 
                                                   Subject: [Megaco] [Fwd: [Fwd: RE: Service Change ALL]]                              
                      30.03.2006 05:48                                                                                                 

Christian

-------- Original Message --------
Subject:           RE: Service Change ALL
Date:              Mon, 16 Apr 2001 11:19:36 -0400
From:              Madhu Babu Brahmanapally <[email-masked]>
To:          'Mario Monteiro' <[email-masked]>,
<[email-masked]>

Hi Mario,

(Of course even though the protocol doesn't address about this, but I will
be happy to see that) Similar to the way the MG to register all its
terminations uses all the ROOT termination Identifier, the MGC also should
be able to use the ROOT termination to take all terminations
out-of-service,
something like

MGC to MG1:

Regards
Madhubabu

-----Original Message-----

MG1 to MGC:

Thanks - Mario