Subject: [Megaco] H.223/H.324m on H248

From: Hans vandermaarel <[email-masked]>
Date: Thu, 30 Mar 2006 04:15:03 -0800 (PST)

Hi All,
   
  Reading the ITU standards I get the impression that it's mandatory to implement H.248.12 for a H.324m or H323 Media Gateway. At the same time I get the feeling that the MGC implementations can't be compatible with any of such implementations as the standard seems quite open in terms of options and ways to handle things.
   
  I also wondered why one needs H.248.12 at all. I would expect one need not inform the MGC on all itty bitty detail in the H245 protocol. I would expect it is sufficient to inform a MGC on events that alter the codec preferences.
   
  E.g. a MG which can internally do transcoding of audio and video will start using H.263 with AMR/G.711 as prefered local codecs. By the time it receives a CapabilityExchange it would just send an event telling the MGC to Modify the codecs. The MG could in the response answer it's new preferences.
   
  Any opinions would be appreciated,
   
  Hans van der Maarel

---------------------------------
Talk is cheap. Use Yahoo! Messenger to make PC-to-Phone calls.  Great rates starting at 1&cent;/min.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Thu, 30 Mar 2006 15:03:55 +0200

I guess that the basic question is, which "capability set" of H.245 should
be terminated on the MG, and which on the MGC ("the ratio might be in
theory between 0 ...100%).

H.248.12 was originally designed from H.323 perspective, e.g., interworking
scenarios like to H.324 in my understanding.
Neither the consideration of H.324m, SIP or 3G-324m was the main scope
then.

Guess your motivation is current 3GPP R7 discussion, thus an H.225.0-less
network application (because of RANAP/BICC in CS domain and SIP in PS
domain). I believe that it's worth to cross-check again the two H.248.12
Packages from that specific 3G-324m point of view.

Albrecht

                      Hans                                                                                                            
                      vandermaarel             To:      [email-masked]                                                               
                      <jjavandermaarel         cc:                                                                                    
                      @yahoo.com>              Subject: [Megaco] H.223/H.324m on H248                                                 
                                                                                                                                      
                      30.03.2006 14:15                                                                                                

Hi All,

Reading the ITU standards I get the impression that it's mandatory to
implement H.248.12 for a H.324m or H323 Media Gateway. At the same time I
get the feeling that the MGC implementations can't be compatible with any
of such implementations as the standard seems quite open in terms of
options and ways to handle things.

I also wondered why one needs H.248.12 at all. I would expect one need not
inform the MGC on all itty bitty detail in the H245 protocol. I would
expect it is sufficient to inform a MGC on events that alter the codec
preferences.

E.g. a MG which can internally do transcoding of audio and video will start
using H.263 with AMR/G.711 as prefered local codecs. By the time it
receives a CapabilityExchange it would just send an event telling the MGC
to Modify the codecs. The MG could in the response answer it's new
preferences.

Any! opinions would be appreciated,

Hans van der Maarel

Talk is cheap. Use Yahoo! Messenger to make PC-to-Phone calls. Great rates
starting at 1¢/min._______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco