Subject: [Megaco] Re: Question to H.248 gm Package (used by ES 283 018)

From: [email-masked]
Date: Sat, 4 Mar 2006 16:09:47 +0100

Thanks Christian for that pointer!

The Annex B ABNF syntax is so allowing to extend a single value towards
'lists' or a 'range'. Is there sth similar for H.248 using binary encoding?

Albrecht

                      Christian Groves                                                                                                 
                      <Christian.Groves@NT         To:      [email-masked]                                                   
                      ECZONE.COM>                  cc:                                                                                 
                                                   Subject: Re: Question to H.248 gm Package (used by ES 283 018)                      
                      02.03.2006 08:43                                                                                                 
                      Please respond to                                                                                                
                      Christian Groves                                                                                                 

Hello All,

H.248 allows you to specify ranges for parameter values natively. No
packages tricks required.
e.g.
H.248.1 Annex B ABNF Syntax
    parmValue            = (EQUAL alternativeValue / INEQUAL VALUE)

    alternativeValue        = (VALUE
                    / LSBRKT VALUE *(COMMA VALUE) RSBRKT
                        ; sublist (i.e. A AND B AND ...)
                    / LBRKT VALUE *(COMMA VALUE) RBRKT
                        ; alternatives (i.e. A OR B OR ...)
                    / LSBRKT VALUE COLON VALUE RSBRKT)
                        ; range

Regards, Christian

neal wrote:

>Hi Albrecht,
>   using higher 16 bits and low 16 bits of this 32 bits integer separately
>or define 2 properties for ranges?
>
>Neal
>----- Original Message -----
>From: "Albrecht Schwarz" <[email-masked]>
>To: <[email-masked]>
>Sent: Wednesday, March 01, 2006 6:53 PM
>Subject: Question to H.248 gm Package (used by ES 283 018)
>
>
>
>
>>Question:
>>How shall be the "Remote Source Port Range" property of the Gate
>>
>>
>Management
>
>
>>Package encoded?
>>The type of property gm/spr is "Integer", but the property is supporting
>>"value ranges".
>>
>>Present definition permits only filtering on individual ports, but not
>>ranges IMHO.
>>
>>Albrecht
>>
>>-------------------------------------------------------------------
>>Mail archive for TISPAN_WG3  can be browsed at the following url :
>>         http://list.etsi.org/TISPAN_WG3.html
>>-------------------------------------------------------------------
>>
>>
>
>-------------------------------------------------------------------
>Mail archive for TISPAN_WG3  can be browsed at the following url :
>         http://list.etsi.org/TISPAN_WG3.html
>-------------------------------------------------------------------
>
>
>
>
>
>

-------------------------------------------------------------------
Mail archive for TISPAN_WG3  can be browsed at the following url :
         http://list.etsi.org/TISPAN_WG3.html
-------------------------------------------------------------------

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Mon, 06 Mar 2006 17:42:48 +1100

Hello Albrecht,

Yes there is:

PropertyParm ::= SEQUENCE
{
name PkgdName,
value SEQUENCE OF OCTET STRING,
extraInfo CHOICE
{
relation Relation,
range BOOLEAN,
sublist BOOLEAN
} OPTIONAL,
…
}

Regards, Christian