Subject: [Megaco] contextAudit{EG} issue

From: "FCG Long Hai" <[email-masked]>
Date: Sat, 20 May 2006 10:46:47 +0800

Hi all,
  When MGC send such request:
!/1 [10.10.0.33] T=2736{C=1{contextAudit{EG} }  }

If the context 1 is not a emergent call,
What shall the replay be?
I think that it shall be as following:
!/1 [10.10.0.121] T=2736{C=1{}}

But it seems that it's not a valid response in ABNF syntax.

actionReply		= CtxToken EQUAL ContextID [ LBRKT
(errorDescriptor /
					commandReply /(commandReply
COMMA
					errorDescriptor)) RBRKT ]

commandReply		= ((contextProperties [COMMA commandReplyList])
/
					commandReplyList)

contextProperties	= contextProperty *(COMMA contextProperty)

The contextProperties shall not be empty, right?

Can any one help me to clarify this issue?

Thanks!

BR
Long hai

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "B Venkat S.R Swamy" <[email-masked]>
Date: Mon, 22 May 2006 09:00:19 +0530

Hi

H248.1 IG and H.248.1 V3(Sep 2005) grammar has now support of sending EmergenyOff in the reply message.

*********************************************************************************

actionReply = CtxToken EQUAL ContextID [LBRKT (errorDescriptor /

commandReply /(commandReply COMMA

errorDescriptor)) RBRKT]

commandReply = ((contextProperties [COMMA commandReplyList]) /

commandReplyList)

; at-most-once

; EmergencyOff to be used in MG to MGC direction only in H.248.1 V1 and V2

; EmergencyToken or EmergencyOffToken, but not both

contextProperty = (topologyDescriptor / priority / EmergencyToken /

EmergencyOffToken / iepsValue /

contextAttrDescriptor)

*********************************************************************************

Thus in the example mentioned below, the response would be

!/1 [10.10.0.121] T=2736{C=1{EGO}}

regards

B Venkat S.R Swamy

Senior Technical Leader

Flextronics Software Systems

Phone: +91-124- 4176213

Fax: +91-124-4300247

web: www.flextronicssoftware.com

"FCG Long Hai" <[email-masked]>

"FCG Long Hai" <[email-masked]>

05/20/2006 08:16 AM

To

<[email-masked]>

cc

Subject

[Megaco] contextAudit{EG} issue

Hi all,

(errorDescriptor /

COMMA

/

commandReplyList)

Thanks!

BR

Long hai

Megaco mailing list

[email-masked]

*********************** FSS-Restricted ***********************

"DISCLAIMER: This message is proprietary to Flextronics Software

Systems Limited (FSS) and is intended solely for the use of the

individual to whom it is addressed. It may contain privileged or

confidential information and should not be circulated or used for

any purpose other than for what it is intended. If you have received

this message in error, please notify the originator immediately.

If you are not the intended recipient, you are notified that you are

strictly prohibited from using, copying, altering, or disclosing

the contents of this message. FSS accepts no responsibility for

loss or damage arising from the use of the information transmitted

by this email including damage from virus."