Subject: Re: [Megaco] Segmentation error

From: "B Venkat S.R Swamy" <[email-masked]>
Date: Fri, 26 May 2006 09:09:40 +0530

Hi

You are right, currently the grammar does not allow for the transaction ID to be given with "459" error.

Solutions could be:

1) Include the transaction ID in the error text in error descriptor, currently only missing segment numbers are given. Here the first element can be transaction id and then list of segments missing.

2) Modify the grammar and include error descriptor also in the new segment reply message as shown below.
!/3 [12.34.56.79]:2944 SM=1{ER=459{"2,3"}}

regards

B Venkat S.R Swamy
Senior Technical Leader
Flextronics Software Systems
Phone:  +91-124- 4176213
Fax: +91-124-4300247
web: www.flextronicssoftware.com

-----"Ron Ho" <[email-masked]> wrote: -----

To: megaco <[email-masked]>
From: "Ron Ho" <[email-masked]>
Date: 05/26/2006 03:23AM
Subject: [Megaco] Segmentation error

Hi All,

V3 segmentation procedure specifies that we need to send error 459 if
we don't get all the segmented responses. However, the sample call
flow does not show which transaction the error message is addressing
to. Is it correct? Should there be the transaction id in the error
message returned?

Thanks,
Ron.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

" DISCLAIMER: This message is proprietary to Flextronics Software Systems Limited (FSS) and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. FSS accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 30 May 2006 07:57:26 -0400

I think the best way to fix this will be to have the error text carry
the TransID.  I will see about taking this to Ottawa in August to be
fixed.
 
Kevin

________________________________

From: B Venkat S.R Swamy [mailto:[email-masked]] 
Sent: Thursday, May 25, 2006 11:40 PM
To: Ron Ho
Cc: megaco
Subject: Re: [Megaco] Segmentation error

Hi
 
You are right, currently the grammar does not allow for the transaction
ID to be given with "459" error.
 
Solutions could be:
1) Include the transaction ID in the error text in error descriptor,
currently only missing segment numbers are given. Here the first element
can be transaction id and then list of segments missing.
 
2) Modify the grammar and include error descriptor also in the new
segment reply message as shown below.
!/3 [12.34.56.79]:2944 SM=1{ER=459{"2,3"}}

regards
B Venkat S.R Swamy     
Senior Technical Leader

	
	Hi All,
	
	V3 segmentation procedure specifies that we need to send error
459 if
	we don't get all the segmented responses. However, the sample
call
	flow does not show which transaction the error message is
addressing
	to. Is it correct? Should there be the transaction id in the
error
	message returned?
	
	Thanks,
	Ron.

" DISCLAIMER: This message is proprietary to Flextronics Software
Systems Limited (FSS) and is intended solely for the use of the
individual to whom it is addressed. It may contain privileged or
confidential information and should not be circulated or used for any
purpose other than for what it is intended. If you have received this
message in error, please notify the originator immediately. If you are
not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of
this message. FSS accepts no responsibility for loss or damage arising
from the use of the information transmitted by this email including
damage from virus."