Subject: RE: [Megaco] class 4 and class 5 applications in H.248

From: "Pellegrino Jose Luis" <[email-masked]>
Date: Wed, 17 May 2006 12:19:35 -0300

Hi, please ignore the last mail I sended by mistake. In fact it was an incomplete version of the present mail. It seems that I am not multitasking man at all,  and I have pushed the incorrect key. Escuse me please.

Now, the complete version.
----------------------------
Hi,

First of all I need thank kevin, Rodrido and Albrecht, for their comments. Despite may be some diagreements, I need to say all comments helped me.

After that, I will intend to clarify some aspects I didn´t do before.

In fact, at first, it was not evident to me that digit collection apllies to trunking as Kevin said. If it would be so I hadn´t sent my first mail. 
In fact, I know that RFC 3525 doesn´t make difference between trunk and lines gateways, but there is a "key" phrase in point 7.1.14 of RFC 3525, where it says: "A DigitMap is a dialing plan resident in the Media Gateway used for......",  and in my opinion, a dialing plan doesn´t seem to be related with a trunk gateway, at least in general cases. So that prhase made me doubt.

Taking into account all the comments received, it seems to be that, may be some applications, as INAP mentioned by Albrecht, and others, where it is necessary to collect digits in a trunk gateway. They may occur in the middle of the call as Kevin said.

Respect the last mail from Rodrigo, I must remark that we use RFC 2833 to transport DTMF between MG's. The initial question is not related with that. In that point I agree with Albrecht (where he says nothing to do with the RTP side).

Respect the others Albrecht comments, I can tell you that we doesn´t have ANSI Class 4 exchange. Our signalling system is based on ITU-T with some national options. 

Finally, I appreciate the differentiation Albrecht made about TMG_TX and TMG_C4.

Thank you all very much.
All comments received are usefull for us.

Jose Luis.

PD. Sorry I'm not as good I would like to be in english, I only do my best effort.

-----Mensaje original-----
De: Pellegrino Jose Luis [mailto:[email-masked]] 
Enviado el: Miércoles, 17 de Mayo de 2006 11:33 a.m.
Para: Yanssen, Rodrigo Duarte; [email-masked]
CC: [email-masked]
Asunto: RE: [Megaco] class 4 and class 5 applications in H.248

Hi,

First of all I need thank kevin, Rodrido and Albrech.
After that, I will intend to clarify some aspects I didn´t do before.

1- In fact, al first, it was not evident to me that digit collection apllies to trunking as Kevin said. I now that RFC 3525 doesn´t make difference between  If it would be so I hadn´t sent my first mail. The "key" phrase is that in point 7.1.14 of RFC 3525, where it says: "A DigitMap is a dialing plan resident in the Media Gateway used for......",  and a dialing plan doesn´t seem to be related with a trunk gateway. Obviously may be some applications where it is desirable to collect digits in a trunk gateway but they aren´t related to routing task, infact they occur in teh middle of the call.

-----Mensaje original-----
De: Yanssen, Rodrigo Duarte [mailto:[email-masked]] 
Enviado el: Miércoles, 17 de Mayo de 2006 09:42 a.m.
Para: [email-masked]
CC: Kevin Boyle; [email-masked]; Pellegrino Jose Luis
Asunto: RE: [Megaco] class 4 and class 5 applications in H.248

Ok, Srs. We have some diferents packeges for diferent application. But we need to remember that our colleague Pelegrino asked to us about DTMF in_band and out_band after established call.

My opinion is that the appropriated method is RFC2833 in_band, or DD/STD for out_band digits because after established calls is not appropriate to configure events to be completed (CE).

And I think that is not appopriate to have profiles on network, because we would be create diferents cells in the same net.

Regards

Rodrigo Yanssen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: quarta-feira, 17 de maio de 2006 04:26
To: Yanssen, Rodrigo Duarte
Cc: Kevin Boyle; [email-masked]; Pellegrino Jose Luis
Subject: RE: [Megaco] class 4 and class 5 applications in H.248

This view is too simplified in my opinion (because not considering the different markets of legacy PSTN/ISDN networks). You should at least distinguish ANSI and non-ANSI (like ETSI) markets. The ANSI CLASS4 exchange is slightly different as the ETSI Transit exchange
(TX) with regards the involvment in service control ("background is the rather early de-regulation in ANSI markets 20 years ago with the two business roles of a local operator and long distance operator").

If you then considering an NGN scenario with a replacement of the CLASS4 or the TX by a H.248 Trunking Gateway, then you need two MG variants:

   (1) TMG_C4 (let's call it "CLASS4 Trunking Media Gateway")
   (2) TMG_TX (let's call it "Transit Trunking Media Gateway")

The 2nd one doesn't require DTMF support at the H.248 interface, - neither individual digits nor digitmaps -, from a replacement requirement. See e.g. ETSI ES 283 024, an H.248 Profile for ETSI TMG_TXs.

But the 1st one has typically that requirement. I also do agree to Kevin that "DigitMap" support is needed for the TMG_C4 (e.g., the previous CLASS4 could had an (INAP) interface to an IN SCP, which needs to be continued).

Another reason is that the TMG_TX is typically considering only SS7 trunks (like in ETSI TISPAN NGN R1), whereas there could be also CAS trunks (like SSR1, SSR2, SSR5). The TMG_C4 has typically to interface as well SSR1 trunks, which again may lead to the requirement of individual digits or digitstring handling.

If you would made an attempt in comparing both TMGs by H.248 Profiles, then the H.248 TMG_TX Profile would be a subset of the H.248 TMG_C4 Profile. And the TMG_C4 would need DigitMap support as outlined by Kevin. This is related to the H.248 TDM Termination and has nothing to do with the RTP side.

My view, Albrecht

                      "Yanssen, Rodrigo                                                                                              
                      Duarte"                    To:      "Kevin Boyle" <[email-masked]>, "Pellegrino Jose Luis"                  
                      <rodrigo.yanssen@s         <[email-masked]>, <[email-masked]>                                     
                      iemens.com>                cc:                                                                                 
                                                 Subject: RE: [Megaco] class 4 and class 5 applications in H.248                     
                      16.05.2006 14:24                                                                                               

I think that the Access Gateways on market, treat a little quantity of E1, normally only one STM-1, while a Virtual Trunk Gateway can control up to 10 STM-1, so in my mind is not appropriate the MG proccess a lot of DS0s with Digit Map, if these events had already completed in the PSTN switch.

Now, if you will use the event dd/ce sending digit by digit, you will not use really this feature, so you are would using CE like STD. And we can not mix Digits to Call Setup and Digits in_band that are using to transport confidencials information like account bank and passwords, that can be transported by in_band RFC 2833.

Regards

___________________________
Rodrigo Yanssen
Siemens - COM NSC FN E
Phone:  +55-11-3908-3527
Mobile: +55-19-9134-8168

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: terça-feira, 16 de maio de 2006 13:38
To: Pellegrino Jose Luis; [email-masked]
Subject: RE: [Megaco] class 4 and class 5 applications in H.248

The edd package in H.248.16 was designed for just the kind of application you are suggesting here -- to collect digits mid-call. Digit collection via a DigitMap in H.248 can occur at any time the MGC chooses to do so by adding a completion event to the Events Descriptor and setting a DigitMap Descriptor appropriately.

Kevin

________________________________

             From: Pellegrino Jose Luis [mailto:[email-masked]]

             Sent: Tuesday, May 16, 2006 12:00 PM
             To: [email-masked]
             Subject: [Megaco] class 4 and class 5 applications in H.248

             Hi MeGaCo community,

             I would like to ask you a question about class 4 and class 5 applications.

             If I am not wrong, digit maps (point 7.1.14 of RFC 3525) and dd/ce have been developed to be used in class 5 application. In fact in my opinion we use digit map with residencial or access gateway, and not just in trunk gateway.

             So the question is:
             Is it possible to use dd/ce in trunk gateway in order to notify a MGC DTMF digits received by the MG during the conversation fase (I mean not during the stablishing period)?
             Or in the hand that feature requires to be implemented, an ad hoc modifications, I mean  It is not a natural use of dd/ce?

             I will understand if you say that what I am asking for, sounds like strange. If you need more explanations  I can explain it in more detail. It is not related to the transport of DTMF from one MG to the other MG: in that case we use the RFC 2833 RTP mechanism.

             Finally, in case what I am asking for is not possible or not recommended, what about of use of dd/std in class 4 applications.

             Sorry for my bad english, and best regard in advance

             José Luis Pellegrino
             Telefónica de Argentina

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Yanssen, Rodrigo Duarte" <[email-masked]>
Date: Wed, 17 May 2006 12:38:39 -0300

Ok Jose Luis,

So, like said Mr. Albrecht (("The 2nd one doesn't require DTMF support at the H.248 interface, - neither individual digits nor digitmaps -, from a replacement requirement. See e.g. ETSI ES 283 024, an H.248 Profile for ETSI TMG_TXs")) is not necessary use Digitmap or DD/CE Package in this scenario.

For me is clear now, if you really want to send out_band digits after established call, the dd/STD packages is more appropriated, and not only for some digits like other signals that will be necessary.

Regards

-----Original Message-----
From: Pellegrino Jose Luis [mailto:[email-masked]] 
Sent: quarta-feira, 17 de maio de 2006 12:20
To: Pellegrino Jose Luis; Yanssen, Rodrigo Duarte; [email-masked]
Cc: [email-masked]
Subject: RE: [Megaco] class 4 and class 5 applications in H.248

Thank you all very much.

Jose Luis.

-----Mensaje original-----
De: Pellegrino Jose Luis [mailto:[email-masked]] 
Enviado el: Miércoles, 17 de Mayo de 2006 11:33 a.m.
Para: Yanssen, Rodrigo Duarte; [email-masked]
CC: [email-masked]
Asunto: RE: [Megaco] class 4 and class 5 applications in H.248

Hi,

-----Mensaje original-----
De: Yanssen, Rodrigo Duarte [mailto:[email-masked]] 
Enviado el: Miércoles, 17 de Mayo de 2006 09:42 a.m.
Para: [email-masked]
CC: Kevin Boyle; [email-masked]; Pellegrino Jose Luis
Asunto: RE: [Megaco] class 4 and class 5 applications in H.248

Regards

Rodrigo Yanssen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: quarta-feira, 17 de maio de 2006 04:26
To: Yanssen, Rodrigo Duarte
Cc: Kevin Boyle; [email-masked]; Pellegrino Jose Luis
Subject: RE: [Megaco] class 4 and class 5 applications in H.248

My view, Albrecht

                      "Yanssen, Rodrigo                                                                                              

Regards

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: terça-feira, 16 de maio de 2006 13:38
To: Pellegrino Jose Luis; [email-masked]
Subject: RE: [Megaco] class 4 and class 5 applications in H.248

Kevin

             Hi MeGaCo community,

             So the question is:

             José Luis Pellegrino
             Telefónica de Argentina