Subject: RE: [Megaco] Critical level

From: "Raphael Tryster" <[email-masked]>
Date: Mon, 29 May 2006 08:14:55 +0200

None of these messages should appear in normal operation.  The no match errors may indicate the lack of an offline agreement between MG and MGC on what the termination names are.  For the others, a trace may show whether it is the MG or MGC that is non-compliant.
 
Raphael Tryster

"Things should be made as simple as possible, but not any simpler."  - Albert Einstein

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, May 26, 2006 4:43 PM
To: [email-masked]
Subject: [Megaco] Critical level

Hello everybody,

 Which of the presented messages have a critical value and which are normal (always appeare during the establishment of connection): 

- No terminationID matched a wildcard

- Syntax Error in Command

- No terminationID matched

- Internal software failure in the MG

- parse error: Invalid offset (for pkgdName) - the most important question for me

Are they serious for the real working of equipment? There is no estimation of critical level in H.248 recommendation.

Best regards!
 
Stan

**********************************************************************************************
This e-mail contains confidential, privileged or proprietary information to VocalTec Communications.
If you received this messege by mistake, please inform us and then delete the original and all copies.
*** eSafe scanned this email for viruses, vandals, and malicious content. ***
**********************************************************************************************

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 30 May 2006 00:06:49 -0400

I think it would largely depend upon implementation.  I know of
maintenance and audit routines in some implementations that can end up
with the "no termID matched a wildcard".  This does not mean there is a
problem, and might indicate that everything is as it should be.
 
Blanket statements about what should and should not appear in normal
operation can be misleading.  I think each implementation needs to look
at its protocol operations and see what makes sense within the bounds of
those functions.
 
As to the last item on the list -- that is not a valid error code and
appears to be related to the parser implementation in use.  I would
consult the author of that parser to see how that issue can be resolved.
 
Kevin

________________________________

From: Raphael Tryster [mailto:[email-masked]] 
Sent: Monday, May 29, 2006 2:15 AM
To: ????? ??????????; [email-masked]
Subject: RE: [Megaco] Critical level

None of these messages should appear in normal operation.  The no match
errors may indicate the lack of an offline agreement between MG and MGC
on what the termination names are.  For the others, a trace may show
whether it is the MG or MGC that is non-compliant.
 
Raphael Tryster

"Things should be made as simple as possible, but not any simpler."  -
Albert Einstein

	-----Original Message-----
	From: [email-masked] [mailto:[email-masked]]
	Sent: Friday, May 26, 2006 4:43 PM
	To: [email-masked]
	Subject: [Megaco] Critical level

	Hello everybody,

	 Which of the presented messages have a critical value and which
are normal (always appeare during the establishment of connection): 

	- parse error: Invalid offset (for pkgdName) - the most
important question for me

	Are they serious for the real working of equipment? There is no
estimation of critical level in H.248 recommendation.

	Best regards!
	 
	Stan

________________________________

This e-mail contains confidential, privileged or proprietary information
to VocalTec Communications.
If you received this messege by mistake, please inform us and then
delete the original and all copies.
*** eSafe scanned this email for viruses, vandals, and malicious
content. *** 
________________________________