Subject: RE: Fw: Add one more Query //Re: [Megaco] V3 relatedclarificationsrequired

From: "Arturo Martin De Nicolas \(AC/EDD\)" <[email-masked]>
Date: Tue, 20 Jun 2006 09:21:46 +0200

Hi Tony and Christian,

topologyDirectionExtension is in fact optional, this was corrected last
year, see H.248 sub-series IG. Further, if present, it takes precedence
over the topologyDirection.

BR,
Arturo

-----Original Message-----
From: Tony Zhang [mailto:[email-masked]] 
Sent: Tuesday, June 20, 2006 9:08 AM
To: Christian Groves
Cc: [email-masked]
Subject: Re: Fw: Add one more Query //Re: [Megaco] V3
relatedclarificationsrequired

Hi Christian:
    if topologyDirectionExtension   is optional,then topologyDirection
should change to optional also.so this isnot compatible with H248.1
version 1 also.
.so if H248.1 version 3 add topologyDirectionExtension  for be
compatible with H248.1 version 1,it is cannot work.
    so maybe change to add more ENUM value is more simply.
Regars!
            Tony Zhang

----- Original Message -----
From: "Christian Groves" <[email-masked]>
To: "Tony Zhang" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, June 20, 2006 10:33 AM
Subject: Re: Fw: Add one more Query //Re: [Megaco] V3 related
clarificationsrequired

> Hello Tony,
> 
> topologyDirectionExtension was needed because we didn't add the 
> extension ellipses (...) to the topologyDirection structure in H.248.1

> version 1. So when we wanted to add different types of "directions" we

> needed to add this extension field.
> 
> With regards to "optional" it should in fact be optional. I think we 
> need to look at someway of fixing this error/omission.
> 
> Regards, Christian
> 
> Tony Zhang wrote:
> 
> >  
> > why *define topologyDirectionExtension is below, why it is not
optional?*
> > why donot add to *topologyDirection ?*
> >
> >     *TopologyRequest                   ::= SEQUENCE*
> >
> >     *{*
> >
> >     *             terminationFrom                               
> >     TerminationID,*
> >
> >     *             terminationTo                                    
> >     TerminationID,*
> >
> >     *             topologyDirection                              
> >     ENUMERATED*
> >
> >     *             {*
> >
> >     *                         bothway(0),*
> >
> >     *                         isolate(1),*
> >
> >     *                         oneway(2)*
> >
> >     *             },*
> >
> >     *             ...,*
> >
> >     *            
> >     streamID                                              StreamID
> >     OPTIONAL,*
> >
> >     *             topologyDirectionExtension             ENUMERATED*
> >
> >     *             {*
> >
> >     *                         onewayexternal(0),*
> >
> >     *                         onewayboth(1),*
> >
> >     *                         ...*
> >
> >     *             }*
> >
> >     ** 
> >
> >     * *
> >
> >     **TopologyRequest                   ::= SEQUENCE**
> >
> >     * *
> >
> >     **{**
> >
> >     * *
> >
> >     **             terminationFrom                               
> >     TerminationID,**
> >
> >     * *
> >
> >     **             terminationTo                                    
> >     TerminationID,**
> >
> >     * *
> >
> >     **             topologyDirection                              
> >     ENUMERATED**
> >
> >     * *
> >
> >     **             {**
> >
> >     * *
> >
> >     **                         bothway(0),**
> >
> >     * *
> >
> >     **                         isolate(1),**
> >
> >     * *
> >
> >     **                         oneway(2)**
> >
> >     * *
> >
> >     **                         onewayexternal(3),**
> >
> >     **
> >
> >     *                         onewayboth(4),*
> >
> >     *** *
> >
> >     **             },**
> >
> >     * *
> >
> >     **             ...,**
> >
> >     * *
> >
> >     **            
> >     streamID                                              StreamID
> >     OPTIONAL,**
> >
>
>-----------------------------------------------------------------------
-
> >
> >_______________________________________________
> >Megaco mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/megaco
> >  
> >
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Tue, 20 Jun 2006 19:03:51 +1000

G'Day Arturo,

Thanks, I had forget about this.

Christian