Subject: Fw: Add one more Query //Re: [Megaco] V3 related clarifications required

From: Tony Zhang <[email-masked]>
Date: Mon, 19 Jun 2006 18:21:30 +0800

why define topologyDirectionExtension is below, why it is not optional?
why donot add to topologyDirection ?
  TopologyRequest                   ::= SEQUENCE

  {

               terminationFrom                                TerminationID,

               terminationTo                                     TerminationID,

               topologyDirection                               ENUMERATED

               {

                           bothway(0),

                           isolate(1),

                           oneway(2)

               },

               …,

               streamID                                              StreamID OPTIONAL,

               topologyDirectionExtension             ENUMERATED

               {

                           onewayexternal(0),

                           onewayboth(1),

                           …

               }

  TopologyRequest                   ::= SEQUENCE

  {

               terminationFrom                                TerminationID,

               terminationTo                                     TerminationID,

               topologyDirection                               ENUMERATED

               {

                           bothway(0),

                           isolate(1),

                           oneway(2)

                           onewayexternal(3),

                           onewayboth(4),

               },

               …,

               streamID                                              StreamID OPTIONAL,
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Tue, 20 Jun 2006 12:33:45 +1000

Hello Tony,

topologyDirectionExtension was needed because we didn't add the 
extension ellipses (...) to the topologyDirection structure in H.248.1 
version 1. So when we wanted to add different types of "directions" we 
needed to add this extension field.

With regards to "optional" it should in fact be optional. I think we 
need to look at someway of fixing this error/omission.

Regards, Christian

Tony Zhang wrote:

>  
> why *define topologyDirectionExtension is below, why it is not optional?*
> why donot add to *topologyDirection ?*
>
>     *TopologyRequest                   ::= SEQUENCE*
>
>     *{*
>
>     *             terminationFrom                               
>     TerminationID,*
>
>     *             terminationTo                                    
>     TerminationID,*
>
>     *             topologyDirection                              
>     ENUMERATED*
>
>     *             {*
>
>     *                         bothway(0),*
>
>     *                         isolate(1),*
>
>     *                         oneway(2)*
>
>     *             },*
>
>     *             …,*
>
>     *            
>     streamID                                              StreamID
>     OPTIONAL,*
>
>     *             topologyDirectionExtension             ENUMERATED*
>
>     *             {*
>
>     *                         onewayexternal(0),*
>
>     *                         onewayboth(1),*
>
>     *                         …*
>
>     *             }*
>
>     ** 
>
>     * *
>
>     **TopologyRequest                   ::= SEQUENCE**
>
>     * *
>
>     **{**
>
>     * *
>
>     **             terminationFrom                               
>     TerminationID,**
>
>     * *
>
>     **             terminationTo                                    
>     TerminationID,**
>
>     * *
>
>     **             topologyDirection                              
>     ENUMERATED**
>
>     * *
>
>     **             {**
>
>     * *
>
>     **                         bothway(0),**
>
>     * *
>
>     **                         isolate(1),**
>
>     * *
>
>     **                         oneway(2)**
>
>     * *
>
>     **                         onewayexternal(3),**
>
>     **
>
>     *                         onewayboth(4),*
>
>     *** *
>
>     **             },**
>
>     * *
>
>     **             …,**
>
>     * *
>
>     **            
>     streamID                                              StreamID
>     OPTIONAL,**
>
>------------------------------------------------------------------------
>

---

From: Tony Zhang <[email-masked]>
Date: Tue, 20 Jun 2006 15:08:22 +0800

Hi Christian:
    if topologyDirectionExtension   is optional,then topologyDirection  should change to optional also.so this isnot compatible with H248.1 version 1 also.
.so if H248.1 version 3 add topologyDirectionExtension  for be compatible with H248.1 version 1,it is cannot work.
    so maybe change to add more ENUM value is more simply.
Regars!
            Tony Zhang