Subject: RE: [Megaco] Error Descriptor Syntax

From: "Carson, Paul" <[email-masked]>
Date: Wed, 7 Jun 2006 11:08:06 +0100

This is legal.

The trailing ";" and unquoted string is a comment.

A comment can follow a "}".

Looking at the ABNF,

    RBRKT = LWSP %x7B LWSP ; "}"

and 

    LWSP = *(WSP / COMMENT / EOL)

a COMMENT is a ";" followed by an unquoted string of characters terminated
by EOL

- PaulC

-----Original Message-----
From: Alon Tal [mailto:[email-masked]] 
Sent: 07 June 2006 10:50
To: [email-masked]
Subject: [Megaco] Error Descriptor Syntax

Is the following error descriptor valid?

!/1 [10.20.30.40]:2944
P = 75040 {
  C = 1046936 {
    MF = STM/15 {
      ER = 530 {}; Receipt of MF while deleting the endpoint
    }
  }
}

As I understand the ABNF, the trailing ";" and unquoted string are illegal.
However, this comes from a live and functioning network, so there might be
something I'm missing.

Thanks,
Alon Tal

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 8 Jun 2006 16:20:09 -0400

Note that a comment, while legal, is completely unparseable.  Because
literally *anything* can appear in a comment, there is no way for the
receiver to analyze the data contained in the comment.

The Error Descriptor is capable of carrying information in the Error
Text construct.  The values contained in the Error Text are defined in
H.248.8 or in the package where the error code is defined, so that
implementations will be able to glean information out of the error text
that could be used to rectify the problem.

I will note that the comment constructs was intended for use in
informational situations, such as sample call flows and the like.  I,
personally, think its use in live deployments is questionable at best.

Kevin 

-----Original Message-----
From: Carson, Paul [mailto:[email-masked]] 
Sent: Wednesday, June 07, 2006 6:08 AM
To: 'Alon Tal'; [email-masked]
Subject: RE: [Megaco] Error Descriptor Syntax

This is legal.

Looking at the ABNF,

and 

a COMMENT is a ";" followed by an unquoted string of characters
terminated by EOL

- PaulC

-----Original Message-----
From: Alon Tal [mailto:[email-masked]]
Sent: 07 June 2006 10:50
To: [email-masked]
Subject: [Megaco] Error Descriptor Syntax

!/1 [10.20.30.40]:2944
P = 75040 {
  C = 1046936 {
    MF = STM/15 {

As I understand the ABNF, the trailing ";" and unquoted string are
illegal.
However, this comes from a live and functioning network, so there might
be something I'm missing.

Thanks,
Alon Tal