Subject: [Megaco] Profile negotiation and Control association

From: xiaoshaoping 38157 <[email-masked]>
Date: Thu, 15 Jun 2006 13:01:25 +0800

Hello,
    I've some problem when understanding the profile negotiation procedure in H248v3:

7.2.8.1.11	ServiceChange Command and Response
"If the MGC returned a profile in the reply other than the one that was provided in the request the MG shall:
a.	continue the control association by issuing a new ServiceChange Command with an agreed profile to confirm to the MGC that the MG has agreed with the profile, or
b.	keep the control association active, so that the MGC will use the profile that it sent in the ServiceChange Reply, or
……"

If the MG choose action "a", I think the control association is not established yet, because ServiceChangeProfile is not agreed between the MGC and MG, so the Registration is not completed, based on following words excerpted from $F.3.1/H248.1 V3:
"Registration starts when the initial ServiceChange Command is sent from the MG to the MGC and completes when the command is replied by the MGC without an alternate address or an error and the ServiceChangeProfile is agreed between the MGC and MG. The control association is established upon completion of registration"
So, how to understand the words of "continue the control association"? 

If the MG choose action "b", does it implies that the MG will accept the profile in the ServiceChange Reply silently, and not issused any new ServiceChange Command to claim which profile it chosed actually? 
If so, I think the words of "keep the control association active" is inaccurate because the new control association is established just now, how to "keep"? 
and what is the definition of "active" state of control association, is the initiation or success of the registration? As I know, the spec just defined initiation, establishment and termination point for the control association as: 
F.2	Control Association Definition
"A control association is a communication relationship whereby an MGC is controlling an MG. A control association is instantiated via registration. The control association is terminated by the MG going OutOfService, being successfully handed off to an alternate MGC, or successfully failing over to an alternate MGC. "

Can somebody give me a light on these problem?

thanks,
Bill Xiaoshaoping

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Wed, 28 Jun 2006 07:43:19 +0200

I think, there are some valid points indicated which should be
clarified/fixed in the Implementers' Guide.
Could you provide a correspondent contribution to next Q3/16 meeting?
Thanks,
Albrecht

                      xiaoshaoping                                                                                                    
                      38157                    To:      [email-masked]                                                               
                      <xiaoshaoping@hu         cc:                                                                                    
                      awei.com>                Subject: [Megaco] Profile negotiation and Control association                          
                                                                                                                                      
                      15.06.2006 07:01                                                                                                

Hello,
    I've some problem when understanding the profile negotiation procedure
in H248v3:

7.2.8.1.11         ServiceChange Command and Response
"If the MGC returned a profile in the reply other than the one that was
provided in the request the MG shall:
a.           continue the control association by issuing a new
ServiceChange Command with an agreed profile to confirm to the MGC that the
MG has agreed with the profile, or
b.           keep the control association active, so that the MGC will use
the profile that it sent in the ServiceChange Reply, or
??"

If the MG choose action "a", I think the control association is not
established yet, because ServiceChangeProfile is not agreed between the MGC
and MG, so the Registration is not completed, based on following words
excerpted from $F.3.1/H248.1 V3:
"Registration starts when the initial ServiceChange Command is sent from
the MG to the MGC and completes when the command is replied by the MGC
without an alternate address or an error and the ServiceChangeProfile is
agreed between the MGC and MG. The control association is established upon
completion of registration"
So, how to understand the words of "continue the control association"?

If the MG choose action "b", does it implies that the MG will accept the
profile in the ServiceChange Reply silently, and not issused any new
ServiceChange Command to claim which profile it chosed actually?
If so, I think the words of "keep the control association active" is
inaccurate because the new control association is established just now, how
to "keep"?
and what is the definition of "active" state of control association, is the
initiation or success of the registration? As I know, the spec just defined
initiation, establishment and termination point for the control association
as:
F.2          Control Association Definition
"A control association is a communication relationship whereby an MGC is
controlling an MG. A control association is instantiated via registration.
The control association is terminated by the MG going OutOfService, being
successfully handed off to an alternate MGC, or successfully failing over
to an alternate MGC. "

thanks,
Bill Xiaoshaoping