Subject: [Megaco] Question on Interface Routing in relation to H.248 Profile for controlling Border Gateway Functions (BGF) (ETSI ES 283 018)

From: "Reinaldo Penno" <[email-masked]>
Date: Sat, 14 Oct 2006 03:00:28 -0400

In the specification above (or TS 102 333 for that matter) there is a
proposal for the termination ID. 

"5.6.1.1.1 Overview and prose specification
The Termination ID structure shall follow the guidelines of H.248 and
shall be based on four fields:
* "ip/<group>/<interface>/<id>"."

I would like to understand what "interface" means in this context when
related to routing.

The scenario is a BGF with many input and output interfaces.

     +----+
Ifa -|    |-ifx
Ifb -| RT |-ify   RT means routing table
Ibc -|    |-ifz
     +----+

Packets come from one of the input interfaces (left), a routing lookup
is done, and exit through one of the output interfaces (right).

Given the termination ID ip/1/ifx/200 and a gate with source IP a.b.c.d
and destination IP e.f.g.h associated with it, which actions should be
done?

A) One should attach the termination to interface Ifx and if packets go
through that interface (and termination) any gate actions are applied.

B) One should override the routing table in order to make sure that
packets from source a.b.c.d and destination e.f.g.h go through Ifx.

The two approaches are quite different:

The first provides a clean separation of Gate Control and routing. You
configure routing to make sure the packets you are interested on go
through the proper interface (and consequently hit the termination) when
egress/ingress the router.

The second approach means an overide of the routing table by the H.248
process. Although possible this represents a protocol layer violation
and it makes me worried about unforseen interaction between routing
protocols and H.248 driven routing table changes.

What would be the correct interpretation?

Thanks,

Reinaldo

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Mon, 16 Oct 2006 15:39:34 +0200

Reinaldo,

1st H.248 vs IP RIB/FIB
   There aren't any H.248 capabilities defined so far, allowing the
   modification of IP RIB/FIB data bases. Thus, H.248 is entirely decoupled
   from IP routing protocols.

2nd TerminationID
   Don't over-interprete this TerminatinationID structure. The defined
   naming convention by ES 283 018 is rather specific because besides the
   basic "identification" function, the syntax is also a) overloaded with
   other functions (a1 -> usage of <group>; a2 -> usage of <interface>);
   and b) hierarchical (-> benefit in case of wildcarding).

   The prime purpose behind (a2) is "IP address realm" indication. Please
   note that the ipdc package (H.248.41) was not yet available when ES 283
   018 was defined.
   So, the term "interface" could mislead if interpreted as "IP interface"
   (but this isn't the definition by Table 4/ES 283 018).

- Albrecht

                      "Reinaldo Penno"                                                                                                
                      <rpenno@juniper.         To:      <[email-masked]>                                                             
                      net>                     cc:                                                                                    
                                               Subject: [Megaco] Question on Interface Routing in relation to H.248 Profile     for   
                      14.10.2006 09:00         controlling Border Gateway Functions (BGF) (ETSI ES 283 018)                           

     +----+
Ifa -|    |-ifx

Thanks,

Reinaldo

---

From: "Reinaldo Penno" <[email-masked]>
Date: Thu, 19 Oct 2006 13:16:09 -0400

Thanks,

Is it possible to change this definition then?

"Interface	Logical or physical interface to a network to/from which
the termination will be sending/receiving media.
(See notes 1and 2)."

Implying the termination will be sending media through a specific
interface implies (for some) a routing override?

I believe it should read.

"Interface	Logical or physical interface to a network to/from which
the termination will be associated.
(See notes 1and 2)." 

Or maybe

"Interface	Logical or physical interface to a network to/from which
the termination assumes media will be sent/received.
(See notes 1and 2)."

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Monday, October 16, 2006 6:40 AM
> To: Reinaldo Penno
> Cc: [email-masked]
> Subject: Re: [Megaco] Question on Interface Routing in 
> relation to H.248 Profile for controlling Border Gateway 
> Functions (BGF) (ETSI ES 283 018)
> 
> 
> Reinaldo,
> 
> 1st H.248 vs IP RIB/FIB
>                                                Subject: 
> [Megaco] Question on Interface Routing in relation to H.248 
> Profile     for   
>                       14.10.2006 09:00         controlling 
> Border Gateway Functions (BGF) (ETSI ES 283 018)              
>              
>                                                               
>                                                               
>           
> 
> 
> 
> 
> In the specification above (or TS 102 333 for that matter) 
> there is a proposal for the termination ID.
> 
> "5.6.1.1.1 Overview and prose specification The Termination 
> ID structure shall follow the guidelines of H.248 and shall 
> be based on four fields:
> I would like to understand what "interface" means in this 
> context when related to routing.
> 
> Packets come from one of the input interfaces (left), a 
> routing lookup is done, and exit through one of the output 
> interfaces (right).
> 
> Given the termination ID ip/1/ifx/200 and a gate with source 
> IP a.b.c.d and destination IP e.f.g.h associated with it, 
> which actions should be done?
> 
> A) One should attach the termination to interface Ifx and if 
> packets go through that interface (and termination) any gate 
> actions are applied.
> 
> B) One should override the routing table in order to make 
> sure that packets from source a.b.c.d and destination e.f.g.h 
> go through Ifx.
> 
> 
> The first provides a clean separation of Gate Control and 
> routing. You configure routing to make sure the packets you 
> are interested on go through the proper interface (and 
> consequently hit the termination) when egress/ingress the router.
> 
> The second approach means an overide of the routing table by 
> the H.248 process. Although possible this represents a 
> protocol layer violation and it makes me worried about 
> unforseen interaction between routing protocols and H.248 
> driven routing table changes.
>