Subject: [Megaco] Error reply with Error Code 431

From: "m.Hamada" <[email-masked]>
Date: Wed, 25 Oct 2006 12:11:14 +0900

Hi all,

I have a question about Reply message with error.

When GC sends the action(e.g. AuditValue) with wildcarded ContextID 
(ALL) and wildcarded TerminationID, if there are no matches to the 
wildcarded ContextID and TerminationID, which is appropriate 
Reply mesage?

(a)
P = TransactionID {
 C = * {
  AV = wildcarded TerminationID {
   ER=431{"optional ErrorText"}
}}}

(b)
P = TransactionID {
 C = * {
  ER = 431 {"optional ErrorText"}
}}

(c)
P = TransactionID {
 ER = 431 {"optional ErrorText"}
}

Thank you for your help in advance.
Kind regards

Masanori Hamada
  E-mail: [email-masked]

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Saurabh, Kumar" <[email-masked]>
Date: Wed, 25 Oct 2006 13:06:37 +0530

Option a (Command Level Error) and Option b (Action Level Error) both
are fine.

-Saurabh

-----Original Message-----
From: m.Hamada [mailto:[email-masked]] 
Sent: Wednesday, October 25, 2006 08:41
To: [email-masked]
Subject: [Megaco] Error reply with Error Code 431

Hi all,

(a)
P = TransactionID {
 C = * {

(b)
P = TransactionID {
 C = * {

(c)
P = TransactionID {

Masanori Hamada

---

From: "Stephen Mell" <[email-masked]>
Date: Thu, 26 Oct 2006 16:50:25 +0100

430-435 are termination errors are probably more naturally returned at the 
command level.

411-412 are Context level errors and are more suited to error descriptors 
at the action level.

but I don't think there are any hard and fast rules.

There was a TISPAN document knocking around which illustrated error 
responses and expected order of message 
validation very well. I can't lay my hands on it now.

H.248.8 is not much help in this area. For example:

Error 521 "Termination is Service Changing" is deprecated in H.248v2, 
presumably this was originally intended for use at the command level.

It is superceded by Error 505 "Transaction Request Received before a 
ServiceChange Reply has been received" which presumably is intended for 
use at the

transaction level. 

But we are left to guess at this.

Steve Mell

-----Original Message-----
Date: Wed, 25 Oct 2006 13:06:37 +0530
From: "Saurabh, Kumar" <[email-masked]>
Subject: RE: [Megaco] Error reply with Error Code 431
To: "m.Hamada" <[email-masked]>
Cc: [email-masked]
Message-ID:
 <[email-masked]>
Content-Type: text/plain;                charset="us-ascii"

-Saurabh

-----Original Message-----
From: m.Hamada [mailto:[email-masked]] 
Sent: Wednesday, October 25, 2006 08:41
To: [email-masked]
Subject: [Megaco] Error reply with Error Code 431

Hi all,

(a)
P = TransactionID {
 C = * {

(b)
P = TransactionID {
 C = * {

(c)
P = TransactionID {

Masanori Hamada