Subject: [Megaco] How to handle unknown Reply ...

From: J S <[email-masked]>
Date: Wed, 25 Oct 2006 09:26:57 -0700 (PDT)

Can anyone explain how to handle unknown/timed out Replies ... e.g.
if MG goes in bad shape, MGC times-out the request and clears the
state. Then reply comes back from MG. How should MGC handle that
reply? 

1. Just Ignore/drop it ? OR

2.  Send some reply back to MG ?? 

e.g. 
MGC                    MG
 |--T=x{}-------------->|
 |-(re-transmission-1)->| 
 |-(re-transmission-2)->|
 | (timedout)           |
...
 |<------------P=x{}----|
(what?)

Thanks in advance ...
-JST

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kamitses, Jerry" <[email-masked]>
Date: Thu, 26 Oct 2006 20:19:20 -0400

3. audit the applicable terminations referenced in the reply.
Proceed on the basis of their current state vs. desired state.
In addition to unknown and timed-out replies you may also 
encounter duplicate replies, in both the ImmAckRequired as 
well as non-ImmAckRequired cases. 

e.g. 
MGC                    MG
 |--T=x{}-------------->|
 |<------------P=x{}----|
 |                      |
 |--T=y{}-------------->|
 |<------------P=y{}----|
 |                      |
		...
 |<------------P=x{}----|

-----Original Message-----
From: J S [mailto:[email-masked]]
Sent: Wednesday, October 25, 2006 12:27 PM
To: [email-masked]
Subject: [Megaco] How to handle unknown Reply ...

e.g. 
MGC                    MG
 |--T=x{}-------------->|
 |-(re-transmission-1)->| 
 |-(re-transmission-2)->|
 | (timedout)           |
...
 |<------------P=x{}----|
(what?)

Thanks in advance ...
-JST

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 26 Oct 2006 21:16:24 -0400

With the exception of the three-way handshake, there is no "reply to a
reply" in H.248.  If a Reply is not valid, then it is ignored.

Kevin 

-----Original Message-----
From: J S [mailto:[email-masked]] 
Sent: Wednesday, October 25, 2006 12:27 PM
To: [email-masked]
Subject: [Megaco] How to handle unknown Reply ...

Can anyone explain how to handle unknown/timed out Replies ... e.g.
if MG goes in bad shape, MGC times-out the request and clears the state.
Then reply comes back from MG. How should MGC handle that reply? 

e.g. 
MGC                    MG
 |--T=x{}-------------->|
 |-(re-transmission-1)->|
 |-(re-transmission-2)->|
 | (timedout)           |
...
 |<------------P=x{}----|
(what?)

Thanks in advance ...
-JST