Subject: [Megaco] Different signal types in cg and tonegen

From: "Luke Zhang \(luzhan\)" <[email-masked]>
Date: Mon, 29 Jan 2007 11:20:39 +0800

Hi,
 
tonegen/pt is of brief type and cg/rt is of timeout type. But rt is also
defined as a signal ID for tonegen/pt. Therefore I can have following
similar signals but of different type:
 
tonegen/pt{tl=rt}    Of brief type
cg/rt                    Of timeout type
 
Is there any difference between these two? Is this tonegen/pt{tl=rt}
just play a short part of tone and stop?
 
Thanks, Luke
___________________________________________________
Luke Zhang
Software Engineer, China R&D Center, Cisco Systems
14th floor, Block C, Keji Building, 900 Yishan Lu, Caohejing Hi-Tech
Park, Shanghai, P.R.C, 200233                    ....
Phone : +86 (21) 2405 7082                         .....   __0
Mobile: +86 159 2133 9185                         ....   _\ <,_
Email : [email-masked] <mailto:[email-masked]>
___(_)/_(_)__
___________________________________________________

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Sudhanshu Garg <[email-masked]>
Date: Mon, 29 Jan 2007 12:56:16 +0530

Hi,

Yes, these two signals are of different types. One is brief signal and 
other is timeout signal.

However there should be a small correction.
Tonegen is designed to be extended only. And rt is defined as a signal ID 
for cg.

cg/pt {tl=rt}, means a brief signal.
cg/rt means a timeout signal.

Regards,
Sudhanshu Garg
Technical Leader
Aricent
Phone:  +91-124-4176333 extn 5109
Fax: +91-124-4176224
web: www.aricent.com

"Luke Zhang \(luzhan\)" <[email-masked]> 
01/29/2007 08:50 AM

To
<[email-masked]>
cc

Subject
[Megaco] Different signal types in cg and tonegen

Hi,

 
Is there any difference between these two? Is this tonegen/pt{tl=rt} just 
play a short part of tone and stop?
 
Thanks, Luke
___________________________________________________
Luke Zhang
Software Engineer, China R&D Center, Cisco Systems
14th floor, Block C, Keji Building, 900 Yishan Lu, Caohejing Hi-Tech Park, 
Shanghai, P.R.C, 200233                    ....
Phone : +86 (21) 2405 7082                         .....   __0
Mobile: +86 159 2133 9185                         ....   _\ <,_
Email : [email-masked]                           ___(_)/_(_)__
___________________________________________________
 _______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

***********************  Aricent-Private   ***********************
"DISCLAIMER: This message is proprietary to Aricent  and is intended solely for the use of 
the individual to whom it is addressed. It may contain privileged or confidential information and should not be 
circulated or used for any purpose other than for what it is intended. If you have received this message in error, 
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for 
loss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco