Subject: [Megaco] Modify the media descriptor of an Ephemeral Terminal in an NULL c ontext

From: "Liu Ti,SNLB FN RDC NA(BJ)" <[email-masked]>
Date: Thu, 4 Jan 2007 11:17:57 +0800

Hi all:

My question is:
Term 1 is already in a context with context id 501. But for some reason a modify command(to modify the media descriptor of Term 1) from media controller has some error: the context id in this command is null.
So what kind of error should be returned:I want to use Error Code 435 (Termination ID Is Not In Specified Context).  My question is :Does the null context also belong to the "specified context"? If not, should this modify command be executed? If this modify command must be discarded, what kind of error code should be returned? Is 435 OK?

Thanks in advance

B.R
Liu Ti

> ___________________________________
> SIEMENS
>                                                     SLC COM CD/FN RDC
                                                    14, Jiu Xian Qiao Lu, Chaoyang Distr.
>                                                     P.O.Box 100016-14
>                                                     Beijing 100016, P.R. China
>                                                    Tel  : (+86)-10-5867-1393
Liu Ti                                        Fax :  (+86)-10-5867-1242
Software Engineer                      E-mail: [email-masked]
COM CD/FN RDC ACCESS   Homepage: www.siemens.com.cn <www.siemens.com.cn> 
> ____________________________________
> 
> 
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Raphael Tryster" <[email-masked]>
Date: Thu, 4 Jan 2007 09:43:55 +0200

Null context should be rejected if the termination is in a context.  435
is a good answer.

Raphael Tryster

________________________________

From: Liu Ti,SNLB FN RDC NA(BJ) [mailto:[email-masked]] 
Sent: Thursday, January 04, 2007 5:18 AM
To: [email-masked]
Subject: [Megaco] Modify the media descriptor of an Ephemeral Terminal
in anNULL c ontext

Hi all: 

My question is: 
Term 1 is already in a context with context id 501. But for some reason
a modify command(to modify the media descriptor of Term 1) from media
controller has some error: the context id in this command is null.

So what kind of error should be returned:I want to use Error Code 435
(Termination ID Is Not In Specified Context).  My question is :Does the
null context also belong to the "specified context"? If not, should this
modify command be executed? If this modify command must be discarded,
what kind of error code should be returned? Is 435 OK?

Thanks in advance 

B.R 
Liu Ti 

                                                    14, Jiu Xian Qiao
Lu, Chaoyang Distr. 
                                                    Beijing 100016, P.R.
China 
                                                   Tel  :
(+86)-10-5867-1393 
COM CD/FN RDC ACCESS   Homepage: www.siemens.com.cn 

**********************************************************************************************
This e-mail contains confidential, privileged or proprietary information to VocalTec Communications.
If you received this messege by mistake, please inform us and then delete the original and all copies.
*** eSafe scanned this email for viruses, vandals, and malicious content. ***
**********************************************************************************************