Subject: Re: gm/1 in different H.248 Profiles; Re: [Megaco] gm/sam syntax clarification.

From: iAmANumber notAFreeMan <[email-masked]>
Date: Tue, 3 Apr 2007 08:01:45 +0000 (GMT)

Thanks for your response Albrecht, can you supply a pointer to the H.248.43 (draft) so I can take a look at the (new?) gm package? I can't seem to find H.248.43 on the ITU web site.

While I think I understand that ETSI TS 102 333 defines the ETSI_GateControl profile (and provides a definition of the gm/1 package in annex B, I am actually using ETSI ES 283 018 as my reference, which defines the ETSI_BGF profile and states in section 5.14 table 67 that Gate Management package gm/1 is a mandatory package. I was not aware that the gm/1 package referred to by the 2 different profiles are themselves different.    

Thanks for your help,
Phil Ilett.

----- Original Message ----
From: "[email-masked]" <[email-masked]>
To: iAmANumber notAFreeMan <[email-masked]>
Cc: [email-masked]
Sent: Tuesday, 3 April, 2007 7:55:59 AM
Subject: gm/1 in different H.248 Profiles; Re: [Megaco] gm/sam syntax clarification.

To the "numbered unfree man":-),

just for information:
you are talking about a different H.248 Profiles.

Reinaldo:   package gm/1 in "ETSI_BGF/1" profile
You:        package gm/1 in "ETSI_GateControl/1" profile

You referred procedural clause is not relevant for the first profile.

But in case that the gm/1 syntax or semantic should be enhance, then I'd
like that you submitt a correspondent change proposal against draft
H.248.43 (note: this Recommendation contains draft gm/2 and the
TISPAN-to-ITU transferred gm/1 packages).

-Albrecht

                      iAmANumber                                                                                                        
                      notAFreeMan              To:      [email-masked]                                                                 
                      <philfillflip@ya         cc:                                                                                      
                      hoo.co.uk>               Subject: [Megaco] gm/sam syntax clarification.                                           
                                                                                                                                        
                      26.03.2007 14:07                                                                                                  

On the subject of gm/sam, I noticed that a recent poster who was asking a
gm/sam related question used the 20.20.20.20/24 syntax when referring to a
gm/sam value.

ETSI TS 102 333 V1.1.2 (2004-2007) Annex B.2 describes property id (sam) as
"Encoded as a DomainAddress as defined in ... H.248..., annex B. "*" is
used as a wildcard for digits"

the ABNF is
   IPv4address = V4hex DOT V4hex DOT V4hex DOT V4hex
and
  V4hex = 1*3(DIGIT) ; "0" ... "255"

The same document in section 5.12.1 bullet 2,  also says ".. in an IPv4
environment...,except that a number of trailing digits may be wildcarded".

question 1: Is 20.20.20.20/24 a valid specification for gm/sam= ? what
about 20.20.20.20/23 ?

question 2: What should the "*" wildcarding result in if the following sam
values are specified?
       a) 192.168.100.1*
       b) 192.168.100.11*

question 3: is there any reason why the "native" H.248 ABNF syntax using
the propertyParm/parmValue/alternativeValue token(s) could not be used for
gm/sam (as I believe it is for gm/spr). If this was allowed then
gm/sam=[192.168.100.1:192.168.100.19] or
gm/sam=[192.168.100.110:192.168.100.119] could be used in a similar way to
gm/spr=[1024:65535].

Thanks for any clarification,
Phil Ilett.

Copy addresses and emails from any email account to Yahoo! Mail - quick,
easy and free. Do it now..._______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

___________________________________________________________ 
New Yahoo! Mail is the ultimate force in competitive emailing. Find out more at the Yahoo! Mail Championships. Plus: play games and win prizes. 
http://uk.rd.yahoo.com/evt=44106/*http://mail.yahoo.net/uk 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Wed, 4 Apr 2007 11:12:55 +0200

Phil:
See Draft H.248.43:
http://ftp3.itu.int/av-arch/avc-site/2005-2008/0703_She/TD-50.zip

Guess you got already the URLs with Christian's email.
-Albrecht

PS
Right, ETSI ES 283 018 should be your reference ...

                      iAmANumber                                                                                                        
                      notAFreeMan              To:      [email-masked]                                              
                      <philfillflip@ya         cc:      [email-masked]                                                                 
                      hoo.co.uk>               Subject: Re: gm/1 in different H.248 Profiles;     Re: [Megaco] gm/sam syntax            
                                               clarification.                                                                           
                      03.04.2007 10:01                                                                                                  

Thanks for your response Albrecht, can you supply a pointer to the H.248.43
(draft) so I can take a look at the (new?) gm package? I can't seem to find
H.248.43 on the ITU web site.

While I think I understand that ETSI TS 102 333 defines the
ETSI_GateControl profile (and provides a definition of the gm/1 package in
annex B, I am actually using ETSI ES 283 018 as my reference, which defines
the ETSI_BGF profile and states in section 5.14 table 67 that Gate
Management package gm/1 is a mandatory package. I was not aware that the
gm/1 package referred to by the 2 different profiles are themselves
different.

Thanks for your help,
Phil Ilett.

----- Original Message ----
From: "[email-masked]"
<[email-masked]>
To: iAmANumber notAFreeMan <[email-masked]>
Cc: [email-masked]
Sent: Tuesday, 3 April, 2007 7:55:59 AM
Subject: gm/1 in different H.248 Profiles; Re: [Megaco] gm/sam syntax
clarification.

just for information:

-Albrecht

                    &nbs p; iAmANumber

& nbsp;
                      <philfillflip@ya         cc:

                      hoo.co.uk>               Subject: [Megaco] gm/sam
syntax clarification.

                      26.03.2007 14:07

the ABNF is