Subject: [Megaco] RE: Transaction Reply in case of multiple actions

From: "Rambabu Gajula" <[email-masked]>
Date: Thu, 5 Apr 2007 05:57:55 +0530

Dear Experts,

Could please help me. 

Thanks a lot for your time.

Thanks with regards,

Rambabu Gajula

________________________________

From: Rambabu Gajula 
Sent: Monday, April 02, 2007 8:36 AM
To: Rambabu Gajula; [email-masked]
Subject: RE: Transaction Reply in case of multiple actions

Can some one clarify queries posted in below e-mail.

Thanks a lot for your time.

Thanks with regards,
Rambabu

 

________________________________

From: Rambabu Gajula 
Sent: Saturday, March 31, 2007 4:10 PM
To: [email-masked]
Subject: Transaction Reply in case of multiple actions

Hello,

Could please let me know, 

If the transactions have more than one action with:

Transaction T1 has

Action A1: 

1)       Context ID

2)       Topology Properties

3)       Optional Commands

4)       Mandatory Commands

Action A2: 

1)       Context ID

2)       Topology Properties

3)       Optional Commands

4)       Mandatory Commands

For First Action (A1), the optional commands are failed (specification
mentioned very clearly process further commands in this action). After
executing all the commands, while applying the topology it encounter
problems (only for optional commands) which may leads to action level
error for A1.  

In this case, shall we go ahead with next action (A2) processing or we
should stop processing and send reply only with first action (A1).

Thanks a lot for your time.

Thanks with Regards,

Rambabu Gajula

 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Tue, 10 Apr 2007 11:59:51 +1000

Hello Rambabu,

I think whether or not you execute A2 or not depends on the type of 
action level error. For instance if the toplogy descriptor was using 
choose $ in expectation that the optional command added a termination, 
and if that command failed then I would consider the a topology error 
hasn't occurred. However is there was some sort of syntax problem 
associated with this e.g. choosing an invalid termination id range then 
I would return an error to A1 and not continue A2.

Regards, Christian

Rambabu Gajula wrote:
> ------------------------------------------------------------------------
>
> *From:* Rambabu Gajula
> *Sent:* Monday, April 02, 2007 8:36 AM
> *To:* Rambabu Gajula; [email-masked]
> *Subject:* RE: Transaction Reply in case of multiple actions
>
>  
>
> ------------------------------------------------------------------------
>
> *From:* Rambabu Gajula
> *Sent:* Saturday, March 31, 2007 4:10 PM
> *To:* [email-masked]
> *Subject:* Transaction Reply in case of multiple actions
>
>  
>
> Hello,
>
>  
>
> ------------------------------------------------------------------------
>