Subject: gm/1 clarifications; Re: [Megaco] Saf/sam & gate management protocol questions

From: [email-masked]
Date: Tue, 3 Apr 2007 08:14:13 +0200

Right,
these semantics are neither explicitly defined in
1) the package (= gm/1), nor
2) the refered profile (ETSI_BGF/1).

I do agree that an explicit description is required, preferably in Draft
H.248.43 in my opinion.
I think a clarification is required for "revertive behaviour" with regards
to your two questions. Right?

I'm a little be confused about your gate&filter notation: guess "filter"
relates to saf & sam, and "gate" is the TerminationID (?) or "(source?)
address/port" of the incoming interface (?) or sth else?

-Albrecht

                      "Reinaldo Penno"                                                                                                  
                      <rpenno@juniper.         To:      <[email-masked]>                                                               
                      net>                     cc:      [email-masked]                                              
                                               Subject: [Megaco] Saf/sam & gate management protocol questions                           
                      26.03.2007 03:16                                                                                                  

Hello Folks,

I tried my best reading the specs but I still have some doubts about
saf/sam in the context of the gate management protocol

Let's suppose an ADD message installs the the following gate&filter [*,
*, UDP, 10.10.10.1, 5060].

If a modify message is received with saf = ON and sam = 20.20.20/24 I
understand that the gate filter will change to [20.20.20/24, *, UDP,
10.10.10.1, 5060].

If another modify message comes and turns saf = OFF, then the gate
reverts back to what it was [*, *, UDP, 10.10.10.1, 5060]. Am I okay up
to this point?

Now, let's suppose the original ADD message installs a full specified
gate [20.20.20.1, 10000, UDP, 10.10.10.1, 5060]. Then a modify message
is received with saf = ON and sam = 20.20.20/24.

My understanding is that sam will _override_ the current source IP in
the gate filter and we will have [20.20.20/24, 10000, UDP, 10.10.10.1,
5060] as the filter. Another possible interpretation is that sam is a
pre/post-filter, i.e., we match against sam and then againt original
gate filter which remains in place. This is my first question.

My second question is what happens is we receive a modify message with
saf = OFF. Does the gate reverts to its original form [20.20.20.1,
10000, UDP, 10.10.10.1, 5060]? Or does it reverts to [*, 10000, UDP,
10.10.10.1, 5060], i.e., source IP "any"?

Thanks,

Reinaldo

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Reinaldo Penno" <[email-masked]>
Date: Tue, 3 Apr 2007 12:38:49 -0400

Hello Albrecht,

Inline... 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Monday, April 02, 2007 11:14 PM
> To: Reinaldo Penno
> Cc: [email-masked]
> Subject: gm/1 clarifications; Re: [Megaco] Saf/sam & gate 
> management protocol questions
> 
> Right,
> I think a clarification is required for "revertive behaviour" 
> with regards to your two questions. Right?

Yes.

> I'm a little be confused about your gate&filter notation: 

Filter means the 5-tuple associated with the gate. That includes saf/sam
that could (nor not) being specified in the ADD/MODIFY messages.

> relates to saf & sam, and "gate" is the TerminationID (?) or 
> "(source?) address/port" of the incoming interface (?) or sth else?
> 
> -Albrecht
> 
> 
> 
>                                                               
>                                                               
>             
>                       "Reinaldo Penno"                        
>                                                               
>             
>                       <rpenno@juniper.         To:      
> <[email-masked]>                                             
>                   
>                       net>                     cc:      
>                                                Subject: 
> [Megaco] Saf/sam & gate management protocol questions         
>                   
>                       26.03.2007 03:16                        
>                                                               
>             
>                                                               
>                                                               
>             
> 
> 
> 
> 
> Hello Folks,
> 
> I tried my best reading the specs but I still have some 
> doubts about saf/sam in the context of the gate management protocol
> 
> Let's suppose an ADD message installs the the following 
> gate&filter [*, *, UDP, 10.10.10.1, 5060].
> 
> If a modify message is received with saf = ON and sam = 
> 20.20.20/24 I understand that the gate filter will change to 
> [20.20.20/24, *, UDP, 10.10.10.1, 5060].
> 
> If another modify message comes and turns saf = OFF, then the 
> gate reverts back to what it was [*, *, UDP, 10.10.10.1, 
> 5060]. Am I okay up to this point?
> 
> Now, let's suppose the original ADD message installs a full 
> specified gate [20.20.20.1, 10000, UDP, 10.10.10.1, 5060]. 
> Then a modify message is received with saf = ON and sam = 20.20.20/24.
> 
> My understanding is that sam will _override_ the current 
> source IP in the gate filter and we will have [20.20.20/24, 
> 10000, UDP, 10.10.10.1, 5060] as the filter. Another possible 
> interpretation is that sam is a pre/post-filter, i.e., we 
> match against sam and then againt original gate filter which 
> remains in place. This is my first question.
> 
> My second question is what happens is we receive a modify 
> message with saf = OFF. Does the gate reverts to its original 
> form [20.20.20.1, 10000, UDP, 10.10.10.1, 5060]? Or does it 
> reverts to [*, 10000, UDP, 10.10.10.1, 5060], i.e., source IP "any"?
> 
> Thanks,
> 
> Reinaldo
> 
> 
>

---

From: [email-masked]
Date: Wed, 4 Apr 2007 11:25:39 +0200

OK, we got the same understanding about "filter", but you still did not
indicate your "gate" understanding.

The reason I'm asking is the fact, that there might be two "gate" concepts
around. gm/1 is not really explicit about the underlying "gate" definition,
that's why ES 283 018 did illustrate the supposed gate concept in Annex A
(A.2 Relationships between gates and H.248 Streams).

This gate concept involves "two IP H.248 Terminations" and "gates"
unidirectional traffic flows.
Another meaningful concept could be related to a single Termination only.

BTW: the ES 283 002 gate concept is identical to the H.248.37 pinhole &
gate definition:
   3.3      pinhole: A configuration of two associated H.248 IP
   Terminations within the same context, which allows/prohibits
   unidirectional forwarding of IP packets under specified conditions
   (e.g., address tuple).
   NOTE ? A pinhole may also be referred to as a "gate".

I think it is not worth to spent too much time on gate definitions, I just
wanted to know what you are exactly mean with "gate" in your original email
(it's a 2- or 3-tuple (?), but which relation to Stream/Termination &
direction?).

-Albrecht

                      "Reinaldo Penno"                                                                                                  
                      <rpenno@juniper.         To:      <[email-masked]>                                            
                      net>                     cc:      [email-masked]                                                                 
                                               Subject: RE: gm/1 clarifications;      Re: [Megaco] Saf/sam & gate management protocol   
                      03.04.2007 18:38         questions                                                                                

Hello Albrecht,

Inline...

Yes.