Subject: [Megaco] V3 question - ServiceChangeIncompleteFlag as extension parameter

From: "Dani Stettiner" <[email-masked]>
Date: Wed, 18 Apr 2007 16:09:16 +0300

Hi All ,

   Section "7.2.8.1.10 ServiceChangeIncompleteFlag"   says (among other
things)

"When this flag is sent in an initial ServiceChange (H.248.1 Version 1)

Command using the ServiceChange extension parameter "X-SC" the following
is used:

Name: SIC

Type: Boolean

Possible values: ON: Flag included

NOTE - The value OFF is not required as subsequent commands will be
H.248.1 Version 3 encoded."

   What is the exact form of  this parameter (in ABNF) when given as
extension in the first message?

   Would it be  X-SCSIC=ON?

    MEGACO/1 [10.4.4.176]:2944

T=32545{

   C = - {

               SC=ROOT{SV{ MT=RS,AD = 2944,V=3,PF=TGW/1,   RE="901 MG
Cold Boot",

                     X-SCSIC=ON

}}}

  thanks

Dan Stettiner
Software Engineer, R&D
H.248/MEGACO 

Audiocodes
Email: [email-masked]
Tel. +972-3-9764415
www.audiocodes.com
<http://www.audiocodes.com/ohttp:/www.audiocodes.com/> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Fri, 20 Apr 2007 10:57:14 +1000

Hello Dani,

You need to look at 7.2.8.1.8 ExtensionParameter for the encoding. e.g. 
The structure of the value is defined
by the following ABNF: X-SC = 1* (NAME EQUAL paramValue [COMMA])

The above structure replaced the "parmValue" component of the H.248.1 
Annex B ABNF (
extension = extensionParameter parmValue).

So the exact encoded form would be:
X-SC=SIC=ON

Regards, Christian

Dani Stettiner wrote:
>
> Hi All ,
>
> Section “*7.2.8.1.10 ServiceChangeIncompleteFlag” *says (among other 
> things)
>
> “When this flag is sent in an initial ServiceChange (H.248.1 Version 1)
>
> Command using the ServiceChange extension parameter "X-SC" the 
> following is used:
>
> *Name*: SIC
>
> *Type*: Boolean
>
> *Possible values*: ON: Flag included
>
> NOTE – The value OFF is not required as subsequent commands will be 
> H.248.1 Version 3 encoded.”
>
> Would it be *X-SCSIC=ON?*
>
> SC=ROOT{SV{ MT=RS,AD = 2944,V=3,PF=TGW/1, RE="901 MG Cold Boot",
>
> * X-SCSIC=ON*
>
> }}}
>
> thanks
>
> //Dan Stettiner///
> ///Software Engineer, R&D//
> //H.248/MEGACO ///
>
> /Audiocodes
> <mailto:[email-masked]>
> Tel. +972-3-9764415
> www.audiocodes.com <http://www.audiocodes.com/ohttp:/www.audiocodes.com/>
>
> ------------------------------------------------------------------------
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 20 Apr 2007 13:36:12 -0400

That ABNF doesn't look right. Making the comma optional means that if it 
omitted, you have the paramValue potentially concatenated with a succeeding NAME.

---

From: Christian Groves <[email-masked]>
Date: Mon, 23 Apr 2007 11:22:24 +1000

Yes it could be cleaned up to ensure the comma is included. Something 
for the IG and/or H.248.1v4.

Christian

Tom-PT Taylor wrote:
> That ABNF doesn't look right. Making the comma optional means that if 
> it omitted, you have the paramValue potentially concatenated with a 
> succeeding NAME.
>
> Christian Groves wrote:
>> Hello Dani,
>>
>> You need to look at 7.2.8.1.8 ExtensionParameter for the encoding. 
>> e.g. The structure of the value is defined