Subject: [Megaco] Starting up with Megaco

From: J Bhanot <[email-masked]>
Date: Mon, 21 Jan 2008 19:32:03 +0530

Hi,

I am just starting up with this stack..

Few queries that i have:

1. have downloaded the tar file (megaco_session-0.5.tar..think thats the
stack :-))...am using windows vista..untared it with wrar...i got following
file megaco_session-0.5.....which says the extension of the file in .5....

looks like i am doing s'thing wrong..

does this stack works with window..if yes, what needs to be done to do so..

2. how do i start with this stack so that i can build applications using
this stack..

Thanking in anticipation..

Cheers
jb
Jagmohan Bhanot
Tata Consultancy Services
Mailto: [email-masked]
Website: http://www.tcs.com
____________________________________________
Experience certainty.   IT Services
                  Business Solutions
                  Outsourcing
____________________________________________

=====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: sarju <[email-masked]>
Date: Mon, 21 Jan 2008 19:38:51 +0530

date and resource

----- Original Message -----
From: "J Bhanot" <[email-masked]>
To: <[email-masked]>
Sent: Monday, January 21, 2008 7:32 PM
Subject: [Megaco] Starting up with Megaco

Hi,

Few queries that i have:

Cheers
jb
Jagmohan Bhanot

This e-mail and all material transmitted with it are for the use of the intended recipient(s) ONLY and contains confidential and/or privileged information. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies and the original message. Any unauthorized review, use, disclosure, dissemination, forwarding, printing or copying of this email or any action taken pursuant to the contents of the present e-mail is strictly prohibited and is unlawful.
The recipient acknowledges that Bharti Telesoft Limited or its management or directors, are unable to exercise control or ensure the integrity over /of the contents of the information contained in e-mail. Any views expressed herein are those of the individual sender only and no binding nature of the contents shall be implied or assumed unless the sender does so expressly with due authority of Bharti Telesoft Limited. E-mail and any contents transmitted with it are prone to viruses and related defects despite all efforts to avoid such by Bharti Telesoft Limited.

---

From: "John Wainwright" <[email-masked]>
Date: Mon, 21 Jan 2008 13:15:35 -0600

We have a situation with an MG connected/communicating to an MGC and the
management entity controlling the MG changes the IP address of the MGC.
The request is to 'fix' the association so that our MG is now talking to
the new MGC.  
My question is what details should go into the SVC message to the old
and new MGCs to resolve this?  The 'handoff' method seems to be used as
part of an MGC directed change but in this case it is more of a mgmt
entity/MG directed change.  Any thoughts?

Thanks
John

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Tue, 22 Jan 2008 15:25:17 +0100

John,

guess your scenario may be addressed with ServiceChangeAddress (and also
ServiceChangeMgcID) parameters.

Draft H.Sup7 provides information about IP interface *re-direction*
("your scenario may be mapped emulated as re-direction IMHO"):

The output draft of our present Q.3/16 meeting will be available
tomorrow afternoon (under following URL):

http://ftp3.itu.int/av-arch/avc-site/2005-2008/0801_Seo/TD-35.zip

TD-35
Updated Draft ITU-T H.Sup7 "Gateway Control Protocol: Establishment
Procedures for the H.248 MGC-MG Control Association" (Ed. 0.14)

Regards, Albrecht

> -----Original Message-----
> From: John Wainwright [mailto:[email-masked]]
> Sent: Montag, 21. Januar 2008 20:16
> To: [email-masked]
> Subject: [Megaco] MGC IP address change
>

---

From: "John Wainwright" <[email-masked]>
Date: Tue, 22 Jan 2008 09:19:54 -0600

Would the MG inform the original MGC via something like the "Forced"
method or should it just communicate to the new MGC.  
In theory calls set up via the old MGC could be in progress although
switching to the new MGC would have to result in them being torn down I
presume.  In this case would it be incumbent on the MG to inform the old
MGC of what's happening such that he can clean up termination data from
his end?

Regards
John

-----Original Message-----
From: Schwarz Albrecht [mailto:[email-masked]] 
Sent: Tuesday, January 22, 2008 8:25 AM
To: John Wainwright; [email-masked]
Subject: RE: [Megaco] MGC IP address change

John,

TD-35

Regards, Albrecht

---

From: "Rajesh Jain -X (rajesjai - Hughes Software at Cisco)" <[email-masked]>
Date: Tue, 22 Jan 2008 07:23:11 -0800

MG need not to inform the old MGC in this case.
The new MGC would audit MG to determine existing calls and take
appropriate action. 

Thanks
Rajesh

-----Original Message-----
From: John Wainwright [mailto:[email-masked]] 
Sent: Tuesday, January 22, 2008 8:50 PM
To: Schwarz Albrecht; [email-masked]
Subject: RE: [Megaco] MGC IP address change

Regards
John

-----Original Message-----
From: Schwarz Albrecht [mailto:[email-masked]]
Sent: Tuesday, January 22, 2008 8:25 AM
To: John Wainwright; [email-masked]
Subject: RE: [Megaco] MGC IP address change

John,

TD-35

Regards, Albrecht