Subject: RE: [Megaco] Megaco digitmap timer

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 9 Jan 2008 10:45:23 -0500

I do not believe that inference to be correct, and the use of brackets
in this way does not appear to be terribly constructive.
 
Note that these are square brackets and not braces.  Braces are "{}".
 
Remember that square brackets specify a choice, and are not used to
denote a subset.  In this particular instance the DigitMap is allowing
the MG to choose between a digit from 0-9 and the long interdigit timer.
I don't see where that would ever be a desired option in the normal
processing of digits.
 
Kevin

________________________________

From: Ramesh Babu Kuppili [mailto:[email-masked]] 
Sent: Friday, December 28, 2007 1:38 AM
To: [email-masked]
Subject: [Megaco] Megaco digitmap timer

Hi,
 
I have a question about megaco digitmap timer.
 
What is the scope of a timer (L or S) within a range in a megaco
digitmap.  For example:
 
In the digitmap:
    15xSxxx[Lx]xxxx
 
My inference from the rfc is (taking a dial sequence of 15105551212
    Digit dialled            Timer started
        1                            L
        5                            L
        1                            L
        0                            S
        5                            S
        5                            S
        5                            L      (this is within the braces.
my assumption is that the timer specifier within braces is valid only
within braces)
        1                            S
        2                            S
        1                            S
        2                            S
 
Is my inference correct that timer specifier within a brace is valid
only within the brace.
 
- ramesh
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Ramesh Babu Kuppili <[email-masked]>
Date: Thu, 10 Jan 2008 10:18:06 +0530

Hello Kevin,
 
Thanks a lot for you clarification.  But i still have a question.
 
>From implementaiton point of view, how will a gateway treat L, or S.  What does it mean by "choose between 0-9 and L timer"?  Does choosing L timer means detect L timer timeout.  Which means we should start the timer in the first case.  My understanding is that L and S in a digitmap are specifiers that specify what timers to start from point onwards.  The example i gave may be too simple and impractical.  But what i was trying to find out is how does L and S in a digitmap effect the timers to start from implementation point of view.
 
I figure that GW should start L timer for interdigit timer to begin with and when it hits S in the digitmap, it should start S timer instead of L timer for interdigit timer.
 
Please let me know if i am on the wrong track.
 
Thanks for your time.
 
- ramesh

 _____ 
From: Kevin Boyle [mailto:[email-masked]] Sent: Wednesday, January 09, 2008 9:15 PMTo: Ramesh Babu Kuppili; [email-masked]: RE: [Megaco] Megaco digitmap timer
I do not believe that inference to be correct, and the use of brackets in this way does not appear to be terribly constructive.

Remember that square brackets specify a choice, and are not used to denote a subset.  In this particular instance the DigitMap is allowing the MG to choose between a digit from 0-9 and the long interdigit timer.  I don't see where that would ever be a desired option in the normal processing of digits.
 
Kevin

 _____ 
From: Ramesh Babu Kuppili [mailto:[email-masked]] Sent: Friday, December 28, 2007 1:38 AMTo: [email-masked]: [Megaco] Megaco digitmap timer
Hi,

What is the scope of a timer (L or S) within a range in a megaco digitmap.  For example:
 
In the digitmap:
    15xSxxx[Lx]xxxx
 
My inference from the rfc is (taking a dial sequence of 15105551212
    Digit dialled            Timer started
        1                            L
        5                            L
        1                            L
        0                            S
        5                            S
        5                            S
        5                            L      (this is within the braces.  my assumption is that the timer specifier within braces is valid only within braces)
        1                            S
        2                            S
        1                            S
        2                            S
 
Is my inference correct that timer specifier within a brace is valid only within the brace.
 
- ramesh