Subject: [Megaco] Problems with Erlang C interface

From: J Bhanot <[email-masked]>
Date: Tue, 29 Jan 2008 20:36:04 +0530

Hi,

I was just trying to connect to already running erlang node via C program 
and while going through the documentation of erl_interface,

came across following lines 

When linking, you will need to specify the path to liberl interface.a and 
libei.a with
-L$OTPROOT/lib/erl interface-3.2.3/lib, and you will need to specify the 
name of the libraries
with -lerl interface -lei. You can do this on the command line or by 
adding the flags to the
LDFLAGS definition in your Makefile.

$ ld -L/usr/local/otp/lib/erl_interface-3.2.3/
lib myprog.o -lerl_interface -lei -o myprog

I have following path : 
/home/j.bhanot/Download/H.248/otp_src_R12B-0/lib/erl_interface

even if I substitute erl_interface-3.2.3 with erl_interface - I don't get 
any lib folder after that and not able to find libraries
lerl_interface and lei..

is there something wrong that i am doing.

Regards,

jb
____________________________________________
=====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: J Bhanot <[email-masked]>
Date: Tue, 29 Jan 2008 20:44:15 +0530

Hi,

just came across that erl_interface library is specfic to OTP release...

I am using otp_src_R12B-0...where can i find erl_interface library for 
this release of OTP.

Thanks,
jb