Subject: [Megaco] FW: Segmentation and TransactionResponseAck

From: [email-masked]
Date: Mon, 28 Jan 2008 16:08:57 -0600

Hi,
 
Section 'E.14.6 Procedures' (Ref. ITU-T Rec. H.248.1 (09/2005)) dictates
that "Upon reception of the final segment, the receiver shall determine
if it has received all the message segments. If it has, then the
receiver shall respond with a TransactionResponseAcknowledgement."
 
Following examples illustrates this, but the Ack is shown as
K=1
 
As per the ABNF for TransactionResponseAcknowledgement,
transactionResponseAck = 

ResponseAckToken LBRKT transactionAck *(COMMA transactionAck) RBRKT

transactionAck = 

TransactionID / (TransactionID "-" TransactionID)

So K=1 is not a valid format and should be K{1}

Am I missing something?

thanks

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 29 Jan 2008 14:55:43 -0500

It is a typo.  This might already be fixed in the IG.  If not, then it
is certainly something that can be placed there.
 
Kevin

________________________________

From: [email-masked]
[mailto:[email-masked]] 
Sent: Monday, January 28, 2008 5:09 PM
To: [email-masked]
Subject: [Megaco] FW: Segmentation and TransactionResponseAck

Hi,

 

transactionAck = 

Am I missing something?

thanks