Subject: [Megaco] Discrepancy in possible values of parameter of Indicator package recommended in ITU-T Rec. H.248.3

From: "suruchi.agarwal" <[email-masked]>
Date: Wed, 16 Apr 2008 12:36:08 +0530

Hi,

There is a discrepancy in the possible values of "Indid" parameter of "Setindactor" signal of "Indicator" package recommended in the ITU-T Rec. H.248.3.

The "Set of line indicators" for the parameter "Indid" are having values "l001-l999 (0x0003-0x03f9)".
In decimal number notation, this range corresponds to 999 values while in hexadecimal notation, this range corresponds to1015 values.

In my opinion, the hexadecimal notation should also correspond to 999 values, i.e., it should be "l001-l999 (0x0003-0x03e9)".
The hexadecimal notation of subsequent values should also be updated accordingly.

Thanks,
With Best Regards,
Suruchi
_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 17 Apr 2008 14:03:55 +1000

Hello Suruchi,

I'm surprised that this package is being implemented! You are correct in 
pointing out the problem.

Given that the current parameter values are:
Possible values:
      Name Description
      il (0x0001) Hold
      ic (0x0002) Conference
      l001-l999 (0x0003-0x03f9) Set of line indicators
      f001-f999 (0x03fa-0x07e0) Set of assignable function indicators
      ir (0x07e1) Ringer/Alerter indication
      im (0x07e2) Message waiting indicator

I'll a little hesitant to agree to update all the hex values because 
people may have already implemented these. i.e. they may already have 
implemented "Message waiting indicator" using 0x07e2, without realising 
the problem with the set of line indicators value range. As such I don't 
think we should invalidate their implementations as part of the fix. So 
I would suggest that in the IG we say:

Possible values:
      Name Description
      il (0x0001) Hold
      ic (0x0002) Conference
      l001-l999 (0x0003-0x03e9) Set of line indicators
      f001-f999 (0x03fa-0x07e0) Set of assignable function indicators
      ir (0x07e1) Ringer/Alerter indication
      im (0x07e2) Message waiting indicator

      Note: Values 0x03ea to 0x03f9 are reserved.

People's thoughts?

Regards, Christian

suruchi.agarwal wrote:
>
> Hi,
>
> There is a discrepancy in the possible values of "Indid" parameter of 
> "Setindactor" signal of "Indicator" package recommended in the ITU-T 
> Rec. H.248.3.
>
> In decimal number notation, this range corresponds to 999 values while 
> in hexadecimal notation, this range corresponds to1015 values.
>
> In my opinion, the hexadecimal notation should also correspond to 999 
> values, i.e., it should be "l001-l999 (0x0003-0x03e9)".
>
> ------------------------------------------------------------------------
>