Subject: [Megaco] An issue about encoder for MEGACO

From: "George Quan" <[email-masked]>
Date: Tue, 15 Apr 2008 14:42:51 +0800

Hi all:

  I found the following encoder in some vendor. I am not sure whether it
is right or not. Please help me. 

=====================================

MEGACO/1 [10.136.1.95]:2944 

 Reply=186002{Context=-{Modify=ROOT}}

 TransactionResponseAck{1}

==========================================

In the packet, Both TransactionRequest and TransactionResponseAck are
embedded in one message, is it right? 

I look into ITU H.248.1 V3, it seems that it don't allow encoding. 

Pls give me some guide.

BTW: the following is defined in P98, ITU H.248.1 V3.

transactionList = 1*(transactionRequest / transactionReply /

transactionPending / transactionResponseAck /

segmentReply) 

thanks 

George

 Best Regard

-------------------------------------------

Juniper Network CN R&D Co. Ltd.

George Quan 

Tel: 8610-5874-7167

Location: 7.1.301  

_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: Ashish Singh <[email-masked]>
Date: Tue, 15 Apr 2008 00:04:26 -0700

George,

As per ABNF grammar, 1 or more of ((transactionRequest
/ transactionReply / transactionPending
/
transactionResponseAck /

segmentReply)
are allowed in a message. Here Stack has encoded 1 TransactionReply and
1 TransactionResponseAck
in a H.248 message. This TransactionResponseAck
is for any previous transaction (with id 1) sent by this entity.

I think this should be fine as per H.248 encoding rules.

Thanks

Ashish

Redback Networks Inc.

San Jose, CA

George Quan wrote:

Hi
all:

I found the
following encoder in some vendor. I am not sure whether it is right or
not. Please
help me.

MEGACO/1
[10.136.1.95]:2944

In
the packet, Both TransactionRequest
and TransactionResponseAck are embedded in one message, is it right?

I
look into ITU H.248.1
V3, it seems that it don't allow encoding.

Pls
give me some guide.

BTW:
the following is
defined in P98, ITU H.248.1 V3.

transactionList
=
1*(transactionRequest / transactionReply /

transactionPending
/
transactionResponseAck /

segmentReply)

thanks

George

Best Regard

George Quan

Tel: 8610-5874-7167

Location: 7.1.301

---

From: "George Quan" <[email-masked]>
Date: Tue, 15 Apr 2008 15:12:59 +0800

Hi Ashish:

   Thanks a lot. 

I saw that ITU H.248 V1 has not defined some rules.  Would you tell me which document define the rule? I think it is reasonable, however, I am working for a MEGACO decoder, I need get more information about the case. 

Thanks again

George 

________________________________

From: Ashish Singh [mailto:[email-masked]] 
Sent: 2008年4月15日 15:04
To: George Quan
Cc: [email-masked]
Subject: Re: [Megaco] An issue about encoder for MEGACO

George,

As per ABNF grammar, 1 or more of ((transactionRequest / transactionReply / transactionPending / transactionResponseAck / 

segmentReply) are allowed in a message. Here Stack has encoded 1 TransactionReply and 1 TransactionResponseAck in a H.248 message. This TransactionResponseAck is for any previous transaction (with id 1) sent by this entity. 

Thanks
Ashish

Redback Networks Inc.
San Jose, CA

George Quan wrote: 

Hi all:

  I found the following encoder in some vendor. I am not sure whether it is right or not. Please help me. 

In the packet, Both TransactionRequest and TransactionResponseAck are embedded in one message, is it right? 

Pls give me some guide.

segmentReply) 

thanks 

George

 Best Regard

George Quan 

Tel: 8610-5874-7167

Location: 7.1.301  

________________________________