Subject: [Megaco] start tone,end tone and Long tone in E.4 of RFC3015

From: Tom Taylor <[email-masked]>
Date: Tue, 29 Apr 2008 09:58:47 -0400

I received the following message as a bounce because it was misaddressed to the 
list administrator's address instead of the list itself. When I tried to advise 
the originator of the message to use the right address, my message to him 
bounced. Nevertheless, in case that person has access to the Megaco list by 
other means, here is the original query.

Tom Taylor

From: KD王永胜 <[email-masked]>
Date: Tue, 29 Apr 2008 17:18:23 +0800

  Hello

Rfc3015 annex E.4 makes me confused.

What’s the meaning of start tone,end tone and Long tone in E.4?

In my point of view,the start and finish of a call process can be descripted 
with the offhook and onhook signaling.So why use these concept?

Can you tell me how to use these concept?

  For example ,In a call process, where is a start tone appear? Can you give me 
a simple explanation!

Thank you so much in advance!

Kind regards

Johnson

_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: "deepak.bissa" <[email-masked]>
Date: Wed, 30 Apr 2008 11:04:32 +0530

Hello,

The start tone and end tone are events that are used to mark the start and end of the tones at MG. These are independent of on hook and off hook transitioning on analog line.

The start tone is used to inform MGC about the detection of a tone when it is started. The tone can be a DTMF tone like the digits dialed by the subscriber or Call Progress tones like the ring back tone.
Similarly, end tone is used to detect end of the tone.
Long tone is used to detect that a tone has been played for a particular duration of time as specified by MGC.

An example of start tone can be that MGC applies an event as
!/1 [192.168.33.106:2944] T=1{C=-{mf=p/1{e=121{dd/std{tl = *}}}}.
This is done in order to detect start tone of DTMF tones.
When digit 0 is dialed at subscriber then MG will notify as
!/1 [192.168.33.104:2944] T=1{C=-{n=p/1{oe=121{dd/d0}}}}

Megaco protocol evolution has taken place under ITU-T H.248 series.
I would request to refer to ITU-T H.248.1 (09/2005)(V3).

With regards,
Deepak Bissa

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tom Taylor
Sent: Tuesday, April 29, 2008 7:29 PM
To: megaco ietf
Subject: [Megaco] start tone,end tone and Long tone in E.4 of RFC3015

Tom Taylor

  Hello

Kind regards

Johnson

"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error,please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility forloss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco