Subject: [Megaco] Compact list of ContextIDs

From: "Miri Epstein" <[email-masked]>
Date: Wed, 16 Apr 2008 16:59:46 +0100

Hello Christian,

Regarding the following example given in H.248.1v3, section 7.2.5:

The command:

Context=*{ContextAttr{ContextList={*}},AuditValue=Root{Audit{}}}

returns:

Context=*{ContextAttr{ContextList={1,2,3,4}},AuditValue=Root{}}

When looking at the ABNF for auditOther, the {} cannot be empty and must
contain an auditReturnParameter:
auditOther = EQUAL termIDList [LBRKT terminationAudit RBRKT]
terminationAudit = auditReturnParameter *(COMMA auditReturnParameter)

So the correct example should be:

The command:

Context=*{ContextAttr{ContextList={*}},AuditValue=Root{Audit{}}}

returns:

Context=*{ContextAttr{ContextList={1,2,3,4}}, AuditValue=Root} 

I believe this fix should be updated in H.248.1 Amendment 1.

Many thanks,
Miri

_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 17 Apr 2008 13:30:15 +1000

Hello Miri,

For the time being we can capture this in the implementors guide.

Regards, Christian