Subject: [Megaco] Info needed.

From: "shashanka bhat" <[email-masked]>
Date: Thu, 27 Nov 2008 12:11:40 +0530

Hi ,

    I have some queries about Megaco.

    1) What is media agnostic MGs ?.
    2) How will MG indicate to MGC that it is media agnostic ?.
    3) Is IA (Interface between SPDF and BGF in IMS) Profile version 1 is
Media agnostic ?.

    4) Any documents to explain the Media Agnostic MGs ?.

Thanks.

-- 
Giri Prasad.
_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Thu, 27 Nov 2008 09:36:41 +0100

See responses inline.
See also:
http://www.ietf.org/mail-archive/web/megaco/current/msg08025.html
 
/Albrecht

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of shashanka bhat
	Sent: Donnerstag, 27. November 2008 07:42
	To: [email-masked]
	Subject: [Megaco] Info needed.

	Hi , 

	    1) What is media agnostic MGs ?.
	[[Schwarz, Albrecht]] The term is defined in ETSI TISPAN ES 283 018 V2 & TS 183 018 V3, 
	see clause 3.1.
	The subject is further detailed in Annex G "Illustration of BGF modes of operation"
	 
	    2) How will MG indicate to MGC that it is media agnostic ?.
	[[Schwarz, Albrecht]] Via the H.248 Stream Descriptor, which contains the *media* description.
	... and these are primarily the SDP elements in the H.248 LD & RD, thus the MGC framework is given by § 5.15 & 5.16 on allowed SDP in H.248
	 
	    3) Is IA (Interface between SPDF and BGF in IMS) Profile version 1 is Media agnostic ?.
	[[Schwarz, Albrecht]] Right, see § 5.15 & 5.16 in ES 283 018 V1. ["m=- X - -"] 
	[[Schwarz, Albrecht]] BTW: "IA" = "Ia" (or do you mean the MSF Implementation Agreements (IAs) on Ia-based Session Border Gateways?) 
	
	    4) Any documents to explain the Media Agnostic MGs ?.
	[[Schwarz, Albrecht]] See e.g. 
	* Annex G
	* TISPAN 19bTD020 WI-03145 H.248 Ia Profile Version 3 - New Annex "Illustration of Protocol Layer Lx based Packet Processing BGF modes"
	http://docbox.etsi.org/TISPAN/TISPAN/50-Meetings/20081128-19Bis/19bTD020_WI-03145_H.248_Ia_Profile_Version_3_-_New_Annex_%E2%80%9CIllustration_of_Protocol_Layer_Lx_based_Packet_Processing_BGF_modes%E2%80%9D.doc
	* or in future the new TISPAN WI-3202 on "Operational Aspects of Border Gateway/Routers - Guidlines for Ia profile versions" (don't know the exact WI title ...)

	Thanks.
	
	-- 
	Giri Prasad.

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Fri, 28 Nov 2008 11:44:57 +0100

Charging may be supported as usual by H.248 systems.
What's your charging model, Giri?
 
Charging in general is based on time, volume, event information or a combination of them.
Saying that, charging aspects are then basically impacted by traffic volume related data gathering from perspective of "media-aware" vs "media-agnostic" modes.
[Time information is usually protocol layer independent (from charging perspective). Event information may however enforce a particular mode, due to the underlying event detection logic ...]
 
Traffic volume based charging may be tight primarily to
a) IP layer and/or
b) application layer.
 
Statistic data for charging in case of (a) is basically media-agnostic. And for (b) it's inherently "application-aware" (media-aware).
E.g. wrt b): RTP-based applications would use H.248.58 statistics for "application data aware" charging support.
 
E.g. wrt a): charging would be based on IP layer statistics like Draft H.248.61
 
Conclusion:
Modes of operations and charging are firstly orthogonal.
However, a particular statistic for charging may enforce a specific mode.
I don't see any issue/gap from H.248 perspective concerning online charging support (like e.g. requirements discussed for 3GPP PCC / EPS). [Offline charging is per see out of scope of a router/gateway control interface.]
 
-Albrecht

	From: shashanka bhat [mailto:[email-masked]] 
	Sent: Freitag, 28. November 2008 06:12
	To: Schwarz Albrecht
	Subject: Re: media agnostic MGs (Border gateway/routers - modes of operation); RE: [Megaco] Info needed.

	One more Query Albrecht.
	
	  - How will the Media Agnostic gateways impact the charging for a call ?.
	  - Would the charging be the same for a call in Agnostic MG as the call in Media Aware MG ?.
	
	 How about the QoS parameters also ?.
	
	Cheers, 
	-Giri.

	
	On Thu, Nov 27, 2008 at 3:09 PM, shashanka bhat <[email-masked]> wrote:

		Thank you Very much Albrecht , for accurate and quick response. 

		On Thu, Nov 27, 2008 at 3:04 PM, Schwarz Albrecht <[email-masked]> wrote:

			See inline.

				From: shashanka bhat [mailto:[email-masked]] 
				Sent: Donnerstag, 27. November 2008 09:56
				To: Schwarz Albrecht
				Subject: Re: media agnostic MGs (Border gateway/routers - modes of operation); RE: [Megaco] Info needed.

				Thanks Albrecht. 
				
				Yes, i was referring to Ia interface.
				
				MGC would indicate the media as "-" in its stream descriptor. 
				
				[[Schwarz, Albrecht]] there are "media type", media format" and other elements in the "m=" line, and there are other SDP lines,too. See examples in 19bTD020   

				But how would MGC (In Ia case, one MGC would connect to many MGs) know that MG is "Media Agnostic" one ?.
				
				[[Schwarz, Albrecht]] as usual, through registration, i.e. ProfileID is the starting point
				In addition the MGC may audit capabilities or/and get MG supported capabilities through provisioning (see Annex G.3/TS 183 018) 
				
				Is it through ServiceChange ?.
				[[Schwarz, Albrecht]] No. 
				It's exactly the same question concerning "supported list of codec types" by an Residential, Access and Trunking Gateway, or an H.248-controlled Media Server. 

				On Thu, Nov 27, 2008 at 2:06 PM, Schwarz Albrecht <[email-masked]> wrote:

					See responses inline.
					See also:
					 
					/Albrecht

					Hi , 

					

					    4) Any documents to explain the Media Agnostic MGs ?.
					[[Schwarz, Albrecht]] See e.g. 
					* Annex G
					* TISPAN 19bTD020 
WI-03145 H.248 Ia Profile Version 3 - New Annex "Illustration of Protocol Layer Lx based Packet Processing BGF modes"	

					http://docbox.etsi.org/TISPAN/TISPAN/50-Meetings/20081128-19Bis/19bTD020_WI-03145_H.248_Ia_Profile_Version_3_-_New_Annex_%E2%80%9CIllustration_of_Protocol_Layer_Lx_based_Packet_Processing_BGF_modes%E2%80%9D.doc
					* or in future the new TISPAN WI-3202 on "Operational Aspects of Border Gateway/Routers - Guidelines for Ia profile versions" (don't know the exact WI title ...)

					Thanks.
					
					-- 
					Giri Prasad.

				-- 
				Giri Prasad.

		-- 
		Giri Prasad.

	-- 
	Giri Prasad.