Subject: [Megaco] Choose payload value for rtpmap

From: "Rick G" <[email-masked]>
Date: Thu, 20 Nov 2008 17:06:27 +0800

Hi,

For your question,

If there is a wildcard ("$") in the "m=" line
m=audio $ RTP/AVP $ $ $ a=rtpmap:$ G726-32/8000
a=rtpmap:$ PCMA/8000
a=fmtp:$ vad=yes
a=rtpmap:$ telephone-event/8000
a=fmtp:$ 0-15

The MG may reply with a specified payload for each payload:
RSP<- m=audio 13888 RTP/AVP 8 101 13
RSP<- a=rtpmap:8 PCMA/8000
RSP<- a=rtpmap:101 telephone-event/8000
RSP<- a=fmtp:101 0-15

Thanks and Best Reagards,
Rick
_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Thu, 20 Nov 2008 10:33:25 +0100

Possible wildcarding on SDP elements is defined by H.248.39.
See § 6.11   concerning "m=" line ...
See § 6.15.1 concerning "a=rtpmap:" line ...
See § 6.15.3 concerning "a=fmtp:" line ...
 
Saying that, your example seems to be syntactically correct.
 
[Semantical aspects: your approach relates to a MG-local resource management of RTP PT value assignments, which may lead finally to asymmetrical PT values per each traffic direction, e.g. when the RD is missing, or RD assignments would be locally not considered, ...
That's why a harmonization on call/session control level (e.g. due to SIP/SDP O/A negotiation) of media format specific PT values seems to be more advantegeous.]
 
-Albrecht
 
PS
 
See also a similar H.248.39 example:

6.15.8   Media description with multiple payload types and multiple attribute lines

Clause 6.11 shows a wildcarding example with multiple list entries in <fmt list> in the "m=" line.

The fourth "m=" line parameter <fmt list> is a list of one or more payload formats. This subclause is considering another wildcarding example with multiple list entries in <fmt list>.

The unambiguous resource selection by the MG may require correspondent "a=" lines in case of wildcarding in the list of formats in the "m=" line. This is reflected in 7.1.8/H.248.1.

NOTE 1 - To avoid ambiguity when requesting the MG to reserve and commit resources, the MGC should supply as much information as needed when using under-specification (i.e., CHOOSE) so that the MG can make an unambiguous selection. For example, when using CHOOSE without specifying the required application type (e.g., "media name" in case of SDP encoding), further information may be needed (e.g., attribute lines in case of SDP encoding).

Such a wildcarding configuration must therefore consider the combination of a single "m=" and multiple "a=" lines.

NOTE 2 - Clause 6.1.1 has examples with scope on "m=" line only.

Table 6-15.8/H.248.39 - Examples

H.248/SDP encoding example
with applied wildcarding:

Result:

H.248 request:

Local{

     v=0
     c=IN IP4 $
     m=audio$ RTP/AVP $ $
     a=rtpmap:$ G729D/8000
     a=rtpmap:$ G726-16/8000
     a=ptime:10

}

H.248 reply:

Local{

     v=0
     c=IN IP4 11.9.19.65
     m=audio 5000 RTP/AVP 98 99
     a=rtpmap:98 G729D/8000
     a=rtpmap:99 G726-16/8000
     a=ptime:10

}

In this example the MGC specifies the encoding name for the two RTP payload types. Thus the MG cannot choose a different encoding name. If the MGC would not send the "a=" line, the MG could choose the encoding name as well. This latter option is not preferred.

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Rick G
	Sent: Donnerstag, 20. November 2008 10:06
	To: [email-masked]
	Subject: [Megaco] Choose payload value for rtpmap

	Hi,
	 
	For your question,
	 
	m=audio $ RTP/AVP $ $ $ 
	a=rtpmap:$ G726-32/8000