Subject: [Megaco] Fax send/receive procedures

From: "Andre Rosa Stefanini" <[email-masked]>
Date: Tue, 6 Jan 2009 16:02:46 -0200

People,

Could you help us in solving a question?

The scenario is the following:

Side A - Fax machine 1 -----> MG1 -----> MGC -----> MG2 -----> Side B -
Fax Machine 2

We are testing with 2 MGs controlled by an MGC via H.248 text (according
H.248.2)

First, the common voice call is setup by one side, not mattering if A or
B.

After that, let's suppose Fax Machine 1 initializes a fax sending,
pressing Snd/Rcv button. As soon as this occur, Fax Machine 2 presses
Snd/Rcv button.

Then, both MGs are reporting V.21Flag to MGC. Is it correct? 

Is there any possibility to distinguish which of fax machines are
sending the fax and which is receiving it? This is for avoiding the
other side (fax receiving side - Fax Machine 2) to send V.21Flag toward
the MGC.

It's not clear on IETF H.248.2 document whether is correct or not both
sides sending V.21flag toward MGC. Could you please clarify this?

Thanks for your attention,

ANDRE

_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Tue, 6 Jan 2009 21:50:37 +0100

I would expect that the one operating Fax 2 would wait for an indication
that change to fax is desired. That would make the handshake in send mode go
through from Fax 1. 
 
The faxes follow ITU-T T.30, so you will find there the sequence for V.21
Flags.
 
Gunnar
  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Andre Rosa Stefanini
Sent: Tuesday, January 06, 2009 7:03 PM
To: [email-masked]
Cc: Alexandre de Brito Matricardi
Subject: [Megaco] Fax send/receive procedures

People,

Side A - Fax machine 1 -----> MG1 -----> MGC -----> MG2 -----> Side B - Fax
Machine 2

First, the common voice call is setup by one side, not mattering if A or B.

After that, let's suppose Fax Machine 1 initializes a fax sending, pressing
Snd/Rcv button. As soon as this occur, Fax Machine 2 presses Snd/Rcv button.

Is there any possibility to distinguish which of fax machines are sending
the fax and which is receiving it? This is for avoiding the other side (fax
receiving side - Fax Machine 2) to send V.21Flag toward the MGC.

It's not clear on IETF H.248.2 document whether is correct or not both sides
sending V.21flag toward MGC. Could you please clarify this?

ANDRE

__________ NOD32 3743 (20090106) Information __________

Detta meddelande dr genomsvkt av NOD32 Antivirus.
http://www.nod32.com

---

From: "RUIKAR RAHUL A" <[email-masked]>
Date: Wed, 7 Jan 2009 04:43:48 +0100

Hi,
 
MG1 will also generate following event towards MGC.
 -- > CNG
 
ctyp/dtone{dtt=cng}
 
For Reference check T.38

Regards,
Rahul Ruikar
Alcatel-Lucent
Alcanet: 2721 4732

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Andre Rosa Stefanini
Sent: Tuesday, January 06, 2009 11:33 PM
To: [email-masked]
Cc: Alexandre de Brito Matricardi
Subject: [Megaco] Fax send/receive procedures

People,

ANDRE

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Wed, 7 Jan 2009 12:27:39 +0100

I do agree to Gunnar.
 
You've to consider both E2E T.30 sequences & H.248 signalling.
There might be race conditions at both H.248 interfaces, but their final
resolution (i.e. which G3FE may sent) is up to T.30 IMO. 
 
Albrecht
 
PS
I've Cc'd the T.3X experts from Q.14/16.

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Gunnar Hellstrom
Sent: Dienstag, 6. Januar 2009 21:51
To: 'Andre Rosa Stefanini'; [email-masked]
Cc: 'Alexandre de Brito Matricardi'
Subject: Re: [Megaco] Fax send/receive procedures

I would expect that the one operating Fax 2 would wait for an indication
that change to fax is desired. That would make the handshake in send
mode go through from Fax 1. 
 
The faxes follow ITU-T T.30, so you will find there the sequence for
V.21 Flags.
 
Gunnar

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of RUIKAR RAHUL A
	Sent: Mittwoch, 7. Januar 2009 04:44
	To: Andre Rosa Stefanini; [email-masked]
	Cc: Alexandre de Brito Matricardi
	Subject: Re: [Megaco] Fax send/receive procedures

	Hi,

	ctyp/dtone{dtt=cng}
	 
	For Reference check T.38

	Regards,
	Rahul Ruikar
	Alcatel-Lucent
	Alcanet: 2721 4732

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Andre Rosa Stefanini
	Sent: Tuesday, January 06, 2009 11:33 PM
	To: [email-masked]
	Cc: Alexandre de Brito Matricardi
	Subject: [Megaco] Fax send/receive procedures

	People,

	Side A - Fax machine 1 -----> MG1 -----> MGC -----> MG2 ----->
Side B - Fax Machine 2

	We are testing with 2 MGs controlled by an MGC via H.248 text
(according H.248.2)

	First, the common voice call is setup by one side, not mattering
if A or B.

	After that, let's suppose Fax Machine 1 initializes a fax
sending, pressing Snd/Rcv button. As soon as this occur, Fax Machine 2
presses Snd/Rcv button.

	Is there any possibility to distinguish which of fax machines
are sending the fax and which is receiving it? This is for avoiding the
other side (fax receiving side - Fax Machine 2) to send V.21Flag toward
the MGC.

	It's not clear on IETF H.248.2 document whether is correct or
not both sides sending V.21flag toward MGC. Could you please clarify
this?

	ANDRE