Subject: [Megaco] Pulse Metering

From: <[email-masked]>
Date: Fri, 17 Jul 2009 10:33:48 +0200

I have a question about the Metering Pulse Burst signal defined in
H.248.26 (01/2005). This signal has two parameters: Burst Pulse Count &
Pulse Repetion Interval. The Burst Pulse Count parameter specifies the
number of metering pulses to be applied as a burst on the line. The
description of this parameter says that "The type, duration and pulse
repetition interval for the metering pulses comprising the burst are
provisioned in the MG".

Considering that the pulse repetition interval is provisioned in the MG,
I don't understand the reason why this signal has a "Pulse Repetition
Interval" parameter. Furthermore the default value for the "Pulse
Repetition Interval" parameter is "1" rather than "provisioned".

Can someone shade some light on this?

Thanks
Bruno

6.3.2.1.1 Burst Pulse Count
Parameter name: Burst Pulse Count
Parameter ID: bpc (0x0001)
Description: This parameter specifies the number of metering pulses to
be applied as a burst
on the line. The type, duration and pulse repetition interval for the
metering
pulses comprising the burst are provisioned in the MG.
Type: Integer
Optional: Yes
Possible values: 1 or more pulses
Default: 1
6.3.2.1.2 Pulse Repetition Interval
Parameter name: Pulse Repetition Interval
Parameter ID: pri (0x0002)
Description: Interval from the leading edge of a metering pulse to the
leading edge of the
next metering pulse.
Type: Integer
Optional: Yes
Possible values: 1 or more milliseconds
Default: 1

---

From: <[email-masked]>
Date: Fri, 17 Jul 2009 11:19:58 +0200

Hi!
 
Your definition for pri is taken from the Enable Metering signal. My question was about the Metering Pulse Burst signal. It may well be that the definition of the pri in the Metering Pulse Burst signal is wrong.
 
Regards,
Bruno

________________________________

De : [email-masked] [mailto:[email-masked]] 
Envoyé : vendredi 17 juillet 2009 11:04
À : CHATRAS Bruno RD-CORE-ISS
Objet : 答复: [Megaco] Pulse Metering

Hi 
    In H.248.26: 

Pulse Repetition Interval 

ParameterID:        pri (0x0002) 

Type:                        Integer 

        Possible values:        Any positive integer 
        This parameter specifies the interval over which the pulses specified in the pulse count should be issued, 

6.5        Procedures 
        If the pulse count is greater than 0, then the MG shall determine the appropriate interval between pulses by dividing the pulse repetition interval value by the pulse count. In the event that the interval determined is not integral, then it is the responsibility of the MG to adjust the individual intervals to avoid long-term rounding errors. 

     So I think the pri parameter means total interval for all pulses specified in mpb signal.

Michael Sun 孙红军 
Network Planning & System Design Department 
  	Product Marketing System 
产品市场体系 
No.68 Zijinghua Rd,Yuhuatai District, NanJing.P.R.China
Tel:+86-25-52870503
Fax:+86-25-52871000
Email:[email-masked] 

<[email-masked]> 
发件人:  [email-masked] 

2009-07-17 16:33 

收件人
<[email-masked]> 
抄送
主题
[Megaco] Pulse Metering

I have a question about the Metering Pulse Burst signal defined in H.248.26 (01/2005). This signal has two parameters: Burst Pulse Count & Pulse Repetion Interval. The Burst Pulse Count parameter specifies the number of metering pulses to be applied as a burst on the line. The description of this parameter says that "The type, duration and pulse repetition interval for the metering pulses comprising the burst are provisioned in the MG". 

Considering that the pulse repetition interval is provisioned in the MG, I don't understand the reason why this signal has a "Pulse Repetition Interval" parameter. Furthermore the default value for the "Pulse Repetition Interval" parameter is "1" rather than "provisioned". 

Thanks 
Bruno 

6.3.2.1.1 Burst Pulse Count 
Parameter name: Burst Pulse Count 
Parameter ID: bpc (0x0001) 
Description: This parameter specifies the number of metering pulses to be applied as a burst 
on the line. The type, duration and pulse repetition interval for the metering 
pulses comprising the burst are provisioned in the MG. 
Type: Integer 
Optional: Yes 
Possible values: 1 or more pulses 
Default: 1 
6.3.2.1.2 Pulse Repetition Interval 
Parameter name: Pulse Repetition Interval 
Parameter ID: pri (0x0002) 
Description: Interval from the leading edge of a metering pulse to the leading edge of the 
next metering pulse. 
Type: Integer 
Optional: Yes 
Possible values: 1 or more milliseconds 
Default: 1 _______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Christian Groves <[email-masked]>
Date: Mon, 20 Jul 2009 13:48:02 +1000

Hello Bruno,

Please see my responses below.

Regards, Christian

> H.248.26 (01/2005). This signal has two parameters: Burst Pulse Count 
> & Pulse Repetion Interval. The Burst Pulse Count parameter specifies 
> the number of metering pulses to be applied as a burst on the line. 
> The description of this parameter says that "The type, duration and 
> pulse repetition interval for the metering pulses comprising the burst 
> are provisioned in the MG".
>
[CNG] I checked the original contribution (AVD-2496 from Beijing May 
2004 
<http://wftp3.itu.int/av-arch//avc-site/2001-2004/0405_Bei/AVD-2496.zip> 
) and "Repetition Interval" being specified as provisioned wasn't there. 
I suspect is crept in during editing along the line.
>
> Considering that the pulse repetition interval is provisioned in the 
> MG, I don't understand the reason why this signal has a "Pulse 
> Repetition Interval" parameter. Furthermore the default value for the 
> "Pulse Repetition Interval" parameter is "1" rather than "provisioned".
>
[CNG] I think it should essentially follow what has been defined by the 
RPI parameter in 6.3.1.1.2. It assumes that a value must be specified. 
So in fact in 6.3.1.1.2 with "Optional: No" there is no default because 
a value must always be sent. It follows then that 6.3.2.1.2 should say 
"Optional: No", "Default: None". This seems to align with the original 
intent.
> Can someone shade some light on this?
[CNG] I've cc'd Kevin as he was editor and contributor on this.
>
> Thanks
> Bruno
>
> *6.3.2.1.1 Burst Pulse Count*
> Default: 1 *
> 6.3.2.1.2 Pulse Repetition Interval*
> ------------------------------------------------------------------------
>
> _______________________________________________
> Megaco mailing list
> [email-masked]

---

From: Silvio Shefer <[email-masked]>
Date: Wed, 22 Jul 2009 12:45:03 +0300

Hi Bruno,

I guess that it probably means that the MGC may override the MG provisioned Pulse Repetition Interval.

                Best regards
                                                Silvain

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, July 17, 2009 11:34 AM
To: [email-masked]
Subject: [Megaco] Pulse Metering

Thanks
Bruno