Subject: [Megaco] simulating termination on-hook when the gateway goes out of service

From: "Matia Marcu" <[email-masked]>
Date: Thu, 14 Apr 2011 11:36:16 +0300

Let's consider the case of two terminations involved in a conversation
when the virtual gateway serving them is restarted.

In this case, when the GW is restored to service, most SSWs are able to
handle correctly the terminations that have been off-hook at the time of
the GW restart.

But some SSWs stop referring to these terminations after the GW is back
in service. The explanation was that, before sending ServiceChange -
Forced on ROOT, the GW should have sent a fictional on-hook notification
for each termination in off-hook state.

We think that, in the spirit of H.248, the GW should not simulate
on-hook when the termination is off-hook.

Is our behaviour correct? 

Many thanks.

Best regards,

Matia 

NOTICE: This email and any files transmitted with it are Enablence and Teledata-Networks confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the sender. This message contains Enablence and Teledata-Networks confidential information and is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

---

From: "Bhattacharjee, Arindam (Arindam)" <[email-masked]>
Date: Thu, 14 Apr 2011 11:32:00 -0500

Hi Matia,

I think by SSW you mean MGC.
In case of ServiceChange-Forced for ROOT of MG , MGC should clean up all the terminations wrt to that MG.
Now in the case when MG is restarted MGC should send auditvalue to refresh all the states of terminations in MG and arm the events for detection of offhk/onhk, digitmaps etc.
Detetction of offhk/onhk may be triggered in MG by using strict parameter = state in your example which makes MG to report with or without transition.

-Arindam

From: [email-masked] [mailto:[email-masked]] On Behalf Of Matia Marcu
Sent: Thursday, April 14, 2011 4:36 AM
To: [email-masked]
Subject: [Megaco] simulating termination on-hook when the gateway goes out of service

Let's consider the case of two terminations involved in a conversation when the virtual gateway serving them is restarted.

In this case, when the GW is restored to service, most SSWs are able to handle correctly the terminations that have been off-hook at the time of the GW restart.

But some SSWs stop referring to these terminations after the GW is back in service. The explanation was that, before sending ServiceChange - Forced on ROOT, the GW should have sent a fictional on-hook notification for each termination in off-hook state.

We think that, in the spirit of H.248, the GW should not simulate on-hook when the termination is off-hook.

Many thanks.

Best regards,

Matia