Subject: [Megaco] Error in H.248.41 IP Realm Availability package definition?

From: Charlie Ross <[email-masked]>
Date: Mon, 25 Apr 2011 16:28:12 -0400

Hello,

In H.248.41 Amendment 1, the IP Realm Availability (ipra) package is defined as extending the IP Domain Connection (ipdc) package.  IP Realm Availability has a property, "available realms" (ar), that is assigned binary property ID 0x0001.  This appears to clash with the inherited "realm" property that is assigned property ID 0x0001 in the parent IP Domain Connection package.  From other examples of package extension that I have seen, it seems that the available realms property should have been given a binary ID that is unique within the IP Realm Availability definition, such as 0x0002.  This would allow both properties to be referenced through IP Realm Availability [package ID: 0x00e0].

ipra/realm [0x00e00001]
ipra/ar [0x00e00001?  or 0x00e00002]

Is this possibly an oversight in the standard or is there some other way to distinguish these properties within IP Realm Availability when using binary encoding?

Thanks for your insights,

Charlie Ross
Media Gateway Design Architect
Ericsson BCAM Business Unit
email: [email-masked]

---

From: Christian Groves <[email-masked]>
Date: Wed, 27 Apr 2011 12:07:43 +1000

Hello Charlie,  cc: Arturo,

Yes it appears that you are correct the available realms property in the 
ipra package does cause a conflict. It either should be binary ID 0x0002 
or the package extension should be removed in order to address the 
issue. Ericsson was the original editor of this work item. This 
Recommendation is also used by Tispan/3GPP so we would need to consider 
this when deciding on a path to take.

Removing the extension is probably the safest path to take. Any other 
opinions?

Regards, Christian

On 26/04/2011 6:28 AM, Charlie Ross wrote:
> Hello,
> In H.248.41 Amendment 1, the IP Realm Availability (ipra) package is 
> defined as extending the IP Domain Connection (ipdc) package.  IP 
> Realm Availability has a property, "available realms" (ar), that is 
> assigned binary property ID 0x0001.  This appears to clash with the 
> inherited "realm" property that is assigned property ID 0x0001 in the 
> parent IP Domain Connection package.  From other examples of package 
> extension that I have seen, it seems that the available realms 
> property should have been given a binary ID that is unique within the 
> IP Realm Availability definition, such as 0x0002.  This would allow 
> both properties to be referenced through IP Realm Availability 
> [package ID: 0x00e0].
> ipra/realm [0x00e00001]
> Is this possibly an oversight in the standard or is there some other 
> way to distinguish these properties within IP Realm Availability when 
> using binary encoding?
> /*Charlie Ross*/
> _email_: [email-masked]
>
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/megaco

---

From: Arturo Martin De Nicolas <[email-masked]>
Date: Fri, 29 Apr 2011 11:45:39 +0200

Hi Christian, Charlie,

Thanks for the info. Yes, seems this was unfortunately overlooked.

At this stage I tend to agree with you, Christian, that it's probably safer to remove the extension. 

I guess this is a good forum for companies to state if they have an opinion. We ourselves may also come back.

Best regards,
Arturo

-----Original Message-----
From: Christian Groves [mailto:[email-masked]] 
Sent: Wednesday, April 27, 2011 4:08 AM
To: [email-masked]
Cc: Arturo Martin De Nicolas
Subject: Re: [Megaco] Error in H.248.41 IP Realm Availability package definition?

Yes it appears that you are correct the available realms property in the ipra package does cause a conflict. It either should be binary ID 0x0002 or the package extension should be removed in order to address the issue. Ericsson was the original editor of this work item. This Recommendation is also used by Tispan/3GPP so we would need to consider this when deciding on a path to take.

Removing the extension is probably the safest path to take. Any other opinions?

Regards, Christian