Subject: [Megaco] Selection of media (m=) at MG

From: Javi Muñoz <[email-masked]>
Date: Tue, 29 Nov 2011 18:40:06 +0100

For the ISDN UDI-TA capability, [ETSI TS 183 036] proposes to describe 
the media at MG using the next SDP description in the Local/Remote 
descriptors:

m=audio <puerto> RTP/AVP <Dynamic_PT> 0 [8]
a=rtpmap:<Dynamic_PT> CLEARMODE/8000

MG must use the codec:

* CLEARMODE: in the phase of the call of information transfer.

* Audio Code G.711-u/A: in the phase of the call of establishment/release.

The phase of the call is known by the MGC (using signalling Q.931, not 
visible to the MG). But, with that SDP description, how may MGC indicate 
to the MG which codec may use at each instant?

Regards,

Javi

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Wed, 30 Nov 2011 08:34:03 +0100

I'm not familiar with the ISDN/SIP interwork spec [ETSI TS 183 036], but I guess that this could be the emulation of ISDN bearer service "UDI with support of tones/announcements" [ITU-T I.231.x].
The (optional?) capability of tones/announcements is just required during the call establishment phase, - before the communication phase.

1st Dependency on MG type
	a) TGW: no impact, because tone/announcement inserted by ISDN local exchange (terminating Q.931); TGW needs just clearmode support
	b) RGW/AGW [ETSI 183 002]: ... call-dependent procedures for specifying the details of the emulation service

2nd H.248 RGW/AGW profile [ETSI 183 002]
You don't find correspondent call dependent procedures, also due to historical reasons because this was the very first profile defined before the "ITU-T H.248 profile template" was developed.
On the other side, it could be transparent for the MG as you said.

E.g., MGC
-> call establishment phase: IF tones/announcements THEN H.248 Command.req for tone/announcement control plus media configuration with voice codec
-> after: H.248 Command.req for modification of the media configuration towards CLEARMODE

Thus, two media configurations in time series.

Regards
Albrecht

PS
My experience: the condition "IF tones/announcements" AND "ISDN bearer service UDI" seems to be very, very rare, thus just starting UDI bearer service emulation in CLEARMODE ...

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Javi Muñoz
> Sent: Dienstag, 29. November 2011 18:40
> To: [email-masked]
> Subject: [Megaco] Selection of media (m=) at MG
> 
> For the ISDN UDI-TA capability, [ETSI TS 183 036] proposes to 
> describe the media at MG using the next SDP description in 
> the Local/Remote
> descriptors:
> 
> The phase of the call is known by the MGC (using signalling 
> Q.931, not visible to the MG). But, with that SDP 
> description, how may MGC indicate to the MG which codec may 
> use at each instant?
> 
> Regards,
> 
> Javi
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/megaco
>

---

From: Javi Muñoz <[email-masked]>
Date: Wed, 30 Nov 2011 11:25:36 +0100

Hello Albrecht,

I agree in general.

However, I have a doubt about ISDN/SIP interwork spec [ETSI TS 183 036]. 
This spec. proposes that in the Q.931/SIP interworking, some EIs Q.931 
are codec to SDP and/or inserted in the SIP body as a PSTN XML element.

Under what criteria, an Q.931 EI should be?:

(a) Codec to SDP

AND / OR  (this is also important)

(b) Inserted in the SIP body as a PSTN XML element

or

(c) None (only interpreted by the AGW, without being carried over SIP)

Regards,

Javi

El 30/11/2011 8:34, Schwarz, Albrecht (Albrecht) escribió:
>> m=audio<puerto>  RTP/AVP<Dynamic_PT>  0 [8]

---

From: Javi Muñoz <[email-masked]>
Date: Wed, 30 Nov 2011 18:12:42 +0100

A second comment,

If:
>>     a) TGW: no impact, because tone/announcement inserted by ISDN 
>> local exchange (terminating Q.931); TGW needs just clearmode support

(I agree)

then, why?
>> E.g., MGC
>> ->  call establishment phase: IF tones/announcements THEN H.248 
>> Command.req for tone/announcement control plus media configuration 
>> with voice codec

That "media configuration with voice codec" (G.711) would be done at the 
MeGaCo termination of the IP side of the MG, not at the termination of 
the ISDN side. If tone/announcement is inserted (in the UNI ISDN) by 
this MG, the termination of the IP side of the MG would not be used, so 
that "voice codec" would not be relevant (no media would be transported 
over the IP network).

am I wrong?

Regards,

Javi

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Wed, 30 Nov 2011 18:27:45 +0100

well spotted, thus just a single media configuration ('Clearmode') would be already sufficient to emulate that ISDN bearer service

PS
Your previous email was related to ISDN-to-SIP interworking at call control level, a subject which is out of scope of MEGACO.
Thus, something for SIPPING, SIP-IMPLEMENTERS, ... (or TISPAN WG3 list) in my understanding. 

> From: Javi Muñoz [mailto:[email-masked]] 
> Sent: Mittwoch, 30. November 2011 18:13
> To: [email-masked]
> Cc: Schwarz, Albrecht (Albrecht)
> Subject: Re: [Megaco] Selection of media (m=) at MG
> 
> A second comment,
> 
> If:
> That "media configuration with voice codec" (G.711) would be 
> done at the MeGaCo termination of the IP side of the MG, not 
> at the termination of the ISDN side. If tone/announcement is 
> inserted (in the UNI ISDN) by this MG, the termination of the 
> IP side of the MG would not be used, so that "voice codec" 
> would not be relevant (no media would be transported over the 
> IP network).
> 
> am I wrong?
> 
> Regards,
> 
> Javi
>

---

From: Javi Muñoz <[email-masked]>
Date: Wed, 30 Nov 2011 18:44:39 +0100

> well spotted, thus just a single media configuration ('Clearmode') would be already sufficient to emulate that ISDN bearer service
However, two comments:

(a) In the "call establishment phase": what must be created at the MG?: 
would it be necessary to create a context, or would it be enough to 
create only an ISDN termination in the null context (which would 
generate that tone/announcement, and then, MGC would apply a modify 
command to create the context for the information phase)?

(b) I believe, the announcement do not necessarily have to be recorded 
in AGW, but that may come from an announcement server (I guess this 
would also be possible for DTMF tones). Could this justify the creation 
of such IP termination with voice codec G.711 in the establishment 
phase, or that communication with the announcement server does not 
belong to the ISDN call and, therefore, it should not be involved in its 
Megaco context?

Regards,

---

From: Javi Muñoz <[email-masked]>
Date: Wed, 30 Nov 2011 19:31:25 +0100

An aditional comment,

if, as we said, we admit the following behavior:

+ call establishment phase: H.248 Command.req for tone/announcement 
control plus media configuration with voice codec
+ information phase: H.248 Command.req for modification of the media 
configuration towards CLEARMODE

The following could happen:

1º Call starts and command.req for tone/announcement is applied.

2º When MGC needs to change to the information phase, the MG responds it 
does not support the CLEARMODE due to insufficient resources (MGC may 
audit the MG before the call to check it supports CLEARMODE, but MGC can 
not know how its resources will change during the call).

In that case, it would not be possible to continue a call that has 
already begun, which should not happen. The SDP description should 
ensure to the MGC that the MG reserves the resources needed by the call 
prior to the establishment of it.

If this is true, it would not be valid to use the modify command between 
the establishment and information phases.

Regards,

Javi

El 30/11/2011 18:44, Javi Muñoz escribió:
>
>> well spotted, thus just a single media configuration ('Clearmode') 
>> would be already sufficient to emulate that ISDN bearer service
> However, two comments:
>
> (a) In the "call establishment phase": what must be created at the 
> MG?: would it be necessary to create a context, or would it be enough 
> to create only an ISDN termination in the null context (which would 
> would also be possible for DTMF tones). Could this justify the 
> creation of such IP termination with voice codec G.711 in the 
> establishment phase, or that communication with the announcement 
> server does not belong to the ISDN call and, therefore, it should not 
> be involved in its Megaco context?
>
> Regards,
>
>
>
>> PS
>> Your previous email was related to ISDN-to-SIP interworking at call 
>> control level, a subject which is out of scope of MEGACO.

---

From: "Bhattacharjee, Arindam (Arindam)" <[email-masked]>
Date: Wed, 30 Nov 2011 14:20:24 -0600

Hi Javi,
> You can do that by using reservevalue =ON in Local control and send SDP offer for both G711 and ClearMode.
>Thus AGW should be able to encode/decode g711 and reserves resource for clearmode.

> in this phase MGC may send reservevalue =OFF with SDP ClearMode only, releasing G711 resource.

-Arindam 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Javi Muñoz
Sent: Wednesday, November 30, 2011 1:31 PM
To: [email-masked]
Subject: Re: [Megaco] Selection of media (m=) at MG

An aditional comment,

Regards,

Javi