Subject: Re: [Megaco] Multiple Streams and mutiplex terminations

From: Javi <[email-masked]>
Date: Tue, 01 Nov 2011 12:36:56 +0100

Hello Christian,

Please see my comments below.

Regards,  Javi

>
>
>> b) "ISDNTerm/BA17/[TEI 1]" may be transported on HDLCPW1 but 
>> ""ISDNTerm/BA18/[TEI 1]" may be transported on HDLCPW2. How would you 
>> model this?. You would need to indicate the termination name in the 
>> properties:
>>
>> ISDNTerm/BA17
>> StreamID=1(TEI=[1,6],SAPI=16)\
>>                               \   ---- HDLCPW1
>> ISDNTerm/BA18                  \ /     StreamID=1 
>> (TEI=[1-ISDNTerm/BA17,9-ISDNTerm/BA19],SAPI=16)
>> StreamID=1(TEI=[1],SAPI=16) ----*
>>                                / \
>> ISDNTerm/BA19                 /   ---- HDLCPW2
>> StreamID=1(TEI=[9],SAPI=16)  /         StreamID=1 
>> (TEI=[6-ISDNTerm/BA17,1-ISDNTerm/BA18],SAPI=16)
>>
> [CNG] I suspected we'd end up at this case. It sounds like you're 
> trying to turn a single Context into an entire router to get around 
> the fact that you can't have a single physical termination in multiple 
> contexts. Have a look at H.248.64 to see how we handled that for an IP 
> router. How many more Terminations do you envisage in a Context?
>
> You could add TerminationID to the TEI parameter, but if you're having 
> lots of Termination it may quickly become complicated.

[Javi] Each MG may have over 50000 interfaces/terminations.

>>
>>
>> [CNG] Yes, so why do you propose a single Termination? Why not add 
>> the interfaces via multiple Terminations to the Context?
>>
>> [Javi] Yes. Indeed, this woud be my solution to the problem: Create 
>> an ephemeral termination for each flow, including flows of HDLCPWs:
>>
>> ISDNTerm/BA17/D/SAPI16,TEI1 --- * --- HDLCPW1/BA17/D/SAPI16,TEI1
>>
>> ISDNTerm/BA17/D/SAPI16,TEI6 --- * --- HDLCPW2/BA17/D/SAPI16,TEI6
>>
>> ISDNTerm/BA18/D/SAPI16,TEI1 --- * --- HDLCPW2/BA18/D/SAPI16,TEI1
>>
>> ISDNTerm/BA19/D/SAPI16,TEI9 --- * --- HDLCPW1/BA19/D/SAPI16,TEI9
>>
>>
>> I think this is possible.
> [CNG] A ephemeral Termination for an ISDN termination? These are 
> typically physical terminations.

[Javi] Really, for each interface I would create:

+ A physical termination maintained in the null context: to notify new 
packet calls to the MGC.

+ An ephemeral termination for each packet flow on the interface.

ISDNTerm/BA17/D [null context]

ISDNTerm/BA17/D/SAPI16,TEI1 --- * --- HDLCPW1/BA17/D/SAPI16,TEI1

ISDNTerm/BA17/D/SAPI16,TEI6 --- * --- HDLCPW2/BA17/D/SAPI16,TEI6

ISDNTerm/BA18/D [null context]

ISDNTerm/BA18/D/SAPI16,TEI1 --- * --- HDLCPW2/BA18/D/SAPI16,TEI1

ISDNTerm/BA19/D [null context]

ISDNTerm/BA19/D/SAPI16,TEI9 --- * --- HDLCPW1/BA19/D/SAPI16,TEI9

It was discussed at the forum the possibilty of creating more than one 
termination for each physical interface, and concluded that it was possible.

---

From: Christian Groves <[email-masked]>
Date: Wed, 02 Nov 2011 10:48:49 +1100

Hello Javi,

Which forum is this being discussed in?

Regards,
Christian

On 1/11/2011 10:36 PM, Javi wrote:
>>> ""ISDNTerm/BA18/[TEI 1]" may be transported on HDLCPW2. How would 
>>> you model this?. You would need to indicate the termination name in 
>>> the properties:
>>>
>>> ISDNTerm/BA17
>> the fact that you can't have a single physical termination in 
>> multiple contexts. Have a look at H.248.64 to see how we handled that 
>> for an IP router. How many more Terminations do you envisage in a 
>> Context?
>>
>> You could add TerminationID to the TEI parameter, but if you're 
>> having lots of Termination it may quickly become complicated.
>

---

From: Javi <[email-masked]>
Date: Wed, 02 Nov 2011 10:37:51 +0100

Hello Christian,

http://www.ietf.org/mail-archive/web/megaco/current/msg08470.html

Regards,

Javi

El 02/11/2011 0:48, Christian Groves escribió:
>>> multiple contexts. Have a look at H.248.64 to see how we handled 
>>> that for an IP router. How many more Terminations do you envisage in 
>>> a Context?
>>>
>> + A physical termination maintained in the null context: to notify 
>> new packet calls to the MGC.
>>
>> It was discussed at the forum the possibilty of creating more than 
>> one termination for each physical interface, and concluded that it 
>> was possible.
>>
>

---

From: Christian Groves <[email-masked]>
Date: Mon, 14 Nov 2011 16:31:51 +1100

Hell Javi,

Please see ny responses below marked [CNG].

Regards, Christian

> http://www.ietf.org/mail-archive/web/megaco/current/msg08470.html

[CNG] OK I thought you meant somewhere other than the Megaco list.

>>>>> you model this?. You would need to indicate the termination name 
>>>>> in the properties:
>>>>>
>>>>> ISDNTerm/BA17
>>>> that for an IP router. How many more Terminations do you envisage 
>>>> in a Context?
>>>>
>>>>> [Javi] Yes. Indeed, this woud be my solution to the problem: 
>>>>> Create an ephemeral termination for each flow, including flows of 
>>>>> HDLCPWs:
>>>>>
[CNG] I think there is only ever one physical termination. There can be 
empheral terminations to describe the connection topology. Something 
like the above would be possible although you would need to work on your 
naming conventions to ensure they are valid.

---

From: Javi Muñoz <[email-masked]>
Date: Mon, 14 Nov 2011 10:57:16 +0100

Hello Christian,
>>>> ISDNTerm/BA17/D/SAPI16-TEI1 --- * --- HDLCPW1/BA17/D/SAPI16-TEI1
>>>>
>>>> ISDNTerm/BA17/D/SAPI16-TEI6 --- * --- HDLCPW2/BA17/D/SAPI16-TEI6
> [CNG] I think there is only ever one physical termination. There can 
> be empheral terminations to describe the connection topology. 
> Something like the above would be possible 

I agree.

> although you would need to work on your naming conventions to ensure 
> they are valid.

I think this naming convention is valid:

* Physical termination:     ISDNTerm/BA17/D

* Ephemeral terminations: ISDNTerm/BA17/D/SAPI16/TEI23

Do you think it has any problem?

Regards,

Javi

---

From: Christian Groves <[email-masked]>
Date: Tue, 15 Nov 2011 09:35:46 +1100

Hello Javi,

I think you may need a different top level for the Physical and 
Ephemeral terminations to avoid any unwanted protocol problems..
i.e. What would happen if you do a Subtract(ISDN/Term/*)? The MG would 
try to subtract Termination in the NULL context which is not allowed.

Regards, Christian

On 14/11/2011 8:57 PM, Javi Muñoz wrote:
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/megaco
>

---

From: Javi Muñoz <[email-masked]>
Date: Tue, 15 Nov 2011 11:14:56 +0100

Hello Christian,
> try to subtract Termination in the NULL context which is not allowed.

May we use  Subtract(ISDNTerm/*/D/*)  ?

Regards,

Javi

---

From: Christian Groves <[email-masked]>
Date: Wed, 16 Nov 2011 09:16:39 +1100

Hello Javi,

H.248 allows wildcarding at different levels of a TerminationID. So you 
could use a subtract like below. However its not unambigious, would 
../D/* still match ISDNTerm/*/D? As I've mentioned previously I think 
its good practise to separate ephemeral and physical terminations at the 
highest level in the heirarchy. 3GPP do this in their naming scheme, ie. 
see TS 29.232 etc.

Regards, Christian

On 15/11/2011 9:14 PM, Javi Muñoz wrote:
>> i.e. What would happen if you do a Subtract(ISDN/Term/*)? The MG 
>> would try to subtract Termination in the NULL context which is not 
>> allowed.
>
>>>> [CNG] I think there is only ever one physical termination. There 
>>>> can be empheral terminations to describe the connection topology. 
>>>> although you would need to work on your naming conventions to 
>>>> ensure they are valid.
>>>

---

From: Javi <[email-masked]>
Date: Wed, 16 Nov 2011 00:52:44 +0100

Hello Christian,

You're right.

I think it's better the next names:

* Ephemeral terminations: ISDNTerm/BA17/Eph/D/SAPI16/TEI23

Do you see any problem now?

Regards,

Javi

El 15/11/2011 23:16, Christian Groves escribió:
> Hello Javi,
>
> H.248 allows wildcarding at different levels of a TerminationID. So
> you could use a subtract like below. However its not unambigious,
> would ../D/* still match ISDNTerm/*/D? As I've mentioned previously I
> think its good practise to separate ephemeral and physical
> terminations at the highest level in the heirarchy. 3GPP do this in
> their naming scheme, ie. see TS 29.232 etc.
>
> Regards, Christian
>

---

From: Javi <[email-masked]>
Date: Wed, 16 Nov 2011 00:59:34 +0100

Or would it be better?

* Ephemeral terminations: Eph/ISDNTerm/BA17/D/SAPI16/TEI23

Regards,

Javi

---

From: Javi Muñoz <[email-masked]>
Date: Fri, 18 Nov 2011 11:28:46 +0100

Heloo Christian,

I agree, I'll use that name.

Thank you very much for everything.

Regards,

Javi

El 16/11/2011 1:57, Christian Groves escribió:
> Hello Javi,
>
> I was suggesting some more like: EphISDNTerm/BA17/D/SAPI16/TEI23 for 
> the ephemeral terminations. That way if you want to clear all 
> ephemeral termination you can simply issue: Subtract(EphISDNTerm/*). 
> Otherwise you'll end up with a very convoluted way to do this as you'd 
> have to do multiple groups.
>
> Regards, Christian
>
> On 16/11/2011 10:52 AM, Javi wrote:
>> Hello Christian,
>>
>> You're right.
>>
>>> would ../D/* still match ISDNTerm/*/D? As I've mentioned previously 
>>> I think its good practise to separate ephemeral and physical 
>>>>>>> can be empheral terminations to describe the connection 
>>>>>>> topology. Something like the above would be possible 
>>>>>>
>>>>>> I agree.
>>>>>>