Subject: [Megaco] OutOfService vs Inactive

From: Javi <[email-masked]>
Date: Sat, 10 Dec 2011 13:44:45 +0100

In a termination *with**a single stream*, which is the differencebetween?:

(a) TerminationState{ServiceStates=OutOfService}

(b) Media{ LocalControl { StreamMode=Inactive } }

Regards,

Javi

---

From: Christian Groves <[email-masked]>
Date: Mon, 12 Dec 2011 09:51:25 +1100

Hello Javi,

ServiceState and Streammode are fundamentally different things. 
Streammode is related to activity on the bearer. ServiceState is related 
to MG internal "readiness". Also the Streammode can be controlled by the 
MGC. i.e. it can change Inactive to Send/Receive.
ServiceState is largely controlled by the MG. i.e. the MGC can't change 
OutOfService to InService.

Regards, Christian

On 10/12/2011 11:44 PM, Javi wrote:
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/megaco

---

From: "Raphael Tryster" <[email-masked]>
Date: Mon, 12 Dec 2011 07:54:03 +0200

"the MGC can't change OutOfService to InService"

But some MGCs sure as hell try.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Christian Groves
Sent: Monday, 12 December 2011 12:51 AM
To: [email-masked]
Subject: Re: [Megaco] OutOfService vs Inactive

Hello Javi,

Regards, Christian

NOTICE: This email and any files transmitted with it are Enablence and Teledata-Networks confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the sender. This message contains Enablence and Teledata-Networks confidential information and is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

---

From: Javi Muñoz <[email-masked]>
Date: Mon, 12 Dec 2011 11:59:44 +0100

Christian,
> the MGC can't change OutOfService to InService.

When MGC  sends to MG a serviceChange command with method Forced or 
Graceful and reason 905 (Out Of Service), MGC requests to MG to put out 
of service the indicated terminations. Is not it?

Regards,

Javi

---

From: "Makaraju, Maridi Raju (Raju)" <[email-masked]>
Date: Mon, 12 Dec 2011 16:59:00 -0600

Javi,

> of service the indicated terminations. Is not it?
[Raju]
Right. There are several reasons why a termination can be out of service(OOS).
Take a look at "H.248.8 : Gateway control protocol: Error code and service change reason description"
http://www.itu.int/rec/T-REC-H.248.8-200708-I/en

Following are some of the relevant ones:

        904 Termination malfunctioning
        905 Termination taken out of service
        906 Loss of lower layer connectivity (e.g. downstream sync)
        907 Transmission Failure

MGC can put a termination OOS and bring it back INS later.
Please see "F.4.1.2 ServiceChange Method Behaviour on Physical Terminations" of:
http://www.itu.int/rec/T-REC-H.248.1-200509-I/en

However, if the termination is OOS due to 904/906/907 reason codes then MGC 
obviously can't bring it INS.

Regards
Raju

---

From: Christian Groves <[email-masked]>
Date: Tue, 13 Dec 2011 10:23:07 +1100

Hello Raphael,

I try lots of things doesn't mean I'm always successful :-). Guess its 
no different for MGCs...

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Tue, 13 Dec 2011 10:38:06 +1100

Hello Javi and Raju,

I was referring to the example provided by Javi, i.e.
(a) TerminationState{ServiceStates=OutOfService}

The MGC can't use the TerminationState descriptor to change the 
servicestate.

The MGC can use Servicechange to change the ServiceState.

Regards, Christian

---

From: "Makaraju, Maridi Raju (Raju)" <[email-masked]>
Date: Mon, 12 Dec 2011 17:41:24 -0600

Christian, Raphael,
 
> > "the MGC can't change OutOfService to InService"
[Raju] If MGC puts a termination OOS administratively (905 Termination taken out of service)
then it can put it "inService". 
Yes, it is NOT guaranteed that the termination will actually come INS as
the termination could be having hardware related issue and in such a case MG would have
notified MGC with any of the following ServiceChange reason codes.

Text in "F.4.1.2 ServiceChange Method Behaviour on Physical Terminations" of H.248.1
clearly supports MGC putting termination OOS and INS.
http://www.itu.int/rec/T-REC-H.248.1-200509-I/en

Regards
Raju

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Christian Groves
> Sent: Monday, December 12, 2011 5:23 PM
> To: Raphael Tryster
> Cc: [email-masked]
> > From: [email-masked] 
> [mailto:[email-masked]] On Behalf
> > Of Christian Groves
> > NOTICE: This email and any files transmitted with it are 
> Enablence and Teledata-Networks confidential and intended 
> solely for the use of the individual or entity to whom they 
> are addressed. If you have received this email in error 
> please notify the sender. This message contains Enablence and 
> Teledata-Networks confidential information and is intended 
> only for the individual named. If you are not the named 
> addressee you should not disseminate, distribute or copy this 
> e-mail. Please notify the sender immediately by e-mail if you 
> have received this e-mail by mistake and delete this e-mail 
> from your system. If you are not the intended recipient you 
> are notified that disclosing, copying, distributing or taking 
> any action in reliance on the contents of this information is 
> strictly prohibited.
> >
> >
> >