Subject: [Megaco] Several SDP session in a Local or Remote Descriptor

From: Javi <[email-masked]>
Date: Fri, 09 Dec 2011 19:06:36 +0100

In a call, which is the difference between these two options (UDP port 
and IP address are the same in both?

Case A):

LocalControl {
    ReservedValue = true
},
Local {
    v=0
    c=IN IP4 adrressX
    m=audio portA RTP/AVP*2 8*
}

Case B):

LocalControl {
    ReservedGroup = true
},
Local {
    v=0
    c=IN IP4 $
    m=audio portA RTP/AVP *2*

    v=0
    c=IN IP4 $
    m=audio portA RTP/AVP *8*
}

Regards,

Javi

---

From: "Makaraju, Maridi Raju (Raju)" <[email-masked]>
Date: Fri, 9 Dec 2011 12:21:49 -0600

Javi,

For Case A with ReservedValue, MGW only reserves one RTP+ip. So, only one media session can be carried over, but the session
can use either payload formats 2 or 8.

For case B ReservedGroup, MGW reserves and returns 2 different RTP+IP addresses (if resources are available), one for each group.
There could be 2 simultaneous media sessions carried using payload formats 2 and 8 respectively, until reservedGroup is set to false.
Please note that reservedGroup can be kept ON until the termination is Subtracted.

Regards
Raju
________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Javi
Sent: Friday, December 09, 2011 12:07 PM
To: [email-masked]
Subject: [Megaco] Several SDP session in a Local or Remote Descriptor

In a call, which is the difference between these two options (UDP port and IP address are the same in both?

Case A):

LocalControl {
   ReservedValue = true
},
Local {
   v=0
   c=IN IP4 adrressX
   m=audio portA RTP/AVP 2 8
}

Case B):

LocalControl {
   ReservedGroup = true
},
Local {
   v=0
   c=IN IP4 $
   m=audio portA RTP/AVP 2

   v=0
   c=IN IP4 $
   m=audio portA RTP/AVP 8
}

Regards,

Javi

---

From: Javi <[email-masked]>
Date: Fri, 09 Dec 2011 19:41:04 +0100

Raju,

But if IP address (and UDP port) is the same in both SDP sessions:

LocalControl {
    ReservedGroup = true
},
Local {
    v=0
    c=IN IP4 adrressX

    v=0
    c=IN IP4 adrressX

then there could not be 2 simultaneous media sessions. In that caso, 
would there be any differnce with?:

LocalControl {
    ReservedValue = true
},
Local {
    v=0
    c=IN IP4 adrressX

El 09/12/2011 19:21, Makaraju, Maridi Raju (Raju) escribió:
> Javi,
> For Case A with ReservedValue, MGW only reserves one RTP+ip. So, only 
> one media session can be carried over, but the session
> For case B ReservedGroup, MGW reserves and returns 2 different RTP+IP 
> addresses (if resources are available), one for each group.
> There could be 2 simultaneous media sessions carried using payload 
> formats 2 and 8 respectively, until reservedGroup is set to false.

> Regards
> Raju
>
>     ------------------------------------------------------------------------
>     *From:* [email-masked] [mailto:[email-masked]]
>     *On Behalf Of *Javi
>     *Sent:* Friday, December 09, 2011 12:07 PM
>     *To:* [email-masked]
>     *Subject:* [Megaco] Several SDP session in a Local or Remote
>     Descriptor
>
>     In a call, which is the difference between these two options (UDP
>     port and IP address are the same in both?
>
>     Case A):
>
>     LocalControl {
>         ReservedValue = true
>     },
>     Local {
>         v=0
>         c=IN IP4 adrressX

---

From: "Makaraju, Maridi Raju (Raju)" <[email-masked]>
Date: Fri, 9 Dec 2011 15:52:37 -0600

Javi,

First of all, having same IP+port for both the groups will be an issue as MGW will receive bearer packets with
both payloads 2 and 8 at once single ip+port. If that is what really needed then it would be preferred
to use ReservedValue.

To answer your question directly...
They are different: In group case the MGW may allocate 2 different resources each handling formats 2,8 respectively.
But in value case MGW allocates just one resource handling both 2 and 8.
So, they are tightly coupled wrt MGW resource allocation and ip+port is assignment directly linked to resource allocation.

Regards
Raju

________________________________
From: Javi [mailto:[email-masked]]
Sent: Friday, December 09, 2011 12:41 PM
To: [email-masked]
Subject: Re: [Megaco] Several SDP session in a Local or Remote Descriptor

Raju,

LocalControl {
   ReservedGroup = true
},
Local {
   v=0
   c=IN IP4 adrressX
   m=audio portA RTP/AVP 2

   v=0
   c=IN IP4 adrressX
   m=audio portA RTP/AVP 8
}

then there could not be 2 simultaneous media sessions. In that caso, would there be any differnce with?:

LocalControl {
   ReservedValue = true
},
Local {
   v=0
   c=IN IP4 adrressX

Regards
Raju
________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Javi
Sent: Friday, December 09, 2011 12:07 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Megaco] Several SDP session in a Local or Remote Descriptor

Case A):

LocalControl {
   ReservedValue = true
},
Local {
   v=0
   c=IN IP4 adrressX

Case B):

LocalControl {
   ReservedGroup = true
},
Local {
   v=0
   c=IN IP4 $
   m=audio portA RTP/AVP 2

   v=0
   c=IN IP4 $
   m=audio portA RTP/AVP 8
}

Regards,

Javi

---

From: Javi <[email-masked]>
Date: Sat, 10 Dec 2011 13:44:38 +0100

Raju,

Thanks for the clarification.

Regards,

Javi

El 09/12/2011 22:52, Makaraju, Maridi Raju (Raju) escribió:
> They are different: In group case the MGW may allocate 2 different 
> resources each handling formats 2,8 respectively.
> So, they are tightly coupled wrt MGW resource allocation and ip+port 
> is assignment directly linked to resource allocation.
> Regards
> Raju
>
>     *From:* Javi [mailto:[email-masked]]
>     *Sent:* Friday, December 09, 2011 12:41 PM
>     *To:* [email-masked]
>     *Subject:* Re: [Megaco] Several SDP session in a Local or Remote
>     Descriptor
>
>     Raju,
>
>     then there could not be 2 simultaneous media sessions. In that
>     caso, would there be any differnce with?:
>
>     LocalControl {
>         ReservedValue = true
>     },
>     Local {
>         v=0
>         c=IN IP4 adrressX
>>     For Case A with ReservedValue, MGW only reserves one RTP+ip. So,
>>     only one media session can be carried over, but the session
>>     For case B ReservedGroup, MGW reserves and returns 2 different
>>     RTP+IP addresses (if resources are available), one for each group.
>>     There could be 2 simultaneous media sessions carried using
>>     payload formats 2 and 8 respectively, until reservedGroup is set
>>     to false.
>>         *From:* [email-masked]
>>         [mailto:[email-masked]] *On Behalf Of *Javi
>>         In a call, which is the difference between these two options
>>         (UDP port and IP address are the same in both?
>>
>>         Case A):
>>
>>         LocalControl {
>>             ReservedValue = true
>>         },
>>         Local {
>>             v=0
>>             c=IN IP4 adrressX