Subject: [Megaco] Wildcard "$" in Add command changes Signal properties in physical termination

From: "Beis, Grigoris (NSN - GR/Athens)" <[email-masked]>
Date: Wed, 22 Aug 2012 11:20:59 +0200

Hello all,

I came across a strange scenario which I haven't been able to justify it
from the H.248.1 document.

We have an MGC-MG connection in a call waiting scenario where the MGC
applies call-waiting tone to the MG in a physical termination via the
following message: C = 1 { MF=port_1{ SG { CG/CW } } } 

The message is successfully ack'ed by the MG and the PSTN subscriber
successfully hears the call-waiting tone. What will happen to the
call-waiting tone if the MGC issues an Add command with wildcard "$" and
ring-back tone application, like the one below?
C = 1 {  A=$ { M { O { MO=IN,NT/JIT=0 } , L  { SDP } } ,  SG{CG/RT} } } 

[ As expected, the MG chooses an ephemeral termination in the subsequent
Add Reply]

Does H.248.1 state anywhere that if a signal is applied in a command
that bears a wildcard "$" termination, , it will replace the last signal
that was applied in the physical termination?  We observed that upon
sending the Add command, the call-waiting tone is deactivated! I would
consider this behavior as a MG deficiency, but I would gladly like to
hear your opinion, as well.

Thank you,
Greg

---

From: "Bhattacharjee, Arindam (Arindam)" <[email-masked]>
Date: Wed, 22 Aug 2012 14:06:27 +0000

Hi Greg,
Your interpretation is correct.
MG should not stop signal on physical termination in your case while adding another termination in that context and should be able to play signals on both terminations as instructed by MGC.
-Arindam

From: [email-masked] [mailto:[email-masked]] On Behalf Of Beis, Grigoris (NSN - GR/Athens)
Sent: Wednesday, August 22, 2012 5:21 AM
To: [email-masked]
Subject: [Megaco] Wildcard "$" in Add command changes Signal properties in physical termination

Hello all,

I came across a strange scenario which I haven't been able to justify it from the H.248.1 document.

We have an MGC-MG connection in a call waiting scenario where the MGC applies call-waiting tone to the MG in a physical termination via the following message: C = 1 { MF=port_1{ SG { CG/CW } } }

The message is successfully ack'ed by the MG and the PSTN subscriber successfully hears the call-waiting tone. What will happen to the call-waiting tone if the MGC issues an Add command with wildcard "$" and ring-back tone application, like the one below?

[ As expected, the MG chooses an ephemeral termination in the subsequent Add Reply]

Does H.248.1 state anywhere that if a signal is applied in a command that bears a wildcard "$" termination, , it will replace the last signal that was applied in the physical termination?  We observed that upon sending the Add command, the call-waiting tone is deactivated! I would consider this behavior as a MG deficiency, but I would gladly like to hear your opinion, as well.

Thank you,

Greg

---

From: "Beis, Grigoris (NSN - GR/Athens)" <[email-masked]>
Date: Wed, 22 Aug 2012 16:19:35 +0200

Hello Arindam,

Thanks for the confirmation. To my knowledge, "$" is simply another
termination; either an ephemeral termination or another idle physical
termination. Our physical termination, however, is not idle. It already
occupies resources like the call-waiting tone.

Br,

Greg

From: ext Bhattacharjee, Arindam (Arindam)
[mailto:[email-masked]] 
Sent: Wednesday, August 22, 2012 5:06 PM
To: Beis, Grigoris (NSN - GR/Athens); [email-masked]
Subject: RE: Wildcard "$" in Add command changes Signal properties
inphysical termination

Hi Greg,

MG should not stop signal on physical termination in your case while
adding another termination in that context and should be able to play
signals on both terminations as instructed by MGC.

-Arindam

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Beis, Grigoris (NSN - GR/Athens)
Sent: Wednesday, August 22, 2012 5:21 AM
To: [email-masked]
Subject: [Megaco] Wildcard "$" in Add command changes Signal properties
in physical termination

Hello all,

Thank you,

Greg