Subject: [Mentoring-coordinators] Need to start matching

From: Brian Haberman <[email-masked]>
Date: Mon, 08 Jul 2013 11:18:30 -0400

All,
      We have 3 weeks until IETF 87.  It would be good if mentors and 
mentor participants had a reasonable amount of time to discuss their 
mentoring logistics prior to the meeting.  Consider this the "Go match!" 
directive and start pairing mentors with participants.  As noted previously:

1. Please use this mailing list to discuss any issues

2. Update the wiki when matches are made

Thanks!
Brian

---

From: Alissa Cooper <[email-masked]>
Date: Mon, 8 Jul 2013 12:04:23 -0400

Brian -- For some reason the "Mentor" column does not appear on the wiki page listing the participants. I'm not sure how to fix that.

On Jul 8, 2013, at 11:18 AM, Brian Haberman <[email-masked]> wrote:

> All,
>     We have 3 weeks until IETF 87.  It would be good if mentors and mentor participants had a reasonable amount of time to discuss their mentoring logistics prior to the meeting.  Consider this the "Go match!" directive and start pairing mentors with participants.  As noted previously:
> 
> _______________________________________________
> mentoring-coordinators mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mentoring-coordinators
>

---

From: Leif Johansson <[email-masked]>
Date: Mon, 08 Jul 2013 18:40:52 +0200

> Brian -- For some reason the "Mentor" column does not appear on the wiki page listing the participants. I'm not sure how to fix that.
Do we need to avoid shooting for the same mentoree or mentor somewhow?

---

From: Brian Haberman <[email-masked]>
Date: Mon, 08 Jul 2013 12:49:13 -0400

It appears for me, but I have to right-scroll to see it.

Brian

---

From: Brian Haberman <[email-masked]>
Date: Mon, 08 Jul 2013 12:55:22 -0400

Leif,

> Do we need to avoid shooting for the same mentoree or mentor somewhow?

That is one of the purposes of this mailing list.  It allows the 
coordinators to work through any conflicts.  Especially since mentors 
and participants have interests that cross area boundaries.

I think there are two ways to make this work (probably more, but work 
with me).

1. Each coordinator take a subset of the mentor participants, identifies 
to the mailing list who they are trying to match, and attempts to match 
them with a mentor.  After making the match, the pairings are posted and 
any conflicts with mentors is resolved on the list.

2. Each coordinator works on a subset of mentor participants selected 
based on their primary IETF area of interest.  Then the same 
publish/match/publish approach described above is used.

Other ideas/thoughts on the coordination effort?

Brian

---

From: Leif Johansson <[email-masked]>
Date: Mon, 08 Jul 2013 23:47:31 +0200

On 07/08/2013 06:55 PM, Brian Haberman wrote:
>>> Brian -- For some reason the "Mentor" column does not appear on the
>>> wiki page listing the participants. I'm not sure how to fix that.
>>>
>>>
> 1. Each coordinator take a subset of the mentor participants,
> identifies to the mailing list who they are trying to match, and
> attempts to match them with a mentor.  After making the match, the
> pairings are posted and any conflicts with mentors is resolved on the
> list.
>
Both might work but I think (1) has a better chance of generating fewer
conflicts.

I pulled two out of the pile (cf separate email) and ran into trouble in
both cases.

I managed to match Mark T with one of his students (!) and Lucy told me
that
somebody at ISOC was aparently arranging separate mentoring for Violet.

I'll get back on the horse tomorrow. Will try to matchup Lucy, MarkT &
JeffH and
report back.

        Cheers Leif

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 10 Jul 2013 10:22:50 -0400

In case this helps, I've tried to assign mentoring participants to each of you to match with mentors. Not everyone got the same number since there is not an even distribution of interests. We have roughly the same number of applications from participants and from mentors, which is good.

Robert:
Te-Yuan Huang
Amine Choukir
Violet Wandaho Njuguna
Anca Zamfir

Leif:
Pierre-Alain Dupont
Nicolas Fiumarelli
Nicolas Iooss

Murray:
abdoulie boye
Vaibhav Bajpai
Alozie Onyinyechi Tina

Ron:
Li Xue
Marcos Siqueira
Karl Knutsson
Mirko Suznjevic
Midori Kato
Simone Ferlin Oliveira

Ralph:
Cedric Dessez
Guillaume Mulocher
Edwin Santos Cordeiro
Shahid Raza
Henaka Ralalage Oshani Erunika Dayaratna

Lars:
Balaji Venkat Venkataswami
Md. Jahangir Hossain
Peng Fan
Naman Muley
Patryk Konczyk
Dr. Fawaz Saleem Bokhari
Diego Daino
Michael Faath

Obviously this need not be set in stone, just thought coordinating a bit might help.

Thanks,
Alissa

---

From: Leif Johansson <[email-masked]>
Date: Wed, 10 Jul 2013 17:09:23 +0200

> In case this helps, I've tried to assign mentoring participants to each of you to match with mentors. Not everyone got the same number since there is not an even distribution of interests. We have…
Excellent idea!

---

From: Ronald Bonica <[email-masked]>
Date: Wed, 10 Jul 2013 15:14:37 +0000

Alicia,

I'm sorry, but I think that I might have shot from the hip. I already made the following matches and contacted the mentors/mentees.

                         Ron

Matches
========

Cedric Dessez        <-> Elwyn Davies
Guillaume Mulocher   <-> Bob Hinden
Nicolas Iooss        <-> Margaret Wasserman
Edwin Santos Cordeiro <-> Arturo Servin
Fan Peng             <-> Dan Romascanu
Pierre-Alain DuPont  <-> Randy Bush

> -----Original Message-----
> From: [email-masked] [mailto:mentoring-
> [email-masked]] On Behalf Of Alissa Cooper
> Sent: Wednesday, July 10, 2013 10:23 AM
> To: Leif Johansson
> Cc: [email-masked]
> Subject: Re: [Mentoring-coordinators] Need to start matching
> 
> In case this helps, I've tried to assign mentoring participants to each
> of you to match with mentors. Not everyone got the same number since
> there is not an even distribution of interests. We have roughly the
> same number of applications from participants and from mentors, which
> is good.
> 
> Robert:
> Te-Yuan Huang
> Amine Choukir
> Violet Wandaho Njuguna
> Anca Zamfir
> 
> Leif:
> Pierre-Alain Dupont
> Nicolas Fiumarelli
> Nicolas Iooss
> 
> Murray:
> abdoulie boye
> Vaibhav Bajpai
> Alozie Onyinyechi Tina
> 
> Ron:
> Li Xue
> Marcos Siqueira
> Karl Knutsson
> Mirko Suznjevic
> Midori Kato
> Simone Ferlin Oliveira
> 
> Ralph:
> Cedric Dessez
> Guillaume Mulocher
> Edwin Santos Cordeiro
> Shahid Raza
> > Both might work but I think (1) has a better chance of generating
> > fewer conflicts.
> >
> > I pulled two out of the pile (cf separate email) and ran into trouble
> > in both cases.
> >
> > I managed to match Mark T with one of his students (!) and Lucy told
> > me that somebody at ISOC was aparently arranging separate mentoring
> > for Violet.
> >
> > JeffH and report back.

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 10 Jul 2013 11:21:12 -0400

Oh, great. I will update the wiki and send out a revised list for everyone else in a few minutes.

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 10 Jul 2013 11:24:49 -0400

Actually Ron had already updated the wiki.

Revised list:

Robert:
Te-Yuan Huang
Amine Choukir
Violet Wandaho Njuguna
Anca Zamfir

Leif:
Nicolas Fiumarelli
Li Xue
Marcos Siqueira
Karl Knutsson

Murray:
abdoulie boye
Vaibhav Bajpai
Alozie Onyinyechi Tina

Ralph:
Shahid Raza

Lars:

---

From: Robert Sparks <[email-masked]>
Date: Wed, 10 Jul 2013 14:57:21 -0500

I'm betting we get a burst of applicants (and hopefully more mentors) in 
the next couple of weeks.
The tables we're using now are likely to get large. I'm worried we will 
assign more applicants to mentors than we meant to, and that we'll have 
applicants fall through the cracks.

Would it be reasonable to make a simple table with two columns (mentor 
name, participant name)?
I'm not familiar with this particular wiki software - it would be nice 
if there were an easy way to link from those names back into the tables 
we already have.

RjS

---

From: Leif Johansson <[email-masked]>
Date: Wed, 10 Jul 2013 22:05:51 +0200

> Leif:
trying for these matchups... don't have confirmations yet though.
> Nicolas Fiumarelli
StephenF
> Li Xue
mrw
> Marcos Siqueira
Giles
> Karl Knutsson
Stewart
I know mrw already has a match but I think we have to ask some of these
to handle > 1, right?

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 10 Jul 2013 16:06:38 -0400

On Jul 10, 2013, at 3:57 PM, Robert Sparks <[email-masked]> wrote:

> I'm betting we get a burst of applicants (and hopefully more mentors) in the next couple of weeks.

Agreed, especially if we send reminder emails, which we probably should.

> The tables we're using now are likely to get large. I'm worried we will assign more applicants to mentors than we meant to, and that we'll have applicants fall through the cracks.
> 
> Would it be reasonable to make a simple table with two columns (mentor name, participant name)?
> I'm not familiar with this particular wiki software - it would be nice if there were an easy way to link from those names back into the tables we already have.

I was thinking Google Docs spreadsheet or something similar. I know folks asked for a wiki but the table structure in the wiki seems a bit limited.

Alissa

---

From: Robert Sparks <[email-masked]>
Date: Wed, 10 Jul 2013 15:19:56 -0500

> Agreed, especially if we send reminder emails, which we probably should.
I agree, and I think we need to beat the drums for mentors quite strongly.
> I was thinking Google Docs spreadsheet or something similar. I know folks asked for a wiki but the table structure in the wiki seems a bit limited.
Sounds reasonable to me.
Btw - I made matches for Te-Yuan, Amine, and Anca. Leif is matching Violet.
Let me know when I have more to match.

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 10 Jul 2013 17:54:36 -0400

I made a Google doc that you should all be able to edit: https://docs.google.com/spreadsheet/ccc?key=0Au4OS7RZgZwHdE81S0NVbTFPNTZUTDJWSkhCRWVkWlE&usp=sharing

On the mentoring sheet, assigned, confirmed mentors are grayed out. Right now we have almost enough mentors for participants, so let's see if we can avoid doubling up. (Feel free to remove the coloring if it's unhelpful since we may indeed need to double up.)

Matches are on the "matches" sheet.

Alissa

---

From: Leif Johansson <[email-masked]>
Date: Thu, 11 Jul 2013 08:37:30 +0200

> Matches are on the "matches" sheet.
Ah, implement two-phase-commit on matches by saying "not yet" in the
date field, nice!

---

From: Brian Haberman <[email-masked]>
Date: Thu, 11 Jul 2013 09:04:34 -0400

> On the mentoring sheet, assigned, confirmed mentors are grayed out. Right now we have almost enough mentors for participants, so let's see if we can avoid doubling up. (Feel free to remove the colo…

With the two new mentors, it looks like we have enough for the current 
set of participants (30 participants & 32 mentors).

I like the Google doc alot more than the wiki...

Brian

---

From: Ralph Droms <[email-masked]>
Date: Thu, 11 Jul 2013 14:40:07 -0400

On Jul 10, 2013, at 5:54 PM 7/10/13, Alissa Cooper <[email-masked]> wrote:

> On the mentoring sheet, assigned, confirmed mentors are grayed out.

"Confirmed" == "intros sent, receipt acknowledged, mentor/applicant pairing accepted" ??

- Ralph

> Right now we have almost enough mentors for participants, so let's see if we can avoid doubling up. (Feel free to remove the coloring if it's unhelpful since we may indeed need to double up.)
>

---

From: Ralph Droms <[email-masked]>
Date: Thu, 11 Jul 2013 14:53:49 -0400

Advice solicited - I'm having some trouble matching up Shahid Raza with a mentor.  Shahid is interested in " 6LoWPAN, CoAP, Security", but none of the as-yet-unassigned mentors matches that set of interests very well at all.  How else have others been deciding on matches aside from technical interests?

- Ralph

---

From: Brian Haberman <[email-masked]>
Date: Thu, 11 Jul 2013 15:31:18 -0400

Ralph,

> Advice solicited - I'm having some trouble matching up Shahid Raza with a mentor.  Shahid is interested in " 6LoWPAN, CoAP, Security", but none of the as-yet-unassigned mentors matches that set of…

You could consider general interest (Security, in Shahid's case) or 
nationality (or close proximity).

Brian

---

From: Ralph Droms <[email-masked]>
Date: Fri, 12 Jul 2013 08:34:20 -0400

On Jul 11, 2013, at 3:31 PM 7/11/13, Brian Haberman <[email-masked]> wrote:

> You could consider general interest (Security, in Shahid's case) or nationality (or close proximity).

Thanks.  I think I found an acceptable match.

- Ralph

---

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 15 Jul 2013 08:29:14 +0000

Hi,

back from vacation. Will get to this later today.

Lars