Subject: [Mentoring-coordinators] mentor form improvement

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 3 Jul 2013 09:38:54 +0000

Hi,

just got some feedback that some folks (students) don't understand the term "SDO" in this bullet point:

	• What other SDOs and/or technical activities do you engage in?

Maybe change it to "what other standardization and/or technical activities do you engage in?"

Lars

---

From: Brian Haberman <[email-masked]>
Date: Wed, 03 Jul 2013 06:51:06 -0400

> Maybe change it to "what other standardization and/or technical activities do you engage in?"

I can see where students would not understand that terminology.  I would 
have no problems with Lars' proposed change.

Brian