Subject: [Mentoring-coordinators] Survey(s)?

From: Alissa Cooper <[email-masked]>
Date: Fri, 2 Aug 2013 13:08:40 +0200

We have heard from so many mentors on the mentors' mailing list that I'm thinking we may only need to write a survey for the mentees. Agreed?

I had hoped to write the survey up before arriving in Berlin but it didn't happen. It will probably be a few days before I get to it.

Alissa

---

From: Leif Johansson <[email-masked]>
Date: Sat, 03 Aug 2013 01:17:59 +0200

> I had hoped to write the survey up before arriving in Berlin but it didn't happen. It will probably be a few days before I get to it.
Good idea.

---

From: Ralph Droms <[email-masked]>
Date: Mon, 5 Aug 2013 08:24:24 +0200

> We have heard from so many mentors on the mentors' mailing list that I'm thinking we may only need to write a survey for the mentees. Agreed?

Sounds right to me.  We might send out one more request for feedback to the mentors, but I don't think we need a formal survey.

- Ralph

> _______________________________________________
> mentoring-coordinators mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mentoring-coordinators

---

From: Robert Sparks <[email-masked]>
Date: Mon, 05 Aug 2013 14:45:41 +0200

Just to make sure one thing I noted a few times is captured in the record:

The initial email exchange and the first in-person encounter were far 
more effective
for those pairs where the coordinator had forwarded the information the 
participant
provided when signing up. Without it, that first contact looked very 
much like any other
first conversation in the meet-and-greet. Time for mentor to reflect on 
the participant's
interest and background seems to help a lot.

As we go forward, should that information sharing 'just happen'?

RjS

---

From: Leif Johansson <[email-masked]>
Date: Mon, 5 Aug 2013 15:43:13 +0200

5 aug 2013 kl. 14:45 skrev Robert Sparks <[email-masked]>:

> The initial email exchange and the first in-person encounter were far more effective
> for those pairs where the coordinator had forwarded the information the participant
> provided when signing up. Without it, that first contact looked very much like any other
> first conversation in the meet-and-greet. Time for mentor to reflect on the participant's

I think so - this is probably the start of requirements gatherimg for a tool btw

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 6 Aug 2013 11:49:51 -0400

Below is an initial list of survey questions for mentees. Please bash. Also keep in mind that many mentees were non-native English speakers, so suggestions for improving the language are welcome too.

Also, do people have a preferred survey service? We probably aren't going to get all that many responses, so I'm tempted to just send it as an email, but if folks have used Survey Monkey or Google forms or other such things before and they don't have a lot of overhead, I'm glad to use one of those.

Suggested questions:

Did you meet your mentor in person in Berlin? Y/N

Did you communicate via email with your mentor before arriving in Berlin? Y/N

How much time did you spend in Berlin with your mentor?

Did you attend any working group meetings with your mentor? Y/N

Did your mentor introduce you to other IETF participants? Y/N

Was your mentor able to answer questions that you had, or find other participants to answer them? Y/N

Do you think the mentoring program helped you understand the IETF and its work? Y/N

Would you recommend the mentoring program to other new participants? Y/N

Will you be keeping in touch with your mentor going forward? Y/N

Suggestions for improving the mentoring program:

Any other thoughts about the mentoring program that you can share:

Alissa

---

From: Ralph Droms <[email-masked]>
Date: Wed, 7 Aug 2013 08:16:34 -0400

Here's a more general question about the overall result of working with a mentor:

Was your mentor effective in your making your attendance at the IETF meeting productive?

...or, perhaps, "in meeting the goals you set for attending this IETF meeting"

- Ralph

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 7 Aug 2013 12:33:42 +0000

Hi,]
> Did you meet your mentor in person in Berlin? Y/N

Can be combined with #3

> Did you communicate via email with your mentor before arriving in Berlin? Y/N

s/via email//

> How much time did you spend in Berlin with your mentor?

Can be combined with #1 "did you meet and if yes for how long"

> Did you attend any working group meetings with your mentor? Y/N

s/working group meetings/meeting sessions/

Did you meet with your mentor at other times or for reasons?

> Will you be keeping in touch with your mentor going forward? Y/N

"have you been keeping in touch or are you planning on"

> Any other thoughts about the mentoring program that you can share:

Lars

---

From: Robert Sparks <[email-masked]>
Date: Wed, 07 Aug 2013 12:40:25 -0500

Here are some suggested tweaks to the last section (I think Ralph's and 
Lars' recent suggestions are good ones)

These are really minor, but they've worked well for me in getting people 
to spend time responding in similar situations.
(These forms have worked well across cultures, but I'm sure they can be 
further improved.) Feel free to ignore them.

>Any other thoughts about the mentoring program that you can share:

With:

What could we do differently to make this program more effective for you 
and for future participants?

What was the best part of the experience for you so far?

RjS