Subject: [MEXT] Multiple Revocation Triggers for handovers

From: "Vijay Devarapalli" <[email-masked]>
Date: Tue, 24 Mar 2009 21:00:30 -0400

Hi Ahmad,

Do we really need all three of the following revocation triggers?

          3  Inter-MAG Handoff - same Access Types
          4  Inter-MAG Handoff - different Access Types
          5  Inter-MAG - Unknown Handoff

Isn't it sufficient for the LMA to tell the old MAG that is a handover
and that is why it is revoking the binding? Why should the old MAG care
about what kind of handover it was? How does it use this information?

I suggest having just one revocation trigger that says "Inter-MAG
Handover".

Vijay

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Wed, 25 Mar 2009 01:34:25 -0500

Hi Vijay,

These map quite good to the HI as per PMIPv6 base protocol RFC5213.
IMO, there is nothing wrong of keeping them. We are not running out of
space. 

On the other hand, "Inter-MAG - Unknown Handoff" handling is a little
different because in PMIPv6 base protocol, when the LMA receive a HI
"Unknown", the LMA would start a timer until it receives a
de-registration from the previous MAG. If LMA does not receive
de-registration, then the LMA will assign a new HNP. This way LMA may
speed the process by sending a BRI to the MAG and the MAG validates if
the MN is attached or NOT. If NOT it sends a successful BRA and that
could be considered in place of de-registration and the LMA can assign
the same HNP to the new PBU coming from the new MAG.

Regards,
Ahmad

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Tuesday, March 24, 2009 6:01 PM
> To: Muhanna, Ahmad (RICH1:2H10)
> Cc: mext
> Subject: Multiple Revocation Triggers for handovers
> 
> Hi Ahmad,
> 
> Isn't it sufficient for the LMA to tell the old MAG that is a 
> handover and that is why it is revoking the binding? Why 
> should the old MAG care about what kind of handover it was? 
> How does it use this information?
> 
> I suggest having just one revocation trigger that says 
> "Inter-MAG Handover".
> 
> Vijay
>

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 25 Mar 2009 11:21:42 -0700

> IMO, there is nothing wrong of keeping them. We are not running out of

It is true that we are not running out of space. But this results in a 
more complicated implementation where you have to implement all three 
revocation triggers and then have the code to process all three. Unless 
there is no need for all three, a statement that says "there is nothing 
wrong in keeping them" does not make sense to me.

> the same HNP to the new PBU coming from the new MAG.

You are talking about modified LMA behavior when HI is set to "Unknown". 
This has no impact on the old MAG. Lets say you have just one trigger 
that says "Inter-MAG Handover". When the LMA receives HI="Unknown", can 
do all the above and send a BRI to the old MAG with the trigger 
"Inter-MAG Handover". The old MAG's behavior does not change.

Am I missing something?

Vijay

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Fri, 27 Mar 2009 01:41:52 -0500

Hi Vijay,

> Subject: Re: Multiple Revocation Triggers for handovers
> 
> Ahmad Muhanna wrote:
> > Hi Vijay,
> > 
> It is true that we are not running out of space. But this 
> results in a more complicated implementation where you have 
> to implement all three revocation triggers and then have the 
> code to process all three. Unless there is no need for all 
> three, a statement that says "there is nothing wrong in 
> keeping them" does not make sense to me.

[Ahmad]
Well, these can be very beneficial for OMs. It will be nice to provide
statics that possibly wont be available at the MAG without the
definition of these triggers. 

> You are talking about modified LMA behavior when HI is set to 

[Ahmad]
Which modified behavior you are referring to here?
If the LMA supports Binding Revocation, it certainly different than
supporting RFC5213 ONLY. Right?
If the LMA supports revocation, then it may need to send a BRI for the
case of HI=unknown anyway; if chooses not and follow RFC5213; no problem
in that either.

I believe, it is much better to leave all of them as is. I do NOT see
how these new triggers would make LMA implementation so complex:)

Additionally, handling the case of HI=unknown is very useful.

AT the end, if the wg group agrees that these need to be collapsed in a
single trigger or two, then we can modify them.

> This has no impact on the old MAG. Lets say you have just one 
> trigger that says "Inter-MAG Handover". When the LMA receives 
> HI="Unknown", can do all the above and send a BRI to the old 
> MAG with the trigger "Inter-MAG Handover". The old MAG's 
> behavior does not change.
> 
> Am I missing something?
> 
> Vijay
> 
> > 
> > 
> > Regards,
> > Ahmad
> >  
> > 
> should the 
> >> old MAG care about what kind of handover it was?

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 30 Mar 2009 13:33:01 -0700

> definition of these triggers. 

I don't see a need for the old MAG to know what kind of handover it was.

> Which modified behavior you are referring to here?

I was referring to LMA's behavior when it receives a PBU with 
HI="Unknown". The old MAG's behavior does not change even if HI is set 
to "Unknown".

> Additionally, handling the case of HI=unknown is very useful.

Not for the old MAG.

> single trigger or two, then we can modify them.

I still think we just need one revocation trigger for the handover 
scenarios.

Vijay

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Mon, 30 Mar 2009 15:44:43 -0500

Hi Vijay,

> 
> 
> > AT the end, if the wg group agrees that these need to be 
> collapsed in 
> > a single trigger or two, then we can modify them.
> 
> I still think we just need one revocation trigger for the 
> handover scenarios.
>
[Ahmad]

If we make it one trigger, then when the old MAG receives a BRI with
""Inter-MAG Handover", the old MAG will be mandated all the time to
ensure whether the mobile node is attached or NOT before sending a BRA.
I believe this is NOT a desirable behavior and it adds unneeded delay. 

The other alternative is to have two R. triggers for this:

1. "Inter-MAG Handover", and 
2. "Inter-MAG Handover-Unknown"

And to mandate the above behavior only in the case of "Inter-MAG
Handover-Unknown".

Is that acceptable?

Regards,
Ahmad
 
> >> that says "Inter-MAG Handover". When the LMA receives 
> HI="Unknown", 
> >> can do all the above and send a BRI to the old MAG with 
> the trigger 
> "Inter-MAG

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 30 Mar 2009 13:57:36 -0700

> I believe this is NOT a desirable behavior and it adds unneeded delay. 

My understanding of the Binding Revocation Protocol is for the old MAG 
to check if the mobile node is still attached before sending a BRA 
message. It needs to do this in all handover cases.

This is to address the case where the MN might attach to the new MAG, 
but come back to the old MAG right away. If the MN is still attached, 
the old MAG would reject the BRI and send a BRA message with status "133 
  Revocation Failed - MN is Attached".

> And to mandate the above behavior only in the case of "Inter-MAG

See above. The old MAG's behavior would still be the same.

Vijay

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Mon, 30 Mar 2009 16:12:54 -0500

Hi Vijay,

> My understanding of the Binding Revocation Protocol is for 
> the old MAG to check if the mobile node is still attached 
> before sending a BRA message. It needs to do this in all 
> handover cases.
> 
> This is to address the case where the MN might attach to the 
> new MAG, but come back to the old MAG right away. If the MN 
> is still attached, the old MAG would reject the BRI and send 
> a BRA message with status "133

[Ahmad]
Ok. Then will update accordingly.

Cheers!
Ahmad