Subject: [MEXT] Call for adoption of draft-premec-mext-extended-home-link

From: marcelo bagnulo braun <[email-masked]>
Date: Wed, 04 Mar 2009 21:38:53 +0100

Hi,

This is call for adoption for draft-premec-mext-extended-home-link-00 as 
WG item to cover the charter item:

(A.9) Extended DSMIPv6 Home Network Support: DSMIPv6 assumes
the home network to be dual stack providing simultaneous IPv6 and
IPv4 network access. It is proposed to extend DSMIPv6 to support
home networks which provides IPv4, or IPv6 respectively, direct
network access only, but where virtual IPv6 home network
connectivity, or virtual IPv4 home network connectivity
respectively, may be obtained by tunneling to the HA. The latter
shall be obtained by DSMIPv6 operation using the v4HoA address as
Care-of-address for the v6HoA address, and vice versa, the v6HoA
address as care-of-address for the v4HoA address.

The document can be found at:

http://tools.ietf.org/html/draft-premec-mext-extended-home-link-00

Please express your opinion on whether this should become a WG document 
before the march 19

thanks, Julien and marcelo

---

From: <[email-masked]>
Date: Wed, 4 Mar 2009 21:40:59 +0100

I support adopting the I-D as a WG item.

-Raj

On 3/4/09 2:38 PM, "Marcelo Bagnulo" <[email-masked]> wrote:

> _______________________________________________
> MEXT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mext

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Wed, 4 Mar 2009 16:33:21 -0500

Hi Marcelo, Julien,

It might be a good idea to check if there is still sufficient interest
in this. I know its in the charter currently, but never hurts to check
again.

FWIW, I don't think this extension is required and suggest dropping this
from the charter.

Vijay

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of marcelo bagnulo braun
> Sent: Wednesday, March 04, 2009 12:39 PM
> To: mext
> Subject: [MEXT] Call for adoption of 
> draft-premec-mext-extended-home-link
> 
> Hi,
> 
> This is call for adoption for 
> draft-premec-mext-extended-home-link-00 as

---

From: "Giaretta, Gerardo" <[email-masked]>
Date: Wed, 4 Mar 2009 13:57:10 -0800

Hi Marcelo,

I support adopting this as WG item

Thanks
Gerardo

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> marcelo bagnulo braun
> Subject: [MEXT] Call for adoption of draft-premec-mext-extended-home-link
> 
> Hi,
>

---

From: marcelo bagnulo braun <[email-masked]>
Date: Thu, 05 Mar 2009 16:29:32 +0100

We will use this call to gage interest as well
So far, it seems that there are enough interested parties to move 
forward imho
Of course, this is only the first step in the document and we need to 
have the same energy all the way to make progress

Regards, marcelo

---

From: Julien Bournelle <[email-masked]>
Date: Wed, 11 Mar 2009 18:44:11 +0100

Hi all,

 I have a question regarding this draft.

 What sort of link can carry IPv6 but not IPv4 ?

 Regards,

 Julien

On Wed, Mar 4, 2009 at 9:38 PM, marcelo bagnulo braun
<[email-masked]> wrote:
> Hi,
>
> This is call for adoption for draft-premec-mext-extended-home-link-00 as WG
> item to cover the charter item:
>

---

From: "Premec, Domagoj" <[email-masked]>
Date: Thu, 12 Mar 2009 11:51:05 +0100

Hi Julien,

The main motivation behind the IPv6-only home link is not the inability of the link to carry the IPv4.  The operator may choose to deploy the IPv6-only network to save the additional managment costs (and headache) associated with operating the dual stack network. Or the operator may prefer IPv6 due to the IPv4 address shortage. Please have a look also at the http://www.ietf.org/internet-drafts/draft-ietf-softwire-dual-stack-lite-00.txt for another example of the IPv6-only link. Given the above considerations and the need to move towards the IPv6 in general, I believe that there is some value in the concept of the IPv6-only home link and that there will be deployments making use of this capability.

regards,
domagoj

> Behalf Of Julien Bournelle
> Sent: 11. ozujak 2009 18:44
> To: marcelo bagnulo braun
> Cc: mext
> Subject: Re: [MEXT] Call for adoption of 
> draft-premec-mext-extended-home-link-00 
> > as WG item to cover the charter item:
> >
> > (A.9) Extended DSMIPv6 Home Network Support: DSMIPv6 
> assumes the home 
> > network to be dual stack providing simultaneous IPv6 and
> > IPv4 network access. It is proposed to extend DSMIPv6 to 
> support home 
> > networks which provides IPv4, or IPv6 respectively, direct network 
> > access only, but where virtual IPv6 home network connectivity, or 
> > virtual IPv4 home network connectivity respectively, may be 
> obtained 
> > by tunneling to the HA. The latter shall be obtained by DSMIPv6 
> > operation using the v4HoA address as Care-of-address for the v6HoA 
> > address, and vice versa, the v6HoA address as 
> care-of-address for the 
> > v4HoA address.
> >
> > Please express your opinion on whether this should become a WG 
> > document before the march 19
> >

---

From: Julien Bournelle <[email-masked]>
Date: Thu, 12 Mar 2009 12:15:26 +0100

Hi,

 see inline,

> The main motivation behind the IPv6-only home link is not the inability of the link to carry the IPv4.  The operator may choose to deploy the IPv6-only network to save the additional managment cost…

 but what I don't understand is that in your I-D, the MN has a v4 HoA,
the HA has a v4 address and you are on the home link. So I don't see
what prevents you from using IPv4 on this link. I fail to understand
the use case.

 Do you have a specific deployment in mind ?

 regards,

 Julien

---

From: "Premec, Domagoj" <[email-masked]>
Date: Thu, 12 Mar 2009 12:43:48 +0100

Julien,
 
>  but what I don't understand is that in your I-D, the MN has 
> a v4 HoA, the HA has a v4 address and you are on the home 
> link. So I don't see what prevents you from using IPv4 on 
> this link. I fail to understand the use case.

The home link is not a dual stack link and the HA doesn't have the v4 address on the interface facing the MN and the MN's v4 home address is not assigned to the physical interface either. The physical link is the IPv6-only and the v4 address can not be used directly, any v4 traffic is tunneled by the MN to the HA's IPv6 address.

>  Do you have a specific deployment in mind ?
Nothing specific really, I would expect this feature to be an interesting option for some 3GPP deployments.

domagoj

P.S.
The support for the IPv4-only home link was added recently to the DMSIP6 draft and so the next revision of this draft  focuses only on the IPv6-only home link.

> From: Julien Bournelle [mailto:[email-masked]] 
> Sent: 12. ozujak 2009 12:15
> To: Premec, Domagoj
> Cc: marcelo bagnulo braun; mext
> > The main motivation behind the IPv6-only home link is not 
> the inability of the link to carry the IPv4.  The operator 
> may choose to deploy the IPv6-only network to save the 
> additional managment costs (and headache) associated with 
> operating the dual stack network. Or the operator may prefer 
> IPv6 due to the IPv4 address shortage. Please have a look 
> also at the 
> http://www.ietf.org/internet-drafts/draft-ietf-softwire-dual-s
> tack-lite-00.txt for another example of the IPv6-only link. 
> Given the above considerations and the need to move towards 
> the IPv6 in general, I believe that there is some value in 
> the concept of the IPv6-only home link and that there will be 
> deployments making use of this capability.
> >
> 
> 
>  but what I don't understand is that in your I-D, the MN has 
> a v4 HoA, the HA has a v4 address and you are on the home 
> link. So I don't see what prevents you from using IPv4 on 
> this link. I fail to understand the use case.
> 
> >> From: [email-masked] [mailto:[email-masked]] 
> On Behalf 
> >> Of Julien Bournelle

---

From: George Tsirtsis <[email-masked]>
Date: Thu, 12 Mar 2009 12:25:33 +0000

The main use case for this as far as I remember has been 3GPP type
links. For reasons that are obscure to me and which others may be able
to articulate better, a 3GPP link between say an MN and its HA, can be
an IPv6-only link.

The 3GPP layer, unfortunately is not entirely agnostic to what goes
over it, which is what causes this somewhat  strange case. In other
words a 3GPP network can be designed/configured to only support IPv6,
in which case there is no way to run native IPv4 over the 3GPP link,
even if either side of the link (e.g.  MN and HA) are IPv6 capable.

I hope this helps
George

---

From: Julien Bournelle <[email-masked]>
Date: Thu, 12 Mar 2009 17:20:22 +0100

Hi george, all,

 thanks for your answer. See below

> even if either side of the link (e.g.  MN and HA) are IPv6 capable.

 ok I see. But what is the interest, for an operator, to configure the 3GPP link
as v6-only if it knows that its clients need v4 ?

 Regards,

 Julien

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 12 Mar 2009 09:29:45 -0700 (PDT)

I tend to agree with Julien.
If 3GPP is deploying an IPv6 only link I think that means the time has come to stop using IPv4, I can not think of any other scenario. At that time only legacy devices at home like printers will be IPv4-only.

My .5 euro cents.

Behcet

________________________________
From: Julien Bournelle <[email-masked]>
To: "Premec, Domagoj" <[email-masked]>
Cc: mext <[email-masked]>
Sent: Thursday, March 12, 2009 6:15:26 AM
Subject: Re: [MEXT] Call for adoption of draft-premec-mext-extended-home-link

Hi,

see inline,

regards,

Julien

---

From: "Giaretta, Gerardo" <[email-masked]>
Date: Thu, 12 Mar 2009 10:45:41 -0700

Hi Julien,

Without going into 3GPP details, due to backward compatibility issue the default bearer in EPS/SAE can be IPv4-only or IPv6-only (they can also be IPv4v6 in case the legacy networks are upgraded). Therefore the home link may be either IPv4-only, IPv6-only or IPv4v6. Let me know if you are interested in more details.

Cheers
Gerardo

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Julien
> Bournelle
> Sent: Thursday, March 12, 2009 9:20 AM
> To: George Tsirtsis
> Cc: mext
> >> The home link is not a dual stack link and the HA doesn't have the v4
> address on the interface facing the MN and the MN's v4 home address is not
> assigned to the physical interface either. The physical link is the IPv6-only
> and the v4 address can not be used directly, any v4 traffic is tunneled by the
> MN to the HA's IPv6 address.
> >>
> >> The support for the IPv4-only home link was added recently to the DMSIP6
> draft and so the next revision of this draft  focuses only on the IPv6-only
> home link.
> >>
> >>

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 12 Mar 2009 12:19:50 -0700 (PDT)

Hi Gerardo,
  I found this in 23.060:
For every IMSI, zero, one, or more dynamic PDP addresses per PDP type can be assigned. For every IMSI, zero, one, or more static PDP addresses per PDP type can be subscribed to
 
this to me says that more than one PDP context, e.g. one for IPv4 another for IPv6 can be established.
 
Am I wrong?
 
Behcet

________________________________
From: "Giaretta, Gerardo" <[email-masked]>
To: Julien Bournelle <[email-masked]>; George Tsirtsis <[email-masked]>
Cc: mext <[email-masked]>
Sent: Thursday, March 12, 2009 12:45:41 PM
Subject: Re: [MEXT] Call for adoption of draft-premec-mext-extended-home-link

Hi Julien,

Cheers
Gerardo

---

From: "Giaretta, Gerardo" <[email-masked]>
Date: Thu, 12 Mar 2009 13:27:26 -0700

You are not wrong. But the two PDP contexts will be related to two different DSMIPv6 sessions, i.e. you have at the same time a IPv4-only home link and IPv6-only home link

Gerardo

From: Behcet Sarikaya [mailto:[email-masked]]
Sent: Thursday, March 12, 2009 12:20 PM
To: Giaretta, Gerardo; Julien Bournelle; George Tsirtsis
Cc: mext
Subject: Re: [MEXT] Call for adoption of draft-premec-mext-extended-home-link

Hi Gerardo,
  I found this in 23.060:

Am I wrong?

Behcet

Hi Julien,

Cheers
Gerardo

> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Julien
> Bournelle
> <[email-masked]<mailto:[email-masked]>> wrote:
> > <[email-masked]<mailto:[email-masked]>> wrote:
> >> Julien,
> >>
> >>> From: Julien Bournelle [mailto:[email-masked]<mailto:[email-masked]>]
> >>> <[email-masked]<mailto:[email-masked]>> wrote:
> >>> > Hi Julien,
> >>> >
> >>> >> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
> >>> On Behalf
> >>> >> Of Julien Bournelle
> >>> >> <[email-masked]<mailto:[email-masked]>> wrote:
> >>> >> > Hi,
> >>> >> >
> >>> >> > [email-masked]<mailto:[email-masked]>
> >>> >> [email-masked]<mailto:[email-masked]>
> >> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
_______________________________________________
MEXT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mext

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 12 Mar 2009 16:09:55 -0700 (PDT)

If you want to view it that way then WiMAX too would give you an IPv4-only and IPv6-only home link because 802.16e MAC is connection oriented and IPv4 and v6 packets are transported using IPv4 CS and IPv6 CS.

Behcet

________________________________
From: "Giaretta, Gerardo" <[email-masked]>
To: Behcet Sarikaya <[email-masked]>; Julien Bournelle <[email-masked]>; George Tsirtsis <[email-masked]>
Cc: mext <[email-masked]>
Sent: Thursday, March 12, 2009 3:27:26 PM
Subject: RE: [MEXT] Call for adoption of draft-premec-mext-extended-home-link

Gerardo
 
From:Behcet Sarikaya [mailto:[email-masked]] 
Sent: Thursday, March 12, 2009 12:20 PM
To: Giaretta, Gerardo; Julien Bournelle; George Tsirtsis
Cc: mext
Subject: Re: [MEXT] Call for adoption of draft-premec-mext-extended-home-link
 
Hi Gerardo,
  I found this in 23.060:

Am I wrong?
 
Behcet

From:"Giaretta, Gerardo" <[email-masked]>
To: Julien Bournelle <[email-masked]>; George Tsirtsis <[email-masked]>
Cc: mext <[email-masked]>
Sent: Thursday, March 12, 2009 12:45:41 PM
Subject: Re: [MEXT] Call for adoption of draft-premec-mext-extended-home-link

Hi Julien,

Cheers
Gerardo