Subject: [MEXT] Question on IPv4 Home Address Lease Expires Revocation Trigger

From: "Vijay Devarapalli" <[email-masked]>
Date: Tue, 24 Mar 2009 21:05:17 -0400

Hi Ahmad,

In draft-ietf-mext-binding-revocation-04.txt, what does the revocation
trigger - "IPv4 HoA Lease Expires" mean? My assumption was that the
lifetime of the IPv4 home address allocated to the mobile node is the
same as the lifetime of the proxy binding.

And who uses this trigger - MAG or LMA? This trigger is not mentioned
anywhere else in the document.

Vijay

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Wed, 25 Mar 2009 00:57:29 -0500

Hi Vijay,

Hmmm.. It is referenced but using the wrong name: here the related text:

   ................................................  In this case, if
   the LMA decides to revoke the mobile node IPv4 proxy HoA ONLY, the
   LMA MUST send a BRI message following the procedure in Section 7.1
   and the following rules:

<SNIP> 

   o  The Revocation Trigger field MUST be set to an appropriate value,
      e.g.  "IPv4 Address Lease Expired".
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^

The trigger should read "IPv4 HoA Lease Expired" will correct it.

As a background, my understanding of the applicable scenario is that the
MN could release the IPv4 address using DHCPRELEASE directly to the DHCP
server that co-located in the LMA (MAG is a DHCP Relay). The LMA would
know of this release BUT the MAG wouldn't. LMA sends the BRI to the MAG
to inform the MAG that the IPv4 address have been released. Initially,
we used only Revocation Trigger for the whole IPv4 HoA release but then
we received some comments during WGLC which suggested that the IPv4
should be referenced using another bit similar to Global (G) bit. 

It made sense; then we need to come up with a name for the Revocation
Trigger. If you have a better name, please let me know. HA also may use
Admin as a R. Trigger with the (V) bit.

Regards,
Ahmad

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Tuesday, March 24, 2009 6:05 PM
> To: Muhanna, Ahmad (RICH1:2H10)
> Cc: mext
> Subject: Question on IPv4 Home Address Lease Expires 
> Revocation Trigger
> 
> Hi Ahmad,
> 
> In draft-ietf-mext-binding-revocation-04.txt, what does the 
> revocation trigger - "IPv4 HoA Lease Expires" mean? My 
> assumption was that the lifetime of the IPv4 home address 
> allocated to the mobile node is the same as the lifetime of 
> the proxy binding.
> 
> And who uses this trigger - MAG or LMA? This trigger is not 
> mentioned anywhere else in the document.
> 
> Vijay
>

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 25 Mar 2009 11:06:43 -0700

>       e.g.  "IPv4 Address Lease Expired".

Ok.

> should be referenced using another bit similar to Global (G) bit. 

In this scenario, the IPv4 address lease didn't really expire. It is 
more like the mobile node decided to release the IPv4 address. So 
wouldn't a BRI message with the 'V' flag set, with the IPv4 home address 
option and the revocation trigger set to "User Initiated Session(s) 
Termination" be sufficient? This does tell the MAG that the IPv4 session 
should be deleted.

Vijay

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Thu, 26 Mar 2009 17:06:44 -0500

> Subject: Re: Question on IPv4 Home Address Lease Expires 
> Revocation Trigger
> 
> Ahmad Muhanna wrote:
> > Hi Vijay,
> > 
> > As a background, my understanding of the applicable 
> scenario is that 
> > the MN could release the IPv4 address using DHCPRELEASE directly to 
> > the DHCP server that co-located in the LMA (MAG is a DHCP 
> Relay). The 
> > LMA would know of this release BUT the MAG wouldn't. LMA 
> sends the BRI 
> > to the MAG to inform the MAG that the IPv4 address have 
> been released. 
> > Initially, we used only Revocation Trigger for the whole IPv4 HoA 
> > release but then we received some comments during WGLC 
> which suggested 
> > that the IPv4 should be referenced using another bit 
> similar to Global (G) bit.
> 
> In this scenario, the IPv4 address lease didn't really 
> expire. It is more like the mobile node decided to release 
> the IPv4 address. So wouldn't a BRI message with the 'V' flag 
> set, with the IPv4 home address option and the revocation 
> trigger set to "User Initiated Session(s) Termination" be 
> sufficient? This does tell the MAG that the IPv4 session 
> should be deleted.
[Ahmad]
That is fine with me.

> > Trigger. If you have a better name, please let me know. HA also may 
> > use Admin as a R. Trigger with the (V) bit.
> > 
> > 
> > Regards,
> > Ahmad
> >  
> > 
> >> Subject: Question on IPv4 Home Address Lease Expires Revocation 
> >> Trigger
> >>
> >> Hi Ahmad,
> >>
> assumption was 
> >> that the lifetime of the IPv4 home address allocated to the mobile 
> >> node is the same as the lifetime of the proxy binding.
> >>