Subject: Re: [MEXT] Review of draft-ietf-mext-flow-binding-01

From: Christian Kaas-Petersen <[email-masked]>
Date: Tue, 10 Mar 2009 09:34:27 +0000 (GMT)

I should like to understand the motivation for N-cast.  Which application
will have a need, when sending packets to a specific mobile node, for 
having its packets replicated and sent over N different links
to a mobile node?

Christian

--- Den man 9/3/09 skrev Giaretta, Gerardo <[email-masked]>:

> Fra: Giaretta, Gerardo <[email-masked]>
> Emne: [MEXT] Review of draft-ietf-mext-flow-binding-01
> Til: "[email-masked]" <[email-masked]>
> Dato: mandag 9. marts 2009 23.37
> 
> 
> - Section 6.1.1: 
> 
>    
> 
>    o  If the Action
> field is set to
> indicate N-cast, the Binding 
> 
>      
> Reference sub-option must
> be present and it must contain one or 
> 
>       more
> BIDs.  If the
> Binding Update sub-option includes only one 
> 
>       BID,
> it must be pointing
> to a care-of address other than the one 
> 
>      
> included in the binding
> update. 
> 
>    
> 
> Based on this, the n-cast would be
> done between the CoA
> in the BID and the CoA in the source address of the packet.
> I think it would be
> much cleaner to always include all BIDs for which n-casting
> is requested. The
> source address of the packet is not processed as CoA when a
> BID is present
> based on the MCoA draft (similarly to what happens in case
> the Alt-CoA option
> is used). This comment applies also to the fourth bullet of
> section 8.1 
> 
>    
> 

      Find din nye laptop på kelkoo.dk. Se de gode tilbud her - http://dk.yahoo.com/r/pat/mm

---

From: Hesham Soliman <[email-masked]>
Date: Tue, 10 Mar 2009 20:43:06 +1100

> having its packets replicated and sent over N different links

=> This is not an unusual handover smoothing technique. But you can also use
it for redundancy when multiple links exist.

Hesham

> _______________________________________________
> MEXT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mext

---

From: George Tsirtsis <[email-masked]>
Date: Tue, 10 Mar 2009 11:00:34 +0000

Yes, this could be appropriate for light UDP traffic e.g., VoIP ....
some health warnings regarding flooding multiple links with traffic
might be in-order.

George