Subject: Re: [MEXT] Proposed RFC editor change for DSMIPv6

From: "Giaretta, Gerardo" <[email-masked]>
Date: Mon, 2 Mar 2009 12:56:11 -0800

Hi Hesham,

The text is fine.

Thanks
Gerardo

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Hesham
> Soliman
> Sent: Saturday, February 28, 2009 12:00 AM
> To: [email-masked]
> Cc: Pasi Eronen; Jari Arkko; Basavaraj Patil
> Subject: [MEXT] Proposed RFC editor change for DSMIPv6
> 
> Folks,
> 
> I had a private conversation with Raj where he suggested that the HA
> discovery for DSMIPv6, when a mobile node is in an IPv4-only network, can be
> done using DHCPv4. Raj referred to a DHCP option designed for MIPv4 that can
> be used to provide the IPv4 address for the HA.
> 
> We discussed the fact that this option would not tell the MN if the HA is
> dual stack or if it supports DSMIPv6 at all. So it will be a trial and error
> type discovery (unlike the current use of DNS or DHCPv6).
> 
> Raj Proposed the text below. One might also want to consider running DHCPv6
> on top of IPv4, which IMO is a clearer option for this case.
> 
> Please let us know if you agree with this text, I'm cc'ing Jari and Pasi
> because Pasi made a comment earlier on this section. Since the draft has
> already been reviewed by the IESG, I suggest that if the WG agrees with this
> text, it should be added to the RFC editor notes.
> 
> Proposed text to be added:
> 
> d/ Note that the use of
>    [I-D.ietf-mip6-bootstrapping-integrated-dhc] cannot give the mobile
>    node information that allows it to communicate with the home agent if
>    the mobile node is located in an IPv4-only network.  In this
>    scenario, the mobile node needs to discover the IPv4 address of its
>    home agent through the DNS.
> 
> a/When the mobile node is located in an IPv4 only network it needs to
> discover the IPv4 address of its home agent. The mobile node can obtain the
> IPv4 address of its home agent through DNS or via DHCPv4 from the DHCP
> Mobile IP Home Agent Option 68 [REF 2132].
> 
> 
> Please comment, silence does not mean that the text is acceptable.
> 
> Hesham
> 
> 
> 
> _______________________________________________
> MEXT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mext

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 2 Mar 2009 16:52:27 -0500

Hi Hesham and others,

I don't think we should do this. The existing DHCPv4 option 68 clearly
indicates that it is the Mobile IPv4 home agent information that is
being conveyed. Using that for discovering the DS-MIPv6 home agent would
be a hack. Moreover, this option will not be able to convey the IPv6
address of the DS-MIPv6 home agent when the mobile node boots up on the
IPv4 access network.

Why don't we have a separate short spec that defines a new DHCPv4 option
for discovering a DS-MIPv6 home agent information when the mobile node
is attached to an IPv4 access network? It shouldn't take too long to get
this spec done. 

Vijay

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Hesham Soliman

---

From: <[email-masked]>
Date: Mon, 2 Mar 2009 22:58:29 +0100

Hi Vijay,

Do you see a problem with using the existing DHCPv4 option for indicating
the IPv4 address of the DSMIP6 HA?

Ideally we should define a new DHCPv4 option which carries the v4 and v6
addresses of the DSMIP6 HA to the MN when booting up in an IPv4 only
network. As Hesham mentioned, the MN will discover via trial/error the type
of HA that the v4 address is associated with.
While this can be done in the DHC WG in parallel if the WG decides to do so,
I see no harm in including the proposed text.

-Raj

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 02 Mar 2009 14:02:49 -0800

Hi Raj,

> the IPv4 address of the DSMIP6 HA?

It can be made to work, but it is not exactly an elegant solution.

> I see no harm in including the proposed text.

This I disagree with. You would end up with two solutions, one in the 
DS-MIPv6 document that says you can use option 68 to discover a DS-MIPv6 
home agent and the other in the DHC WG that defines a new option. We 
should decide now itself, whether we want to use option 68 or a new option.

Vijay

---

From: Frank Xia <[email-masked]>
Date: Mon, 02 Mar 2009 16:23:02 -0600

Hi All

I think we should define new DHCPv4 option.

Please check the pointer
http://www.ietf.org/mail-archive/web/mext/current/msg01375.html
which described the discussion the requirement for
DHCPv4 option when DHCPv6 ones were standardized.

BR
Frank

---

From: Jari Arkko <[email-masked]>
Date: Tue, 03 Mar 2009 11:24:28 +0100

I agree with Vijay and we should not do this.

I'm not sure if I'm missing something, but 
http://www.ietf.org/internet-drafts/draft-ietf-mip6-hiopt-17.txt carries 
IPv4 addresses of Mobile IPv6 home agents as well. Why isn't that 
sufficient?

Jari

---

From: Hesham Soliman <[email-masked]>
Date: Tue, 03 Mar 2009 22:27:38 +1100

> I agree with Vijay and we should not do this.

=> I think we have agreement not to do this based on the comments received.

> IPv4 addresses of Mobile IPv6 home agents as well. Why isn't that

=> Because it's assumed to only be present in IPv6-enabled networks. But as
I mentioned in the email, we can either trasport DHCPv6 over v4 or
extend/define a new option for this. Probably easier to do the latter...

Hesham

---

From: Jari Arkko <[email-masked]>
Date: Tue, 03 Mar 2009 13:11:24 +0100

Hesham,

> extend/define a new option for this. Probably easier to do the latter...

Ok, got it. We can easily define an RFC to do this. Write it up and send 
it to me...

Jari

---

From: Frank Xia <[email-masked]>
Date: Tue, 03 Mar 2009 13:37:44 -0600

Hi Jari

I propsed this as MEXT item last May
http://www.ietf.org/mail-archive/web/mext/current/msg01375.html.

I would like to be of any help if needed.

BR
Frank

----- Original Message ----- 
From: "Jari Arkko" <[email-masked]>
To: "Hesham Soliman" <[email-masked]>
Cc: "Basavaraj Patil" <[email-masked]>; "Pasi Eronen" 
<[email-masked]>; <[email-masked]>
Sent: Tuesday, March 03, 2009 6:11 AM
Subject: Re: [MEXT] Proposed RFC editor change for DSMIPv6