Subject: [MEXT] Last Call: draft-ietf-mext-binding-revocation (Binding Revocation for IPv6 Mobility) to Proposed Standard

From: The IESG <[email-masked]>
Date: Wed, 12 Aug 2009 08:59:29 -0700 (PDT)

The IESG has received a request from the Mobility EXTensions for IPv6 WG 
(mext) to consider the following document:

- 'Binding Revocation for IPv6 Mobility '
   <draft-ietf-mext-binding-revocation-08.txt> as a Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action.  Please send substantive comments to the
[email-masked] mailing lists by 2009-08-26. Exceptionally, 
comments may be sent to [email-masked] instead. In either case, please 
retain the beginning of the Subject line to allow automated sorting.

The file can be obtained via
http://www.ietf.org/internet-drafts/draft-ietf-mext-binding-revocation-08.txt

IESG discussion can be tracked via
https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=17614&rfc_flag=0

---

From: Xiangsong Cui <[email-masked]>
Date: Thu, 13 Aug 2009 12:02:33 +0800

Hi all,

Thank the authors for the good job and I have a minor comment.

In section 8.2 (the last paragraph),

   o  If the Status field indicates any value other than success, the
      home agent SHOULD examine any mobility options included in the
      Binding Revocation Acknowledgement.  The home agent MAY log the
      appropriate event to reflect the received status.

I think it is not very clear how should the home agent handle the BCE
(e.g. the resource and revocation in progress flag) and the revocation
timer (if there is some timer is running).

The corresponding part from LMA is better, I think.

      It is based on the local mobility anchor local policy how to
      handle the mobile node BCE(s) that the mobile access gateway
      indicated it failed the revocation procedure, however, the LMA MAY
      log the event.

Regards

Xiangsong

----- Original Message ----- 
From: "The IESG" <[email-masked]>
To: "IETF-Announce" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, August 12, 2009 11:59 PM
Subject: [MEXT] Last Call: draft-ietf-mext-binding-revocation 
(BindingRevocation for IPv6 Mobility) to Proposed Standard

> _______________________________________________
> MEXT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mext

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Thu, 13 Aug 2009 01:57:50 -0500

Hi,
Sure, we will clarify the text for the HA in the next revision.

Thanks.

Regards,
Ahmad

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Xiangsong Cui
> Sent: Wednesday, August 12, 2009 11:03 PM
> To: [email-masked]; IETF-Announce
> Cc: [email-masked]
> Subject: Re: [MEXT] Last Call: 
> draft-ietf-mext-binding-revocation (BindingRevocation for 
> IPv6 Mobility) to Proposed Standard
> 
> Hi all,
> 
> I think it is not very clear how should the home agent handle 
> the BCE (e.g. the resource and revocation in progress flag) 
> and the revocation timer (if there is some timer is running).
> 
> > The IESG has received a request from the Mobility 
> EXTensions for IPv6 
> > WG
> > final comments on this action.  Please send substantive comments to 
> > the [email-masked] mailing lists by 2009-08-26. 
> Exceptionally, comments 
> > may be sent to [email-masked] instead. In either case, please retain 
> > the beginning of the Subject line to allow automated sorting.
> >

---

From: Xiangsong Cui <[email-masked]>
Date: Fri, 14 Aug 2009 11:03:42 +0800

Hi,

There is an editorial issue in the author list, both the head and the end.
I think "Startent Networks"should be "Starent Networks", right?

Regards
Xiangsong

----- Original Message ----- 
From: "Ahmad Muhanna" <[email-masked]>
To: "Xiangsong Cui" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, August 13, 2009 2:57 PM
Subject: RE: [MEXT] Last Call: draft-ietf-mext-binding-revocation 

Hi,

Thanks.

Regards,
Ahmad

---

From: <[email-masked]>
Date: Fri, 14 Aug 2009 16:50:11 +0200

Dear Ahmad,

I also have only some formal remarks for the text: 
On page 6:
(G) is used without defining it before as Global bit, so I would suggest
message with the Global (G) and (A) bits set

Page 12:
Another case is when a mobile node which support_s_ client mobile IPv6
roam_s_ to an access network

If the Proxy Binding Update and Proxy Binding _Acknowledgement_ messages

Page 28:
Shouldn't it say
o  If the Status field indicates that the BRI was processed
      successfully, the local mobility anchor MUST delete the current timer
Instead of 
o  If the Status field indicates that the BRI was processed
      successfully, the local mobility anchor deletes the current timer

Page 29, 31:
=> I suggest to stick to a single expression throughout the draft: either Acknowledge (A) bit or Acknowledgement (A) bit

Page 30:
   When the local mobility anchor receive_s a valid Binding Revocation

   o  In the case that one of the bindings identified in the received
      Binding Revocation Indication message has already been released
      before receiving the it, 
=> delete _the_ after _receiving_

age 32:
access gateway use_s the mobility ...

Include (Binding Update List) after using acronym BUL (that's what it stands for, right?)

Page 33:
When the mobile access gateway receive_s_ a valid

Page 34:

   o  The Acknowledge (A) bit MUST be set in the to request the local
=> deleter either _in the_ or add _messsage_ after _in the_

					The Alternate Care-of Address option(s)
      contain the proxy Care-of address(es) which their bindings are
      being impacted by this Binding Revocation Indication message.

=> Do you mean ... the proxy Care-of address(es) the bindings of which are ... ?

Best regards
Dirk
-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Xiangsong Cui
Gesendet: Freitag, 14. August 2009 05:04
An: Ahmad Muhanna
Cc: [email-masked]
Betreff: Re: [MEXT] Last Call: draft-ietf-mext-binding-revocation (BindingRevocation for IPv6 Mobility) to Proposed Standard

Hi,

Regards
Xiangsong

----- Original Message ----- 
From: "Ahmad Muhanna" <[email-masked]>
To: "Xiangsong Cui" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, August 13, 2009 2:57 PM
Subject: RE: [MEXT] Last Call: draft-ietf-mext-binding-revocation 

Hi,

Thanks.

Regards,
Ahmad

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Fri, 14 Aug 2009 11:55:46 -0500

Thanks. Will fix it.

Regards,
Ahmad

> From: Xiangsong Cui [mailto:[email-masked]] 
> Sent: Thursday, August 13, 2009 10:04 PM
> To: Muhanna, Ahmad (RICH1:2H10)
> Cc: [email-masked]
> > From: [email-masked] [mailto:[email-masked]] 
> On Behalf 
> > Of Xiangsong Cui
> >       indicated it failed the revocation procedure, 
> however, the LMA 
> > MAY
> >       log the event.
> >
> > Regards
> >
> > Xiangsong
> >
> >

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Fri, 14 Aug 2009 13:22:21 -0500

Hello Dirk,
Thanks for the comments, please see inline.

Regards,
Ahmad

> From: [email-masked] [mailto:[email-masked]] 
> Sent: Friday, August 14, 2009 9:50 AM
> Cc: [email-masked]; [email-masked]
> Subject: AW: [MEXT] Last Call: 
> (G) is used without defining it before as Global bit, so I 
> would suggest message with the Global (G) and (A) bits set

[Ahmad]
Thanks for catching this. Will fix it.
> 
> Page 12:
> Another case is when a mobile node which support_s_ client 
> mobile IPv6 roam_s_ to an access network
[Ahmad]
Ok.

> _Acknowledgement_ messages
[Ahmad]
Ok.
 
>       successfully, the local mobility anchor MUST delete the 
> current timer Instead of o  If the Status field indicates 
> that the BRI was processed
[Ahmad]
Ok.
 
> Page 29, 31:
> => I suggest to stick to a single expression throughout the 
> draft: either Acknowledge (A) bit or Acknowledgement (A) bit

[Ahmad]
Agree. This is a typo. Will use Acknowledge throughout the doc.

> => delete _the_ after _receiving_

[Ahmad]
Ok.

> access gateway use_s the mobility ...

[Ahmad]
Ok.
> what it stands for, right?)

[Ahmad]
It should be mentioned the first time BUL appears in the document. Will make sure that is the case.

> When the mobile access gateway receive_s_ a valid

[Ahmad]
Ok.

> 
> Page 34:
> 
>    o  The Acknowledge (A) bit MUST be set in the to request 
> the local => deleter either _in the_ or add _messsage_ after _in the_
> 
[Ahmad]
Ok.

> => Do you mean ... the proxy Care-of address(es) the bindings 
[Ahmad]
Yeh. That is probably clearer.

Thanks again!
Ahmad
> Betreff: Re: [MEXT] Last Call: