Subject: [MEXT] Aeronautical NEMO RO

From: <[email-masked]>
Date: Fri, 11 Sep 2009 09:43:34 +0200

Dear all,

In order to proceed with the discussion on the aeronautical NEMO RO use case, we have prepared a solution space document that investigates the possible solutions and highlights issues where we think that additional work/investigations are required.

In addition, the topology draft has been updated as well (http://tools.ietf.org/html/draft-bauer-mext-aero-topology-01).

Christian

-----Ursprüngliche Nachricht-----
Von: IETF I-D Submission Tool [mailto:[email-masked]] 
Gesendet: Mittwoch, 9. September 2009 14:47
An: Bauer, Christian
Cc: Ayaz, Serkan; [email-masked]
Betreff: New Version Notification for draft-bauer-mext-aero-solspace-00 

A new version of I-D, draft-bauer-mext-aero-solspace-00.txt has been successfuly submitted by Christian Bauer and posted to the IETF repository.

Filename:	 draft-bauer-mext-aero-solspace
Revision:	 00
Title:		 Solution Space for Aeronautical NEMO RO
Creation_date:	 2009-09-09
WG ID:		 Independent Submission
Number_of_pages: 29

Abstract:
Many potential solutions have been proposed for NEMO Route
Optimization, although none has been adopted up to now.  This draft
aims on evaluating the different approaches for the aeronautical use
case.  At the end, a recommendation for the next steps is given.

The IETF Secretariat.

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 11 Sep 2009 13:02:41 +0200

[email-masked] a écrit :
> Dear all,
> 
> In order to proceed with the discussion on the aeronautical NEMO RO 
> use case, we have prepared a solution space document that 
> investigates the possible solutions and highlights issues where we 
> think that additional work/investigations are required.

Thanks for this solspace draft whose url is:

http://tools.ietf.org/html/draft-bauer-mext-aero-solspace-00

> In addition, the topology draft has been updated as well 
> (http://tools.ietf.org/html/draft-bauer-mext-aero-topology-01).

I have an overall question: is the absence of plane-to-plane 
communications scenarios from both the topology and solspace drafts - on 
purpose?  Or is it that nobody submitted input for it?

(In the solspace draft you analyze MNN-to-CN, MR-CN, MR-CR and MR-HA
  communications, but not MR-to-MR communications.  In the topology
  draft, MR-to-CN, points of attachment and ground equipment seem
  needed.)

The IP mechanisms to achieve plane-to-plane communications may be easily
developed, and they relate to the concept of NEMO network mobility and
IPv6, and Mobile IPv6: may be categorized as optimal paths, the related
IP techniques may be Route Optimization.

Alex

> 
> Christian
> 
> 
> -----Ursprüngliche Nachricht----- Von: IETF I-D Submission Tool 
> [mailto:[email-masked]] Gesendet: Mittwoch, 9. September 2009 
> 14:47 An: Bauer, Christian Cc: Ayaz, Serkan; [email-masked] 
> A new version of I-D, draft-bauer-mext-aero-solspace-00.txt has been 
> successfuly submitted by Christian Bauer and posted to the IETF 
> repository.
> 
> Filename:	 draft-bauer-mext-aero-solspace Revision:	 00 Title: 
> Solution Space for Aeronautical NEMO RO Creation_date:	 2009-09-09 WG
>  ID:		 Independent Submission Number_of_pages: 29
> 
> Abstract: Many potential solutions have been proposed for NEMO Route
> _______________________________________________ MEXT mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/mext
>

---

From: <[email-masked]>
Date: Fri, 11 Sep 2009 13:54:53 +0200

Hi Alex,

> IP techniques may be Route Optimization.
Air-to-air communication is of course existing, however, these applications often have broadcast semantics and, most importantly, are directly sitting on top of layer 2.

That is because they have no requirement for *multihop* communication. This is true for what is available today and even future ATS applications don't seem to have a requirement that goes beyond single-hop/broadcast-only communications (AFAIK).

The requirements document mentions air-to-air as (part of the) routing path for MNN-CN communications (see Des2 - Nesting). As this is not necessarily related to NEMO, it has been ommited.

Christian

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 11 Sep 2009 15:32:51 +0200

Hi Christian and thanks for the reply.

Just a few points below, about plane-to-plane.

[email-masked] a écrit :
>> communications scenarios from both the topology and solspace drafts
>> - on purpose?  Or is it that nobody submitted input for it?
>> 
>> (In the solspace draft you analyze MNN-to-CN, MR-CN, MR-CR and
>> MR-HA communications, but not MR-to-MR communications.  In the
>> topology draft, MR-to-CN, points of attachment and ground equipment
>> seem needed.)
>> 
>> The IP mechanisms to achieve plane-to-plane communications may be
>> easily developed, and they relate to the concept of NEMO network
>> mobility and IPv6, and Mobile IPv6: may be categorized as optimal
>> paths, the related IP techniques may be Route Optimization.
> 
> Air-to-air communication is of course existing, however, these
> applications often have broadcast semantics and, most importantly,
> are directly sitting on top of layer 2.

Yes, I guess mostly broadcast semantics...

Mostly on layer 2 would mean almost layer 3 which is a good direction I
believe.

> That is because they have no requirement for *multihop*
> communication. This is true for what is available today and even
> future ATS applications don't seem to have a requirement that goes
> beyond single-hop/broadcast-only communications (AFAIK).

I am looking for ATS applications which go beyond single hop, but still
between two planes.  Between a LFN in one plane and a LFN in another plane.

> The requirements document mentions air-to-air as (part of the)
> routing path for MNN-CN communications (see Des2 - Nesting). As this
> is not necessarily related to NEMO, it has been ommited.

Ah I don't mean Nesting.  I meant a topology like this:

                 ___                                __
                 \  \                              /  /
-----           |  |                              |  |           -----
\    \          |  |                              |  |          /    /
  \    \         |  |                              |  |         /    /
   \    \        |  |   o )))))))))))))))))))))o   |  |        /    /
    \    \_______|  |__ | __                __ |___|  |_______/    /
     \                  |   \              /   |                  /
      \    LFN1        MR1   \            /   MR2       LFN2     /
       \     |          |     \          /     |          |     /
        \   --------------    )         (    --------------    /
         \ ______   _________/           \_ _______   ________/
                 |  |                              |  |
                 |  |                              |  |
                 |  |                              |  |
                 |  |                              |  |
                 |  |                              |  |
                 /__/                              \__\

In this topology: the mobile networks are not nested, LFN1 communicates
with LFN2 through their respective MR, ground facilities are not needed.

Alex

---

From: <[email-masked]>
Date: Fri, 11 Sep 2009 16:05:19 +0200

Hi,

> between two planes.  Between a LFN in one plane and a LFN in another
plane.
That's what I tried to answer with my last mail ;-)

There is AFAIK no requirement for MNN-to-MNN (or aircraft-to-aircraft)
*multihop* communication for ATS and AOS.

> Ah I don't mean Nesting.  I meant a topology like this:
Nice drawing :-)

But I think this could only happen, in theory, within the PIES domain.

Christian

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 11 Sep 2009 16:43:19 +0200

> But I think this could only happen, in theory, within the PIES domain.

Hmm... but PIES domain seems to be all that requires Internet access, 
whereas plane-to-plane communications would happen without requiring 
Internet access.

Alex