Subject: [MEXT] Re-sending BA message

From: Wassim Haddad <[email-masked]>
Date: Fri, 18 Sep 2009 16:21:46 -0400

Hi,

I'd like to ask for a clarification concerning one particular case in the RO mode:

When a MN sends a BU message to the CN and requests a BA in return (which is optional), if we assume
that the CN gets the BU message, sends a BA then re-directs the traffic to the MN's new CoA.
How should the MN react if, for some reasons, it does not receive the BA message but it starts receiving
data packets to its new CoA?

Regards,

Wassim H.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 18 Sep 2009 13:37:58 -0700

Hello Wassim,

I think it should accept the packets.

Regards,
Charlie P.

Wassim Haddad wrote:
> ------------------------------------------------------------------------
>
> _______________________________________________
> MEXT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mext
>

---

From: <[email-masked]>
Date: Fri, 18 Sep 2009 22:45:43 +0200

Hi Charlie,

If the MN requested an Ack for the BU from the CN and does not receive it,
it can be perceived as the Ack being lost. Hence IMO the MN should resend
the BU and if the CN were to start sending packets to the CoA, the MN should
drop those packets.

-Basavaraj

---

From: Sri Gundavelli <[email-masked]>
Date: Fri, 18 Sep 2009 14:01:14 -0700 (PDT)

But, these are sent with the Type II Routing header, which
clearly ties the HoA to the CoA, and the intent is clear
on both the ends.

Sri

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 18 Sep 2009 17:03:51 -0400

Hi Raj, Charlie,

Both behaviors are acceptable as far as RFC 3775 is concerned.

After all the MN had sent the BU and is getting route optimized packets in response. So it should not drop the packets. It could retransmit the BU meanwhile.

The MN dropping packets while the BU is retransmitted is also permitted behavior.

Vijay

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Friday, September 18, 2009 1:46 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [MEXT] Re-sending BA message
>
>
> Hi Charlie,
>
> >> I'd like to ask for a clarification concerning one particular case
> in
> >> the RO mode:
> >>
> >> How should the MN react if, for some reasons, it does not receive
> the
> >> BA message but it starts receiving

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 18 Sep 2009 14:05:15 -0700

Hello Basavaraj,

[email-masked] wrote:
> it can be perceived as the Ack being lost.
Check.

>  Hence IMO the MN should resend
> the BU

Check.

>  and if the CN were to start sending packets to the CoA, the MN should
> drop those packets.
>   

Why?  They're perfectly good packets!

Regards,
Charlie P.

---

From: <[email-masked]>
Date: Fri, 18 Sep 2009 23:09:29 +0200

Okay... I can live with the fact that it is implementation dependent then on
the MN. 

-Basavaraj

On 9/18/09 4:03 PM, "ext Vijay Devarapalli" <[email-masked]> wrote:

> After all the MN had sent the BU and is getting route optimized packets in
> response. So it should not drop the packets. It could retransmit the BU
> meanwhile.
>

---

From: Wassim Haddad <[email-masked]>
Date: Fri, 18 Sep 2009 17:19:02 -0400

Hi Vijay,

Do you also mean that the MN can receive and send data packets to the CN using the
new CoA in the absence of a BA message while retransmitting a BU in which it is
requesting a binding for its new CoA?

Wassim H.

-----Original Message-----
From: Vijay Devarapalli [mailto:[email-masked]]
Sent: Friday, September 18, 2009 3:04 PM
To: [email-masked]; [email-masked]; Wassim Haddad
Cc: [email-masked]
Subject: RE: [MEXT] Re-sending BA message

Hi Raj, Charlie,

Vijay

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of [email-masked]
> If the MN requested an Ack for the BU from the CN and does not receive
> it, it can be perceived as the Ack being lost. Hence IMO the MN should
> resend the BU and if the CN were to start sending packets to the CoA,
> the MN should drop those packets.
>
> -Basavaraj
>
>
> >> When a MN sends a BU message to the CN and requests a BA in return
> >> (which is optional), if we assume that the CN gets the BU message,
> >> sends a BA then re-directs the traffic to the MN's new CoA.
> >> -------------------------------------------------------------------
> >> -
> ----
> >>

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 18 Sep 2009 14:20:31 -0700 (PDT)

I also agree with Charlie. By sending a BU MN wishes to establish a route optimized connection to CN and the received packets indicate that it worked, so why drop them?
Regards,

Behcet

----- Original Message ----
> From: Charles E. Perkins <[email-masked]>
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Sent: Friday, September 18, 2009 4:05:15 PM
> > On 9/18/09 3:37 PM, "Charles Perkins" wrote:
> >
> >  
> >> Hello Wassim,
> >>
> >>> (which is optional), if we assume

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 18 Sep 2009 17:36:45 -0400

Receive, yes. But for sending, I would err on not sending route optimized packets until I receive a binding ack. I would reverse tunnel through the HA even through the CN is sending packets directly to my CoA. But RFC 3775 does not prohibit a MN from assuming the binding is already created based on the fact that it received route optimized packets from the CN and sending route optimized packets to it.

Vijay

> From: Wassim Haddad [mailto:[email-masked]]
> Sent: Friday, September 18, 2009 2:19 PM
> To: Vijay Devarapalli; [email-masked];
> [email-masked]
> Cc: [email-masked]
> After all the MN had sent the BU and is getting route optimized packets
> in response. So it should not drop the packets. It could retransmit the
> BU meanwhile.
>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 18 Sep 2009 15:07:33 -0700

Hello Vijay,

I hope this is a rare case -- if so, the answer doesn't matter too much.

However, if the BU can work without the BA, then I don't see why it
should suddenly fail when the requested BA is lost.

The best course of action is, I think, depending on timing.

If the MN wants to be sure there is an optimized routing path
to the CN, but does not expect any data immediately, then it
should certainly set the 'A' bit.

If the MN did not set the 'A' bit, but the CN had a nearly-expired
binding cache entry, then the CN could send optimized packets
by way of a nearly expired BCE, but the mobile node would not
have any assurance that the optimized path would remain
available.

If the mobile node sends a binding from a new CoA and the
correspondent node replies correctly, that should be counted
as an implicit acknowledgment.  Of course, the mobile node
could send another BU, if it likes stimulating the economy by
soaking up excess bandwidth over the air.

But I can't see any reason to drop the packets.  It's just a way
to cause more hiccups in an application that's trying as hard as
it can to work smoothly.

Regards,
Charlie P.

Vijay Devarapalli wrote:
>>> If the MN requested an Ack for the BU from the CN and does not
>>>       
>> receive
>>     
>>> it, it can be perceived as the Ack being lost. Hence IMO the MN
>>>       
>> should
>>     
>>>>> ------------------------------------------------------------------
>>>>>           
>> -
>>     
>>>>> -
>>>>>           
>>> ----
>>>

---

From: Xiangsong Cui <[email-masked]>
Date: Sat, 19 Sep 2009 08:48:57 +0800

Hello,

In my understanding, this is a normal case.

Because there is no sequenced delivery mechanism
in generic IP network, it is a very ordinary case that
CN sends BA firstly but the traffic packet arrives
at MN earlier.

I think it is better for the MN to accept the packets
between BU and BA message, although it is not
explicitly required in current specification.

Regards
Xiangsong

----- Original Message ----- 
From: "Charles E. Perkins" <[email-masked]>
To: "Vijay Devarapalli" <[email-masked]>
Cc: <[email-masked]>
Sent: Saturday, September 19, 2009 6:07 AM
Subject: Re: [MEXT] Re-sending BA message

>> Receive, yes. But for sending, I would err on not sending route optimized 
>> packets until I receive a binding ack. I would reverse tunnel through the 
>> HA even through the CN is sending packets directly to my CoA. But RFC 
>> 3775 does not prohibit a MN from assuming the binding is already created 
>> based on the fact that it received route optimized packets from the CN 
>> and sending route optimized packets to it.
>>
>> Vijay
>>
>>