Subject: [MEXT] I-D Action:draft-ietf-mext-binary-ts-02.txt

From: [email-masked]
Date: Wed, 16 Dec 2009 03:00:01 -0800 (PST)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Mobility EXTensions for IPv6 Working Group of the IETF.

	Title           : Traffic Selectors for Flow Bindings
	Author(s)       : G. Tsirtsis, et al.
	Filename        : draft-ietf-mext-binary-ts-02.txt
	Pages           : 18
	Date            : 2009-12-16

This document defines binary formats for IPv4 and IPv6 traffic
selectors to be used in conjunction with flow bindings for Mobile
IPv6.

Status of this Memo

This Internet-Draft is submitted to IETF in full conformance with the
provisions of BCP 78 and BCP 79.

Internet-Drafts are working documents of the Internet Engineering
Task Force (IETF), its areas, and its working groups.  Note that
other groups may also distribute working documents as Internet-
Drafts.

Internet-Drafts are draft documents valid for a maximum of six months
and may be updated, replaced, or obsoleted by other documents at any
time.  It is inappropriate to use Internet-Drafts as reference
material or to cite them other than as "work in progress."

The list of current Internet-Drafts can be accessed at
http://www.ietf.org/ietf/1id-abstracts.txt.

The list of Internet-Draft Shadow Directories can be accessed at
http://www.ietf.org/shadow.html.

This Internet-Draft will expire on June 19, 2010.

Copyright Notice

Copyright (c) 2009 IETF Trust and the persons identified as the
document authors.  All rights reserved.

This document is subject to BCP 78 and the IETF Trust's Legal
Provisions Relating to IETF Documents
(http://trustee.ietf.org/license-info) in effect on the date of
publication of this document.  Please review these documents
carefully, as they describe your rights and restrictions with respect
to this document.  Code Components extracted from this document must
include Simplified BSD License text as described in Section 4.e of
the Trust Legal Provisions and are provided without warranty as
described in the BSD License.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mext-binary-ts-02.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: George Tsirtsis <[email-masked]>
Date: Wed, 16 Dec 2009 11:07:01 +0000

Just published the updated draft. Thanks for all the comments during the WGLC.

As far as I know there are no loose ends so Marcelo/Julien please
consider forwarding this as well as the flow bindings draft to the
IESG.

Thanks
George

---------- Forwarded message ----------
From:  <[email-masked]>
Date: Wed, Dec 16, 2009 at 11:00 AM
Subject: [MEXT] I-D Action:draft-ietf-mext-binary-ts-02.txt
To: [email-masked]
Cc: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Mobility EXTensions for IPv6 Working
Group of the IETF.

Status of this Memo

Copyright Notice

_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: "Yuri Ismailov" <[email-masked]>
Date: Wed, 16 Dec 2009 18:51:21 +0100

Hi George, 

Surprized that did not get answer on my comment.
Was irrelevant or not understandable or not important or etc...
Regards
Yuri

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of George Tsirtsis
Sent: Wednesday, December 16, 2009 12:07 PM
To: IETF MEXT WG ML; [email-masked]
Subject: [MEXT] Fwd: I-D Action:draft-ietf-mext-binary-ts-02.txt

As far as I know there are no loose ends so Marcelo/Julien please consider forwarding this as well as the flow bindings draft to the IESG.

Thanks
George

---------- Forwarded message ----------
From:  <[email-masked]>
Date: Wed, Dec 16, 2009 at 11:00 AM
Subject: [MEXT] I-D Action:draft-ietf-mext-binary-ts-02.txt
To: [email-masked]
Cc: [email-masked]

This document defines binary formats for IPv4 and IPv6 traffic selectors to be used in conjunction with flow bindings for Mobile IPv6.

Status of this Memo

This Internet-Draft is submitted to IETF in full conformance with the provisions of BCP 78 and BCP 79.

Internet-Drafts are working documents of the Internet Engineering Task Force (IETF), its areas, and its working groups.  Note that other groups may also distribute working documents as Internet- Drafts.

Internet-Drafts are draft documents valid for a maximum of six months and may be updated, replaced, or obsoleted by other documents at any time.  It is inappropriate to use Internet-Drafts as reference material or to cite them other than as "work in progress."

The list of current Internet-Drafts can be accessed at http://www.ietf.org/ietf/1id-abstracts.txt.

The list of Internet-Draft Shadow Directories can be accessed at http://www.ietf.org/shadow.html.

Copyright Notice

Copyright (c) 2009 IETF Trust and the persons identified as the document authors.  All rights reserved.

This document is subject to BCP 78 and the IETF Trust's Legal Provisions Relating to IETF Documents
(http://trustee.ietf.org/license-info) in effect on the date of publication of this document.  Please review these documents carefully, as they describe your rights and restrictions with respect to this document.  Code Components extracted from this document must include Simplified BSD License text as described in Section 4.e of the Trust Legal Provisions and are provided without warranty as described in the BSD License.

Below is the data which will enable a MIME compliant mail reader implementation to automatically retrieve the ASCII version of the Internet-Draft.

---

From: "Laganier, Julien" <[email-masked]>
Date: Wed, 16 Dec 2009 10:15:52 -0800

Hi Yuri,

> Was irrelevant or not understandable or not important or etc...

Dave Craig also had a related question on the Next Header field. It's my understanding that George's answer also addresses your comment:

Dave Craig wrote:
> 3.2. page 12 (OP), Suggest making the next header match against any of 
> the IPv6 next headers.  This would enable a filter to match against a 
> jumbo payload that might be behind a router alert.  New text might 
> read, "This field identifies the first 8-bit next header value" of any 
> of the next headers in the packet, "from the..."

George Tsirtsis wrote:
> We are not supposed to be doing recursive searches....we are just
> looking at IP header and Transport header....that's it. This is the 
> directive we got from the chairs as well as the IESG....i.e., keep 
> this simple while we gather implementation experience and only 
> complicate things further based on specific needs from deployments.

So we only match based on the last next header field, that of the payload. Thus the NH field will contain e.g., UDP, TCP, ICMPv6, and ESP, but no options.

Does that address your concern?

--julien

---

From: "Yuri Ismailov" <[email-masked]>
Date: Thu, 17 Dec 2009 08:22:56 +0100

Ohhh, sorry,
I must have missed it.
Perfectly fine with me

Regards
Yuri

-----Original Message-----
From: Laganier, Julien [mailto:[email-masked]] 
Sent: Wednesday, December 16, 2009 7:16 PM
To: Yuri Ismailov; George Tsirtsis; IETF MEXT WG ML;
[email-masked]
Subject: RE: [MEXT] Fwd: I-D Action:draft-ietf-mext-binary-ts-02.txt

Hi Yuri,

> Was irrelevant or not understandable or not important or etc...

Dave Craig also had a related question on the Next Header field. It's my
understanding that George's answer also addresses your comment:

> complicate things further based on specific needs from deployments.

So we only match based on the last next header field, that of the
payload. Thus the NH field will contain e.g., UDP, TCP, ICMPv6, and ESP,
but no options.

--julien

---

From: George Tsirtsis <[email-masked]>
Date: Thu, 17 Dec 2009 09:47:53 +0000

OK good, thanks Yuri/Julian.
George

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 17 Dec 2009 09:12:18 -0800 (PST)

I think that the title issue has not yet been resolved.
I don't like the current title. There were several good proposals like Raj's. Why not modify the title?

I realize that such a change would require changing the abstract and some parts of the text as well, I think the abstract should say more on what the binary format is.

These are editorial changes needed to improve the draft.

Regards,

Behcet

----- Original Message ----
> From: George Tsirtsis <[email-masked]>
> To: Yuri Ismailov <[email-masked]>
> Cc: "Laganier, Julien" <[email-masked]>; [email-masked]; IETF MEXT WG ML <[email-masked]>
> Sent: Thu, December 17, 2009 3:47:53 AM
> Subject: Re: [MEXT] Fwd: I-D Action:draft-ietf-mext-binary-ts-02.txt
> 
> wrote: