Subject: [MEXT] Minutes and presentations from the "alt-mext" discussion group at IETF 81

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 04 Aug 2011 15:47:48 -0700

Hello folks,

We had a lively discussion at an ad-hoc meeting for people
interesting in discussion DMM and other [mext]-related
topics at the IETF.  I have collected together the
materials at the following website:
http://www.psg.com/~charliep/txt/ietf81/alt_mext/

Here are some minutes, collected from Alex and Dirk
[thanks!].

One important procedural detail from the meeting bears
repetition.

It was stated that the reason we did not have a scheduled
meeting of the [mext] WG at IETF 81, was because there was
not much discussion on the mailing list.  Some of the
discussion had instead gone to the old DMM mailing list.
I recommended that we shut down the DMM mailing list,
because anything related to DMM ought to be discussed
on the main [mext] mailing list now that DMM is on our
charter.  No one objected to my recommendation.

Is there anyone on the [mext] mailing list who would
object if the DMM mailing list were to be shut down?

For all other comments, please direct discussion to this
mailing list.

Regards,
Charlie P.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 04 Aug 2011 15:56:22 -0700

Hello again folks,

> Here are some minutes, collected from Alex and Dirk

Please excuse -- I forgot to include the minutes in my
previous message...

==================================================================

Agenda:
	alt_mext-Minutes.txt

- Purpose of meeting (vs. scheduled WG meetings)

- Need to increase participation on mailing list
   = Should decommission [dmm] mailing list

- Discussion of DMM I-Ds and topic (60 mins)

- Enhancements to (DS)MIP6 to meet deployment and
   4G+ architecture needs (60 mins)

- Anything else that people have in mind.

Presenters [including filename on
		http://www.psg.com/~charliep/txt/ietf81/alt_mext/]

	Charles Perkins:	Agenda
		Agenda-Mext_Discussion.pptx
	Sri Gundavelli:		Source Address Selection
		Evolving-The-SAS-Rules-for-Mobility-Awareness-2.pdf
	Anthony Chan:	problem statement for dynamic mobility mgmt.
		distributed-mobility-should.ppt
	Luo Wen:		PMIP Based DMM Approach-Song
		PMIP Based DMM Approach-Song.pptx
	Basavaraj Patil:	Reasons for DMM (backhaul, etc.)
		DMM_Approaches_with_MIP6_IETF80.pdf
	Charles Perkins:	Mobile IP for 4G wireless
		MIPv4_for_4G.pptx

== Minutes from Alexandru Petrescu <[email-masked]> ===

MEXT Discussion Group met on July 27th, 2011, in room 303ABC of
Hilton, in Québec, Canada, during the IETF 81 meeting, as announced in
the attached email.

Approximately 21-27 people were in the room, varying in time.

It was led by Charles Perkins and Raj Patil.  There was projector and
slides.

CP humurously named this the "not MEXT WG" meeting, laughs.

CP invited to post to MEXT email list (and no longer use the DMM
email list [email-masked]) and he gave reasonable argument for that.

Requirements discussion happened.

Sri on Source Address Selection and Policy Table DHCP.

Antony Chan on problem statement for dynamic mobility mgmt.

Raj Patil on reasons for DMM: not backhauling, latency, inefficient
routing, scalability and cost.

Dapeng Liu (spelling?) of ZTE saying DMM based on PMIP is different than
LR PMIP in that order of LMA and MAG.

Carlos on PMIP-DMM will present in Mobopts RG.

Pete McCann on lawful interception.

CP on IETF Protocols for 4th generation wireless.

Mobile IP in 4G Networks.

GTP for HA.

WLAN as a "trusted network".

EAP running HA instead of AAA, because HA-VPN inefficient.

SIPTO.

LIPTA (local IP Access).

Discussion.

CP said maybe slides will he upload send ref.

End of minutes.

Alex

======= Minutes from Dirk von Hugo <[email-masked]> ======

Discussions between Hendrik, Raj, Charlie on reason for missing deployment
   of host-based mobility and low ML traffic (decommission DMM!)
- session continuity (pot. w/o HoA continuity) vs. MIP mobility with
   constant HoA
- multiple HAs for different sessions?(Marco and Raj)
Alex proposes to derive DMM requirements from relaxed MIP requirements
Charlie: solution space too large for exhaustive analysis
Raj: practical limit to existing boundaries - no new solution
Jouni: No solution for all possible deployment cases
minimum baseline for deployment?
take into account effort required on host?

1. Discussion of DMM I-Ds and topic (60 mins)

Sri: Motivation
local breakout vs. home tunneling
mobility chaining (EPC&WLAN for off-load)
goals: can we evolve the source address selection for mobility awareness?
Prefix coloring (address properties)
application configuration
protocol extensions (e.g. PIO in RA, or new DHCPv6 option)
IPv6 host policy table on address selection
	(some apps need no mobility support!)
Charlie: mobility vs. other app specific (QoS) requirements
  - connection manager functionality (aka. socket stuff)
Juan Carlos on similar work in MIF WG
Alex on 6MAN WG items

Anthony presents impressive wish list ("desirables" rather than 
requirements)
RO in flat topology?
Raj slide on reasons for DMM:
- backhauling all traffic to central GW
- latency considerations
- inefficient routing (to a distant HA) and signalling overhead
- scalability and cost

ZTE presentation
MN and CN on different MAGs
Raj: difference to LR?
Charlie: both on same domain - if not, traffic will go through LMA

general discussion:
Pete: keep in mind centralized accounting/charging (not to talk about 
billing!) at GGSN - how to solve in distributed architecture?

2. Enhancements to (DS)MIP6 to meet deployment and 4G+ architecture 
needs (60 mins)
charlie: motivation (no 3GPP consideration of IETF - GTP!)
possible solution elements: enabling easier evolution towards IETF solution
- PMIP with GTP extensions?
- EAP-AKA enabled HA?
- SFF-based HOs for heterogeneous networks
         HA can help based on existing MSA with UE

Raj: criteria for IETF superiority? Proved??

Charlies other slides...
discussion on GTP (Alex)
Pete: LTE is moving target - consider LTE what it will be in some years ...
Raj and Sri: 3GPP as closed system - not to try to enter, but focus on WLAN
Charlie: Always been told "it is too late" no it's not

Raj: flow mobility will be covered in Netext

==========================================================================

Regards,
Charlie P.

---

From: Julien Laganier <[email-masked]>
Date: Thu, 4 Aug 2011 19:10:51 -0700

On Thu, Aug 4, 2011 at 3:47 PM, Charles E. Perkins
<[email-masked]> wrote:
> [...]
> not much discussion on the mailing list.

Thanks for highlighting this, Charlie. In the future I'd like to focus
face-to-face meeting time to 1) resolution of issues that have failed
resolution on the mailing list, and 2) presentation of new issues that
might be of interest to the WG, e.g., while the WG is in a
re-chartering phase. I believe this is in the spirit of RFC 2418 that
states that "most of the work of an IETF working group will be
conducted on the mailing list."

--julien