Subject: [MIB-DOCTORS] draft-harrington-text-mib-doc-template-03

From: "David Harrington" <[email-masked]>
Date: Wed, 16 May 2007 02:22:57 -0400

Here is an updated version of the template document.
Please review and send me comments.

I reorganized the document to separate the template from the
surrounding text, and responded to all the comments made during IETF
Last Call.

Since the internet draft is being submitted as a BCP candidate, your
review is very important.

An xml2rfc template is also attached. This xml file generates the text
template, and the xml template contains advice about how to fill in
the text template. Used with an XML editor like XXE, the comments
provide advice at the point of editing.

David Harrington
[email-masked] 
[email-masked]
[email-masked]
_______________________________________________
MIB-DOCTORS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mib-doctors

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 16 May 2007 09:09:28 +0200

> review is very important.

Has this revision been posted to the ID archive? Being somewhat old
fashioned, I prefer to have IDs posted to the archive so that it is
clear what has been reviewed by reference to the ID number without
having to dig into email archives...

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Wed, 16 May 2007 10:09:37 +0300

A few editorial comments: 

1. Should not the title refer to 'MIB Modules' rather than 'a MIB
Module'? 
2. Section 1: s/expedite/expediting
3. Section 2: s/MIB Doctor directorate/MIB Doctors team
4. It would be useful to explain the usage of the placeholder [TODO]
which stands for different things within the template (modeled
technology, subtree name, etc.) 
5. In the Security Considerations section in the template one paragraph
copied from http://www.ops.ietf.org/mib-security.html looks like text
but does not belong to the Security considerations text ('For all MIB
modules you must evaluate ...). It should be taken out. 
6. I believe that it would be more clear if the Security Considerations
section 8 in the template would list alternate texts as numbered
options, same as section 9 does for the IANA considerations
7. Section 9 in the template: s/[TODO}/[TODO]

Dan

> -----Original Message-----
> From: David Harrington [mailto:[email-masked]] 
> Sent: Wednesday, May 16, 2007 9:23 AM
> To: 'MIB Doctors (E-mail)'
> Subject: [MIB-DOCTORS] draft-harrington-text-mib-doc-template-03
> 
> surrounding text, and responded to all the comments made 
> during IETF Last Call.
> 
> Since the internet draft is being submitted as a BCP 
> candidate, your review is very important.
> 
> An xml2rfc template is also attached. This xml file generates 
> the text template, and the xml template contains advice about 
> how to fill in the text template. Used with an XML editor 
> like XXE, the comments provide advice at the point of editing.
> 
> David Harrington
> [email-masked]
> [email-masked]
> [email-masked]
>

---

From: "David Harrington" <[email-masked]>
Date: Wed, 16 May 2007 07:45:32 -0400

Hi,

Yes. I have submitted it.

dbh 

> From: Juergen Schoenwaelder 
> [mailto:[email-masked]] 
> Sent: Wednesday, May 16, 2007 3:09 AM
> To: David Harrington
> Cc: 'MIB Doctors (E-mail)'
> Subject: Re: [MIB-DOCTORS] draft-harrington-text-mib-doc-template-03
>

---

From: "David B Harrington" <[email-masked]>
Date: Wed, 16 May 2007 08:00:47 -0400

Hi,

Thanks for the quick review. I'll address these.
I have a question about
> 3. Section 2: s/MIB Doctor directorate/MIB Doctors team

According to http://www.alvestrand.no/ietf/chair/directorates.html,
the MIB Doctors are a directorate. Is that not accurate? Is this
terminology not politically correct? Just so we know.

dbh

> From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
> Sent: Wednesday, May 16, 2007 3:10 AM
> To: David Harrington; MIB Doctors (E-mail)
> Subject: RE: [MIB-DOCTORS] draft-harrington-text-mib-doc-template-03
>

---

From: "Wijnen, Bert \(Bert\)" <[email-masked]>
Date: Wed, 16 May 2007 14:26:12 +0200

Inline

Bert Wijnen  

> From: David B Harrington [mailto:[email-masked]] 
> Sent: Wednesday, May 16, 2007 2:01 PM
> To: 'Romascanu, Dan (Dan)'; 'David Harrington'; 'MIB Doctors (E-mail)'
> the MIB Doctors are a directorate. Is that not accurate? Is 
> this terminology not politically correct? Just so we know.
> 

We had the MIB Doctors Team long before Harald (as IETF chair) wanted
us (ADs) to create/add public pointers to the composition of any 
directorates and their charters. Once that was established he also asked
me (and others) to put pointers to similar teams (teams that advise ADs)
on that page. So formally it is not a directorate, but it fullfills a
simlar function, namely to advise one or more ADs.

I do not know if this warrants the use of "directorate" or "team".

I just wanted to give you some background/history.

Bert
> > 3. Section 2: s/MIB Doctor directorate/MIB Doctors team 4. 
> It would be 
> > useful to explain the usage of the placeholder [TODO] which 
> stands for 
> > different things within the template (modeled technology, subtree 
> > name, etc.) 5. In the Security Considerations section in 
> the template 
> > one paragraph copied from http://www.ops.ietf.org/mib-security.html 
> > looks like
> text
> > 6. I believe that it would be more clear if the Security 
> > Considerations section 8 in the template would list 
> alternate texts as 
> > numbered options, same as section 9 does for the IANA 
> considerations 
> during IETF 
> > > An xml2rfc template is also attached. This xml file generates the 
> > > text template, and the xml template contains advice about how to 
> > > fill in the text template. Used with an XML editor like XXE, the 
> > > comments provide advice at the point of editing.
> > > 
> > > David Harrington
> > > [email-masked]
> > > [email-masked]
> > > [email-masked]
> > > 
> > 
> >

---

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Wed, 16 May 2007 16:30:24 +0300

I made more like an instinctive correction because I never used or heard
somebody using the term 'MIB Doctors directorate'. David is actually
right, and the IESG wiki
http://www.ietf.org/IESG/content/directorates.html which is the updated
version of Harald's page list the MIB Doctors as a Directorate. So I
retreat my comment with the exception of the usage of singular. 

Dan

Now that we know what we are and what we do, are we also subject to the
Hippocratic oath? This means we cannot leave any MIB document in pain
:-)

> From: Wijnen, Bert (Bert) [mailto:[email-masked]] 
> Sent: Wednesday, May 16, 2007 3:26 PM
> To: David B Harrington; Romascanu, Dan (Dan); David 
> Harrington; MIB Doctors (E-mail)
> We had the MIB Doctors Team long before Harald (as IETF 
> chair) wanted us (ADs) to create/add public pointers to the 
> composition of any directorates and their charters. Once that 
> was established he also asked me (and others) to put pointers 
> to similar teams (teams that advise ADs) on that page. So 
> formally it is not a directorate, but it fullfills a simlar 
> function, namely to advise one or more ADs.
> 
> > > Subject: RE: [MIB-DOCTORS] 
> draft-harrington-text-mib-doc-template-03
> > > 
> > > one paragraph copied from 
> http://www.ops.ietf.org/mib-security.html
> > > looks like
> > text

---

From: "David B Harrington" <[email-masked]>
Date: Wed, 16 May 2007 10:15:30 -0400

The community seems divided; some want to put them out of their
misery, while others want to use extraordinary measures of life
support ;-)

dbh 

> Sent: Wednesday, May 16, 2007 9:30 AM
> To: Wijnen, Bert (Bert); David B Harrington; David 
> > > According to 
> http://www.alvestrand.no/ietf/chair/directorates.html,

> > > > but does not belong to the Security considerations text 
> ('For all
> > > MIB
> > > > > Subject: [MIB-DOCTORS]

---

From: "David B Harrington" <[email-masked]>
Date: Wed, 16 May 2007 10:15:30 -0400

Hi, 

> Considerations

IANA Considerations are three mutually exclusive options.
That's not true of the security considerations. 

My concern is that if I put in options, it would need to be in the
form:
"Read-write Option#1"
"Read-write Option#2"
"Read Option#1"
"Notify-only Option#1"

Read-write has a mutually exclusive choice. Notify-only has only one
option, read-only has only one option. So I would need to add
instructions about selecting one or more of each set of options
depending on whether there are RW object, whether they are sensitive,
whether there are sensitive read-only objects, whether there are
notify-only and whether they are sensitive. And then I would have to
include text that says my added advice of how to select options is not
part of the boilerplate and should be removed. I think it would end up
less clear.

If you want to rewrite the security boilerplate to define mutually
exclusive choices, then using the option markers would make more
sense. I am not sure you can do that given the protocol-sense of the
options.

dbh

---

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Wed, 16 May 2007 17:39:40 +0300

I would suggest that we try using option markers and either editing the
instructions as close as possible to what we have at
http://www.ops.ietf.org/mib-security.html, or just pointing to
http://www.ops.ietf.org/mib-security.html for picking what options
apply. 

Dan

> Sent: Wednesday, May 16, 2007 5:16 PM
> To: Romascanu, Dan (Dan); 'David Harrington'; 'MIB Doctors (E-mail)'
> > numbered options, same as section 9 does for the IANA considerations
> 
> Read-write has a mutually exclusive choice. Notify-only has 
> only one option, read-only has only one option. So I would 
> need to add instructions about selecting one or more of each 
> set of options depending on whether there are RW object, 
> whether they are sensitive, whether there are sensitive 
> read-only objects, whether there are notify-only and whether 
> they are sensitive. And then I would have to include text 
> that says my added advice of how to select options is not 
> part of the boilerplate and should be removed. I think it 
> would end up less clear.
> 
> If you want to rewrite the security boilerplate to define 
> mutually exclusive choices, then using the option markers 
> would make more sense. I am not sure you can do that given 
> the protocol-sense of the options.
> 
> dbh
> 
> 
> 
>