Subject: [MIB-DOCTORS] deprecated Counters and new Discontinuity Object(s)

From: "Joan Cucchiara" <[email-masked]>
Date: Fri, 4 Jul 2008 11:44:08 -0400

MIB Drs.

Currently, I'm working on an "early" review of the BGP4 MIB in the IDR WG.

We are discussing the possibility of  adding a  Discontinuity Object (at 
least one) to this MIB.
(It has no discontinuity objects at this time, but there are definitely BGP 
specific discontinuities
that would affect these counters (loss of peer and/or transitions of the 
FSM).

The question that I have is this:  there are a few counters that are being 
Deprecated (they are
contained in a table where the entire table is actually deprecated) and 
replaced by a new Table
which contains similar/same counters.

Assuming that a Discontinuity Object is added for these new Counters, should 
these Deprecated
Counters have their DESCRIPTION clauses updated to include a  statement 
about the Discontinuity
Object?

Thanks,
   Joan

_______________________________________________
MIB-DOCTORS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mib-doctors

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 4 Jul 2008 19:15:17 +0200

On Fri, Jul 04, 2008 at 11:44:08AM -0400, Joan Cucchiara wrote:

> Assuming that a Discontinuity Object is added for these new
> Counters, should these Deprecated Counters have their DESCRIPTION
> clauses updated to include a statement about the Discontinuity
> Object?

I would say no. Well, it depends on the concrete text you want to
add. But the default discontinuity indicator is sysUpTime and you
should not change the semantics of deployed objects.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
_______________________________________________
MIB-DOCTORS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mib-doctors

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 6 Jul 2008 18:08:07 +0200

The latest argument of Juergen is the key one in my opinion. No text on
discontinuity does define a specific behavior that should not be changed
at this phase. 

Dan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Juergen 
> Schoenwaelder
> Sent: Friday, July 04, 2008 8:15 PM
> To: Joan Cucchiara
> Cc: MIB Doctors (E-mail)
> Subject: Re: [MIB-DOCTORS] deprecated Counters and 
> newDiscontinuity Object(s)
> 
> Counters, 
> > should these Deprecated Counters have their DESCRIPTION clauses 
> > updated to include a statement about the Discontinuity Object?
> 
> I would say no. Well, it depends on the concrete text you 
> want to add. But the default discontinuity indicator is 
> sysUpTime and you should not change the semantics of deployed objects.
> 
> /js
> 
> --