Subject: [MIB-DOCTORS] Question to the MIB doctors regarding MIB registries at IANA

From: Michelle Cotton <[email-masked]>
Date: Fri, 17 Feb 2012 11:24:27 -0800

Hello MIB Doctors,

As you may or may not be aware, we are almost finished with converting the IANA registries to using xml as the source.
There are approximately 14 maintained MIBs on the IANA protocols page.  We understand these files need to be kept in a text format to retain their functionality.
What we are proposing is the following:

Using the IANA Finisher MIB as an example….

At the Protocols page, http://www.iana.org/protocols, when you click on IANA Finisher MIB, you will go to a page that looks like this:

http://www.viagenie.ca/ianaxml/ianafinisher-mib/ianafinisher-mib.xml
(Viagenie is assisting us with some of the conversions…this is why this mock-up is located on their website)

You will see at the bottom there is an attached file which contains the simple MIB, just as it appears currently on the IANA website.
Will this new format work for everyone?  Are there any questions or concerns?

I hope that this will satisfy both our goal of converting the registries to XML as the source and keeping the functionality of the MIBs.

Thank you,

Michelle Cotton
Manager, IANA Services
ICANN

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sun, 19 Feb 2012 12:05:02 +0100

> Will this new format work for everyone?  Are there any questions or concerns?

There is a general concern that the XML pages require Java script
support to be meaningfully rendered - but that is a meta issue and I
might be in the majority of people who is running tools that do not
run Java script.
 
> I hope that this will satisfy both our goal of converting the registries to XML as the source and keeping the functionality of the MIBs.

What matters most is that the MIB files are available and that the
location where they can be fetched is stable. (Ideally does not even
change from where they are now - but if you change them, try to find a
location that can stay stable.)

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>