Subject: Re: [MIB-DOCTORS] MIBs in RFCs

From: Benoit Claise <[email-masked]>
Date: Wed, 15 May 2013 14:01:51 +0200

Hi Sandy,

I believe this list is correct.
Copying the mib-doctors, just in case ...

Regards, Benoit
> Hi Benoit and Joel,
>
> I'm getting ready to train one of our editors on MIB checking.  Before doing that, I'm hoping you, as OPs ADs, can verify that the items listed below are still current, and let me know if anything is missing.  Does this list seem right?
>
> 1) Section 1 should always be "The Internet-Standard Management Framework" and  match the text that appears at <https://svn.tools.ietf.org/area/ops/trac/wiki/mib-boilerplate>.
>
> 2) The Security Considerations should match the text available at <https://svn.tools.ietf.org/area/ops/trac/wiki/mib-security>.
>
> 3) The "LAST-UPDATED" and "REVISION" clauses should be updated with the date the file is being edited, with a time of 0000, for example:
>
>     LAST-UPDATED "YYYYMMDD0000Z"
>
> 4) IANA assignments need to be updated within the MIB (if necessary)
>
> 5) It's okay to edit text within quote marks (mostly applies to "DESCRIPTION" clauses)
>
> 6) No in-text citations within the MIB because the MIB is meant to be extracted from the document (and would therefore be incomplete without the references section of the document).
>
>
> Thanks!
> Sandy
>
>

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 15 May 2013 11:50:48 -0700

Hi -

> From: "Benoit Claise" <[email-masked]>
> To: "Sandy Ginoza" <[email-masked]>
...
> Copying the mib-doctors, just in case ...
...
> > 6) No in-text citations within the MIB because the MIB is meant
> > to be extracted from the document (and would therefore be
> > incomplete without the references section of the document).

I think a citation within a MIB module is fine as long as the citation provides
sufficient context (via, for example, the REFERENCE clause) to
accurately resolve it, and adds useful detail which would be impractical
to replicate within the DESCRIPTION clause.  A citation lacking
sufficient context is useless. From an implementor's perspective,
the more precise the citation, the better.   Likewise, a citation that
adds nothing to what the DESCRIPTION text already says is pointless.

Randy