Subject: [MIB-DOCTORS] Fwd: New Version Notification for draft-ietf-lisp-mib-10.txt

From: "Gregg Schudel (gschudel)" <[email-masked]>
Date: Thu, 23 May 2013 22:15:38 +0000

Hi all

I'm hoping I got the correct MIB folks here (and the chairs :)
Amit, Victor, and I have completed the -10 version of the MIB.

We believe we've addressed all of the excellent feedback/inputs
from Brian, Harrie, and others (thank you so much for the 
time you've taken to provide such thorough reviews!)

We're looking forward to completing this process (and coding!)

Begin forwarded message:

> From: <[email-masked]>
> Subject: New Version Notification for draft-ietf-lisp-mib-10.txt
> Date: May 23, 2013 2:16:55 PM PDT
> To: Gregg Schudel <[email-masked]>, Amit Jain <[email-masked]>, "Victor Moreno" <[email-masked]>
> 
> 
> A new version of I-D, draft-ietf-lisp-mib-10.txt
> has been successfully submitted by Gregg Schudel and posted to the
> IETF repository.
> 
> Filename:	 draft-ietf-lisp-mib
> Revision:	 10
> Title:		 LISP MIB
> Creation date:	 2013-05-22
> Group:		 lisp
> Number of pages: 64
> URL:             http://www.ietf.org/internet-drafts/draft-ietf-lisp-mib-10.txt
> Status:          http://datatracker.ietf.org/doc/draft-ietf-lisp-mib
> Htmlized:        http://tools.ietf.org/html/draft-ietf-lisp-mib-10
> Diff:            http://www.ietf.org/rfcdiff?url2=draft-ietf-lisp-mib-10
> 
> Abstract:
>   This document defines managed objects for the Locator/ID Separation
>   Protocol (LISP).  These objects provide information useful for
>   monitoring LISP devices, including determining basic LISP
>   configuration information, LISP functional status, and operational
>   counters and other statistics.
> 
> The IETF Secretariat

Best regards,
Gregg

--------------------------------------------------------------------
.:|:.:|:. | gregg schudel (ccie#9591) LISP technical marketing engr
  cisco   | mobile: +1 571 332 2222   email: [email-masked]
--------------------------------------------------------------------
cisco corporate legal statement: 
http://www.cisco.com/web/about/doing_business/legal/cri/index.html
--------------------------------------------------------------------

---

From: "Gregg Schudel (gschudel)" <[email-masked]>
Date: Thu, 23 May 2013 22:19:54 +0000

Attaching a "diff" for easier viewing of corrections/edits
(sorry - forgot to attach it in the previous email )

Best regards,
Gregg

---

From: Harrie Hazewinkel <[email-masked]>
Date: Fri, 24 May 2013 14:47:33 +0200

Hi Gregg, (all,)

Will go over the changes asap (next week).

Harrie

>>  counters and other statistics.

Harrie
[email-masked]

---

From: Luigi Iannone <[email-masked]>
Date: Thu, 30 May 2013 17:20:57 +0200

Hi All,

As request by Benoit in his review I submitted the MIB definition to the libsmi tool (http://www.ibr.cs.tu-bs.de/bin/smitools.cgi)

The output concerning the MIB definition in this version is the following:

mibs/MIB-Definition-v10.txt:33: [2] {bad-identifier-case} `XXX' should start with a lower case letter
mibs/MIB-Definition-v10.txt:33: [2] {object-identifier-not-prefix} Object identifier element `XXX' name only allowed as first element
mibs/MIB-Definition-v10.txt:15: [2] {module-identity-registration} illegal module identity registration
mibs/MIB-Definition-v10.txt:193: [5] {index-element-has-default} warning: index element `lispFeaturesInstanceID' of row `lispFeaturesEntry' has a default value
mibs/MIB-Definition-v10.txt:193: [5] {index-element-has-default} warning: index element `lispFeaturesInstanceID' of row `lispIidToVrfEntry' has a default value
mibs/MIB-Definition-v10.txt:193: [5] {index-element-has-default} warning: index element `lispFeaturesInstanceID' of row `lispGlobalStatsEntry' has a default value

Note the following:

- The first three lines are an error that will be solved when IANA will assign the OBJECT IDENTIFIER lispMib {mib-2 XXX} value.

- The last three lines are just warning for the fact that the InstanceID has a default value (0). This has been discussed in previous mails and authors put the default value in a DEFVAL clause, as suggested during document review. 

So, the MIB definition will be completely validate as soon as IANA provides the value for the object identifier.

The remaining step is Harrie's check on the changes, then I guess we can move the document forward.

ciao

Luigi