Subject: [MIB-DOCTORS] FW: [BEHAVE] nat-mib-06: separate MIB modules

From: "ietfdbh" <[email-masked]>
Date: Fri, 3 May 2013 08:11:54 -0400

Hi,

The BEHAVE WG has rewritten the NAT-MIB.
They felt that RFC4008 did not meet the needs of the community, so
deprecated the whole thing and wrote a whole new module, but kept it within
the existing NAT-MIB.
This "feels wrong" to me, since they're not just updating a MIB module,
they're totally replacing it.
They've gotten advice both ways.
I thought it would be good to see how other MIB Doctors feel about this.

David Harrington
[email-masked]
+1-603-828-1401

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
ietfdbh
Sent: Thursday, May 02, 2013 7:15 PM
To: 'Simon Perreault'; [email-masked]
Cc: [email-masked]
Subject: [BEHAVE] nat-mib-06: separate MIB modules

Hi,

I would like to suggest a change.
If I understand correctly, this document deprecates the entire RFC4008
NAT-MIB, and proposes a completely new MIB under the same name.
I think this is sub-optimal.
In NMS applications that support multiple devices, some of which support
RFC4008 and some of which support this new MIB module, it will be
potentially confusing to call them by the same name.
You really have two completely different MIB modules that you are trying to
sell under the same name.
I think that is not a good idea.

I recommend writing an RFC4008bis document to deprecate the RFC4008 NAT-MIB.
Then put your proposed new MIB objects into a separate MIB module, using a
different name for the newly designed MIB for managing NATs (maybe
NEW-NAT-MIB, but I'd hope for something that more accurately describes the
modified purpose of the MIB, maybe NAT-MONITORING-MIB) Put this in a
separate RFC.

I think that would be a much cleaner solution, and much more obvious what
you are doing here.

David Harrington
[email-masked]
+1-603-828-1401

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Simon Perreault
Sent: Wednesday, May 01, 2013 4:31 AM
To: [email-masked]
Subject: Re: [BEHAVE] I-D Action: draft-ietf-behave-nat-mib-06.txt

Group,

This version fixes MIB syntax issues and updates the security considerations
section according to the recommended boilerplate.

As far as we know this is ready for WGLC.

Simon

Le 2013-05-01 10:28, [email-masked] a écrit :
>
> A New Internet-Draft is available from the on-line Internet-Drafts
directories.
>   This draft is a work item of the Behavior Engineering for Hindrance
Avoidance Working Group of the IETF.
>
> 	Title           : Additional Managed Objects for Network Address
Translators (NAT)
> 	Author(s)       : Simon Perreault
>                            Tina Tsou
>                            Senthil Sivakumar
> 	Filename        : draft-ietf-behave-nat-mib-06.txt
> 	Pages           : 82
> 	Date            : 2013-05-01
>
> Abstract:
>     This memo defines a portion of the Management Information Base (MIB)
>     for devices implementing Network Address Translator (NAT) function.
>     This MIB module may be used for monitoring of a device capable of NAT
>     function.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-behave-nat-mib
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-behave-nat-mib-06
>
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-ietf-behave-nat-mib-06
>
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>

--
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 3 May 2013 14:33:19 +0200

> I thought it would be good to see how other MIB Doctors feel about this.

I have probably been pushing them into this because at the beginning
it was not really clear why the existing NAT-MIB is fatally flawed
such that it needs a complete replacement. If the behave WG has
meanwhile reached concensus that indeed the existing NAT-MIB is
fatally flawed and needs a complete replacement, then indeed what you
suggest makes sense. I assume the WG has checked with those who have
implementations of the existing NAT-MIB (if any) that they agree on a
need for a complete new MIB.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>