Subject: [MIB-DOCTORS] [IANA #675758] Re: what to do with "reserved" interface types?

From: "Amanda Baber via RT" <[email-masked]>
Date: Wed, 19 Jun 2013 00:53:56 +0000

Hi Martin (and Dan, for whom I have a MIB formatting question),

I apologize for the long delay on this:

> I noticed that there are no rules (that I can see) for how you
> construct a MIB enumeration label out of the name of an ifType in the
> registry.  For example, in the registry, value 7 has the Name
> "IEEE802.3", but the label in the MIB is "iso88023Csmacd".  Ok, it
> also seems that recent names actually match the MIB name one-to-one,
> so maybe this is not a problem.   

I understand that older non-conforming names are typically grandfathered in.

> But how is this done for the
> "Address Family Numbers" registry and corresponding
> IANA-ADDRESS-FAMILY-NUMBERS-MIB?   I guess we need to figure something
> out for the SAFI values.

I cannot find the document that created the MIB for Address Family Numbers. It appears, though, that registrations there have been listed according to the rules used in the ifTypes MIB: first word lower-case, subsequent words capitalized. 

Dan, do you have any thoughts on this? 

> >  As for the registry I think we'd prefer that the description
> replicated the
> >  original registry's description precisely, and used "Reserved for
> Private
> >  Use," if that's what appears in the registry, rather than "Private
> Use."
> 
> The text "Private Use" seems to be what appears in the registry, (from
> http://www.iana.org/assignments/safi-namespace/safi-namespace.xml)
> that's why I used it.

Sorry about that. I was obviously looking at the wrong registry. The wording for that range has now been changed, though, for the sake of clarity, to the standard "Reserved for Private Use," lest it look like a registration rather than a reservation.

thanks,
Amanda

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 19 Jun 2013 08:36:52 +0200 (CEST)

Hi,

"Amanda Baber via RT" <[email-masked]> wrote:
> I cannot find the document that created the MIB for Address Family
> Numbers. It appears, though, that registrations there have been
> listed according to the rules used in the ifTypes MIB: first word
> lower-case, subsequent words capitalized.

In some cases this is true, but not for all entries.  For example, 

  "Fibre Channel World-Wide Node Name" becomes "fibreChannelWWNN",
  "AFI for L2VPN information" becomes "afi"

Would it make sense to extend these two registries with a new column,
"Name", which would be a single word like in the ifType registry?
Then the iftype-mib-rules can be applied to this name to produce the
MIB and YANG name.

> Sorry about that. I was obviously looking at the wrong registry. The
> wording for that range has now been changed, though, for the sake of
> clarity, to the standard "Reserved for Private Use," lest it look
> like a registration rather than a reservation.

Ok, I will update our document to match this.

/martin

---

From: "Martin Bjorklund via RT" <[email-masked]>
Date: Wed, 19 Jun 2013 07:01:55 +0000

Hi,

/martin

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 19 Jun 2013 10:39:33 +0000

Hi,

I do not have an answer to the question originally asked by Amanda, this goes back too long into history. I am fine with the proposal made by Martin (extending the registries with a "Name" column). This seems useful and I do not see any complications resulting from this. 

Regards,

Dan

> -----Original Message-----
> From: Martin Bjorklund via RT [mailto:[email-masked]]
> Sent: Wednesday, June 19, 2013 10:02 AM
> To: [email-masked]; Romascanu, Dan (Dan); j.schoenwaelder@jacobs-
> university.de; [email-masked]; [email-masked]
> Subject: Re: [IANA #675758] Re: what to do with "reserved" interface
> types?
> 
> Hi,
> 
> > > construct a MIB enumeration label out of the name of an ifType in
> > > the registry.  For example, in the registry, value 7 has the Name
> > Numbers. It appears, though, that registrations there have been listed
> > according to the rules used in the ifTypes MIB: first word lower-case,
> > subsequent words capitalized.
> 
> Then the iftype-mib-rules can be applied to this name to produce the MIB
> and YANG name.
> 
> > clarity, to the standard "Reserved for Private Use," lest it look like
> > a registration rather than a reservation.
>

---

From: "Romascanu, Dan \(Dan\) via RT" <[email-masked]>
Date: Wed, 19 Jun 2013 10:56:53 +0000

Hi,

Regards,

Dan