Subject: Re: [MIB-DOCTORS] Review of draft-ietf-l2vpn-vpls-mib-10

From: Randy Presuhn <[email-masked]>
Date: Wed, 17 Jul 2013 13:44:55 -0700 (GMT-07:00)

Hi -

>From: Andy Bierman <[email-masked]>
>Sent: Jul 17, 2013 11:56 AM
>To: Randy Presuhn <[email-masked]>
>Cc: Steve Waldbusser <[email-masked]>, [email-masked], "Giles Heron (giheron)" <[email-masked]>, "Kiran Koushik Agrahara Sreenivasa (kkoushik)" <[email-masked]>, [email-masked]
>Subject: Re: [MIB-DOCTORS] Review of draft-ietf-l2vpn-vpls-mib-10
...
>The WG can require creation in any order and hope for
>the best from vendors.
...

That's true about *any* requirement.

My point is that from an implementation perspective
(both manager and agent) "creation in any order"
(if dangling reference semantics are properly
specified) is probably the *simplest* for developers
to get right.  It's the easiest to reason about,
the easiest to test, easiest for managers, and easiest
for agents.  It's also the easiest to extend, should
the need arise.

Randy

---

From: Andy Bierman <[email-masked]>
Date: Wed, 17 Jul 2013 14:01:07 -0700

> for agents.  It's also the easiest to extend, should

Does SNMP suck for configuration because agent developers
do not do the "right thing" during implementation, or do
agent developers do the "wrong thing" during implementation
because SNMP sucks for configuration?

A: in the end it doesn't matter.  NMS developers are not
using SNMP for configuration.

> Randy

Andy

---

From: Thomas Nadeau <[email-masked]>
Date: Wed, 17 Jul 2013 17:02:14 -0400

> using SNMP for configuration.

	I agree. Having this debate is a waste of time; the industry has voted a long time ago...

	--Tom

> 
> 
>> Randy
> 
> Andy
> _______________________________________________
> MIB-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mib-doctors
>