Subject: [MIB-DOCTORS] Anyone know an existing TC for "Country Code"?

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 12 Dec 2013 13:04:00 -0000

Hi,

Just trying to stop wheels being reinvented.

I am just reviewing a MIB module that includes a new TC for the two octet
(uppercase alpha) string that represents the country codes defined in ISO3166-1.

If something is already defined, we might use it instead.

Adrian

---

From: Harrie Hazewinkel <[email-masked]>
Date: Thu, 12 Dec 2013 14:17:37 +0100

Hello Adrian,

I am not aware of some defined in the MIBs of the IETF.

Only these:

1) http://www.faqs.org/rfcs/rfc1759.html =>
	The object prtLocalizationCountry defines it, but it is not a textual convention.

2) a Cisco MIB that has this defined. Neither a formal standard within the IETF.

I guess, both do not help you much.

Harrie

On Dec 12, 2013, at 2:04 PM, "Adrian Farrel" <[email-masked]> wrote:

> _______________________________________________
> MIB-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mib-doctors

Harrie
[email-masked]

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 12 Dec 2013 13:45:37 -0000

Thanks,
Well, this helps a bit because it hints that no-one else found a TC in
existence.

Cheers,
Adrian

---

From: Harrie Hazewinkel <[email-masked]>
Date: Thu, 12 Dec 2013 14:50:24 +0100

Hello,

What actually would be best is to make a separate MIB module that includes all this sort of TCs.
For  instance, there is one for network addresses. 

Only then various other questions come to mind
- Is it needed?
- What is all considered general?
- Where do we stop?
- ...

I guess, publishing a complete overview of TCs is a start.

Harrie

Harrie
[email-masked]

---

From: Benoit Claise <[email-masked]>
Date: Thu, 12 Dec 2013 15:19:27 +0100

Hello,
> I guess, publishing a complete overview of TCs is a start.
 From the MIB doctors page: 
http://www.ietf.org/iesg/directorate/mib-doctors.html
-> Generic and Common Textual Conventions: 
http://trac.tools.ietf.org/area/ops/trac/wiki/mib-common-tcs

 From this page, you can also see at the bottom

    Jürgen Schönwälder maintains a TC list in xml2rfc format that can be
    rendered as .txt or .html.

    http://www.beadg.de/ietf/smiv2-tc-lists/iana-tc-list.html
    http://www.beadg.de/ietf/smiv2-tc-lists/iana-tc-list.txt
    http://www.beadg.de/ietf/smiv2-tc-lists/ietf-tc-list.html
    http://www.beadg.de/ietf/smiv2-tc-lists/ietf-tc-list.txt

    The complete build machinery is in a Makefile:
    http://www.beadg.de/ietf/smiv2-tc-lists/Makefile

Btw, nothing related to countries there.

Regards, Benoit