Subject: Re: [MIB-DOCTORS] SNMP for the STD for IETF standards EU procurement platform

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Wed, 30 Jul 2014 15:23:17 +0200

Andrei, not sure if I correctly formulated the $subject.
Pls correct if needed.

So you had a set of SNMP standards that you would want to include.

It is probably best to include MIB doctors in the discussion.
AS I said, a set of base/always-present MIB modules should probably
also be included. I remember that we did define such a set several years back
when we worked together with ITU SG4 and other organizations to try and
define a list of applicable standards work in the various bodies.
Unfortunately I cannot quickly fin that list. I am sure there are MIB
doctors on the list that have the ptrs handy.

Also, the IETF OPS ADs may want to be onvolved in this.

Comments on the list that you did send to me;

On 24/07/14 17:08, Andrei Robachevsky wrote:
> RFC	TITLE	
 >       Base Spec Boolean	Rationale
> 2578	Structure of Management Information Version 2 (SMIv2)
	0	STD58, Data definition language
> 2579	Textual Conventions for SMIv2
	0	STD58, Data definition language
> 2580	Conformance Statements for SMIv2
	0	STD58, Data definition language

About the above 3:
As I said verbally to you, I am not sure that the data modeling language
itself is something that governments would use themselves. So not sure if it
is useful to include them.

> 3412	Message Processing and Dispatching for the Simple Network Management Protocol (SNMP)
>	1	STD62
> 3413	Simple Network Management Protocol (SNMP) Applications
	1	STD62
> 3414	User-based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3)
>	1	STD62, v3 security features
> 3415	View-based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP)
>	1	STD62, v3 security features
> 3416	Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP)
>	1	STD62, Describes SNMPv2 (this is also the protocol operations used in SNMPv3)
> 3417	Transport Mappings for the Simple Network Management Protocol (SNMP)
>	1	STD62
> 3418	Management Information Base (MIB) for the Simple Network Management Protocol (SNMP)
> 	1	STD62
>

I think (as I experssed verbally) that I would also include a base set of MIB modules,
after all, it makes no sense to have SNMP if you do not have MIB modules.
The list should probably include

- RFC2863, IF-MIB
- RFC6933, ENTITY-MIB

but probably many more. There is a list at
     http://www.simpleweb.org/ietf/rfcs/rfcbynumber.php
or maybe even better
     http://www.simpleweb.org/ietf/rfcs/rfcbystatus.php#Draft%20standard

that lists a lot of them. Not all are relevant or must-be-present MIB modules though.

MIB doctors, does anyone of you have a handy ptr to the list that we normally promote
as needed/useful? I thought we used to have that also at the ops.ietf.org page,
but I do not see it on the current page.

Andrei,
I think it is also important to say something about the fact tht these days we (IETF)
promote MIB modules and SNMP for monitoring or traps.
But for configuration, we now promote NETCONF. See IESG statement:
     http://www.ietf.org/iesg/statement/writable-mib-module.html

Bert

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 30 Jul 2014 15:49:37 +0200

On Wed, Jul 30, 2014 at 03:23:17PM +0200, Bert Wijnen (IETF) wrote:
> MIB doctors, does anyone of you have a handy ptr to the list that we
> normally promote as needed/useful? I thought we used to have that
> also at the ops.ietf.org page, but I do not see it on the current
> page.

I think coverage of the IP stack is generally a good thing. This means
typically the IP-MIB [RFC 4293], the IP-FORWARD-MIB [RFC 4292], the
UDP-MIB [RFC 4113], and the TCP-MIB [RFC 4022].

The rest is I believe more or less is device class specific.

- Devices having Ethernet interfaces may want to support the relevant
  MIB modules (which are now under IEEE control, not sure it makes
  sense to list to the old IETF specifications).

- Devices that are managed hosts (desktop but more typically servers)
  may want to support that HOST-RESOURCES-MIB [RFC 2790].

- Ethernet switches should implement one of the bridge MIB modules,
  they are meanwhile under IEEE control.

- IP routers likely should support MIB modules corresponding to the
  routing protocol(s) supported and the interface types supported.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>