Subject: Re: [MIB-DOCTORS] 'MIB Doctor' review of draft-ietf-pce-pcep-mib-06

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 17 Dec 2014 15:25:07 +0100

On Tue, Dec 16, 2014 at 06:48:45PM +0000, Daniel King wrote:
> Copying in mib-doctors as well.
> 
> In summary, the object (pcePcepPeerAddrType) is an index so we cannot put it
> in a group, yet when we restrict the scope (in Compliance clause) the
> compiler complains it is not in a group. :-/
> 
> https://tools.ietf.org/html/draft-ietf-pce-pcep-mib-11
>

This is one of the odd things in SMIv2. Congratulation for hitting
it. ;-)

My recommendation is to write down the syntax variation and to
comment it out. This way, it clear for the human what was meant
and SMIv2 compilers will be happy as well.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Jonathan Hardwick <[email-masked]>
Date: Wed, 17 Dec 2014 20:15:58 +0000

Juergen, many thanks for this.

PCEP MIB co-authors:

As per Juergen's advice, I have commented out the offending restriction, as follows.  This has resolved the warning.  Please let me know ASAP if you have any comments on this.

-- The following restriction is commented out because of a limitation
-- in SMIv2 which does not allow index objects to be restricted in
-- scope.  Nevertheless, this object is intended to be restricted in
-- scope, as follows.
--
--     OBJECT       pcePcepPeerAddrType
--     SYNTAX       InetAddressType { unknown(0), ipv4(1), ipv6(2) }
--     DESCRIPTION  "Only unknown(0), ipv4(1), and ipv6(2) support
--                   is required."

Thanks
Jon

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: 17 December 2014 14:25
To: Daniel King
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; Jonathan Hardwick
Subject: Re: 'MIB Doctor' review of draft-ietf-pce-pcep-mib-06

/js

---

From: Kiran Agrahara Sreenivasa <[email-masked]>
Date: Wed, 17 Dec 2014 13:18:02 -0700

Hi Jon
No comments - Thanks for fixing this.

Thanks
Kiran

-----Original Message-----
From: Jonathan Hardwick [mailto:[email-masked]] 
Sent: Wednesday, December 17, 2014 2:16 PM
To: Daniel King; Kiran Agrahara Sreenivasa; [email-masked]; [email-masked]; Juergen Schoenwaelder
Cc: [email-masked]
Subject: RE: 'MIB Doctor' review of draft-ietf-pce-pcep-mib-06

PCEP MIB co-authors:

Thanks
Jon

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]]
Sent: 17 December 2014 14:25
To: Daniel King
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; Jonathan Hardwick
Subject: Re: 'MIB Doctor' review of draft-ietf-pce-pcep-mib-06

On Tue, Dec 16, 2014 at 06:48:45PM +0000, Daniel King wrote:
> In summary, the object (pcePcepPeerAddrType) is an index so we cannot 
> put it in a group, yet when we restrict the scope (in Compliance 
> clause) the compiler complains it is not in a group. :-/
> 

This is one of the odd things in SMIv2. Congratulation for hitting it. ;-)

My recommendation is to write down the syntax variation and to comment it out. This way, it clear for the human what was meant and SMIv2 compilers will be happy as well.

/js

---

From: Quintin zhao <[email-masked]>
Date: Thu, 18 Dec 2014 00:24:06 +0000

Jon,

Thanks for fixing this and I have no further comments.

Quintin

-----邮件原件-----
发件人: Jonathan Hardwick [mailto:[email-masked]] 
发送时间: 2014年12月17日 15:16
收件人: Daniel King; [email-masked]; [email-masked]; Quintin zhao; Juergen Schoenwaelder
抄送: [email-masked]
主题: RE: 'MIB Doctor' review of draft-ietf-pce-pcep-mib-06

PCEP MIB co-authors:

Thanks
Jon

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]]
Sent: 17 December 2014 14:25
To: Daniel King
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; Jonathan Hardwick
Subject: Re: 'MIB Doctor' review of draft-ietf-pce-pcep-mib-06

/js

---

From: Benoit Claise <[email-masked]>
Date: Thu, 18 Dec 2014 12:04:20 +0100

Thanks all,
Including Adrian, your responsible AD, in the discussion.

Regards, Benoit