Subject: [MIB-DOCTORS] FW: [mpls] I-D Action: draft-ietf-mpls-tp-oam-id-mib-06.txt

From: Mach Chen <[email-masked]>
Date: Tue, 9 Dec 2014 03:27:21 +0000

Hi Joan,

The authors uploaded a revision to address the Shepherd's comments. I have reviewed this version and am OK with it. 

Would you please take a look at the latest version of this document? If you are OK with it, we can move it forward.

Thanks,
Mach

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, December 04, 2014 8:49 AM
To: [email-masked]
Cc: [email-masked]
Subject: [mpls] I-D Action: draft-ietf-mpls-tp-oam-id-mib-06.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Multiprotocol Label Switching Working Group of the IETF.

        Title           : MPLS-TP Operations, Administration, and Management (OAM) Identifiers Management Information Base (MIB)
        Authors         : Sam Aldrin
                          Venkatesan Mahalingam
                          Kannan KV Sampath
                          Thomas D. Nadeau
	Filename        : draft-ietf-mpls-tp-oam-id-mib-06.txt
	Pages           : 27
	Date            : 2014-12-03

Abstract:
   This memo defines a portion of the Management Information Base (MIB)
   for use with network management protocols in the Internet community.
   In particular, it describes Operations, Administration, and
   Management (OAM) identifiers related managed objects for
   Multiprotocol Label Switching (MPLS) and MPLS based Transport Profile
   (TP).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-mpls-tp-oam-id-mib/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-mpls-tp-oam-id-mib-06

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-mpls-tp-oam-id-mib-06

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: "Joan Cucchiara" <[email-masked]>
Date: Tue, 9 Dec 2014 10:23:14 -0500

Mach,

I'll take a look soon.  Can you tell me what MIB compilers this has been
compiled with?

Thanks,
 -Joan

> From: Mach Chen [mailto:[email-masked]]
> Sent: Monday, December 08, 2014 10:27 PM
> To: [email-masked]
> Cc: [email-masked];
[email-masked];
> [email-masked]; [email-masked]
> Subject: FW: [mpls] I-D Action: draft-ietf-mpls-tp-oam-id-mib-06.txt
> 
> Hi Joan,
> 
> Would you please take a look at the latest version of this document? If
you
> are OK with it, we can move it forward.
> 
> Thanks,
> Mach
> 
>  This draft is a work item of the Multiprotocol Label Switching Working
Group
> of the IETF.
> 
>         Title           : MPLS-TP Operations, Administration, and
Management
> (OAM) Identifiers Management Information Base (MIB)
>         Authors         : Sam Aldrin
>                           Venkatesan Mahalingam
>                           Kannan KV Sampath
>                           Thomas D. Nadeau
> Please note that it may take a couple of minutes from the time of
submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> -----
> No virus found in this message.
> Checked by AVG - www.avg.com
> Version: 2014.0.4794 / Virus Database: 4235/8703 - Release Date: 12/08/14

---

From: Mach Chen <[email-masked]>
Date: Wed, 10 Dec 2014 03:21:24 +0000

Thanks Joan,

I have tried OiDViEW MIB Complier and it passed the check.

Best regards,
Mach

> From: Joan Cucchiara [mailto:[email-masked]]
> Sent: Tuesday, December 09, 2014 11:23 PM
> To: Mach Chen
> Cc: [email-masked]; [email-masked];
> Subject: RE: [mpls] I-D Action: draft-ietf-mpls-tp-oam-id-mib-06.txt
> 
> Mach,
> 
> I'll take a look soon.  Can you tell me what MIB compilers this has been compiled
> with?
> 
> Thanks,
>  -Joan
> 
> > The authors uploaded a revision to address the Shepherd's comments. I
> > have reviewed this version and am OK with it.
> >

---

From: "Joan Cucchiara" <[email-masked]>
Date: Fri, 12 Dec 2014 13:08:01 -0500

Mach,

I will take a look over the weekend.    Should be compiled by smilint too I
think, but I can look into doing that.

Thanks,
  -Joan

> Sent: Tuesday, December 09, 2014 10:21 PM
> To: Joan Cucchiara
> > I'll take a look soon.  Can you tell me what MIB compilers this has
> > been compiled with?
> >
> > Thanks,
> >  -Joan
> >
> > > The authors uploaded a revision to address the Shepherd's comments.
> > > I have reviewed this version and am OK with it.
> > >
> Version: 2014.0.4794 / Virus Database: 4235/8709 - Release Date: 12/09/14

---

From: "Joan Cucchiara" <[email-masked]>
Date: Sun, 14 Dec 2014 22:29:25 -0500

Mach,

Comments below (3 of them).

Thanks,
  -Joan

smilint compiler output:
--------------------
While processing your request the following errors and/or warnings have been
found:

mibs/MPLS-OAM-ID-STD-MIB.my:22: [4] {module-identity-registration} warning:
uncontrolled MODULE-IDENTITY registration
mibs/MPLS-OAM-ID-STD-MIB.my:5: [5] {import-unused} warning: identifier
`zeroDotZero' imported from module `SNMPv2-SMI' is never used
mibs/MPLS-OAM-ID-STD-MIB.my:10: [5] {import-unused} warning: identifier
`TEXTUAL-CONVENTION' imported from module `SNMPv2-TC' is never used

Additional descriptions of some error/warning messages:

Warning:     module-identity-registration (level 4)
Message:     uncontrolled MODULE-IDENTITY registration
Description: The identities of IETF MIB modules should be registered below
             mib-2, transmission, or snmpModules so that the registration
             space can be controlled by IANA.

1)   Would like to see the Level 5 warnings fixed because that is  a minor
edit.   I am okay with the level 4 warning because most of the MPLS MIBs are
registered under mplsStdMIB branch.  

Compliance Statement of the MIB
----------------------------------------------
2) Compliance (mentioned this before)

There is no read-only compliance. Has it been made clear
to the WGs (MPLS and PWE3) that SNMP sets  will need to
be supported in order to be compliant with the MIB?

Section 8. Security Section
---------------------------------
3) Please fix the incomplete sentence which is: 
"These are the tables and objects and their sensitivity/vulnerability: "

> From: MIB-DOCTORS [mailto:[email-masked]] On Behalf Of
> Joan Cucchiara
> Sent: Friday, December 12, 2014 1:08 PM
> To: 'Mach Chen'
> Cc: [email-masked]; [email-masked]; draft-ietf-mpls-tp-
> [email-masked]; [email-masked]
> Subject: Re: [MIB-DOCTORS] [mpls] I-D Action: draft-ietf-mpls-tp-oam-id-
> mib-06.txt
> 
> Mach,
> 
> MIB-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mib-doctors
> 
> 
> -----
> Version: 2014.0.4794 / Virus Database: 4235/8722 - Release Date: 12/12/14

---

From: Mach Chen <[email-masked]>
Date: Mon, 15 Dec 2014 03:37:05 +0000

Hi Joan,

Many thanks for taking your time to review the document and the detailed comments!

To the Authors:

Please look at Joan's comments and address them accordingly.

Best regards,
Mach

> From: mpls [mailto:[email-masked]] On Behalf Of Joan Cucchiara
> Sent: Monday, December 15, 2014 11:29 AM
> To: Mach Chen
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Re: [mpls] [MIB-DOCTORS] I-D Action:
> draft-ietf-mpls-tp-oam-id-mib-06.txt
> 
> 
> Mach,
> 
> There is no read-only compliance. Has it been made clear to the WGs (MPLS and
> PWE3) that SNMP sets  will need to be supported in order to be compliant with
> the MIB?
> 
> > Cc: [email-masked]; [email-masked];
> > draft-ietf-mpls-tp- [email-masked]; [email-masked]
> > Subject: Re: [MIB-DOCTORS] [mpls] I-D Action:
> > draft-ietf-mpls-tp-oam-id- mib-06.txt
> >
> > Mach,
> >
> > > > I'll take a look soon.  Can you tell me what MIB compilers this
> > > > has been compiled with?
> > > >
> > > > Thanks,
> > > >  -Joan
> > > >
> > > > > A New Internet-Draft is available from the on-line
> > > > > Internet-Drafts
> > > > directories.
> > > > >    This memo defines a portion of the Management Information
> > > > > Base
> > > (MIB)