Subject: Re: [MIB-DOCTORS] [Technical Errata Reported] RFC1628 (4831)

From: Benoit Claise <[email-masked]>
Date: Fri, 28 Oct 2016 07:38:39 +0200

MIB doctors,

Any quick feedback before I verify this errata?

Regards, B.
> The following errata report has been submitted for RFC1628,
> "UPS Management Information Base".
>
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=1628&eid=4831
>
> --------------------------------------
> Type: Technical
> Reported by: Sean Van Gorder <[email-masked]>
>
> Section: 4
>
> Original Text
> -------------
>         OBJECT     upsOutputSource
>         SYNTAX     INTEGER {
>             normal(2),
>             battery(4)
>         }
>         DESCRIPTION
>                 "Support of the values other(1), none(2), bypass(4),
>                 booster(6) and reducer(7) is not required."
>
> Corrected Text
> --------------
>         OBJECT     upsOutputSource
>         SYNTAX     INTEGER {
>             normal(3),
>             battery(5)
>         }
>         DESCRIPTION
>                 "Support of the values other(1), none(2), bypass(4),
>                 booster(6) and reducer(7) is not required."
>
> Notes
> -----
> This error appears 3 separate times, in the MODULE-COMPLIANCE definitions upsSubsetCompliance, upsBasicCompliance, and upsFullCompliance.
>
> The wrong numbers are specified with the named values, which must match the OBJECT-TYPE definition of upsOutputSource.
>
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary.
>
> --------------------------------------
> RFC1628 (no draft string recorded)
> --------------------------------------
> Title               : UPS Management Information Base
> Publication Date    : May 1994
> Author(s)           : J. Case, Ed.
> Category            : PROPOSED STANDARD
> Source              : Uninterruptible Power Supply
> Area                : Operations and Management
> Stream              : IETF
> Verifying Party     : IESG
>
> .
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 28 Oct 2016 08:27:49 +0200

Funny that this is reported only 22 years after the publication of RFC
1628. Anyway, I have fixed this is my libsmi copy of this module now.

/js

On Fri, Oct 28, 2016 at 07:38:39AM +0200, Benoit Claise wrote:
> _______________________________________________
> MIB-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mib-doctors

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Benoit Claise <[email-masked]>
Date: Fri, 28 Oct 2016 08:33:09 +0200

Right. The first thing I checked was existing errata.
Seems like nobody ever noticed all this time.

Regards, Benoit