Subject: [mif] comments of the routing section

From: "Min Hui" <[email-masked]>
Date: Thu, 11 Dec 2008 18:31:29 +0800

Hi, Marc

I'm Hui Min in China Mobile, I'm the colleague of Hui Deng.

I've read your draft about mif, and I have some comments on the routing
section, see in the below.

Please help to check them, thanks.

3.  Routing

   A multi-homed host may have multiple routes to a destination.

   However, by default, it does not have any hint concerning which

   interface would be the best to use for that destination.  For

   example, as discussed in

   [I-D.savolainen-6man-fqdn-based-if-selection] and

   [I-D.hui-ip-multiple-connections-ps], a service provider might want

   to influence the routing table of the host connecting to its network.

   (TBD: expand)[huimin1]<https://mail.google.com/mail/?ui=1&ik=&ui=1&ik=c684b2013e&view=cm&tf=1&to=mif%40ietf.org&zx=7pg53i5l6zl3&init=1&zx=gxo6pbgrwj7e#_msocom_1>

   A host usually has a node-scoped routing table.  Therefore, when a

   multi-homed host is connected to multiple networks and each service

   provider wants to influence the routing table of the host, then

   conflicts might arise from the multiple routing information being

   pushed to the
host.[huimin2]<https://mail.google.com/mail/?ui=1&ik=&ui=1&ik=c684b2013e&view=cm&tf=1&to=mif%40ietf.org&zx=7pg53i5l6zl3&init=1&zx=gxo6pbgrwj7e#_msocom_2>

   A user on such multi-homed host might want a local policy to

   influence which interface will be used based on various conditions.

   On a multi-homed host, some source addresses are not valid if used on

   some interfaces[huimin3]<https://mail.google.com/mail/?ui=1&ik=&ui=1&ik=c684b2013e&view=cm&tf=1&to=mif%40ietf.org&zx=7pg53i5l6zl3&init=1&zx=gxo6pbgrwj7e#_msocom_3>
 .  For example, an RFC1918 source address might be

   appropriate on the VPN interface but not on the public interface of

   the multi-homed host.  If the source address is not chosen

   appropriately,[huimin4]<https://mail.google.com/mail/?ui=1&ik=&ui=1&ik=c684b2013e&view=cm&tf=1&to=mif%40ietf.org&zx=7pg53i5l6zl3&init=1&zx=gxo6pbgrwj7e#_msocom_4>
  then sent packets might be filtered in the path if

   source address filtering is in place and reply packets might never

   come back to the source.
 ------------------------------

 [huimin1]<https://mail.google.com/mail/?ui=1&ik=&ui=1&ik=c684b2013e&view=cm&tf=1&to=mif%40ietf.org&zx=7pg53i5l6zl3&init=1&zx=gxo6pbgrwj7e#_msoanchor_1>It
will be better to illustrate the default gateway mechanism.

 [huimin2]<https://mail.google.com/mail/?ui=1&ik=&ui=1&ik=c684b2013e&view=cm&tf=1&to=mif%40ietf.org&zx=7pg53i5l6zl3&init=1&zx=gxo6pbgrwj7e#_msoanchor_2>The
confliction might be the second step needs to be considered, the first step
is how to send and receive the operator's routing information.

 [huimin3]<https://mail.google.com/mail/?ui=1&ik=&ui=1&ik=c684b2013e&view=cm&tf=1&to=mif%40ietf.org&zx=7pg53i5l6zl3&init=1&zx=gxo6pbgrwj7e#_msoanchor_3>Only
work in strong host model described in rfc1122. In weak host model things
will be different.

 [huimin4]<https://mail.google.com/mail/?ui=1&ik=&ui=1&ik=c684b2013e&view=cm&tf=1&to=mif%40ietf.org&zx=7pg53i5l6zl3&init=1&zx=gxo6pbgrwj7e#_msoanchor_4>Is
it more appropriate to put this problem in address selection policy section?

-----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> > Of
Marc
> > Blanchet
> > Sent: Wednesday, December 10, 2008 4:47 AM
> > To: [email-masked]
> > Subject: [mif] [Fwd: I-D
> Action:draft-blanchet-mif-problem-statement-00.txt]
> >
> > hi,
> >  here is the first pass of the PS document. I tried to summarize the
> > issues, be concise and to the point. Please comment!
> >
> > Marc.
> >
> > -------- Message original --------
> > Sujet : I-D Action:draft-blanchet-mif-problem-statement-00.txt
> > Date : Tue,  9 Dec 2008 12:45:02 -0800 (PST) De :
> > [email-masked] Répondre à : [email-masked] Pour
> > : [email-masked]
> >
> > A New Internet-Draft is available from the on-line Internet-Drafts
> > directories.
> >
> >  Title           : Multiple Interfaces Problem Statement
> >  Author(s)       : M. Blanchet
> >  Filename        : draft-blanchet-mif-problem-statement-00.txt
> >  Pages           : 7
> >  Date            : 2008-12-09
> >
> > A multi-homed host receives node configuration information from each
> > of its access networks.  Some configuration objects are global to
> > the node, some are local to the interface.  Various issues arise
> > when multiple configuration objects that are global to the node are
> > received on the many interfaces the multi-homed host has.  This
> > document describes these issues.
> >
> > A URL for this Internet-Draft is:
> >
> http://www.ietf.org/internet-drafts/draft-blanchet-mif-problem-stateme
> nt-0
> > 0.txt
> >
> > Internet-Drafts are also available by anonymous FTP at:
> > ftp://ftp.ietf.org/internet-drafts/
> >
> > Below is the data which will enable a MIME compliant mail reader
> > implementation to automatically retrieve the ASCII version of the
> > Internet-Draft.
> >
> >
> > --
> > =========
> > IPv6 book: Migrating to IPv6, Wiley, 2006. http://www.ipv6book.ca
> > Stun/Turn server for VoIP NAT-FW traversal: http://numb.viagenie.ca
>
_______________________________________________
mif mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mif

---

From: Marc Blanchet <[email-masked]>
Date: Sat, 27 Dec 2008 08:56:48 -0500

Hi,
 initially, there was an agreement to have the problem statement being
written
and then use it as the background to invite people on the mailing list.

I think we are ready. Shall we open the mailing list?

Marc.