Subject: Re: [mif] I-D Action:draft-ietf-mif-current-practices-00.txt

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 10 Dec 2009 15:23:13 +0100

MIFers,

I have some comments on draft-ietf-mif-current-practices-00.

First, I am happy it exists and seems very relevant to some needs.

Section "3.2.2.  Linux and BSD-based Operating Systems" basically talks 
DHCP and the problem of most implementations using a single default 
route.  I agree with it.

However, I would list more in this section.  When someone tries in 
practice to use multiple interfaces on linux one gets quickly also to 
the following tools:

-bridging brconf
-"bonding"
-tc

These have certain disadvantages, for example brconf only repeats 
packets from one interface to another whereas what I want is to receive 
packets from both interfaces to a 3rd interface.  "bonding" does that a 
little bit, but only works on Ethernet, it doesn't work with a ppp0 
interface, for example.  About tc I am not yet sure.

There may be other tools I am not aware of and I would like to learn 
about for using multiple interfaces simultaneously.

Alex

[email-masked] a écrit :
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Multiple Interfaces Working Group of the IETF.
> 
> 
> 	Title           : Current Practices for Multiple Interface Hosts
> 	Author(s)       : M. Wasserman
> 	Filename        : draft-ietf-mif-current-practices-00.txt
> 	Pages           : 16
> 	Date            : 2009-10-19
> 
> An increasing number of hosts are operating in multiple-interface
> environments, where different network interfaces are providing
> unequal levels of service or connectivity.  This document summarizes
> current practices in this area, and describes in detail how some
> common operating systems cope with these challenges.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-mif-current-practices-00.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Margaret Wasserman <[email-masked]>
Date: Sun, 13 Dec 2009 16:54:38 -0500

Hi Alexandru,

On Dec 10, 2009, at 9:23 AM, Alexandru Petrescu wrote:
>
> Section "3.2.2.  Linux and BSD-based Operating Systems" basically  
> talks DHCP and the problem of most implementations using a single  
> default route.  I agree with it.
>
> practice to use multiple interfaces on linux one gets quickly also  
> to the following tools:
>
> -bridging brconf
> -"bonding"
> -tc

This is a good idea.  I will add what I know about these things, and  
hopefully others can chime in with further details.

Margaret

---

From: Zhen Cao <[email-masked]>
Date: Tue, 15 Dec 2009 15:22:08 +0800

On Thu, Dec 10, 2009 at 10:23 PM, Alexandru Petrescu
<[email-masked]> wrote:
> Section "3.2.2.  Linux and BSD-based Operating Systems" basically talks DHCP
> and the problem of most implementations using a single default route.  I
> agree with it.

Linux actually has multiple routing tables: main, default, local, and
can be added easily to enforce source routing policy
(http://lartc.org/howto/lartc.rpdb.html). We can use "ip route list
table main/default/local" to access these tables.

So I do not think it is good to state that most implementations use a
single route. Actually for each policy, there is one default routes.
Do you agree?

Thanks for discussion,
Zhen

>
> However, I would list more in this section.  When someone tries in practice
> to use multiple interfaces on linux one gets quickly also to the following
> tools:
>
> -bridging brconf
> -"bonding"
> -tc
>
> These have certain disadvantages, for example brconf only repeats packets
> from one interface to another whereas what I want is to receive packets from
> both interfaces to a 3rd interface.  "bonding" does that a little bit, but
> only works on Ethernet, it doesn't work with a ppp0 interface, for example.
>  About tc I am not yet sure.
>
> There may be other tools I am not aware of and I would like to learn about
> for using multiple interfaces simultaneously.
>
> Alex
>
> mif mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif
>

---

From: liu dapeng <[email-masked]>
Date: Thu, 17 Dec 2009 02:20:24 +0800

Hi Alexandru,

> about for using multiple interfaces simultaneously.
There are some host based router software such as "Zebra
http://www.zebra.org/" which could turn the host in to virtually a
router and the multiple interfaces of the host could be simultaneous
used.  but i am not sure this could be recognized as the tools that
facilitate multiple interfaces.

Best regards,
Dapeng Liu

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 16 Dec 2009 20:33:31 +0100

> single route. Actually for each policy, there is one default routes.

I still have to check the main, default, local routing tables.

I think DHCP is only concerned about one of those tables, not sure 
which.  But I think it is because of that default route being 
re-configured that poses most problems to using several interfaces 
simultaneously.

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 16 Dec 2009 20:41:17 +0100

> facilitate multiple interfaces.

Well, depends.  Which part of the Zebra tools do you think could help to 
use several interfaces simultaneously?  Any particular routing protocol 
such as RIP or OSPF?  Or something else of Zebra?

Thanks,

Alex