Subject: [mif] Happy Eyeballs Extension for MIF

From: GangChen <[email-masked]>
Date: Wed, 9 Mar 2011 21:42:36 +0800

Hello all,

A New Internet-Draft is available.

       Title           : Happy Eyeballs Extension for Multiple Interfaces
       Author(s)       : G. Chen
       Filename        : draft-chen-mif-happy-eyeballs-extension-00.txt
       Pages           : 6
       Date            : 2011-03-07

The memo has been proposed to extend happy eyeballs algorithm to fit
into multiple interfaces environment.  Based on this extended
heuristic algorithm, a client with multiple interface could determine
the optimal flow path in which specific interface has been chosen.
Furthermore, an appropriate IP address family for each interface can
be also identified to guarantee user experiences during IPv6
transition period.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-chen-mif-happy-eyeballs-extension-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Please kindly review it.
Comments are welcome.

BRs

Gang

---

From: <[email-masked]>
Date: Sun, 27 Mar 2011 14:43:12 +0000

Hi,

This is interesting work. Couple of questions:

Is the value of I initially zero for any destination/hostname that has not yet been connected to?

draft-ietf-mif-dhcpv6-route-option and RFC4191 allow definition of specific routes. In the presence of specific routes it sounds, for me at least, somewhat odd to send connection attempts via all interfaces. What about incrementing I for a destination address that matches a more specific route? Hence initial connection attempt would be sent over the interface that has matching route and other interfaces would be tried only if no reply on the preferred one?

How does the value of I relate to time? (i.e. if I is -1 does the node wait 10ms before trying corresponding less-preferred interface).

Why would the DNS query be sent over all interfaces? Is it because "I" for a destination name is initially a zero? Like in routing case, if Improved DNS Server Selection is in play, would the "I" be nonzero for those interfaces over which DNS suffix matching the requested name has been received on?

Best regards,

	Teemu

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> ext GangChen
> Sent: 09. maaliskuuta 2011 14:43
> To: mif
> Subject: [mif] Happy Eyeballs Extension for MIF
> 
> Hello all,
> 
> _______________________________________________
> mif mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif