Subject: [mif] Comments on Improved DNS server selection

From: Dave Thaler <[email-masked]>
Date: Mon, 28 Mar 2011 12:22:26 +0000

My thoughts after the end of today's WG discussion...

I don't yet buy that there's any real world scenario we care about
where there's one interface that wants to configure different 
DNS servers for different namespaces.

If you want to do that, you have to deal with hosts that don't 
yet do whatever the new option would do, and to handle them
you'd hand out the IPs of a DNS server inside that ISP that then 
uses the more detailed information when it does recursive queries
for example. 

And once you have that, you don't need DNS IPs in the DNS suffix list.

-Dave

---

From: <[email-masked]>
Date: Mon, 28 Mar 2011 12:43:57 +0000

This part of the discussions reminded me of the very first version of this draft (October 2008)
http://tools.ietf.org/id/draft-savolainen-6man-fqdn-based-if-selection-00.txt
that simply used:
- DHCPv4 Domain Search Option number 119 
- DHCPv6 Domain Search List Option number 24 
to choose between interfaces... 

But then things started growing, as those were not ok to use and as features crept in:)

So is this proposal essentially to go backwards a bit and have option format very similar to Search List Options?

Having only name in the option actually requires having DNS Proxy in figure 2 scenario of draft-ietf-v6ops-multihoming-without-nat66), while having DNS server address in the option makes it possible for hosts to bypass the DNS proxy and talk directly to correct DNS server.

E.g. OPTION_DNS_SERVER_SELECT could have address of this proxy, while new options would point directly to DNS servers with knowledge of private namespaces.

Best regards,

	Teemu

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> ext Dave Thaler
> Sent: 28. maaliskuuta 2011 14:22
> To: [email-masked]
> Subject: [mif] Comments on Improved DNS server selection
> 
> _______________________________________________
> mif mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif