Subject: [mif] I-D Action:draft-ietf-mif-problem-statement-10.txt

From: [email-masked]
Date: Fri, 11 Mar 2011 06:30:01 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Multiple Interfaces Working Group of the IETF.

	Title           : Multiple Interfaces and Provisioning Domains Problem Statement
	Author(s)       : M. Blanchet, P. Seite
	Filename        : draft-ietf-mif-problem-statement-10.txt
	Pages           : 20
	Date            : 2011-03-11

This document describes issues encountered by a node attached to
multiple provisioning domains.  This node receives configuration
information from each of its provisioning domains where some
configuration objects are global to the node, others are local to the
interface.  Issues such as selecting the wrong interface to send
trafic happen when conflicting node-scoped configuration objects are
received and inappropriately used.  Moreover, other issues are the
result of simulatenous attachment to multiple networks, such as
domain selection or addressing and naming space overlaps, regardless
of the provisioning mechanism.  While multiple provisioning domains
are typically seen on nodes with multiple interfaces, this document
also discusses single interface nodes situation.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mif-problem-statement-10.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: <[email-masked]>
Date: Mon, 14 Mar 2011 09:53:10 +0100

Hi all,

Problem statement has been updated with session management issues, as discussed during IETF79 (e.g. problems with on-going sessions).

Pierrick
 
> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]]
> De la part de [email-masked]
> Envoyé : vendredi 11 mars 2011 15:30
> À : [email-masked]
> Cc : [email-masked]
> Objet : I-D Action:draft-ietf-mif-problem-statement-10.txt
>

---

From: Scott W Brim <[email-masked]>
Date: Mon, 14 Mar 2011 11:07:45 -0400

> Problem statement has been updated with session management issues, as discussed during IETF79 (e.g. problems with on-going sessions).

A good start on session management.  There are a few things I would
change for next time:

* terminology inconsistencies ("session" and "connection", "logical"
and "virtual")

* Session management is independent of address selection, and can deal
with the multi-interface problem at one or more of several stack
layers.

* I would add more use case references, not just MIP/PMIP/Shim6.

* I would add something about APIs.

But we can do all of that later.  This is pretty good for now.

... Scott

---

From: <[email-masked]>
Date: Mon, 14 Mar 2011 18:59:58 +0100

Hi Scott,

Thanks for comments. Please see inline for answers.

Pierrick

> De : Scott W Brim [mailto:[email-masked]]
> Envoyé : lundi 14 mars 2011 16:08
> À : SEITE Pierrick RD-RESA-REN
> Cc : [email-masked]
> Objet : Re: [mif] I-D Action:draft-ietf-mif-problem-statement-10.txt
> 
> > Problem statement has been updated with session management issues, as
> discussed during IETF79 (e.g. problems with on-going sessions).
> 

In Beijing we said that connection manager was a poor name and that session manager would be better. However, "connection manager" is well-known in the mobile world. So, I could agree to use only "session manager", but saying somewhere in the document that session manager is sometimes called connection manager. Is it ok for the WG?

I agree regarding inconsistency between virtual and logical. If no opposition, the next version will use only "Virtual".

> with the multi-interface problem at one or more of several stack

You're right, session management comes into play at different layers; and my understanding is that address selection is a part of session management. Am I missing something?
 
> * I would add more use case references, not just MIP/PMIP/Shim6.

Ok, feel free to propose other use-cases. Anyway, we don't need to be exhaustive, it's just examples. Note that we have also MPTCP.

> * I would add something about APIs.

Considering current text on session management, we could stress that, in order to resolve the MIF issues, specific extensions to current socket API should be defined. These extensions would aim to provide information, or control services, to applications/session manager. Then we should refer to the MIF API draft. Is it ok, or do you see specific issues with API which should be described in the PS?

> But we can do all of that later.  This is pretty good for now.

Thanks.