Subject: [mif] Announcing draft-mouton-mif-dhcpv6-drlo-00 about default route with DHCPv6

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 02 Aug 2011 17:23:15 +0200

Dear MIF,

We would like to announce a new draft focusing to offer default route
with DHCPv6:

            "Default Router List Option for DHCPv6 (DRLO)"
                draft-mouton-mif-dhcpv6-drlo-00.txt
http://tools.ietf.org/html/draft-mouton-mif-dhcpv6-drlo-00.txt

Thank you in advance for commenting on this draft.

Alex and Maximilien

--------------------------------------------------------------------
Implementation Details

A prototype linux implementation is ongoing, and modifies ISC Client and
Server; Relay works unmodified.

A wireshark capture is attached (dissector code available upon request).

Server uses a new pattern of 'format codes' "6SmMoA", and the conf file
says:
[...]
> option dhcp6.default-router 2002:c130:13c1:11f::ff 8400
> 00:07:32:06:7e:72,2002:c130:13c1:11f:13c1:11f::fe 88
> 00:07:32:06:7e:73 ,2002:c130:13c1:11f::f5 8300 ;
[...]

Client conf file says:
> interface "eth0"{ request
> dhcp6.domain-search,dhcp6.name-servers,dhcp6.default-router; }
Client says:
> RCV:  X-- Server ID: 00:01:00:01:15:67:c9:7d:00:12:3f:1c:a2:95
> RCV:  | | X-- TEST_AJOUT eth0 et 0 et 2.
> RCV:  | | X-- DEFAULT_ROUTER_ADDR 2002:c130:13c1:11f::ff.
> RCV:  | | | X-- Default_router_lifetime 8000.
> RCV:  | | | X-- Default_router_link_layer_addr 00:22:68:17:59:ae.
> RCV:  | | X-- TEST_AJOUT eth0 et 0 et 2.
> RCV:  | | X-- DEFAULT_ROUTER_ADDR 2002:c130:13c1:11f::fe.
> RCV:  | | | X-- Default_router_lifetime 8400.
> RCV:  | | | X-- Default_router_link_layer_addr 00:07:32:06:7e:72.
> RCV:  Advertisement recorded.

After execution of the DHCP exchange, the neigh cache is (note "expires"
corresponding to the lifetime):
> # ip -6 route show
[...]
> default via 2002:c130:13c1:11f::ff dev eth0  proto kernel metric 1024
> expires 7752sec mtu 1500 advmss 1440 hoplimit 0
[...]

Thank you for considering this draft.

Alex

---

From: Wojciech Dec <[email-masked]>
Date: Thu, 18 Aug 2011 14:11:59 +0200

Hello Alex,

reading through the draft, other than it proposing a new option with a
different format, could you elaborate on why/what is the issue in
http://tools.ietf.org/html/draft-ietf-mif-dhcpv6-route-option-02 for
conveying the default router info (which the draft already covers)?

Thanks,
Wojciech.

On 2 August 2011 17:23, Alexandru Petrescu <[email-masked]>wrote:

>               draft-mouton-mif-dhcpv6-drlo-**00.txt
> http://tools.ietf.org/html/**draft-mouton-mif-dhcpv6-drlo-**00.txt<http://tools.ietf.org/html/draft-mouton-mif-dhcpv6-drlo-00.txt>
>
> ------------------------------**------------------------------**--------
> Implementation Details
>
>> 00:07:32:06:7e:72,2002:c130:**13c1:11f:13c1:11f::fe 88
>> dhcp6.domain-search,dhcp6.**name-servers,dhcp6.default-**router; }
>>
> Client says:
>
>> RCV:  X-- Server ID: 00:01:00:01:15:67:c9:7d:00:12:**3f:1c:a2:95
> _______________________________________________
> mif mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif
>
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 18 Aug 2011 16:28:47 +0200

Le 18/08/2011 14:11, Wojciech Dec a écrit :
> Hello Alex,
>
> reading through the draft, other than it proposing a new option with
> a different format, could you elaborate on why/what is the issue in

Hello Wojciech,

Thank you for reading our draft.

With respect to your draft: indeed I believe there may some issues with
the way it proposes to convey the default router info.

For example, if I am not mistaken, your draft does not communicate the
MAC address of the default router.  Some times communicating the MAC
address could speed up the process (avoid the subsequent NS/NA to solve
the MAC address).

Also, it does not treat of lifetime of this default route (although it
does treat of DHCP lifetimes).  An ND-lifetime could be necessary
sometimes to the ND structures in the Default Router List.

Your draft communicates the default route as 128 0 bits, which may be
too long in certain constrained environments (it adds around half to
size of the entire message).

There may be other issues about your draft that I would like to discuss.

On another hand, what do you think about our draft, other than just
being a different format than yours?

Then, do you think it may be useful to communicate MAC and ND-lifetime
of default route?

Thanks,

Alex

>
> Thanks, Wojciech.
>
> On 2 August 2011 17:23, Alexandru Petrescu
> <[email-masked] <mailto:[email-masked]>>
> wrote:
>
> Dear MIF,
>
> draft-mouton-mif-dhcpv6-drlo-__00.txt
> http://tools.ietf.org/html/__draft-mouton-mif-dhcpv6-drlo-__00.txt
> <http://tools.ietf.org/html/draft-mouton-mif-dhcpv6-drlo-00.txt>
>
> ------------------------------__------------------------------__--------
>
>
>
Implementation Details
>
> A prototype linux implementation is ongoing, and modifies ISC Client
> and Server; Relay works unmodified.
>
> Server uses a new pattern of 'format codes' "6SmMoA", and the conf
> file says: [...]
>
> 00:07:32:06:7e:72,2002:c130:__13c1:11f:13c1:11f::fe 88
> dhcp6.domain-search,dhcp6.__name-servers,dhcp6.default-__router; }
>
> Client says:
>
> RCV:  X-- Server ID: 00:01:00:01:15:67:c9:7d:00:12:__3f:1c:a2:95
> RCV: | | X-- TEST_AJOUT eth0 et 0 et 2. RCV:  | | X--
> DEFAULT_ROUTER_ADDR 2002:c130:13c1:11f::ff. RCV:  | | | X--
> Default_router_lifetime 8000. RCV:  | | | X--
> Default_router_link_layer_addr 00:22:68:17:59:ae. RCV:  | | X--
> TEST_AJOUT eth0 et 0 et 2. RCV:  | | X-- DEFAULT_ROUTER_ADDR
> 2002:c130:13c1:11f::fe. RCV:  | | | X-- Default_router_lifetime 8400.
> After execution of the DHCP exchange, the neigh cache is (note
> "expires" corresponding to the lifetime):
>
> # ip -6 route show
>
> [...]
>
> _______________________________________________ mif mailing list
> [email-masked] <mailto:[email-masked]>