Subject: [mif] FW: New Liaison Statement, "OMA Open Connection Manager API (OpenCMAPI)"

From: Hui Deng <[email-masked]>
Date: Sat, 10 Dec 2011 23:12:52 +0800

Hello all
 
OMA CD wg would like to align their connection manager API design work with MIF api.
Feel free to comment on it.
 
thanks
 
-Hui

> Subject: New Liaison Statement, "OMA Open Connection Manager API (OpenCMAPI)"
> From: [email-masked]
> To: [email-masked]; [email-masked]
> Date: Fri, 9 Dec 2011 21:32:21 +0000
> CC: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
> 
> Title: OMA Open Connection Manager API (OpenCMAPI)
> Submission Date: 2011-12-08
> URL of the IETF Web page: /liaison/1120/
> 
> From: Open Mobile Alliance (Thierry Berisot <[email-masked]>)
> To: Multiple Interfaces ([email-masked], [email-masked])
> Cc: Ralph Droms <[email-masked]>,Jari Arkko <[email-masked]>,Multiple Interfaces Discussion List <[email-masked]>,Murray Kucherawy <[email-masked]>,<[email-masked]>,<[email-masked]>,<[email-masked]>
> Reponse Contact: 
> Technical Contact: 
> Purpose: For information
> 
> Body: 
> Attachment(s):
> 
> OMA Open Connection Manager API (OpenCMAPI) https://datatracker.ietf.org/documents/LIAISON/file1301.doc
> 
>

---

From: <[email-masked]>
Date: Mon, 12 Dec 2011 00:05:24 +0100

Hi Hui,

It think it does make sense to coordinate effort from IETF/MIF and OMA-DM on multiple connection API design. Actually, some of the OMA API requirements are inline with the MIF API, e.g. DNS selection, routing configuration, first hop selection. Moreover, as discussed during the last IETF, the multiple interface management should rely on different APIs acting at different layers; some of these API are clearly not in the IETF scope but are covered by the OMA DM.

Pierrick

________________________________

De : [email-masked] [mailto:[email-masked]] De la part de Hui Deng
Envoyé : samedi 10 décembre 2011 16:13
À : [email-masked]
Objet : [mif] FW: New Liaison Statement, "OMA Open Connection Manager API (OpenCMAPI)"

Hello all

thanks
 
-Hui

> Cc: Ralph Droms <[email-masked]>,Jari Arkko <[email-masked]>,Multiple Interfaces Discussion List <[email-masked]>,Murray Kucherawy <[email-masked]>,<[email-masked]>,<O [email-masked]>,<[email-masked]>
> Reponse Contact: 
> Technical Contact: 
> Purpose: For information
> 
> Body: 
> Attachment(s):
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 12 Dec 2011 13:19:01 +0100

There is a MIF api?  (I didn't know).

Some mobility related software was implemented managing connections and 
it used Socket Interface (as an "api").  For example there is RFC4584 
"Extension to Sockets API for Mobile IPv6".

But what is MIF api?

Alex

Le 10/12/2011 16:12, Hui Deng a écrit :
>  > CC: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]
>  >
>  > Cc: Ralph Droms <[email-masked]>,Jari Arkko
> <[email-masked]>,Multiple Interfaces Discussion List
> <[email-masked]>,Murray Kucherawy
> <[email-masked]>,<[email-masked]>,<O
> [email-masked]>,<[email-masked]>
>  > Reponse Contact:
>  > Technical Contact:
>  > Purpose: For information
>  >
>  > Body:
>  > Attachment(s):
>  >
>  > OMA Open Connection Manager API (OpenCMAPI)
> https://datatracker.ietf.org/documents/LIAISON/file1301.doc
>  >
>  >
>
>
> _______________________________________________
> mif mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif

---

From: <[email-masked]>
Date: Mon, 12 Dec 2011 14:00:11 +0100

Hi Alex,

Actually, the MIF WG is expected to specify an API. Hereafter is the corresponding part of the charter:

3) MIF API: While no changes are needed for applications to run on
multiple interface hosts, a new API could provide additional services
to applications running on hosts attached to multiple provisioning
domains. For instance, these services could assist advanced
applications in having greater control over first-hop, source address
and/or DNS selection issues. This API will be defined as an abstract
interface specification, i.e., specific details about mapping to
operating system primitives or programming language will be left out.

Pierrick

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de
> Alexandru Petrescu
> Envoyé : lundi 12 décembre 2011 13:19
> À : [email-masked]
> Objet : Re: [mif] FW: New Liaison Statement, "OMA Open Connection Manager
> API (OpenCMAPI)"
>