Subject: [mif] FW: New draft: IRON Applicability for Multiple Interface Nodes

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 11 Jan 2012 09:06:39 -0800

Hello Hui,

The draft I announced on Jan 4th (below) was motivated
by our discussions back in December:

http://www.ietf.org/mail-archive/web/mif/current/msg01597.html
http://www.ietf.org/mail-archive/web/mif/current/msg01599.html

I would appreciate it if you could take the time to
review the draft and post comments.

Thanks - Fred
[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Templin, Fred L
Sent: Wednesday, January 04, 2012 11:52 AM
To: [email-masked]
Subject: [mif] New draft: IRON Applicability for Multiple Interface Nodes

Hello,

I have submitted a new draft on "IRON Applicability for
Multiple Interface Nodes" (see below). Please review and
send comments.

Fred
[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, January 04, 2012 10:18 AM
To: [email-masked]
Subject: I-D Action: draft-templin-mif-ironapp-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : IRON Applicability for Multiple Interface Nodes
	Author(s)       : Fred L. Templin
	Filename        : draft-templin-mif-ironapp-00.txt
	Pages           : 7
	Date            : 2012-01-04

   The Internet Routing Overlay Network (IRON) is a new internetworking
   and routing architecture that addresses important issues including
   routing scaling, network renumbering, mobility management, mobile
   networks, multihoming, traffic engineering, NAT traversal and
   security.  In this document, we focus on IRON's applicability for
   multiple interface (mif) nodes.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-templin-mif-ironapp-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-templin-mif-ironapp-00.txt
_______________________________________________
mif mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mif

---

From: "Hui Deng" <[email-masked]>
Date: Thu, 12 Jan 2012 22:59:09 +0800

Hello Fred,

Thanks for writing MIF iron document, 
Comments from MIF:
1) MIF is not targeting a new internetworking and routing architecture, MIF
is proposed to solve today existing industry's architecture such as 3GPP,
BBF, WIFI deployment or Ethernet/PON office network. For new architecture
proposal, it would better to be discussed in IRTF.
2) MIF is not going to solve one OS handling two interfaces with the same
conflict IP address and prefix. At this moment, it is talking about how to
select happy eyeball path with multiple interfaces.

Comments from research direction:
1) Thinking about the possibility how to deploy VSP integrated with the
existing architecture like 3GPP, BBF, WIFI. It will take a revolutionary way
other than incremental deployment since it will change both host and
network, host is especially harder in today's mobile industry by supporting
IRON interface.
2) As far as I learned, IETF is more focusing on the problem with the
limited scope other than a general solution which can solve everything like
1st paragraph of in section of Introduction.

Excuse me for not reading in detail about your 4 drafts.

Thanks again

-Hui

> From: Templin, Fred L [mailto:[email-masked]]
> Sent: Thursday, January 12, 2012 1:07 AM
> To: Hui Deng
> Cc: [email-masked]
> Subject: FW: New draft: IRON Applicability for Multiple Interface Nodes
> 
> Hello Hui,
>

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 12 Jan 2012 11:20:58 -0800

Hi Hui,

Thanks for your reply, and please see below for
follow-up: 

> From: Hui Deng [mailto:[email-masked]] 
> Sent: Thursday, January 12, 2012 6:59 AM
> To: Templin, Fred L
> Cc: [email-masked]
> Subject: RE: New draft: IRON Applicability for Multiple 
> Interface Nodes
> 
> Hello Fred,
> 
> BBF, WIFI deployment or Ethernet/PON office network.

IRON is concerned with solving problems for the existing
industry's architecture. It does not replace any of the
existing architecture, but rather augments the existing
architecture.

> For new architecture

IRON is not a new architecture, but rather a ready-for-
deployment second edition of an architecture already
published through the IRTF RRG (see RFC6179). Hence,
IRON is now proposed as an IETF working document.

> select happy eyeball path with multiple interfaces.

The IRON soultion to happy eyeballs is to expose only
a single, stable IRON virtual interface to the
application and to dynamically ensure that the IRON
interface remains mapped to the best underlying ISP
interface(s) based on current ISP connectivity.

> network,

No; no changes to the current network deployment.
IRON only requires a few new routers be deployed
in the network in incremental fashion. (Modification
of existing routers is also possible.)

> host is especially harder in today's mobile industry 
> by supporting IRON interface.

The MIF node would require a new IRON virtual interface,
yes. The IRON interface is really the same as for GRE,
but also asks for dynamic mapping of the IRON interface
to ISP interface(s) so that applications see a constant
and stable interface with constant and stable IP config.

> 1st paragraph of in section of Introduction.

OK, but if the limited scope solution also happens to
generalize, then so much the better - right?
 
> Excuse me for not reading in detail about your 4 drafts.

The progression in understanding should be to first
become familiar with the IRON virtual interface in
the current MIF draft. Then, read IRON followed by
SEAL followed by VET followed by AERO - while taking
a break between documents as necessary without risk
of losing context. So, the documents are inter-
dependent in a seperable and healthy way without
being co-dependent in a pathological way.

Thanks - Fred

> > From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of
> > Templin, Fred L
> > From: [email-masked] 
> [mailto:[email-masked]]
> > On Behalf Of [email-masked]