Subject: [mif] MIF API - Access Network Selection

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 1 Aug 2012 16:11:44 -0500

Hi Ted,

In one of your slides you showed today, you showed that on one
interface there are 2 networks.
Is selecting one network versus the other part of this API work?

Regards,

Behcet

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 1 Aug 2012 16:29:34 -0500

Hi Ted,

On Wed, Aug 1, 2012 at 4:16 PM, Ted Lemon <[email-masked]> wrote:
> On Aug 1, 2012, at 2:11 PM, Behcet Sarikaya wrote:
>
> By "network" do you mean something like two access points, or do you mean
> two interfaces?

Yes, it could be multiple APs or Base Stations.

>The expectation is that we will attempt to use any network
> we are actually connected to.   The connection manager is responsible for
> choosing which access point to connect to,

Where is connection manager specified? a Mif document?

> and until that decision is made,
> we aren't connected to a network on that interface from the perspective of
> the MIF API.   Similarly for a wireline connection in a market where more
> than one provider shares the wireline.
>

Regards,

Behcet

---

From: Ted Lemon <[email-masked]>
Date: Wed, 1 Aug 2012 22:02:34 +0000

On Aug 1, 2012, at 2:29 PM, Behcet Sarikaya wrote:
Where is connection manager specified? a Mif document?

I think that the MIF API sets a baseline for what the connection manager has to be able to do.   I think that a single connection manager spec from the MIF working group would be presumptuous, because the precise functioning of the connection manager is really something that's core to the business of a lot of customers of the MIF API.   So as long as the connection manager implementation supports the functionality required by the MIF API, I don't think we should try to go any further than that.

---

From: <[email-masked]>
Date: Thu, 2 Aug 2012 09:01:44 +0000

Hi,

Sorry for jumping into the discussion but, actually, this is a very interesting point.

Couple of IETF ago, we discussed the interest for a "connection manager" item in MIF. Actually, Ted gives a good summary of the consensus in MIF. Full specification of a Connection manager is out of the IETF scope,  but it is expected from the MIF API to provide information and functionalities that a connection manager may need. On the other hand,  I think that ongoing work in MIF ( implementation guideline or specification of the high-level API) may provide guidance on how a connection manager should use the MIF API .

Pierrick

De : [email-masked] [mailto:[email-masked]] De la part de Ted Lemon
Envoyé : jeudi 2 août 2012 00:03
À : <[email-masked]>; Behcet Sarikaya
Cc : <[email-masked]>
Objet : Re: [mif] MIF API - Access Network Selection

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Ted Lemon <[email-masked]>
Date: Thu, 2 Aug 2012 16:21:48 +0000

On Aug 2, 2012, at 2:01 AM, <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>> wrote:
Full specification of a Connection manager is out of the IETF scope,  but it is expected from the MIF API to provide information and functionalities that a connection manager may need. On the other hand,  I think that ongoing work in MIF ( implementation guideline or specification of the high-level API) may provide guidance on how a connection manager should use the MIF API .

In fact, the current work on the MIF API is assuming that the connection manager may use, and indeed _require_ features of the operating system which are not exposed in the MIF API.   The reason for this division is that it's expected that the vendor of a device or operating system will almost certainly have a single connection manager that controls the connections of the machine, and that there is no way to anticipate the context in which this connection manager will operate.   So its deliverables are fairly clear, but its requirements are clear as mud.

If this is not in fact the consensus of the working group, then people who know more about how connection managers work (if there are any who can participate) should be proposing additional API messages.

For my part, I think that we have a pretty clear and manageable job to do if we just solve the problem of providing the minimal functionality that a high-level API or smart application would need.

---

From: "Zuniga, Juan Carlos" <[email-masked]>
Date: Thu, 2 Aug 2012 12:29:30 -0400

Ted, Pierrick,

I think specifying connection manager requirements is a good idea and
very much in line with the laundry list we were discussing during my
presentation. 

>From my side, I also would like to see a connection manager interface
that allows providing a common behavior from different devices operating
in the same managed network.

As Ted mentions, we can start by defining the list of API messages to
have more concrete examples and then have a more concrete discussion.

Regards,

Juan Carlos

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Ted Lemon
Sent: Thursday, August 02, 2012 12:22 PM
To: List List
Subject: Re: [mif] MIF API - Access Network Selection

On Aug 2, 2012, at 2:01 AM, <[email-masked]>
<[email-masked]> wrote:

	Full specification of a Connection manager is out of the IETF
scope,  but it is expected from the MIF API to provide information and
functionalities that a connection manager may need. On the other hand,
I think that ongoing work in MIF ( implementation guideline or
specification of the high-level API) may provide guidance on how a
connection manager should use the MIF API .

In fact, the current work on the MIF API is assuming that the connection
manager may use, and indeed _require_ features of the operating system
which are not exposed in the MIF API.   The reason for this division is
that it's expected that the vendor of a device or operating system will
almost certainly have a single connection manager that controls the
connections of the machine, and that there is no way to anticipate the
context in which this connection manager will operate.   So its
deliverables are fairly clear, but its requirements are clear as mud.

If this is not in fact the consensus of the working group, then people
who know more about how connection managers work (if there are any who
can participate) should be proposing additional API messages.

For my part, I think that we have a pretty clear and manageable job to
do if we just solve the problem of providing the minimal functionality
that a high-level API or smart application would need.

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 2 Aug 2012 12:23:13 -0500

My question was if access network selection is part of the MIF API.
The answer is no.
It is the job of so-called connection manager, a functionality usually
provided by the operating system, i.e. iOS/Android, etc.
It also means the answer is it is implementation issue.

Yes?

Behcet

On Thu, Aug 2, 2012 at 4:01 AM,  <[email-masked]> wrote:
> Couple of IETF ago, we discussed the interest for a “connection manager”
> item in MIF. Actually, Ted gives a good summary of the consensus in MIF.
> Full specification of a Connection manager is out of the IETF scope,  but it
> is expected from the MIF API to provide information and functionalities that
> a connection manager may need. On the other hand,  I think that ongoing work
> in MIF ( implementation guideline or specification of the high-level API)
> may provide guidance on how a connection manager should use the MIF API .
>
>
>
> Pierrick
>
>
>
> I think that the MIF API sets a baseline for what the connection manager has
> to be able to do.   I think that a single connection manager spec from the
> MIF working group would be presumptuous, because the precise functioning of
> the connection manager is really something that's core to the business of a
> lot of customers of the MIF API.   So as long as the connection manager
> implementation supports the functionality required by the MIF API, I don't
> think we should try to go any further than that.
>
>
>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu
> ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;
> As emails may be altered, France Telecom - Orange is not liable for messages
> that have been modified, changed or falsified.
> Thank you.

---

From: Ted Lemon <[email-masked]>
Date: Thu, 2 Aug 2012 17:46:03 +0000

On Aug 2, 2012, at 10:23 AM, Behcet Sarikaya wrote:
It also means the answer is it is implementation issue.

Yes?

Yes.   More precisely, the answer has been assumed to be out of scope, and is therefore left to the implementor.

---

From: "Zuniga, Juan Carlos" <[email-masked]>
Date: Thu, 2 Aug 2012 14:05:17 -0400

Access network selection is a function carried out at a higher layer by
some entity, such as a connection manager. 

This function is clearly out of scope for MIF. 

However, whether this entity requires some specific messages from the
MIF API in order to perform the selection correctly, I believe is still
TBD.

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Ted Lemon
Sent: Thursday, August 02, 2012 1:46 PM
To: <[email-masked]>; Behcet Sarikaya
Cc: <[email-masked]>
Subject: Re: [mif] MIF API - Access Network Selection

	
	Yes?

Yes.   More precisely, the answer has been assumed to be out of scope,
and is therefore left to the implementor.