Subject: [mif] Issues #10, #11 & #12: "Walled-garden" use cases are invalid

From: Margaret Wasserman <[email-masked]>
Date: Fri, 9 Nov 2012 07:25:03 -0500

This issue claims that walled-garden use cases are invalid based on text from RFC 3002, which is an informational IAB report from an invitation-only IAB workshop held in 2000.  

There has been some list discussion explaining that use cases #1, #5 and #7 are not inherently walled-garden use cases.

Also, it is not required that our work comply with the opinions expressed in IAB workshop reports.  Workshop reports are not even IETF consensus documents, and they do not place requirements on IETF protocol work.

My proposed resolution is to close these issues with no changes to the document.

Thoughts?
Margaret

---

From: Lorenzo Colitti <[email-masked]>
Date: Fri, 9 Nov 2012 09:18:34 -0500

On Fri, Nov 9, 2012 at 7:25 AM, Margaret Wasserman <[email-masked]>wrote:

> There has been some list discussion explaining that use cases #1, #5 and
> #7 are not inherently walled-garden use cases.
>

In that case, the use cases should be reworded so they do not refer to
walled gardens.

Also, it is not required that our work comply with the opinions expressed
> in IAB workshop reports.  Workshop reports are not even IETF consensus
> documents, and they do not place requirements on IETF protocol work.
>

The IAB is responsible for "oversight of [...] the architecture for the
protocols and procedures used by the Internet". If the IAB issues a strong
recommendation not to design for this use case, then it is silly for us to
target it.