Subject: [mif] Call for volunteers about architecture design

From: Hui Deng <[email-masked]>
Date: Sat, 16 Mar 2013 11:58:14 -0700

Hello all

Based on yesterday discussion, cochairs would like to call for volunteers
who would like to work on architecture related design work, please kindly
help to send emails to co-chairs.

Thanks

-Hui

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Sat, 16 Mar 2013 21:09:57 +0000

On Mar 16, 2013, at 12:58 PM, Hui Deng <[email-masked]> wrote:

> Based on yesterday discussion, cochairs would like to call for volunteers who would like to work on architecture related design work, please kindly help to send emails to co-chairs.

I'm willing to do that, but give fair warning that I think this is trivially solved in a manner that we have solved other problems such as PPP Multilink. IP should be able to view a set of interfaces as if they were one, and the simplest way to do that is to insert a virtual interface between the set of interfaces and IP. If they are Ethernet interfaces and the device is a switch or a router, it probably does 802.1 Ethernet Switching between them. The discussion point will be how one treats that construct on a host, or when they are of differing interface types.

---

From: Ted Lemon <[email-masked]>
Date: Sat, 16 Mar 2013 21:16:58 +0000

> I'm willing to do that, but give fair warning that I think this is trivially solved in a manner that we have solved other problems such as PPP Multilink. IP should be able to view a set of interfac…

This isn't at all the problem we are talking about.   See my slides from the intarea presentation for details.

---

From: Alexandru Petrescu <[email-masked]>
Date: Sun, 17 Mar 2013 02:38:32 +0100

Le 16/03/2013 22:16, Ted Lemon a écrit :
>> I'm willing to do that, but give fair warning that I think this is
>> trivially solved in a manner that we have solved other problems
>> such as PPP Multilink. IP should be able to view a set of
>> interfaces as if they were one, and the simplest way to do that is
>> to insert a virtual interface between the set of interfaces and
>> IP. If they are Ethernet interfaces and the device is a switch or
>> a router, it probably does 802.1 Ethernet Switching between them.
>> The discussion point will be how one treats that construct on a
>> host, or when they are of differing interface types.
>
> This isn't at all the problem we are talking about.   See my slides
> from the intarea presentation for details.

This kind of problem - make one virtual interface to link all other
interfaces together, with goals such as bandwidth augmentation, on a
Mobile Router (not a Host) - is discussed in the ITS Intelligent
Transportation Systems email list ietf.org/mailman/listinfo/its

(this is one problem being considered there, but there are other ITS
problems considered there.  And there there is thought that MIF may
consider this case - it seems not.)

Alex

>
> _______________________________________________ mif mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/mif
>

---

From: Ted Lemon <[email-masked]>
Date: Sun, 17 Mar 2013 11:51:06 +0000

> consider this case - it seems not.)

I think we should definitely consider this problem in the architecture discussion.   Whether it's in-scope or out of scope is another question.

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 18 Mar 2013 15:58:01 +0100

Le 17/03/2013 12:51, Ted Lemon a écrit :
>> This kind of problem - make one virtual interface to link all
>> other interfaces together, with goals such as bandwidth
>> augmentation, on a Mobile Router (not a Host) - is discussed in the
>> ITS Intelligent Transportation Systems email list
>> ietf.org/mailman/listinfo/its
>>
>> (this is one problem being considered there, but there are other
>> ITS problems considered there.  And there there is thought that MIF
>> may consider this case - it seems not.)
>
> I think we should definitely consider this problem in the
> architecture discussion.   Whether it's in-scope or out of scope is
> another question.

In addition to simultaneous use of multiple interfaces for bandwidth
augmentation on a low-ratio egress-ingress bandwidth Mobile Router (its
egress bandwith is much lower than ingress bandwidth),

there is another aspect which deserves mentioning in a mif'ed Host: the
use of Mobile IP and handovers.  This would be such that a Host to offer
highly available connections - when WiFi is available use WiFi, but if
cellular is available then use cellular.  This could be a sequential use
of interfaces (only one interface is used exclusively), as opposed to
simultaneous use of interfaces.

The architecture aspect in  this is the difference between simultaneous
vs sequential use of interfaces.  This could be illustrated with
pictures of topology.

This is something very complex to deal with.

Alex

---

From: <[email-masked]>
Date: Tue, 19 Mar 2013 09:13:53 +0000

Hi Alex,

Except the problem of access discovery and selection, I'm not sure there are multiple provisioning domains issues with sequential use of interfaces. This is something we can do with current terminal... Maybe I'm wrong but, anyway, I guess the architecture work will start with discussion on use-cases to identify what is relevant or not.

Pierrick

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de
> Alexandru Petrescu
> Envoyé : lundi 18 mars 2013 15:58
> À : Ted Lemon
> Cc : <[email-masked]>
> Objet : Re: [mif] Call for volunteers about architecture design
> 
> use of Mobile IP and handovers.  This would be such that a Host to
> offer highly available connections - when WiFi is available use WiFi,
> but if cellular is available then use cellular.  This could be a
> sequential use of interfaces (only one interface is used exclusively),
> as opposed to simultaneous use of interfaces.
> 
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 19 Mar 2013 15:33:43 +0100

Le 19/03/2013 10:13, [email-masked] a écrit :
> Hi Alex,
>
> Except the problem of access discovery and selection, I'm not sure
> there are multiple provisioning domains issues with sequential use of
> interfaces.

I am not sure either.

If continuous sessions are needed after a handover WiFi-3G (each is in a
different provisioning domain), then Mobile IP should be used; if Mobile
IP is used then there is a routing problem at the initial setup phase
(the default route points to a tunnel interface but the HA should be
reached with a host-specific route on the real interface).

There could be advice from HA to mobile to tell it how to set up that
route (use one the real interface for reaching HA and the tunnel
interface for all other traffic).  This advice is just another kind of
advice that should be taken with precaution.

Or there could be a visual interface on the terminal to set manually the
default route and other specific routes. (was already said).

Alex

> This is something we can do with current terminal... Maybe I'm wrong
> but, anyway, I guess the architecture work will start with discussion
> on use-cases to identify what is relevant or not.
>
> Pierrick
>
>> -----Message d'origine----- De : [email-masked]
>> [mailto:[email-masked]] De la part de Alexandru Petrescu
>> Envoyé : lundi 18 mars 2013 15:58 À : Ted Lemon Cc :
>> <[email-masked]> Objet : Re: [mif] Call for volunteers about
>> architecture design
>>
>>>> augmentation, on a Mobile Router (not a Host) - is discussed in
>>>> the ITS Intelligent Transportation Systems email list
>>>> (this is one problem being considered there, but there are
>>>> other ITS problems considered there.  And there there is
>>>> thought that MIF may consider this case - it seems not.)
>>>
>>> architecture discussion.   Whether it's in-scope or out of scope
>>>  is another question.
>>
>> In addition to simultaneous use of multiple interfaces for
>> bandwidth augmentation on a low-ratio egress-ingress bandwidth
>> Mobile Router (its egress bandwith is much lower than ingress
>> bandwidth),
>>
>> there is another aspect which deserves mentioning in a mif'ed Host:
>> the use of Mobile IP and handovers.  This would be such that a Host
>> to offer highly available connections - when WiFi is available use
>> WiFi, but if cellular is available then use cellular. This could be
>> a sequential use of interfaces (only one interface is used
>> exclusively), as opposed to simultaneous use of interfaces.
>>
>> The architecture aspect in  this is the difference between
>> simultaneous vs sequential use of interfaces.  This could be
>> illustrated with pictures of topology.
>>
Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
> exploites ou copies sans autorisation. Si vous avez recu ce message
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi
> que les pieces jointes. Les messages electroniques etant susceptibles
> d'alteration, France Telecom - Orange decline toute responsabilite si
> ce message a ete altere, deforme ou falsifie. Merci.
>
> This message and its attachments may contain confidential or
> privileged information that may be protected by law; they should not
>  be distributed, used or copied without authorisation. If you have
> received this email in error, please notify the sender and delete
> this message and its attachments. As emails may be altered, France
> Telecom - Orange is not liable for messages that have been modified,
>  changed or falsified. Thank you.
>
>
>

---

From: <[email-masked]>
Date: Tue, 19 Mar 2013 15:03:30 +0000

Ok, so, being more generic than MIP, the problem is about simultaneous usage (not sequential) of physical and virtual interfaces, on a single physical interface. This problem is identified in MIF problem statement. 

Pierrick
> De : Alexandru Petrescu [mailto:[email-masked]]
> Envoyé : mardi 19 mars 2013 15:34
> À : SEITE Pierrick OLNC/OLN
> Cc : Ted Lemon; <[email-masked]>
> If continuous sessions are needed after a handover WiFi-3G (each is in
> a different provisioning domain), then Mobile IP should be used; if
> Mobile IP is used then there is a routing problem at the initial setup
> phase (the default route points to a tunnel interface but the HA should
> be reached with a host-specific route on the real interface).
> 
> Or there could be a visual interface on the terminal to set manually
> the default route and other specific routes. (was already said).
> 
> Alex
> 
> 
> Envoyé
> >> : lundi 18 mars 2013 15:58 À : Ted Lemon Cc :
> other
> >>>> interfaces together, with goals such as bandwidth augmentation, on
> >>>> a Mobile Router (not a Host) - is discussed in the ITS Intelligent
> >> augmentation on a low-ratio egress-ingress bandwidth Mobile Router
> >> (its egress bandwith is much lower than ingress bandwidth),
> >>
> a
> >> sequential use of interfaces (only one interface is used
> ______________________________________________________________________
> > ___________________________________________________
> >
> >
> >
> >
> this
> > message and its attachments. As emails may be altered, France Telecom
> > - Orange is not liable for messages that have been modified,  changed
> > or falsified. Thank you.
> >
> >
> >
>

---

From: Ted Lemon <[email-masked]>
Date: Tue, 19 Mar 2013 15:10:10 +0000

>> there are multiple provisioning domains issues with sequential use of

My take on this, for what it's worth, is that the work MIF is doing will be useful, but not central, to what you are trying to do.   MIF is focusing on what happens when all the interfaces are on at the same time, but we also want to enable the provision sufficient functionality that you can set up a connection manager that makes choices about which interfaces to keep alive when.

I am not _convinced_ that we need to do a lot of work in that space—we may be able to leverage work that IEEE has already done, for example, in which case our job would be filling in the gaps that IEEE has not already addressed, or getting IEEE to do it, whichever makes the most sense.

But the point is that I think you should probably be interested in what MIF is doing, but I suspect that the work MIF is doing is not crucial to the work you are doing.

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 19 Mar 2013 16:36:21 +0100

Le 19/03/2013 16:03, [email-masked] a écrit :
> Ok, so, being more generic than MIP, the problem is about
> simultaneous usage (not sequential) of physical and virtual
> interfaces, on a single physical interface.

I agree in this sense.

(to me 'simultaneous use' is when we say simultaneous use for bandwidth
augmentation.  Distinct HAroute and defroute - what we discuss above -
is a method to do mobility registration at the same time as traffic, but
does not offer bandwidth augmentation.)

For the pure use of interfaces in a sequential manner, I dont see
anything else than a Mobile IP problem, which is solved, as you say.

> This problem is identified in MIF problem statement.

Ok.

Alex

>
> Pierrick
>> -----Message d'origine----- De : Alexandru Petrescu
>> [mailto:[email-masked]] Envoyé : mardi 19 mars 2013
>> 15:34 À : SEITE Pierrick OLNC/OLN Cc : Ted Lemon; <[email-masked]>
>>> Except the problem of access discovery and selection, I'm not
>>> sure there are multiple provisioning domains issues with
>>> sequential use of interfaces.
>>
>> I am not sure either.
>>
>> If continuous sessions are needed after a handover WiFi-3G (each
>> is in a different provisioning domain), then Mobile IP should be
>> used; if Mobile IP is used then there is a routing problem at the
>> initial setup phase (the default route points to a tunnel interface
>> but the HA should be reached with a host-specific route on the
>> real interface).
>>
>> There could be advice from HA to mobile to tell it how to set up
>> that route (use one the real interface for reaching HA and the
>> tunnel interface for all other traffic).  This advice is just
>> another kind of advice that should be taken with precaution.
>>
>> Or there could be a visual interface on the terminal to set
>> manually the default route and other specific routes. (was already
>> said).
>>
>> Alex
>>
>>
>>> This is something we can do with current terminal... Maybe I'm
>>> wrong but, anyway, I guess the architecture work will start with
>>> discussion on use-cases to identify what is relevant or not.
>>>
>>> Pierrick
>>>
>>>> : lundi 18 mars 2013 15:58 À : Ted Lemon Cc : <[email-masked]>
>>>>>> interfaces together, with goals such as bandwidth
>>>>>> augmentation, on a Mobile Router (not a Host) - is
>>>>>> discussed in the ITS Intelligent Transportation Systems
>>>>>> email list ietf.org/mailman/listinfo/its
>>>>>>
>>>>>> thought that
>> MIF
>>>>> architecture discussion.   Whether it's in-scope or out of
>>>>> scope is another question.
>>>>
>>>> there is another aspect which deserves mentioning in a mif'ed
>>>> Host: the use of Mobile IP and handovers.  This would be such
>>>> that a Host to offer highly available connections - when WiFi
>>>> is available use WiFi, but if cellular is available then use
>>>> cellular. This could be
>> a
>>>> _______________________________________________ mif mailing
>>>> list [email-masked] https://www.ietf.org/mailman/listinfo/mif
>>>
>>>
>>> confidentielles ou privilegiees et ne doivent donc pas etre
>>> diffuses, exploites ou copies sans autorisation. Si vous avez
>>> recu ce message par erreur, veuillez le signaler a l'expediteur
>>> et le detruire ainsi que les pieces jointes. Les messages
>>> electroniques etant susceptibles d'alteration, France Telecom -
>>> Orange decline toute responsabilite si ce message a ete altere,
>>> deforme ou falsifie. Merci.
>>>
>>> privileged information that may be protected by law; they should
>>> not be distributed, used or copied without authorisation. If you
>>> have received this email in error, please notify the sender and
>>> delete
>> this
>>> message and its attachments. As emails may be altered, France
>>> Telecom - Orange is not liable for messages that have been
>>> modified,  changed or falsified. Thank you.
>>>
>>>
>>>
>>
>
>
> confidentielles ou privilegiees et ne doivent donc pas etre
> diffuses, exploites ou copies sans autorisation. Si vous avez recu ce
> message par erreur, veuillez le signaler a l'expediteur et le
> detruire ainsi que les pieces jointes. Les messages electroniques
> etant susceptibles d'alteration, France Telecom - Orange decline
> toute responsabilite si ce message a ete altere, deforme ou falsifie.
> Merci.
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 19 Mar 2013 16:37:21 +0100

Le 19/03/2013 16:10, Ted Lemon a écrit :
> My take on this, for what it's worth, is that the work MIF is doing
> will be useful, but not central, to what you are trying to do.   MIF
> is focusing on what happens when all the interfaces are on at the
> same time, but we also want to enable the provision sufficient
> functionality that you can set up a connection manager that makes
> choices about which interfaces to keep alive when.
>
> I am not _convinced_ that we need to do a lot of work in that
> space—we may be able to leverage work that IEEE has already done, for
> example, in which case our job would be filling in the gaps that IEEE
> has not already addressed, or getting IEEE to do it, whichever makes
> the most sense.
>
> But the point is that I think you should probably be interested in
> what MIF is doing, but I suspect that the work MIF is doing is not
> crucial to the work you are doing.

I agree.  I am interested in what MIF is doing.

Alex

---

From: "Hui Deng" <[email-masked]>
Date: Wed, 20 Mar 2013 15:14:58 +0800

For sequential use of interfaces, I guess mobile IP is not the only solution, today most internet application has figured out how to do session continuity without mobile ip support.
http://datatracker.ietf.org/doc/draft-deng-mif-api-session-continuity-guide/

-Hui
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexandru Petrescu
Sent: Tuesday, March 19, 2013 11:36 PM
To: [email-masked]
Cc: <[email-masked]>
Subject: Re: [mif] Call for volunteers about architecture design

Le 19/03/2013 16:03, [email-masked] a écrit :
> Ok, so, being more generic than MIP, the problem is about simultaneous 
> usage (not sequential) of physical and virtual interfaces, on a single 
> physical interface.

I agree in this sense.

(to me 'simultaneous use' is when we say simultaneous use for bandwidth augmentation.  Distinct HAroute and defroute - what we discuss above - is a method to do mobility registration at the same time as traffic, but does not offer bandwidth augmentation.)

For the pure use of interfaces in a sequential manner, I dont see anything else than a Mobile IP problem, which is solved, as you say.

Ok.

Alex

>>> there are multiple provisioning domains issues with sequential use 
>>> of interfaces.
>>
>> I am not sure either.
>>
>> If continuous sessions are needed after a handover WiFi-3G (each is 
>> in a different provisioning domain), then Mobile IP should be used; 
>> if Mobile IP is used then there is a routing problem at the initial 
>> setup phase (the default route points to a tunnel interface but the 
>> HA should be reached with a host-specific route on the real 
>> interface).
>>
>> interface for all other traffic).  This advice is just another kind 
>> of advice that should be taken with precaution.
>>
>>> but, anyway, I guess the architecture work will start with 
>>>> : lundi 18 mars 2013 15:58 À : Ted Lemon Cc : <[email-masked]> Objet 
>>>> : Re: [mif] Call for volunteers about architecture design
>>>>
>>>>>> interfaces together, with goals such as bandwidth augmentation, 
>>>>>> on a Mobile Router (not a Host) - is discussed in the ITS 
>>>>>> Intelligent Transportation Systems email list 
>>>> Host: the use of Mobile IP and handovers.  This would be such that 
>>>> a Host to offer highly available connections - when WiFi is 
>>>> available use WiFi, but if cellular is available then use cellular. 
>>>> This could be
>> a
>>> diffuses, exploites ou copies sans autorisation. Si vous avez recu 
>>> ce message par erreur, veuillez le signaler a l'expediteur et le 
>>> toute responsabilite si ce message a ete altere, deforme ou 
>>> falsifie. Merci.
>>>
> received this email in error, please notify the sender and delete this 

_______________________________________________
mif mailing list
[email-masked]
https://w