Subject: [mif] Generalising PVD IDs

From: Brian E Carpenter <[email-masked]>
Date: Fri, 08 Nov 2013 10:55:02 +1300

I suggested that PVD IDs are a subset of a more general need,
which is IDs for a reachable address scope.

The notion of address scope that I have in mind was discussed
in a couple of expired drafts:
http://tools.ietf.org/html/draft-carpenter-grobj-reqts-00#section-2

A much older draft actually proposed a specific format for
a ScopeID, namely an imaginary IPv6 address under a ULA
prefix. I don't stand by that, but you can find it in
http://tools.ietf.org/html/draft-carpenter-behave-referral-object-00#section-4.10.

Regards
   Brian

---

From: Ted Lemon <[email-masked]>
Date: Fri, 8 Nov 2013 02:00:16 +0000

PVD IDs should be something that can somehow be displayed in a menu, like SSIDs.   It may be that that works by having a text version and a machine version, but there abide dragons.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 08 Nov 2013 15:15:38 +1300

> PVD IDs should be something that can somehow be displayed in a menu, like SSIDs.   It may be that that works by having a text version and a machine version, but there abide dragons.

Display is one thing, mnemonic is another. Are you thinking of something like

My_ISP_Lemon

or (say)

FD37:3467:3170:160:28cc:dc4c:9705:6681

   Brian

---

From: Ted Lemon <[email-masked]>
Date: Fri, 8 Nov 2013 05:04:28 +0000

> My_ISP_Lemon

Possibly something like "Example WiFi".   OTOH, it would be good if the identifier also looked like this: wifi.example.com.   If it did, we could hang a DANE cert off the name and use it to validate the key for leap-of-faith associations.   So maybe what I'd like to see in the UI is "Example WiFi (wifi.example.com)".   Or maybe that's too much to ask of the end user—I don't know.   Do we have the right expertise on this mailing list to answer this question, or should we be looking for additional advice?