Subject: [mile] Binding/containment of RID and IODEF in 6046

From: Brian Trammell <[email-masked]>
Date: Mon, 12 Dec 2011 18:14:02 +0100

Greetings, all,

In answering a question from the appsdir review on 6046, I've discovered what might an issue with the transport of RID that may have an impact on 6045, as well.

The question is "what is the media type of a RID message"; the (obvious enough that I didn't notice it was missing from 6046) answer is "text/xml".

However, as defined right now that's not the case. What is sent instead is multiple XML bodies: the <RID> element followed by the <IODEF-Document> element followed by an XML signature. The extension of RID as foreseen in the GRC charter item would add other elements to this.

Should this be handled in the context of RFC6045, or RFC6046? In the former case, we would allow the <RID> element to contain arbitrary elements, as I think was alluded to in an earlier either directly or through a <Content> element, so that <RID> becomes the root element of all RID messages, something like:

<RID>
 ... other RID elements
 <Content>
  <IODEF-Document/>
 </Content>
</RID>
 
In the latter, RFC6046 would have to define a new schema, containing RID and IODEF as well as other information which could be annotated by RID in the future, like:

<RID-Transport-Envelope>
  <RID/>
  <IODEF-Document/>
</RID-TransportEnvelope>

If we expect RID documents to coexist with the data they carry anywhere _except on the wire_, it probably makes sense to update 6045 to use the former. In both of these cases, it's kind of painful to express the type of "extensible" containment we need for future GRC-like cases using xsd, so I don't think there's an ease of implementation argument either way. IIRC, this is one of the reasons the RID element didn't contain its content in the first place... but if we want a text/xml body with one root element -- which I think we do -- clearly we need some container.

Thoughts?

Best regards,

Brian (author hat)

---

From: <[email-masked]>
Date: Mon, 12 Dec 2011 12:22:22 -0500

Hi Brian,

The solution proposed below came up in Paul Cichonski's review where he suggested we go back to IODEF being encapsulated in RID as an optional element.  I think that is the cleanest option.  I agree that it makes sense to have this, but gave a response based on prior WG decisions.  I did ask for opinions, but didn't get any.  This was right at the end of WGLC.  I think it is messy to have another layer at transport.  It does change implementations and that was one of the reasons cited for not making the change.

FYI- The GRC extension would not add to this as it would not be used with IODEF documents or RID.  It is intended as a generalization of RID to be used with other XML schemas for their transport.  Handling it in the same way makes sense.

Can we have some more opinions?

Thanks,
Kathleen (I think as an editor)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian Trammell
Sent: Monday, December 12, 2011 12:14 PM
To: [email-masked]
Subject: [mile] Binding/containment of RID and IODEF in 6046

Greetings, all,

<RID>
 ... other RID elements
 <Content>
  <IODEF-Document/>
 </Content>
</RID>

<RID-Transport-Envelope>
  <RID/>
  <IODEF-Document/>
</RID-TransportEnvelope>

Thoughts?

Best regards,

Brian (author hat)
_______________________________________________
mile mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mile

---

From: "Waltermire, David A." <[email-masked]>
Date: Mon, 12 Dec 2011 15:02:21 -0500

Kathleen,

I'd like to understand your thinking regarding why adding a layer at transport is more messy.  How do you envision RID, IODEF and transport fitting together with the GRC extension?

Thanks,
Dave Waltermire

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 12, 2011 12:22 PM
To: [email-masked]; [email-masked]
Subject: Re: [mile] Binding/containment of RID and IODEF in 6046

Hi Brian,

Thanks,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian Trammell
Sent: Monday, December 12, 2011 12:14 PM
To: [email-masked]
Subject: [mile] Binding/containment of RID and IODEF in 6046

Greetings, all,

<RID>
 ... other RID elements
 <Content>
  <IODEF-Document/>
 </Content>
</RID>

<RID-Transport-Envelope>
  <RID/>
  <IODEF-Document/>
</RID-TransportEnvelope>

Thoughts?

Best regards,

Brian (author hat)

---

From: <[email-masked]>
Date: Mon, 12 Dec 2011 15:16:36 -0500

Hi Dave,

I don't see the GRC piece as an extension to IODEF and RID, but rather a generalization of RID, where the included XML is some other XML schema.  The request for this came from the GRC-XML and LI-XML communities that wanted a way to securely transfer XML documents.

RID (IODEF)   generalized to GRC-Exchange(XML schema)

I think the last proposal is messy as we then need a wrapper at a layer up instead of just having RID do this.  Why have a wrapper that has a schema that optionally includes an IODEF and RID document when RID can do that for IODEF?  Please show other points if I am missing something, discussion is good as this changes things and we need to know if that is OK for developers and to have people weigh in on what they think is the right solution.  I just think the approach of RID being the envelope is simpler.

Thanks,
Kathleen

-----Original Message-----
From: Waltermire, David A. [mailto:[email-masked]] 
Sent: Monday, December 12, 2011 3:02 PM
To: Moriarty, Kathleen; [email-masked]; [email-masked]
Subject: RE: [mile] Binding/containment of RID and IODEF in 6046

Kathleen,

Thanks,
Dave Waltermire

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 12, 2011 12:22 PM
To: [email-masked]; [email-masked]
Subject: Re: [mile] Binding/containment of RID and IODEF in 6046

Hi Brian,

Thanks,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian Trammell
Sent: Monday, December 12, 2011 12:14 PM
To: [email-masked]
Subject: [mile] Binding/containment of RID and IODEF in 6046

Greetings, all,

<RID>
 ... other RID elements
 <Content>
  <IODEF-Document/>
 </Content>
</RID>

<RID-Transport-Envelope>
  <RID/>
  <IODEF-Document/>
</RID-TransportEnvelope>

Thoughts?

Best regards,

Brian (author hat)

---

From: Brian Trammell <[email-masked]>
Date: Mon, 12 Dec 2011 22:27:18 +0100

hi, Kathleen,

on review and further consideration, I'm convinced -- the RID as envelope approach seems to be the cleaner way to do this, especially in light of future plans wrt GRC...

cheers, Brian (author hat)

Sent from my iPhone