Subject: [mile] I-D Action: draft-ietf-mile-rfc6046-bis-06.txt

From: [email-masked]
Date: Tue, 17 Jan 2012 14:00:30 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Managed Incident Lightweight Exchange Working Group of the IETF.

	Title           : Transport of Real-time Inter-network Defense (RID) Messages over HTTP/ TLS
	Author(s)       : Brian Trammell
	Filename        : draft-ietf-mile-rfc6046-bis-06.txt
	Pages           : 8
	Date            : 2012-01-17

   The Incident Object Description Exchange Format (IODEF) defines a
   common XML format for document exchange, and Realtime Internetwork
   Defense (RID) defines extensions to IODEF intended for the
   cooperative handling of security incidents within consortia of
   network operators and enterprises.  This document specifies a
   application-layer protocol for RID based upon the passing of RID
   messages over HTTP/TLS.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mile-rfc6046-bis-06.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-mile-rfc6046-bis-06.txt

---

From: Brian Trammell <[email-masked]>
Date: Tue, 17 Jan 2012 23:02:26 +0100

Greetings, all,

This revision of rfc6046-bis addresses all IETF Last Call comments received.

Best regards,

Brian (as author of rfc6046-bis)

On Jan 17, 2012, at 11:00 PM, [email-masked] wrote:

> _______________________________________________
> mile mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mile

---

From: <[email-masked]>
Date: Tue, 17 Jan 2012 22:06:25 -0500

Hi Brian,

In RID's last call a couple of the message names changed, which should be reflected in RFC6046-bis.  

RequestAuthorization is now Acknowledgement (makes more sense with the function actually served)
IncidentQuery is now Query - this was to generalize it a bit more and was one of the requests.

Also, any message can receive a response of Acknowledgement.  This was possible back in RFC6045, but nested within  the communication flow section, so it wasn't readily apparent.  I adjusted the text in RFC6045 to make this more clear as a possible response.  If there is a problem decrypting a message or other processing issue, you need a way to provide that.  This is done through the Acknowledgement using the Justification class enumerations.

Thanks,
Kathleen (as author)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian Trammell
Sent: Tuesday, January 17, 2012 5:02 PM
To: [email-masked]
Subject: Re: [mile] I-D Action: draft-ietf-mile-rfc6046-bis-06.txt

Greetings, all,

Best regards,

---

From: Brian Trammell <[email-masked]>
Date: Wed, 18 Jan 2012 15:03:23 +0100

Hi, Kathleen,

Oops... Was so busy tracking LC that I forgot to check rfc6045-bis-06. I've fixed this in rfc6046-bis-07, just submitted.

Thanks for catching this!

Cheers,

Brian (apparently-distracted author hat)